<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="stylesheet" media="print" onload="this.onload=null;this.media='all';" id="ao_optimized_gfonts" href="https://fonts.googleapis.com/css?family=Lora%3A400%2C400i%2C700%7CLora%3A400%2C700%2Cbold%2Cregular&amp;display=swap" /><link rel="profile" href="http://gmpg.org/xfn/11"><meta property="fb:pages" content="23117126720" /><link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png"><link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png"><link rel="manifest" href="/site.webmanifest"><link rel="mask-icon" href="/safari-pinned-tab.svg" color="#ffc414"><meta name="msapplication-TileColor" content="#231f20"><meta name="theme-color" content="#231f20"> <style type="text/css">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</style><meta name='robots' content='max-image-preview:large' /><link rel="stylesheet" media="print" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_84cd334b3ef23c4cf846364bfb8743b8.css" onload="this.onload=null;this.media='all';" /><noscript id="aonoscrcss"><link media="all" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_84cd334b3ef23c4cf846364bfb8743b8.css" rel="stylesheet" /></noscript><title>The Rundown | May 13-20 - Philadelphia Weekly</title><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://philadelphiaweekly.com/the-rundown-may-13-20/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="The Rundown | May 13-20 - Philadelphia Weekly" /><meta property="og:description" content="All aboard the Bearded Ladies’ Beardmobile" /><meta property="og:url" content="https://philadelphiaweekly.com/the-rundown-may-13-20/" /><meta property="og:site_name" content="Philadelphia Weekly" /><meta property="article:publisher" content="https://www.facebook.com/phillyweekly/" /><meta property="article:published_time" content="2021-05-13T17:13:14+00:00" /><meta property="article:modified_time" content="2021-05-13T17:13:18+00:00" /><meta property="og:image" content="https://philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard-1024x683.jpg" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="683" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@phillyweekly" /><meta name="twitter:site" content="@phillyweekly" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://philadelphiaweekly.com/#organization","name":"Philadelphia Weekly","url":"https://philadelphiaweekly.com/","sameAs":["https://www.facebook.com/phillyweekly/","https://www.instagram.com/phillyweekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://twitter.com/phillyweekly"],"logo":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#logo","inLanguage":"en-US","url":"https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&quality=70&strip=all&ssl=1","width":500,"height":500,"caption":"Philadelphia Weekly"},"image":{"@id":"https://philadelphiaweekly.com/#logo"}},{"@type":"WebSite","@id":"https://philadelphiaweekly.com/#website","url":"https://philadelphiaweekly.com/","name":"Philadelphia Weekly","description":"","publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://philadelphiaweekly.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/the-rundown-may-13-20/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard.jpg?fit=2400%2C1600&quality=70&strip=all&ssl=1","width":2400,"height":1600,"caption":"Image: Plate 3 Photography"},{"@type":"WebPage","@id":"https://philadelphiaweekly.com/the-rundown-may-13-20/#webpage","url":"https://philadelphiaweekly.com/the-rundown-may-13-20/","name":"The Rundown | May 13-20 - Philadelphia Weekly","isPartOf":{"@id":"https://philadelphiaweekly.com/#website"},"primaryImageOfPage":{"@id":"https://philadelphiaweekly.com/the-rundown-may-13-20/#primaryimage"},"datePublished":"2021-05-13T17:13:14+00:00","dateModified":"2021-05-13T17:13:18+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://philadelphiaweekly.com/the-rundown-may-13-20/"]}]},{"@type":"Article","@id":"https://philadelphiaweekly.com/the-rundown-may-13-20/#article","isPartOf":{"@id":"https://philadelphiaweekly.com/the-rundown-may-13-20/#webpage"},"author":{"@id":"https://philadelphiaweekly.com/#/schema/person/6d10bb5ac4140a42ca14aa4e8065e28d"},"headline":"The Rundown | May 13-20","datePublished":"2021-05-13T17:13:14+00:00","dateModified":"2021-05-13T17:13:18+00:00","mainEntityOfPage":{"@id":"https://philadelphiaweekly.com/the-rundown-may-13-20/#webpage"},"publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"image":{"@id":"https://philadelphiaweekly.com/the-rundown-may-13-20/#primaryimage"},"keywords":"events,food and drink,parties,philly,Philly events,The Rundown,things to do","articleSection":"Food / Drink,Party,The Rundown","inLanguage":"en-US"},{"@type":"Person","@id":"https://philadelphiaweekly.com/#/schema/person/6d10bb5ac4140a42ca14aa4e8065e28d","name":"Philly Editor","image":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/a2af5953cb6b5d09567512df874c23dd?s=96&d=mm&r=g","caption":"Philly Editor"}}]}</script> <link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//c0.wp.com' /><link rel='dns-prefetch' href='//i0.wp.com' /><link rel='dns-prefetch' href='//i1.wp.com' /><link rel='dns-prefetch' href='//i2.wp.com' /><link href='https://use.typekit.net' rel='preconnect' /><link href='https://www.google-analytics.com' rel='preconnect' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Feed" href="https://philadelphiaweekly.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Comments Feed" href="https://philadelphiaweekly.com/comments/feed/" /><link rel="alternate" type="text/calendar" title="Philadelphia Weekly &raquo; iCal Feed" href="https://philadelphiaweekly.com/events/?ical=1" /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify;}</style> <script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/plugins/jquery-manager/assets/js/jquery-3.5.1.min.js' id='jquery-core-js'></script> <script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/plugins/jquery-manager/assets/js/jquery-migrate-3.3.0.min.js' id='jquery-migrate-js'></script> <script type='application/json' id='wpp-json'>{"sampling_active":0,"sampling_rate":50,"ajax_url":"https:\/\/philadelphiaweekly.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":29534,"token":"f955cd4ccf","lang":0,"debug":0}</script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-700394-5' id='google_gtagjs-js' async></script> <script type='text/javascript' id='google_gtagjs-js-after'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["philadelphiaweekly.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-700394-5", {"anonymize_ip":true});</script> <link rel="https://api.w.org/" href="https://philadelphiaweekly.com/wp-json/" /><link rel="alternate" type="application/json" href="https://philadelphiaweekly.com/wp-json/wp/v2/posts/29534" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://philadelphiaweekly.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://philadelphiaweekly.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.7.1" /><link rel='shortlink' href='https://philadelphiaweekly.com/?p=29534' /><link rel="alternate" type="application/json+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fthe-rundown-may-13-20%2F" /><link rel="alternate" type="text/xml+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fthe-rundown-may-13-20%2F&#038;format=xml" />  <script>"use strict";

!function() {
  var t = window.driftt = window.drift = window.driftt || [];
  if (!t.init) {
    if (t.invoked) return void (window.console && console.error && console.error("Drift snippet included twice."));
    t.invoked = !0, t.methods = [ "identify", "config", "track", "reset", "debug", "show", "ping", "page", "hide", "off", "on" ], 
    t.factory = function(e) {
      return function() {
        var n = Array.prototype.slice.call(arguments);
        return n.unshift(e), t.push(n), t;
      };
    }, t.methods.forEach(function(e) {
      t[e] = t.factory(e);
    }), t.load = function(t) {
      var e = 3e5, n = Math.ceil(new Date() / e) * e, o = document.createElement("script");
      o.type = "text/javascript", o.async = !0, o.crossorigin = "anonymous", o.src = "https://js.driftt.com/include/" + n + "/" + t + ".js";
      var i = document.getElementsByTagName("script")[0];
      i.parentNode.insertBefore(o, i);
    };
  }
}();
drift.SNIPPET_VERSION = '0.3.1';
drift.load('rk5uegyicbzi');</script> <meta name="generator" content="Site Kit by Google 1.31.0" /><script type="text/javascript">window.MemberfulOptions = {
    site: "https://philadelphiaweekly.memberful.com",
    intercept: [
            "http://philadelphiaweekly.com/?memberful_endpoint=auth",
            "https://philadelphiaweekly.com/?memberful_endpoint=auth",
            "http://philadelphiaweekly.com?memberful_endpoint=auth",
            "https://philadelphiaweekly.com?memberful_endpoint=auth",
          ],
    memberSignedIn: false  };

  (function() {
    var s = document.createElement('script');
    s.type = 'text/javascript';
    s.async = true;
    s.src = 'https://d35xxde4fgg0cx.cloudfront.net/assets/embedded.js';

    setup = function() { window.MemberfulEmbedded.setup(); };

    s.addEventListener("load", setup, false);

    ( document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0] ).appendChild( s );
  })();</script> <meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://philadelphiaweekly.com"><link rel="https://theeventscalendar.com/" href="https://philadelphiaweekly.com/wp-json/tribe/events/v1/" /><style>@-webkit-keyframes bgslide {
                from {
                    background-position-x: 0;
                }
                to {
                    background-position-x: -200%;
                }
            }

            @keyframes bgslide {
                    from {
                        background-position-x: 0;
                    }
                    to {
                        background-position-x: -200%;
                    }
            }

            .wpp-widget-placeholder {
                margin: 0 auto;
                width: 60px;
                height: 3px;
                background: #dd3737;
                background: -webkit-gradient(linear, left top, right top, from(#dd3737), color-stop(10%, #571313), to(#dd3737));
                background: linear-gradient(90deg, #dd3737 0%, #571313 10%, #dd3737 100%);
                background-size: 200% auto;
                border-radius: 3px;
                -webkit-animation: bgslide 1s infinite linear;
                animation: bgslide 1s infinite linear;
            }</style><style type="text/css">.header{background-color: #0a0a0a;}.header .SearchForm-button{color: #ffffff;}.Navigation--primary{color: #ffffff;}</style><style type="text/css">/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}</style> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=32%2C21&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=192%2C128&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=180%2C120&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=270%2C180&#038;quality=70&#038;strip=all&#038;ssl=1" /> <script>window.dataLayer = window.dataLayer || [];
	  function gtag(){dataLayer.push(arguments);}
	  gtag('js', new Date());

	  gtag('config', 'UA-700394-5');</script> </head><body class="post-template-default single single-post postid-29534 single-format-standard tribe-no-js tribe-theme-parent-truro tribe-theme-child-truro-pw-child"> <a class="skip-link screen-reader-text" href="#Content">Skip to content</a><header class="header header--four"><div class="header-section header-section--primary"><div class="header-container"><div class="header-sectionInner"><div class="header-part"><div class="Branding"> <a href="https://philadelphiaweekly.com/" rel="home"> <img class="Branding-logo" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/PW-weekly-white-horizontal-1-1.svg" alt="Philadelphia Weekly" width="200px" /> </a></div></div><div class="header-part header-part__navigation"><nav class="Navigation Navigation--primary"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation" class="menu"><li id="menu-item-227" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li id="menu-item-221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li id="menu-item-188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li id="menu-item-191" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li id="menu-item-192" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li id="menu-item-193" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li id="menu-item-194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li id="menu-item-7201" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li id="menu-item-195" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li id="menu-item-222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li id="menu-item-27615" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27615"><a href="https://philadelphiaweekly.com/sections/altphilly/">AltPhilly</a></li><li id="menu-item-518" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li id="menu-item-375" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li id="menu-item-377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li id="menu-item-385" class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li id="menu-item-384" class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li id="menu-item-543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-128" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></nav><div class="utility-navigation"><nav class="Navigation Navigation--utility"><div class="menu-utility-navigation-container"><ul id="menu-utility-navigation" class="menu"><li id="menu-item-27636" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27636"><a href="https://philadelphiaweekly.com/join/">Join</a></li><li id="menu-item-132" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-132"><a href="https://philadelphiaweekly.com/?memberful_endpoint=auth"><span>Sign In</span></a></li></ul></div></nav><form class="SearchForm SearchForm--header" method="get" action="https://philadelphiaweekly.com/"> <span class="screen-reader-text">Search for:</span> <input class="SearchForm-field" type="text" placeholder="Type &amp; press enter" value="" name="s" title="Search for:" /> <button type="submit" class="screen-reader-text" aria-label="Search">Search</button> <button class="SearchForm-button" aria-label="Submit"><i class="fa fa-search" aria-hidden="true"></i></button></form></div></div></div></div></div></header><nav class="Navigation Navigation--mobile"><div class="container"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27615"><a href="https://philadelphiaweekly.com/sections/altphilly/">AltPhilly</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></div></nav><div class="content content--fullWidth" id="content"><div class="content-inner"><div class="content-container"><div class="content-row content-row--article"><main class="content-main"><header class="article-header"><div class="meta-tags"> <span class="Meta-item"><li class="Meta-item Meta-item--categories"><ul class="Meta Meta--banner"><li class="Meta-item Meta-item--categories"><ul><li><a href="https://philadelphiaweekly.com/sections/food-drink/" title="Food / Drink">Food / Drink</a></li><li><a href="https://philadelphiaweekly.com/sections/party/" title="Party">Party</a></li><li><a href="https://philadelphiaweekly.com/sections/featured-sections/the-rundown/" title="The Rundown">The Rundown</a></li></ul></li></ul></li> </span></div><h1>The Rundown | May 13-20</h1><div class="posts-teaser"><p>All aboard the Bearded Ladies’ Beardmobile</p></div><footer class="Post-footer"><ul class="Meta Meta--article"><li class="Meta-item Meta-item--author"> <a class="meta-author-article" href="https://philadelphiaweekly.com/writer/philly-weekly-staff/"><figure class="meta-author-headshot"><img width="100" height="100" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-headshot size-headshot wp-post-image jetpack-lazy-image" alt="Philadelphia Weekly" loading="lazy" data-attachment-id="13" data-permalink="https://philadelphiaweekly.com/favicon/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="500,500" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="favicon" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=300%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?w=500&amp;quality=70&amp;strip=all&amp;ssl=1 500w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=300%2C300&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=350%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 350w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=150%2C150&amp;quality=70&amp;strip=all&amp;ssl=1 150w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></figure> <span class="meta-author-name">Philly Weekly Staff</span></a></li><li class="Meta-item Meta-item--date">May 13th, 2021</li></ul><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/the-rundown-may-13-20/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20The Rundown | May 13-20%20-%20https://philadelphiaweekly.com/the-rundown-may-13-20/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20The Rundown | May 13-20%20-%20https://philadelphiaweekly.com/the-rundown-may-13-20/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: The Rundown | May 13-20%20https://philadelphiaweekly.com/the-rundown-may-13-20/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></footer></header><header class="Post-header"><figure class="Post-thumbnail"> <a data-fancybox="gallery" data-caption="Image: Plate 3 Photography" href="https://philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard.jpg"><img width="1200" height="675" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-feature-image size-feature-image wp-post-image jetpack-lazy-image" alt="Bearded Ladies" loading="lazy" data-attachment-id="29548" data-permalink="https://philadelphiaweekly.com/the-rundown-may-13-20/rdbeard/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard.jpg?fit=2400%2C1600&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2400,1600" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;7.1&quot;,&quot;credit&quot;:&quot;Kathryn Raines&quot;,&quot;camera&quot;:&quot;Canon EOS 5D Mark III&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1603513497&quot;,&quot;copyright&quot;:&quot;2018&quot;,&quot;focal_length&quot;:&quot;34&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.0025&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="RDBeard" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1 1200w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard.jpg?zoom=2&amp;resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1 2400w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></a><figcaption>Image: Plate 3 Photography</figcaption></figure></header><div class="sharing-desktop"><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/the-rundown-may-13-20/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20The Rundown | May 13-20%20-%20https://philadelphiaweekly.com/the-rundown-may-13-20/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20The Rundown | May 13-20%20-%20https://philadelphiaweekly.com/the-rundown-may-13-20/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: The Rundown | May 13-20%20https://philadelphiaweekly.com/the-rundown-may-13-20/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></div><article id="Post-29534"  class="Post Post--single post-29534 post type-post status-publish format-standard has-post-thumbnail hentry category-food-drink category-party category-the-rundown tag-events tag-food-and-drink tag-parties tag-philly tag-philly-events tag-the-rundown tag-things-to-do"><div class="Post-content"><h4>The Bearded Ladies Cabaret Company has announced show details for the Beardmobile – a roving, multi-use cabaret truck that makes live performance accessible in the age of the pandemic.</h4><p>The 15-foot box truck will be the main stage for a series of outdoor pop-up performances throughout Philadelphia, presented as part of the queer cabaret group’s Late Night Snacks series this May. Visit <a href="https://www.beardedladiescabaret.com">beardedladiescabaret.com</a> for tickets and details.</p><figure class="wp-block-image size-large"><img data-attachment-id="29544" data-permalink="https://philadelphiaweekly.com/the-rundown-may-13-20/rdbeard1/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?fit=2400%2C1600&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2400,1600" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;5&quot;,&quot;credit&quot;:&quot;Kathryn Raines&quot;,&quot;camera&quot;:&quot;Canon EOS 5D Mark III&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1603501925&quot;,&quot;copyright&quot;:&quot;2018&quot;,&quot;focal_length&quot;:&quot;70&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.016666666666667&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="RDBeard1" data-image-description data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="1024" height="683" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=1024%2C683&#038;quality=70&#038;strip=all&#038;ssl=1" alt class="wp-image-29544 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=770%2C513&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=1536%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=2048%2C1365&amp;quality=70&amp;strip=all&amp;ssl=1 2048w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=525%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 525w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=1240%2C827&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=680%2C453&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?w=2280&amp;quality=70&amp;strip=all&amp;ssl=1 2280w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=1024%2C683&amp;is-pending-load=1#038;quality=70&#038;strip=all&#038;ssl=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg"><noscript><img data-attachment-id="29544" data-permalink="https://philadelphiaweekly.com/the-rundown-may-13-20/rdbeard1/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?fit=2400%2C1600&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2400,1600" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;5&quot;,&quot;credit&quot;:&quot;Kathryn Raines&quot;,&quot;camera&quot;:&quot;Canon EOS 5D Mark III&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1603501925&quot;,&quot;copyright&quot;:&quot;2018&quot;,&quot;focal_length&quot;:&quot;70&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.016666666666667&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="RDBeard1" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="1024" height="683" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=1024%2C683&#038;quality=70&#038;strip=all&#038;ssl=1" alt="" class="wp-image-29544" srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=770%2C513&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=1536%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=2048%2C1365&amp;quality=70&amp;strip=all&amp;ssl=1 2048w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=525%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 525w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=1240%2C827&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?resize=680%2C453&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBeard1.jpg?w=2280&amp;quality=70&amp;strip=all&amp;ssl=1 2280w" sizes="(max-width: 1024px) 100vw, 1024px" data-recalc-dims="1" /></noscript><figcaption>Image: Plate 3 Photography</figcaption></figure><p><strong>Love Jawns</strong></p><p>This is a project from Yolanda Wisher and Philadelphia Contemporary that fuses poetry and music performances, featuring Ursula Rucker, DJ Junior, and films by Wren Rene. May 13, 8pm. Vernon Park.</p><p><strong>Black Femme Magic</strong></p><p>An entire evening curated by LaNeshe Miller-White, featuring Noelle Diane Johnson, Karen Smith, and Caitlin Green, hosted by Cookie Diorio. May 15, 2pm. Bartram’s North.&nbsp;&nbsp;</p><p><strong>Opera Philly</strong></p><p>A performance hosted by Cookie Diorio featuring T-VOCE, Opera Philly&#8217;s all-city youth choir. May 19, 5:30pm. Cherry Street Pier.</p><p><strong>Tak Kenal Maka Tak Sayang</strong></p><p>Sinta Storms, Modero &amp; Co. and Bearded Ladies offer an evening of Indonesian dance, Gamelan and poetry all devoted to the saying: Tak Kenal Maka Tak Sayang (translation: To Know Is To Love), featuring Modero Dancers, Katherine Antarisko, and the Gamelan Orchestra, hosted by Anthony Martinez-Briggs. May 22, 5pm. Fleisher Art Memorial.</p><p><strong>Love Tour Host Show</strong></p><p>Hosted by the Beards&#8217; own John Jarboe and introducing the Beardmobile host team. May 27, 6pm. Bartram’s North.</p><p><strong>Unity at the Initiative: Queer Skate Day</strong></p><p>A queer skate day celebrating Asian Arts Initiative’s Unity at the Initiative with live music and performance, hosted by Sam Rise featuring Vichte Boul Ra, Icon Ebony Fierce and Messapotamia Lafae. May 29, 2pm. Venue to be determined.</p><figure class="wp-block-image size-large"><img data-attachment-id="29538" data-permalink="https://philadelphiaweekly.com/the-rundown-may-13-20/dollar-gill-m2qowh0neoo-unsplash/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="dollar-gill-M2qOwH0Neoo-unsplash" data-image-description data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="1024" height="683" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash.jpg?resize=1024%2C683&#038;quality=70&#038;strip=all&#038;ssl=1" alt class="wp-image-29538 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?resize=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?resize=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?resize=770%2C513&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?resize=1536%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?resize=2048%2C1365&amp;quality=70&amp;strip=all&amp;ssl=1 2048w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?resize=525%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 525w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?resize=1240%2C827&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?resize=680%2C453&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?w=2280&amp;quality=70&amp;strip=all&amp;ssl=1 2280w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash.jpg?resize=1024%2C683&amp;is-pending-load=1#038;quality=70&#038;strip=all&#038;ssl=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg"><noscript><img data-attachment-id="29538" data-permalink="https://philadelphiaweekly.com/the-rundown-may-13-20/dollar-gill-m2qowh0neoo-unsplash/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="dollar-gill-M2qOwH0Neoo-unsplash" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="1024" height="683" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash.jpg?resize=1024%2C683&#038;quality=70&#038;strip=all&#038;ssl=1" alt="" class="wp-image-29538" srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?resize=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?resize=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?resize=770%2C513&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?resize=1536%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?resize=2048%2C1365&amp;quality=70&amp;strip=all&amp;ssl=1 2048w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?resize=525%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 525w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?resize=1240%2C827&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?resize=680%2C453&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/dollar-gill-M2qOwH0Neoo-unsplash-scaled.jpg?w=2280&amp;quality=70&amp;strip=all&amp;ssl=1 2280w" sizes="(max-width: 1024px) 100vw, 1024px" data-recalc-dims="1" /></noscript><figcaption>Image: <a href="https://unsplash.com/@dollargill">Dollar Gill</a> </figcaption></figure><h4><strong>10th annual Philadelphia Latino Film Festival</strong></h4><p>The 10th annual Philadelphia Latino Film Festival, taking place May 30 to June 6, will feature eight days of virtual filmmaker offerings, free screenings and more. For all the details, visit <a href="https://www.phlaff.org/2021-films">phlaff.org/2021-films</a>, but, for now, here are some of our favorites.</p><p><strong>La Nave del Olvido</strong></p><p>By Nicole Ruiz Benavides from Chile, this film follows the life of Claudina, a repressed elderly woman who is a widow from the countryside. She meets Elsa, a married woman, who invites Claudina to discover real love. Claudina embarks on a tough journey to find freedom and eventually learns that it is individual and inalienable.This is the film’s Philadelphia premiere. The film also won two awards at the Huelva Film Festival in Spain.</p><p><strong>NEGRA</strong></p><p>Also premiering at the festival is this feature-length documentary film from Mexico by Medhin Tewolde Serrano that shows the director in her search of exploring what it means to inhabit Mexico as a Black woman. It tells the story of five afro-descendant women from southern Mexico, exposing racism, resistance and the processes of self-acceptance, strategies for transcending stereotypes, and the celebration of their identity.&nbsp;</p><p><strong>Joyride</strong></p><p>This short, narrative film by Edwin Alexis Gómez tells the story of sisters Marina and Karina, who break their grandmother, Juana, out of her senior living facility. Juana enlists them to take her to the Grand Canyon in secret. The car ride reveals some painful family history and allows Juana to carry out some unfinished business. This will be the film’s east coast premiere. The film also won the Most Popular Award at the 2020 PBS Short Film Festival.</p><p><strong>Superestar</strong></p><p>This short narrative film by Daniel Larios is about two Salvadoran women, one a first-generation indie-pop singer, and the other an immigrant bathroom attendant at an LA nightclub, as they bond over their different troubles and their mutual love of music. This will be the film’s east coast premiere.</p><p><strong>When You Clean a Stranger’s Home</strong></p><p>This short video essay by Sharon Arteaga<strong> </strong>is a film about a first-generation high school student describing what her and her mom learn about people when cleaning their homes for a living. House décor and items left around convey a privilege that unveils her imagination, jealousy and frustrations. This will be the film’s east coast premiere. The film also won the audience award at the 2020 Cine Las Americas International Film Festival.&nbsp;</p><p><strong>#Whitina</strong></p><p>This short narrative film is by J. Sean Smith, the first Latina to be awarded the George Lucas Family Foundation Scholarship at the University of Southern California School of Cinematic Arts MFA program. The film, inspired by coming of age cult classics,<strong> </strong>is about exploring the crossroads of the inner and outer struggles of being Mexican-American against the backdrop of a social media-obsessed society. High school cheerleader and whitina (white acting Latina) Genesis Valdez is forced to go on the run with her two former best friends after a confrontation with undercover I.C.E. agents. Not realizing the whole thing was filmed by two middle schoolers, the group goes #viral. While on the run, Chris reveals he is a dreamer and could get deported. Genesis makes a decision to help Chris escape learning what it really means to be “down for La Raza.”</p><figure class="wp-block-image size-large"><img data-attachment-id="29541" data-permalink="https://philadelphiaweekly.com/the-rundown-may-13-20/rdartage/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?fit=2560%2C1706&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1706" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="RDArtAge" data-image-description data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="1024" height="683" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge.jpeg?resize=1024%2C683&#038;quality=70&#038;strip=all&#038;ssl=1" alt class="wp-image-29541 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?resize=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?resize=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?resize=770%2C513&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?resize=1536%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?resize=2048%2C1365&amp;quality=70&amp;strip=all&amp;ssl=1 2048w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?resize=525%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 525w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?resize=1240%2C827&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?resize=680%2C453&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?w=2280&amp;quality=70&amp;strip=all&amp;ssl=1 2280w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge.jpeg?resize=1024%2C683&amp;is-pending-load=1#038;quality=70&#038;strip=all&#038;ssl=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg"><noscript><img data-attachment-id="29541" data-permalink="https://philadelphiaweekly.com/the-rundown-may-13-20/rdartage/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?fit=2560%2C1706&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1706" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="RDArtAge" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="1024" height="683" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge.jpeg?resize=1024%2C683&#038;quality=70&#038;strip=all&#038;ssl=1" alt="" class="wp-image-29541" srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?resize=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?resize=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?resize=770%2C513&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?resize=1536%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?resize=2048%2C1365&amp;quality=70&amp;strip=all&amp;ssl=1 2048w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?resize=525%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 525w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?resize=1240%2C827&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?resize=680%2C453&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDArtAge-scaled.jpeg?w=2280&amp;quality=70&amp;strip=all&amp;ssl=1 2280w" sizes="(max-width: 1024px) 100vw, 1024px" data-recalc-dims="1" /></noscript><figcaption>Image: Daniela Fedorowicz</figcaption></figure><h4><strong>Time for some outdoor drinking</strong></h4><p>‘Tis the season for sipping cocktails on the patio with pals, while taking in the sun and rising temps. We’ve rounded up some of our go-to Philadelphia restaurants, bars, beer and wine gardens offering outdoor seating and drinking this spring and summer.  </p><p><strong>Art in the Age</strong></p><p>Old City’s one-of-a-kind tasting room, home bar supply and bottle shop offers a socially-distanced happy hour<strong> </strong>daily from 3 – 5pm featuring $2 off small batch bottled cocktails and $1 off local craft beer and cider at their outdoor cocktail garden. Stay and sip your bottled cocktails in the garden or grab a four-pack to take to the beach, park hangs, stoop sitting, etc. Hours of operation are Tuesday through Sunday from noon – 6pm. 116 N. 3rd St. | 215.922.2600 | <a href="http://artintheage.com/">artintheage.com</a>&nbsp;&nbsp;</p><p><strong>Assembly Rooftop Lounge</strong></p><p>Center City’s rooftop lounge with panoramic views of the Benjamin Franklin Parkway, City Hall and the Philadelphia Museum of Art boasts expansive outdoor seating with their vast, chic rooftop, fit for sipping on popular frozen cocktails whilst taking in sweeping views of the parkway. Happy hour specials are available from 4 – 6 featuring a full menu of small bites, craft beer, cocktails and wine. Opening hours: Tuesday through Saturday 4 &#8211; 9pm. 1840 Benjamin Franklin Parkway | 215.963.2723 |&nbsp; <a href="https://assemblyrooftop.com/">assemblyrooftop.com</a>&nbsp;&nbsp;</p><p><strong>The Bourse</strong></p><p>Old City’s modern artisanal food hall offers imbibers the choice of delicious mimosas and Bloody Marys from Grubhouse Philly, and local and domestic brews available for purchase at Freebyrd Chicken. Folks can enjoy these libations at The Bourse’s expansive outdoor 5th Street patio during the spring and summer months. Opening hours: Monday through Saturday from 7am – 10pm and Sunday from 9am – 6pm. 111 S. Independence Mall E. | 215.625.0300 | <a href="http://www.theboursephilly.com/">theboursephilly.com</a>&nbsp;</p><p><strong>Philadelphia Brewing Company</strong></p><p>The city’s largest and oldest brewery located in Kensington holds an expansive beer garden open for service year-round with covered picnic tables galore available for patrons to take a seat, grab a pint (or six pack) of<strong> </strong>Walt Wit, Working Cat, or Kenzinger, BYO food, and enjoy the warm weather. Bonus: the beer garden is dog-friendly, too! Opening hours: Monday through Saturday from 11am – midnight, and Sunday from 11am – 11pm.&nbsp; 2440 Frankford Ave. | <a href="https://www.google.com/search?client=firefox-b-1-d&amp;q=philly+brweing+co+phone+number">215.427.2739</a> | <a href="http://philadelphiabrewing.com/">philadelphiabrewing.com</a>&nbsp;</p><p><strong>REX 1516</strong></p><p>Philadelphia’s go-to for elevated Southern cuisine remains open for take-out, delivery and outdoor dining at their streetery set-up. Half a dozen cocktails, including their Horned Lake Hurricane, Tequila Thrasher, Gin Mot Mot and more are available to go or for sipping outdoors at their South Street location. Open Monday through Thursday 1pm – 8pm, Friday and Saturday noon – 9pm, and Sunday noon – 8pm. 1516 South St. | 267.319.1366 | <a href="https://rex1516.com/">rex1516.com</a>&nbsp;</p><figure class="wp-block-image size-large"><img data-attachment-id="29540" data-permalink="https://philadelphiaweekly.com/the-rundown-may-13-20/rdroyalboucherie-1-1/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?fit=2000%2C1333&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2000,1333" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;13&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;ILCE-7M3&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1559572455&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;69&quot;,&quot;iso&quot;:&quot;800&quot;,&quot;shutter_speed&quot;:&quot;0.0025&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="RDRoyalBoucherie-1-1" data-image-description data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?fit=1024%2C682&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="1024" height="682" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?resize=1024%2C682&#038;quality=70&#038;strip=all&#038;ssl=1" alt class="wp-image-29540 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?resize=1024%2C682&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?resize=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?resize=770%2C513&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?resize=1536%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?resize=525%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 525w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?resize=1240%2C826&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?resize=680%2C453&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?w=2000&amp;quality=70&amp;strip=all&amp;ssl=1 2000w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?resize=1024%2C682&amp;is-pending-load=1#038;quality=70&#038;strip=all&#038;ssl=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg"><noscript><img data-attachment-id="29540" data-permalink="https://philadelphiaweekly.com/the-rundown-may-13-20/rdroyalboucherie-1-1/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?fit=2000%2C1333&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2000,1333" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;13&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;ILCE-7M3&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1559572455&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;69&quot;,&quot;iso&quot;:&quot;800&quot;,&quot;shutter_speed&quot;:&quot;0.0025&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="RDRoyalBoucherie-1-1" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?fit=1024%2C682&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="1024" height="682" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?resize=1024%2C682&#038;quality=70&#038;strip=all&#038;ssl=1" alt="" class="wp-image-29540" srcset="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?resize=1024%2C682&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?resize=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?resize=770%2C513&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?resize=1536%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?resize=525%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 525w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?resize=1240%2C826&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?resize=680%2C453&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDRoyalBoucherie-1-1.jpg?w=2000&amp;quality=70&amp;strip=all&amp;ssl=1 2000w" sizes="(max-width: 1024px) 100vw, 1024px" data-recalc-dims="1" /></noscript><figcaption>Image: Courtesy of Royal Boucherie</figcaption></figure><p><strong>Royal Boucherie</strong></p><p>Old City’s American brasserie specializing in French-style cuisine offers quite the extensive curated craft cocktail and French-forward wine selection, as well as brand-new sidewalk streetery and the return of their second-floor, verdant rooftop garden – one of Philadelphia’s most hidden gems. Imbibers are welcome to sip on a tasty tipple such as the À La Philly,<strong> </strong>composed of Northbound rye whiskey, Bénédictin, sweet vermouth, absinthe and Peychaud’s, at one of their many outdoor tables. Opening hours: Wednesday through Sunday from 4 &#8211; 10pm. 52 S. 2<sup>nd</sup> St. | 267.606.6313 | <a href="https://www.royalboucherie.com/">royalboucherie.com</a></p><div class="wp-block-image"><figure class="aligncenter size-large"><img data-attachment-id="29543" data-permalink="https://philadelphiaweekly.com/the-rundown-may-13-20/rdburgeratephilly/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?fit=933%2C1400&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="933,1400" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;6.3&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;Canon EOS 6D&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1617761030&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;105&quot;,&quot;iso&quot;:&quot;100&quot;,&quot;shutter_speed&quot;:&quot;0.01&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="RDBurgerAtePhilly" data-image-description data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?fit=200%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?fit=682%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="682" height="1024" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?resize=682%2C1024&#038;quality=70&#038;strip=all&#038;ssl=1" alt class="wp-image-29543 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?resize=682%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1 682w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?resize=200%2C300&amp;quality=70&amp;strip=all&amp;ssl=1 200w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?resize=770%2C1155&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?resize=233%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 233w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?resize=680%2C1020&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?w=933&amp;quality=70&amp;strip=all&amp;ssl=1 933w" data-lazy-sizes="(max-width: 682px) 100vw, 682px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?resize=682%2C1024&amp;is-pending-load=1#038;quality=70&#038;strip=all&#038;ssl=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg"><noscript><img data-attachment-id="29543" data-permalink="https://philadelphiaweekly.com/the-rundown-may-13-20/rdburgeratephilly/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?fit=933%2C1400&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="933,1400" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;6.3&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;Canon EOS 6D&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1617761030&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;105&quot;,&quot;iso&quot;:&quot;100&quot;,&quot;shutter_speed&quot;:&quot;0.01&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="RDBurgerAtePhilly" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?fit=200%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?fit=682%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="682" height="1024" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?resize=682%2C1024&#038;quality=70&#038;strip=all&#038;ssl=1" alt="" class="wp-image-29543" srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?resize=682%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1 682w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?resize=200%2C300&amp;quality=70&amp;strip=all&amp;ssl=1 200w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?resize=770%2C1155&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?resize=233%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 233w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?resize=680%2C1020&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/05/RDBurgerAtePhilly.jpg?w=933&amp;quality=70&amp;strip=all&amp;ssl=1 933w" sizes="(max-width: 682px) 100vw, 682px" data-recalc-dims="1" /></noscript><figcaption>Image: Courtesy of STARR</figcaption></figure></div><h4><strong>More fun things in Philly to check out</strong></h4><p>As the weather warms and the pandemic restrictions ease, we’ve rounded up a few things – both virtual and live and in person – you’ll want to check out.</p><p><strong>TS Hawkins’ ‘They’ll Neglect to Tell You’</strong></p><p>Grace is a burgeoning therapist. Merci dangles for freedom at the bottom of a bourbon glass. College sweethearts and newlyweds, they elope to Philadelphia for a fresh beginning. Stumbling into polarizing landscapes, they struggle in margins of heart and home. Theatre Exile presents a Studio X-hibition virtual reading of “They’ll Neglect to Tell You,” written by international author and performance artist TS Hawkins. May 17 at 7pm. <a href="https://theatreexile.org">theatreexile.org</a></p><p><strong>Difficult Journey Home</strong><strong><em>&nbsp;</em></strong></p><p>On Friday, May 28, the Independence Seaport Museum will debut a special temporary exhibit on cruiser Olympia<em> </em>that tells the story of the warship&#8217;s transport of the Unknown Soldier across the Atlantic Ocean. Titled<a href="https://phillyseaport.org/unknownevents"> Difficult Journey Home</a>, the exhibit will feature a 10-panel installation that examines the 15-day treacherous voyage home that Olympia faced after departing from Le Havre France in 1921. The exhibit will also feature animations that highlight the tropical force winds and 20-to-30-foot waves the ship<em> </em>encountered. The exhibit will be available for viewing aboard the Olympia until Thanksgiving weekend. <a href="https://phillyseaport.org/unknownevents">phillyseaport.org</a></p><p><strong>Red Owl Tavern</strong></p><p>The modern American restaurant and bar located across from historic Independence Hall has announced the seasonal return of&nbsp; Lobster Clam Bakes – every Monday night through Labor Day with $25 Lobster Clam Bakes served in a traditional New England-style speckled pot with a copious array of seafood including half-pound lobster, clams, mussels, shrimp, corn on the cob and fingerling potatoes. Lobster Clam Bakes will remain on Red Owl Tavern’s menu throughout the week ($41), but Mondays are the day to feast on the classic summer feast when the pots are just $25 each. 433 Chestnut St. | 215.923.2267 | <a href="http://www.redowltavern.com/">redowltavern.com</a>&nbsp;</p><p><strong>A Botanical Paradise: Kazakhstan &amp; the Altai Mountains</strong></p><p>Schuylkill Center for Environmental Education and Paul Meyer present an illustrated lecture on his recent botanical travels in northeast Kazakhstan. The world’s largest landlocked country, few travelers from the western world have visited this extraordinarily beautiful region, noted for its rich steppe and alpine flora. In addition, Meyer will share stories of the people, architecture, and culture. May 20 at 7pm. <a href="https://www.schuylkillcenter.org">schuylkillcenter.org</a></p><p><strong>The Burger That Ate Philadelphia</strong></p><p>STARR’s newest virtual restaurant concept is here. An ode to classic 1950’s horror movies, The Burger That Ate Philadelphia is lean, mean and ready to <s>take</s> eat Philadelphia by storm. The Burger That Ate Philadelphia offers seven different burgers complemented by three types of fries and a variety of signature dipping sauces. Instead of your typical, eight-ounce patty, The Burger That Ate Philadelphia boasts double smash patties – crispy on the outside and juicy on the inside. <a href="https://www.google.com/maps/place/Frankford+Hall/@39.9694431,-75.1368357,17z/data=!3m1!4b1!4m5!3m4!1s0x89c6c8697963d74f:0xefe38747d15a28c7!8m2!3d39.969439!4d-75.134647">1210 Frankford Ave</a>. <a href="https://theburgerthatatephiladelphia.com">theburgerthatatephiladelphia.com</a></p><h5 class="related-posts__title">Related</h5><ul class="related-posts"><li><a href="https://philadelphiaweekly.com/online-fun-is-all-around-us-here-are-a-few-of-our-favorites/" rel="bookmark" title="Permanent Link to Online fun is all around us – here are a few of our favorites">Online fun is all around us – here are a few of our favorites</a></li><li><a href="https://philadelphiaweekly.com/the-black-coast-is-set-to-drop-quarantine-style-ep-soon/" rel="bookmark" title="Permanent Link to The Black Coast is set to drop ‘quarantine style’ EP soon">The Black Coast is set to drop ‘quarantine style’ EP soon</a></li><li><a href="https://philadelphiaweekly.com/former-pagan-freddie-augello-says-he-didnt-kill-april-kauffman/" rel="bookmark" title="Permanent Link to Former Pagan Freddie Augello says he didn’t kill April Kauffman">Former Pagan Freddie Augello says he didn’t kill April Kauffman</a></li><li><a href="https://philadelphiaweekly.com/stu-bykofsky-dont-fall-for-larry-krasners-cynical-bait-and-switch-trick/" rel="bookmark" title="Permanent Link to Stu Bykofsky: Don’t fall for Larry Krasner’s cynical bait-and-switch trick">Stu Bykofsky: Don’t fall for Larry Krasner’s cynical bait-and-switch trick</a></li></ul><ul class="Meta"><li class="Meta-item Meta-item--tags"><ul><li><a href="https://philadelphiaweekly.com/tag/events/" title=" events ">events</a></li><li><a href="https://philadelphiaweekly.com/tag/food-and-drink/" title=" food and drink ">food and drink</a></li><li><a href="https://philadelphiaweekly.com/tag/parties/" title=" parties ">parties</a></li><li><a href="https://philadelphiaweekly.com/tag/philly/" title=" philly ">philly</a></li><li><a href="https://philadelphiaweekly.com/tag/philly-events/" title=" Philly events ">Philly events</a></li><li><a href="https://philadelphiaweekly.com/tag/the-rundown/" title=" The Rundown ">The Rundown</a></li><li><a href="https://philadelphiaweekly.com/tag/things-to-do/" title=" things to do ">things to do</a></li></ul></li></ul></div></article><ul class="author-article-bio"><li class="author-bio__item"> <a class="author-bio__headshot" href="https://philadelphiaweekly.com/writer/philly-weekly-staff/"><figure><img width="100" height="100" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-headshot size-headshot wp-post-image jetpack-lazy-image" alt="Philadelphia Weekly" loading="lazy" data-attachment-id="13" data-permalink="https://philadelphiaweekly.com/favicon/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="500,500" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="favicon" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=300%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?w=500&amp;quality=70&amp;strip=all&amp;ssl=1 500w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=300%2C300&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=350%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 350w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=150%2C150&amp;quality=70&amp;strip=all&amp;ssl=1 150w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></figure> </a><div class="author-name__container"> <a class="author-bio__name" href="https://philadelphiaweekly.com/writer/philly-weekly-staff/"><h6>Philly Weekly Staff</h6> </a><ul class="author-bio__social"><li class="author-bio__social__item"> <a href="https://www.twitter.com/phillyweekly"> <i class="author-bio__social__icon fa fa-twitter" aria-hidden="true"></i><div class="author-bio__social__handle">@phillyweekly</div> </a></li></ul></div><div class="author-bio__info"><p>Articles compiled by Philly Weekly&#8217;s editorial team.</p></div></li></ul></main></div><section class="RelatedPosts"><div class="category-row__bar"><h2 class="category-row__title">Up Next in Food / Drink</h2></div><ul class="posts-row"><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/the-rundown-march-4-11/" title="The Rundown | March 4-11"> <img width="680" height="480" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/03/kevin-jarrett-SBYy3dBUKbM-unsplash-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Eastern State Penn" loading="lazy" data-attachment-id="27355" data-permalink="https://philadelphiaweekly.com/the-rundown-march-4-11/kevin-jarrett-sbyy3dbukbm-unsplash/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/03/kevin-jarrett-SBYy3dBUKbM-unsplash-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="kevin-jarrett-SBYy3dBUKbM-unsplash" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/03/kevin-jarrett-SBYy3dBUKbM-unsplash-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/03/kevin-jarrett-SBYy3dBUKbM-unsplash-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/03/kevin-jarrett-SBYy3dBUKbM-unsplash-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/03/kevin-jarrett-SBYy3dBUKbM-unsplash-scaled.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/03/kevin-jarrett-SBYy3dBUKbM-unsplash-scaled.jpg?zoom=3&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 2040w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/03/kevin-jarrett-SBYy3dBUKbM-unsplash-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/the-rundown-march-4-11/" title="The Rundown | March 4-11"><h5 class="RecentPosts-title">The Rundown | March 4-11</h5> </a><div class="posts-teaser"><p>Stuff to do – outside of your house</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Mar 4, 2021</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/icepack-may-14-21/" title="Icepack | May 14-21"> <img width="680" height="480" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/05/Icepack-Beach-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Beach" loading="lazy" data-attachment-id="19975" data-permalink="https://philadelphiaweekly.com/icepack-may-14-21/icepack-beach/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/05/Icepack-Beach-scaled.jpg?fit=2560%2C1748&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1748" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1589212473&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Icepack-Beach" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/05/Icepack-Beach-scaled.jpg?fit=300%2C205&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/05/Icepack-Beach-scaled.jpg?fit=1024%2C699&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/05/Icepack-Beach-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/05/Icepack-Beach-scaled.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/05/Icepack-Beach-scaled.jpg?zoom=3&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 2040w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/05/Icepack-Beach-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/icepack-may-14-21/" title="Icepack | May 14-21"><h5 class="RecentPosts-title">Icepack | May 14-21</h5> </a><div class="posts-teaser"><p>Sadly, ignorance know no bounds when it comes to COVID-19</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">May 14, 2020</li></ul></footer></li><li class="posts-row__item"><div class="Post-content"> <a href="https://philadelphiaweekly.com/stay-frosty-if-youve-never-tasted-the-gem-that-is-freds-water-ice-in-southwest-youre-missing-out/" title="Stay frosty: If you’ve never tasted the gem that is Fred’s Water Ice in Southwest, you’re missing out"><h5 class="RecentPosts-title">Stay frosty: If you’ve never tasted the gem that is Fred’s Water Ice in Southwest, you’re missing out</h5> </a><div class="posts-teaser"><p>Yo, Philly grubbers!</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Jul 27, 2019</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/calendar-jan-2-9/" title="Calendar: Jan. 2-9"> <img width="680" height="480" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/9-jewsandtattoos.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Guy with tattoos" loading="lazy" data-attachment-id="14852" data-permalink="https://philadelphiaweekly.com/calendar-jan-2-9/9-jewsandtattoos/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/9-jewsandtattoos.jpg?fit=1024%2C591&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1024,591" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="9-jewsandtattoos" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/9-jewsandtattoos.jpg?fit=300%2C173&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/9-jewsandtattoos.jpg?fit=1024%2C591&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/9-jewsandtattoos.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/calendar-jan-2-9/" title="Calendar: Jan. 2-9"><h5 class="RecentPosts-title">Calendar: Jan. 2-9</h5> </a><div class="posts-teaser"><p>There's a ton to get into in the city all this week. You just need to get out and explore</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Jan 4, 2020</li></ul></footer></li></ul></section><div class="Columns-row columns-even"><div class="Columns-column"><div class="most-popular"><h2>Most Popular This Week</h2><ol class="most-popular-list"><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/interests/" class="wpp-taxonomy category category-4892">Interests</a>, <a href="https://philadelphiaweekly.com/sections/news/" class="wpp-taxonomy category category-92">News</a>, <a href="https://philadelphiaweekly.com/sections/opinion/" class="wpp-taxonomy category category-3039">Opinion</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/the-thinner-blue-line/">The thinner blue line</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/interests/" class="wpp-taxonomy category category-4892">Interests</a>, <a href="https://philadelphiaweekly.com/sections/news/" class="wpp-taxonomy category category-92">News</a>, <a href="https://philadelphiaweekly.com/sections/people/" class="wpp-taxonomy category category-91">People</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/complaint-alleges-a-pattern-of-misconduct-at-district-attorneys-office/">Complaint alleges a pattern of misconduct at D.A.&#8217;s office</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="wpp-taxonomy category category-92">News</a>, <a href="https://philadelphiaweekly.com/sections/people/" class="wpp-taxonomy category category-91">People</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/im-going-to-kick-krasners-ass/">‘I’m going to kick Krasner’s ass’</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/opinion/" class="wpp-taxonomy category category-3039">Opinion</a>, <a href="https://philadelphiaweekly.com/sections/people/" class="wpp-taxonomy category category-91">People</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/stu-bykofsky-dont-fall-for-larry-krasners-cynical-bait-and-switch-trick/">Stu Bykofsky: Don’t fall for Larry Krasner’s cynical bait-and-switch trick</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="wpp-taxonomy category category-92">News</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/food-festivities-and-all-the-fireworks-planned-for-this-summers-wawa-welcome-america-celebration/">Food, festivities and ALL the fireworks planned for this summer’s Wawa Welcome America celebration</a></li></ol></div> <a class="Button" href="/popular">More Popular Articles</a></div><div class="Columns-column columns-even__right"><div class="calendar-events-teaser"><h2>Upcoming Philly Events</h2><ul class="calendar-events"><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/peppa-pig-meet-and-greets-weekend/"> <time class="calendar-events__date">Sat, May 15</time><h6 class="calendar-events__title">Peppa Pig Meet and Greets Weekend</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Sesame Place</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/measure-twice-cut-once-exploring-franklin-as-part-of-philadelphias-built-identity-2021-05-15/"> <time class="calendar-events__date">Sat, May 15</time><h6 class="calendar-events__title">Measure Twice, Cut Once: Exploring Franklin as Part of Philadelphia’s Built Identity</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Carpenters&#8217; Hall</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/philadelphia-franchise-show-2/"> <time class="calendar-events__date">Sat, May 15</time><h6 class="calendar-events__title">Philadelphia Franchise Show</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author"></li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/isaac-tin-wei-lin-liminality-2021-05-15/"> <time class="calendar-events__date">Sat, May 15</time><h6 class="calendar-events__title">Isaac Tin Wei Lin: Liminality</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Fleisher/Ollman Gallery</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/films-at-aamp-inside-buffalo-screening-and-qa/"> <time class="calendar-events__date">Sat, May 15</time><h6 class="calendar-events__title">Films at AAMP: Inside Buffalo Screening and Q&amp;A</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Virtual &#8211; Zoom</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/the-around-the-world-virtual-scavenger-hunt-the-asia-pacific-game/"> <time class="calendar-events__date">Sat, May 15</time><h6 class="calendar-events__title">The Around the World Virtual Scavenger Hunt: The Asia Pacific Game</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Virtual</li></ul></li></ul> <a class="Button" href="/calendar">More Events</a></div></div></div></div></div></div><footer class="footer"><div class="footer-section footer-section--primary"><div class="footer-container"></div></div><div class="footer-section footer-section--secondary"><div class="footer-container"><div class="footer-inner"><div class="footer-inner__branding"><div class="footer-inner__logo"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_social"><p>Follow @PhillyWeekly</p><ul class="footer-inner__social__list"><li> <a href="https://www.facebook.com/pg/phillyweekly/posts/"> <i class="fa fa-facebook-square" aria-hidden="true"></i> <span>Facebook</span> </a></li><li> <a href="https://twitter.com/PhillyWeekly/"> <i class="fa fa-twitter" aria-hidden="true"></i> <span>Twitter</span> </a></li><li> <a href="https://www.instagram.com/phillyweekly/"> <i class="fa fa-instagram" aria-hidden="true"></i> <span>Instagram</span> </a></li><li> <a href="https://philadelphiaweekly.com/feeds"> <i class="fa fa-rss" aria-hidden="true"></i> <span>Your News Reader</span> </a></li></ul></div></div><nav class="Navigation Navigation--footer"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-133"><a href="#">About PW</a><ul class="sub-menu"><li id="menu-item-334" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334"><a href="https://philadelphiaweekly.com/about/">About Us</a></li><li id="menu-item-386" class="menu-item menu-item-type-post_type_archive menu-item-object-writer menu-item-386"><a href="https://philadelphiaweekly.com/writer/">Our Writers</a></li><li id="menu-item-25676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25676"><a href="https://philadelphiaweekly.com/locations/">Dropbox Locations</a></li><li id="menu-item-336" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-336"><a href="/advertising">Advertising &#038; Partnerships</a></li><li id="menu-item-338" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-338"><a href="/events/community/add">Submit an Event</a></li></ul></li><li id="menu-item-134" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-134"><a href="#">Explore PW</a><ul class="sub-menu"><li id="menu-item-228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-228"><a href="https://philadelphiaweekly.com/sections/">Sections</a></li><li id="menu-item-137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-136" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-335"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li><li id="menu-item-29460" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29460"><a href="https://philadelphiaweekly.com/sections/altphilly/">AltPhilly Exclusives</a></li></ul></li></ul></div></nav><div class="footer-inner_contact-text"><div class="footer-inner__logo--desktop"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_contact"><p>1520 Locust Street, Fifth Floor</p><p>Philadelphia, PA 19102</p></div><div class="footer-inner_contact footer-inner_contact__phone"><p>215-543-3743</p><p><a href="mailto:mail@philadelphiaweekly.com">mail@philadelphiaweekly.com</a></p></div><div class="footer-info"> &copy; Copyright Philadelphia Weekly</div></div></div></div></footer></div><div
 class="hustle-ui hustle-popup hustle-palette--gray_slate hustle_module_id_1 module_id_1  " 
 data-id="1"
 data-render-id="0"
 data-tracking="enabled" 
 data-intro="fadeIn"
 data-outro="fadeOut"
 data-overlay-close="1"
 data-close-delay="false" 
 style="opacity: 0;"
 ><div class="hustle-popup-mask hustle-optin-mask" aria-hidden="true"></div><div class="hustle-popup-content"><div class="hustle-info hustle-info--default"><button class="hustle-button-icon hustle-button-close"> <span class="hustle-icon-close" aria-hidden="true"></span> <span class="hustle-screen-reader">Close this module</span> </button><div class="hustle-layout"><div class="hustle-layout-header"><span class="hustle-title">Enjoying Philly Weekly?</span><span class="hustle-subtitle">Consider joining altPhilly, an exclusive community with access to members-only content and more. <a href="https://philadelphiaweekly.com/join">Learn More</a></span></div><div class="hustle-layout-content"><div class="hustle-image hustle-image-fit--contain" aria-hidden="true"><img src="https://philadelphiaweekly.com/wp-content/uploads/2021/03/altphilly.jpg" alt="Alt Philly" class="hustle-image-position--centercenter" /></div></div><div class="hustle-layout-footer"><div class="hustle-cta-container"><a class="hustle-button hustle-button-cta " href="https://philadelphiaweekly.memberful.com/checkout?plan=62041" target="_blank" data-cta-type="cta">Join Now</a></div></div></div><p class="hustle-nsa-link"><a href="#">Hide this message</a></p></div></div></div> <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script>  <script type='text/javascript' src='https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script> <script type='text/javascript' id='wp-polyfill-js-after'>( 'fetch' in window ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );( 'objectFit' in document.documentElement.style ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-object-fit.min.js?ver=2.3.4"></scr' + 'ipt>' );</script> <script type='text/javascript' id='contact-form-7-js-extra'>var wpcf7 = {"api":{"root":"https:\/\/philadelphiaweekly.com\/wp-json\/","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript' id='wpa-complementary-js-extra'>var wpaComplementary = {"container":""};</script> <script type='text/javascript' id='longdesc.button-js-extra'>var wparest = {"url":"https:\/\/philadelphiaweekly.com\/wp-json\/wp\/v2\/media","text":"<span>Long Description<\/span>"};</script> <script type='text/javascript' id='jquery-ui-datepicker-js-after'>jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});</script> <script type='text/javascript' id='hustle_front-js-extra'>var Modules = [{"settings":{"auto_close_success_message":"0","triggers":{"on_time_delay":"30","on_time_unit":"seconds","on_scroll":"scrolled","on_scroll_page_percent":20,"on_scroll_css_selector":"","enable_on_click_element":"1","on_click_element":"","enable_on_click_shortcode":"1","on_exit_intent_per_session":"1","on_exit_intent_delayed_time":"0","on_exit_intent_delayed_unit":"seconds","on_adblock_delay":"0","on_adblock_delay_unit":"seconds","trigger":["time"]},"animation_in":"fadeIn","animation_out":"fadeOut","after_close_trigger":["click_close_icon"],"after_close":"keep_show","expiration":365,"expiration_unit":"days","on_submit":"nothing","on_submit_delay":"5","on_submit_delay_unit":"seconds","close_cta":"0","close_cta_time":"0","close_cta_unit":"seconds","hide_after_cta":"keep_show","hide_after_subscription":"keep_show","is_schedule":"0","schedule":{"not_schedule_start":"1","start_date":"03\/15\/2021","start_hour":"12","start_minute":"00","start_meridiem_offset":"am","not_schedule_end":"1","end_date":"03\/21\/2021","end_hour":"11","end_minute":"59","end_meridiem_offset":"pm","active_days":"all","week_days":[],"is_active_all_day":"1","day_start_hour":"00","day_start_minute":"00","day_start_meridiem_offset":"am","day_end_hour":"11","day_end_minute":"59","day_end_meridiem_offset":"pm","time_to_use":"server","custom_timezone":"UTC"},"allow_scroll_page":"0","close_on_background_click":"1","auto_hide":"0","auto_hide_unit":"seconds","auto_hide_time":"5"},"module_id":"1","blog_id":"0","module_name":"AltPhilly","module_type":"popup","active":"1","module_mode":"informational"}];
var incOpt = {"is_admin":"","native_share_enpoints":{"facebook":"https:\/\/www.facebook.com\/sharer\/sharer.php?u=https%3A%2F%2Fphiladelphiaweekly.com%2Fthe-rundown-may-13-20","twitter":"https:\/\/twitter.com\/intent\/tweet?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fthe-rundown-may-13-20&text=The%20Rundown%20%7C%20May%2013-20","pinterest":"https:\/\/www.pinterest.com\/pin\/create\/button\/?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fthe-rundown-may-13-20","reddit":"https:\/\/www.reddit.com\/submit?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fthe-rundown-may-13-20","linkedin":"https:\/\/www.linkedin.com\/shareArticle?mini=true&url=https%3A%2F%2Fphiladelphiaweekly.com%2Fthe-rundown-may-13-20","vkontakte":"https:\/\/vk.com\/share.php?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fthe-rundown-may-13-20","whatsapp":"https:\/\/api.whatsapp.com\/send?text=https%3A%2F%2Fphiladelphiaweekly.com%2Fthe-rundown-may-13-20","email":"mailto:?subject=The%20Rundown%20%7C%20May%2013-20&body=https%3A%2F%2Fphiladelphiaweekly.com%2Fthe-rundown-may-13-20"},"ajaxurl":"https:\/\/philadelphiaweekly.com\/wp-admin\/admin-ajax.php","page_id":"29534","page_slug":"the-rundown-may-13-20","is_upfront":"","script_delay":"3000"};</script> <script type='text/javascript' id='truro-scripts-js-extra'>var customizer = {"sliderSlideCount":"1","sliderLoop":"0","sliderAutoPlay":"0","sliderAutoPlaySpeed":"7000","sliderArrows":"1","sliderDots":"1"};</script> <script type='text/javascript' id='jetpack-lazy-images-js-extra'>var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};</script> <script type='text/javascript' id='jetpack-carousel-js-extra'>var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/philadelphiaweekly.com\/wp-admin\/admin-ajax.php","nonce":"bcb8dbe3f4","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/philadelphiaweekly.com\/wp-login.php?redirect_to=https%3A%2F%2Fphiladelphiaweekly.com%2Fthe-rundown-may-13-20%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};</script> <style type="text/css" id="hustle-module-1-0-styles" class="hustle-module-styles hustle-module-styles-1">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</style><link rel="stylesheet" href="https://use.typekit.net/cgg8jik.css"> <script defer src="https://philadelphiaweekly.com/wp-content/cache/autoptimize/js/autoptimize_ed87ddf12281698e80c33faef56a1db4.js"></script></body></html>