<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id="ao_optimized_gfonts" href="https://fonts.googleapis.com/css?family=Lora%3A400%2C400i%2C700&amp;display=swap" /><link rel="profile" href="http://gmpg.org/xfn/11"><meta property="fb:pages" content="23117126720" /><link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png"><link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png"><link rel="manifest" href="/site.webmanifest"><link rel="mask-icon" href="/safari-pinned-tab.svg" color="#ffc414"><meta name="msapplication-TileColor" content="#231f20"><meta name="theme-color" content="#231f20"> <style type="text/css">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</style><link rel="preload" as="style" media="all" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_8799864562268de0d9ec1a150edfc1c1.css" onload="this.onload=null;this.rel='stylesheet'" /><noscript id="aonoscrcss"><link media="all" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_8799864562268de0d9ec1a150edfc1c1.css" rel="stylesheet" /></noscript><title>The Rundown | July 30-Aug. 6 - Philadelphia Weekly</title><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://philadelphiaweekly.com/the-rundown-july-30-aug-6/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="The Rundown | July 30-Aug. 6 - Philadelphia Weekly" /><meta property="og:description" content="Our weekly list for those choosing to ride COVID-19 out behind closed doors" /><meta property="og:url" content="https://philadelphiaweekly.com/the-rundown-july-30-aug-6/" /><meta property="og:site_name" content="Philadelphia Weekly" /><meta property="article:publisher" content="https://www.facebook.com/phillyweekly/" /><meta property="article:published_time" content="2020-07-30T15:58:48+00:00" /><meta property="article:modified_time" content="2020-07-30T15:58:59+00:00" /><meta property="og:image" content="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/hanson-lu-qFEcWSM_ST8-unsplash-scaled.jpg?fit=2560%2C1985&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta property="og:image:width" content="2560" /><meta property="og:image:height" content="1985" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@phillyweekly" /><meta name="twitter:site" content="@phillyweekly" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://philadelphiaweekly.com/#organization","name":"Philadelphia Weekly","url":"https://philadelphiaweekly.com/","sameAs":["https://www.facebook.com/phillyweekly/","https://www.instagram.com/phillyweekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://twitter.com/phillyweekly"],"logo":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#logo","inLanguage":"en-US","url":"https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&quality=70&strip=all&ssl=1","width":500,"height":500,"caption":"Philadelphia Weekly"},"image":{"@id":"https://philadelphiaweekly.com/#logo"}},{"@type":"WebSite","@id":"https://philadelphiaweekly.com/#website","url":"https://philadelphiaweekly.com/","name":"Philadelphia Weekly","description":"","publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://philadelphiaweekly.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/the-rundown-july-30-aug-6/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/hanson-lu-qFEcWSM_ST8-unsplash-scaled.jpg?fit=2560%2C1985&quality=70&strip=all&ssl=1","width":2560,"height":1985,"caption":"Whether you're itching to get out of the house or are just fine with having fun from the comforts of home, this week's The Rundown has a ton for you to consider. | Image: Hanson Lu"},{"@type":"WebPage","@id":"https://philadelphiaweekly.com/the-rundown-july-30-aug-6/#webpage","url":"https://philadelphiaweekly.com/the-rundown-july-30-aug-6/","name":"The Rundown | July 30-Aug. 6 - Philadelphia Weekly","isPartOf":{"@id":"https://philadelphiaweekly.com/#website"},"primaryImageOfPage":{"@id":"https://philadelphiaweekly.com/the-rundown-july-30-aug-6/#primaryimage"},"datePublished":"2020-07-30T15:58:48+00:00","dateModified":"2020-07-30T15:58:59+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://philadelphiaweekly.com/the-rundown-july-30-aug-6/"]}]},{"@type":"Article","@id":"https://philadelphiaweekly.com/the-rundown-july-30-aug-6/#article","isPartOf":{"@id":"https://philadelphiaweekly.com/the-rundown-july-30-aug-6/#webpage"},"author":{"@id":"https://philadelphiaweekly.com/#/schema/person/6d10bb5ac4140a42ca14aa4e8065e28d"},"headline":"The Rundown | July 30-Aug. 6","datePublished":"2020-07-30T15:58:48+00:00","dateModified":"2020-07-30T15:58:59+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://philadelphiaweekly.com/the-rundown-july-30-aug-6/#webpage"},"publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"image":{"@id":"https://philadelphiaweekly.com/the-rundown-july-30-aug-6/#primaryimage"},"keywords":"Citizens Bank Park,events,fairmount park,fringe festival,Philliyes","articleSection":"Arts,Comedy,Interests","inLanguage":"en-US"},{"@type":["Person"],"@id":"https://philadelphiaweekly.com/#/schema/person/6d10bb5ac4140a42ca14aa4e8065e28d","name":"Philly Editor","image":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/a2af5953cb6b5d09567512df874c23dd?s=96&d=mm&r=g","caption":"Philly Editor"}}]}</script> <link rel='dns-prefetch' href='//www.googletagmanager.com' /><link href='https://use.typekit.net' rel='preconnect' /><link href='https://www.google-analytics.com' rel='preconnect' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Feed" href="https://philadelphiaweekly.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Comments Feed" href="https://philadelphiaweekly.com/comments/feed/" /><link rel="alternate" type="text/calendar" title="Philadelphia Weekly &raquo; iCal Feed" href="https://philadelphiaweekly.com/events/?ical=1" /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify;}</style> <script type='text/javascript'>var wpp_params = {"sampling_active":"0","sampling_rate":"50","ajax_url":"https:\/\/philadelphiaweekly.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"21637","token":"c8e38ba187","debug":""};</script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-700394-5' async></script> <script type='text/javascript'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["philadelphiaweekly.com"]} );
gtag('js', new Date());
gtag('config', 'UA-700394-5', {"anonymize_ip":true} );</script> <link rel='https://api.w.org/' href='https://philadelphiaweekly.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://philadelphiaweekly.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://philadelphiaweekly.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.1" /><link rel='shortlink' href='https://philadelphiaweekly.com/?p=21637' /><link rel="alternate" type="application/json+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fthe-rundown-july-30-aug-6%2F" /><link rel="alternate" type="text/xml+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fthe-rundown-july-30-aug-6%2F&#038;format=xml" /><meta name="generator" content="Site Kit by Google 1.8.1" /><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://philadelphiaweekly.com"><link rel="https://theeventscalendar.com/" href="https://philadelphiaweekly.com/wp-json/tribe/events/v1/" /><link rel='dns-prefetch' href='//c0.wp.com'/><link rel='dns-prefetch' href='//i0.wp.com'/><link rel='dns-prefetch' href='//i1.wp.com'/><link rel='dns-prefetch' href='//i2.wp.com'/><style type="text/css">.header{background-color: #0a0a0a;}.header .SearchForm-button{color: #ffffff;}.Navigation--primary{color: #ffffff;}</style><style type="text/css">/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}</style> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link rel="amphtml" href="https://philadelphiaweekly.com/the-rundown-july-30-aug-6/amp/"><link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=32%2C21&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=192%2C128&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=180%2C120&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=270%2C180&#038;quality=70&#038;strip=all&#038;ssl=1" /> <script>window.dataLayer = window.dataLayer || [];
	  function gtag(){dataLayer.push(arguments);}
	  gtag('js', new Date());

	  gtag('config', 'UA-700394-5');</script> </head><body class="post-template-default single single-post postid-21637 single-format-standard tribe-no-js tribe-theme-parent-truro tribe-theme-child-truro-pw-child"> <a class="skip-link screen-reader-text" href="#Content">Skip to content</a><header class="header header--four"><div class="header-section header-section--primary"><div class="header-container"><div class="header-sectionInner"><div class="header-part"><div class="Branding"> <a href="https://philadelphiaweekly.com/" rel="home"> <img class="Branding-logo" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/PW-weekly-white-horizontal-1-1.svg" alt="Philadelphia Weekly" width="200px" /> </a></div></div><div class="header-part header-part__navigation"><nav class="Navigation Navigation--primary"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation" class="menu"><li id="menu-item-227" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li id="menu-item-221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li id="menu-item-188" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li id="menu-item-191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li id="menu-item-192" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li id="menu-item-193" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li id="menu-item-194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li id="menu-item-7201" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li id="menu-item-195" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li id="menu-item-222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li id="menu-item-518" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li id="menu-item-375" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li id="menu-item-377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li id="menu-item-385" class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li id="menu-item-366" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-366"><a href="https://philadelphiaweekly.com/sections/featured-sections/savage-love/">Savage Love</a></li><li id="menu-item-384" class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li id="menu-item-543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-128" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></nav><div class="utility-navigation"><form class="SearchForm SearchForm--header" method="get" action="https://philadelphiaweekly.com/"> <span class="screen-reader-text">Search for:</span> <input class="SearchForm-field" type="text" placeholder="Type &amp; press enter" value="" name="s" title="Search for:" /> <button type="submit" class="screen-reader-text" aria-label="Search">Search</button> <button class="SearchForm-button" aria-label="Submit"><i class="fa fa-search" aria-hidden="true"></i></button></form></div></div></div></div></div></header><nav class="Navigation Navigation--mobile"><div class="container"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-366"><a href="https://philadelphiaweekly.com/sections/featured-sections/savage-love/">Savage Love</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></div></nav><div class="content content--fullWidth" id="content"><div class="content-inner"><div class="content-container"><div class="content-row content-row--article"><main class="content-main"><header class="article-header"><div class="meta-tags"> <span class="Meta-item"><li class="Meta-item Meta-item--categories"><ul class="Meta Meta--banner"><li class="Meta-item Meta-item--categories"><ul><li><a href="https://philadelphiaweekly.com/sections/arts/" title="Arts">Arts</a></li><li><a href="https://philadelphiaweekly.com/sections/comedy/" title="Comedy">Comedy</a></li><li><a href="https://philadelphiaweekly.com/sections/interests/" title="Interests">Interests</a></li></ul></li></ul></li> </span></div><h1>The Rundown | July 30-Aug. 6</h1><div class="posts-teaser"><p>Our weekly list for those choosing to ride COVID-19 out behind closed doors</p></div><footer class="Post-footer"><ul class="Meta Meta--article"><li class="Meta-item Meta-item--author"> <a class="meta-author-article" href="https://philadelphiaweekly.com/writer/eugene-zenyatta/"><figure class="meta-author-headshot"><img width="200" height="200" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-headshot size-headshot wp-post-image jetpack-lazy-image" alt="" data-attachment-id="16719" data-permalink="https://philadelphiaweekly.com/writer/eugene-zenyatta/joe-hernandez-oebdsi0q4f0-unsplash/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="joe-hernandez-OebdsI0Q4F0-unsplash" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 200w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=680%2C680&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=1472%2C1472&amp;quality=70&amp;strip=all&amp;ssl=1 1472w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=1104%2C1104&amp;quality=70&amp;strip=all&amp;ssl=1 1104w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=912%2C912&amp;quality=70&amp;strip=all&amp;ssl=1 912w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=550%2C550&amp;quality=70&amp;strip=all&amp;ssl=1 550w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=470%2C470&amp;quality=70&amp;strip=all&amp;ssl=1 470w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?zoom=2&amp;resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 400w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?zoom=3&amp;resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 600w" data-lazy-sizes="(max-width: 200px) 100vw, 200px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></figure> <span class="meta-author-name">Eugene Zenyatta</span></a></li><li class="Meta-item Meta-item--date">July 30th, 2020</li></ul><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/the-rundown-july-30-aug-6/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20The Rundown | July 30-Aug. 6%20-%20https://philadelphiaweekly.com/the-rundown-july-30-aug-6/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20The Rundown | July 30-Aug. 6%20-%20https://philadelphiaweekly.com/the-rundown-july-30-aug-6/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: The Rundown | July 30-Aug. 6%20https://philadelphiaweekly.com/the-rundown-july-30-aug-6/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></footer></header><header class="Post-header"><figure class="Post-thumbnail"> <a data-fancybox="gallery" data-caption="Whether you&#8217;re itching to get out of the house or are just fine with having fun from the comforts of home, this week&#8217;s The Rundown has a ton for you to consider. | Image: Hanson Lu" href="https://philadelphiaweekly.com/wp-content/uploads/2020/07/hanson-lu-qFEcWSM_ST8-unsplash-scaled.jpg"><img width="1200" height="675" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/hanson-lu-qFEcWSM_ST8-unsplash-scaled.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-feature-image size-feature-image wp-post-image jetpack-lazy-image" alt="Woman dancing" data-attachment-id="21648" data-permalink="https://philadelphiaweekly.com/the-rundown-july-30-aug-6/hanson-lu-qfecwsm_st8-unsplash/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/hanson-lu-qFEcWSM_ST8-unsplash-scaled.jpg?fit=2560%2C1985&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1985" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="hanson-lu-qFEcWSM_ST8-unsplash" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/hanson-lu-qFEcWSM_ST8-unsplash-scaled.jpg?fit=300%2C233&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/hanson-lu-qFEcWSM_ST8-unsplash-scaled.jpg?fit=1024%2C794&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/hanson-lu-qFEcWSM_ST8-unsplash-scaled.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1 1200w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/hanson-lu-qFEcWSM_ST8-unsplash-scaled.jpg?zoom=2&amp;resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1 2400w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/hanson-lu-qFEcWSM_ST8-unsplash-scaled.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></a><figcaption>Whether you&#8217;re itching to get out of the house or are just fine with having fun from the comforts of home, this week&#8217;s The Rundown has a ton for you to consider. | Image: Hanson Lu</figcaption></figure></header><div class="sharing-desktop"><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/the-rundown-july-30-aug-6/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20The Rundown | July 30-Aug. 6%20-%20https://philadelphiaweekly.com/the-rundown-july-30-aug-6/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20The Rundown | July 30-Aug. 6%20-%20https://philadelphiaweekly.com/the-rundown-july-30-aug-6/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: The Rundown | July 30-Aug. 6%20https://philadelphiaweekly.com/the-rundown-july-30-aug-6/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></div><article id="Post-21637"  class="Post Post--single post-21637 post type-post status-publish format-standard has-post-thumbnail hentry category-arts category-comedy category-interests tag-citizens-bank-park tag-events tag-fairmount-park tag-fringe-festival tag-philliyes"><div class="Post-content"><h4>E<strong>vents and openings giving us life again </strong></h4><p>Things are slowly getting up-to-speed again. Here are a few events, specials and reopenings that prove that statement.</p><p><strong>Virtual Hamlet</strong></p><p>Laurel Hill Cemetery and REV Theatre Company are teaming up to bring a theatrical experience like no other. “Hamlet,” a virtual reading, will feature a glittering cast of Philadelphia actors all performing one of William Shakespeare&#8217;s most famous plays. The tragedy of Hamlet: a prince haunted by his murdered father looking for revenge. Falling into madness, the country of Denmark&#8217;s beloved rulers face the truth of their monarchy. This free virtual, theatrical reading will take place Saturday, Aug. 1, at 7:30 pm on Zoom. Donations appreciated. thelaurelhillcemetery.org/events/hamlet.</p><p><strong>Park fun</strong></p><p>Fairmount Park Conservancy is encouraging park-goers to safely explore the lesser-known gems of East and West Fairmount Park this summer and fall. The nonprofit champion for Philadelphia parks is offering a variety of ways to discover all that the 2,050-acre park offers, from a new free scavenger hunt to guided yoga and hikes to solo park cleanups. In addition, the Conservancy has created a new digital guide, highlighting trails, historic landmarks, and natural areas in Fairmount Park. The Fairmount Park Digital Guide allows users to find less traveled gems all on their own. Find the guide at <a href="http://www.myphillypark.org/">myphillypark.org</a>.</p><p><strong>Red Owl is back</strong></p><p>Guess WHO&#8217;s back? Red Owl Tavern, Old City’s modern American restaurant and bar perched on the corner of 5th and Chestnut streets across from Independence Hall, has re-opened for takeout with outdoor dining and brunch. Diners are encouraged to grab their Quaran-Team and sit down for a sizzling lunch or dinner on the sunny, socially-distanced patio across from Independence Hall, order a delicious takeout meal, or stop by for grab-and-go breakfast items. The all-too-tempting brunch menu includes favorites such as the Tavern Omelet, Berry Cobbler French Toast, Egg White Scramble, or Breakfast Sandwich. The brunch menu will be expanded to include some lunch offerings and will be available on Saturdays from Noon to 7pm, and on Sundays from 10am to 3 pm on Red Owl Tavern’s expansive patio. 422 Chestnut St. <a href="http://www.redowltavern.com/">RedOwlTavern.com</a>. 215- 923-2267.</p><figure class="wp-block-image size-large"><img data-attachment-id="21641" data-permalink="https://philadelphiaweekly.com/the-rundown-july-30-aug-6/rundown-chicken/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Rundown-chicken" data-image-description data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" alt class="wp-image-21641 jetpack-lazy-image" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?w=2560&amp;quality=70&amp;strip=all&amp;ssl=1 2560w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?resize=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?resize=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?resize=770%2C513&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?resize=1536%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?resize=2048%2C1365&amp;quality=70&amp;strip=all&amp;ssl=1 2048w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?resize=525%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 525w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?resize=1240%2C827&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?resize=680%2C453&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?w=2280&amp;quality=70&amp;strip=all&amp;ssl=1 2280w" data-lazy-sizes="(max-width: 1140px) 100vw, 1140px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg"><noscript><img data-attachment-id="21641" data-permalink="https://philadelphiaweekly.com/the-rundown-july-30-aug-6/rundown-chicken/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Rundown-chicken" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" alt="" class="wp-image-21641" srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?w=2560&amp;quality=70&amp;strip=all&amp;ssl=1 2560w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?resize=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?resize=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?resize=770%2C513&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?resize=1536%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?resize=2048%2C1365&amp;quality=70&amp;strip=all&amp;ssl=1 2048w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?resize=525%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 525w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?resize=1240%2C827&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?resize=680%2C453&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Rundown-chicken-scaled.jpg?w=2280&amp;quality=70&amp;strip=all&amp;ssl=1 2280w" sizes="(max-width: 1140px) 100vw, 1140px" /></noscript><figcaption>We&#8217;re just going to leave this deliciousness right here for your viewing pleasure. | Image provided</figcaption></figure><p><strong>Fried chicken Fridays</strong></p><p>Running through Friday, Aug. 14, The Bourse Food Hall invites fried chicken lovers to its patio for “Fried Chicken Fridays” with Freebyrd Chicken, a month-long pop-up. Each Friday from 3-8 pm, Freebyrd Chicken will be on The Bourse’s 5th Street patio across from Independence Mall slinging grab-and-go fried chicken sandwiches and beers. All guests must be seated at a table after ordering. Masks are required at all times, unless seated. Tables are first-come, first-served. 111 S Independence Mall E in Philadelphia’s Old City District. Theboursephilly.com.</p><p><strong>BlackStar Film Festival</strong></p><p>Philly Stewards gave us a heads up on this event, which takes place Aug. 20-26. While online this year, you’ll see a lot of panels and films from Black and Brown filmmakers, including one session where prospective movie makers can make their pitches to a panel of experts. Visit blackstarfest.org for a complete lineup, ticket info and more.</p><figure class="wp-block-image size-large"><img data-attachment-id="21640" data-permalink="https://philadelphiaweekly.com/the-rundown-july-30-aug-6/sooc-cbp/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?fit=2247%2C1500&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2247,1500" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;7.1&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1491394664&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;70&quot;,&quot;iso&quot;:&quot;640&quot;,&quot;shutter_speed&quot;:&quot;0.00025&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SOOC-CBP" data-image-description data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?fit=1024%2C684&amp;quality=70&amp;strip=all&amp;ssl=1" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?fit=1024%2C684&amp;quality=70&amp;strip=all&amp;ssl=1" alt class="wp-image-21640 jetpack-lazy-image" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?w=2247&amp;quality=70&amp;strip=all&amp;ssl=1 2247w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?resize=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?resize=1024%2C684&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?resize=770%2C514&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?resize=1536%2C1025&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?resize=2048%2C1367&amp;quality=70&amp;strip=all&amp;ssl=1 2048w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?resize=524%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 524w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?resize=1240%2C828&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?resize=680%2C454&amp;quality=70&amp;strip=all&amp;ssl=1 680w" data-lazy-sizes="(max-width: 1140px) 100vw, 1140px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?fit=1024%2C684&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg"><noscript><img data-attachment-id="21640" data-permalink="https://philadelphiaweekly.com/the-rundown-july-30-aug-6/sooc-cbp/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?fit=2247%2C1500&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2247,1500" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;7.1&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1491394664&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;70&quot;,&quot;iso&quot;:&quot;640&quot;,&quot;shutter_speed&quot;:&quot;0.00025&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SOOC-CBP" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?fit=1024%2C684&amp;quality=70&amp;strip=all&amp;ssl=1" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?fit=1024%2C684&amp;quality=70&amp;strip=all&amp;ssl=1" alt="" class="wp-image-21640" srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?w=2247&amp;quality=70&amp;strip=all&amp;ssl=1 2247w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?resize=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?resize=1024%2C684&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?resize=770%2C514&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?resize=1536%2C1025&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?resize=2048%2C1367&amp;quality=70&amp;strip=all&amp;ssl=1 2048w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?resize=524%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 524w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?resize=1240%2C828&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/SOOC-CBP.jpg?resize=680%2C454&amp;quality=70&amp;strip=all&amp;ssl=1 680w" sizes="(max-width: 1140px) 100vw, 1140px" /></noscript><figcaption>Citizens Bank Park will be the home of the Live-In, Drive-In concert series, a four-week local drive-in concert series featuring musical guests, comedy shows and more. | Image: Maria S. Young</figcaption></figure><h4><strong>How we’ll be enjoying the Live-In/Drive In concert series</strong></h4><p>Live Nation Philadelphia, in partnership with the Philadelphia Phillies, recently announced plans for a four-week local drive-in concert series coming to the parking lot of Citizens Bank Park, home of the Phillies. The Live-In/Drive-In Concert Series presented by Budweiser Zero, a new alcohol-free brew from Budweiser, kicks off on Sunday, Aug. 16 and will continue with a wide variety of musical genres through Labor Day Weekend. Visit <a href="http://phillies.com/drivein">phillies.com/drivein</a> for the full lineup and details, but here are a few acts we’re excited to see.</p><p><strong>AJR</strong></p><p>Multi-platinum indie pop trio AJR has today announced “A Night In Your Car with AJR,” a special drive-in show at Citizens Bank Park in Philadelphia on Aug. 19. AJR’s latest single “<a href="https://open.spotify.com/track/53BHUFdQphHiZUUG3nx9zn?si=BUgxr0anTaqQBU9g1xAJjQ">BANG!</a>” has racked up more than 90 million worldwide streams, is No. 2 at Alternative Radio and recently made its Billboard Hot 100 debut. In their decade music roundups, Spotify named AJR’s smash “Sober Up” one of the Best Rock Songs of the 2010s and Apple Music named AJR’s hit “Weak” one of the Best Alt Songs of the 2010s.</p><p><strong>Lotus</strong></p><p>Long-running Philadelphia-based instrumental-electronic quintet Lotus, which is releasing its new album “Free Swim” on Aug. 21, will return to the live stage on Friday, Sept. 4. “It has without a doubt been a trying time for everyone,” shares the group’s Jesse Miller. “As a band who has built our sound, following and career around live performances, it has been tough to cancel show after show. With all that in mind, we are embracing the chance to play this unique drive-in show. While it might be different than packing onto a dance floor, we hope we can take this opportunity to capture the magic and energy that is improvised music played live.”</p><p><strong>The Front Bottoms</strong></p><p>The Front Bottoms will hit the drive-in stage Sunday, Aug. 23. This Jersey-based duo has been around for awhile now and won legions of fans with its alt-rock, punk sound. Want to warm up for the show? The Front Bottoms dropped a new album only a few weeks ago.</p><p><strong>Michael Blackson &amp; Friends with special guest DJ Jazzy Jeff</strong></p><p>Catch the comedian – and apparently some of his friends – along with the legendary DJ Jazzy Jeff on Monday, Sept. 7. It’s an awesome way to wrap up this series, right? Blackson has appeared in a number of movies, but you might know him for his appearances at local comedy clubs back in the day right here in Philly.</p><p><strong>Pigeons Playing Ping Pong</strong></p><p>OK, we admit we didn’t know who these guys were, but, with a name like that, we had to find out. Turns out they’re a Baltimore funk-jam band that will be at the series Aug. 21. Just Google them and click the “Images” button. After you see photos of them in action, we think you’ll agree that this is a show you’ll want to see.</p><p><strong>The Struts</strong></p><p>The English rock band hits the stage on Saturday, Aug. 22. They’ve been around for just short of a decade, and you’ve probably not only heard their music, but also seen them on a number of national television shows. Or maybe you caught them as an opening act for some of the biggest names in the business. In any event, you don’t want to miss this performance in Philly.</p><figure class="wp-block-image size-large"><img data-attachment-id="21639" data-permalink="https://philadelphiaweekly.com/the-rundown-july-30-aug-6/valleyforge-national-historical-park-2200vp/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?fit=2200%2C1237&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2200,1237" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ValleyForge-National-Historical-Park-2200VP" data-image-description data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?fit=300%2C169&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?fit=1024%2C576&amp;quality=70&amp;strip=all&amp;ssl=1" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?fit=1024%2C576&amp;quality=70&amp;strip=all&amp;ssl=1" alt class="wp-image-21639 jetpack-lazy-image" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?w=2200&amp;quality=70&amp;strip=all&amp;ssl=1 2200w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?resize=300%2C169&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?resize=1024%2C576&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?resize=770%2C433&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?resize=1536%2C864&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?resize=2048%2C1152&amp;quality=70&amp;strip=all&amp;ssl=1 2048w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1 1200w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?resize=622%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 622w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?resize=1240%2C697&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?resize=680%2C382&amp;quality=70&amp;strip=all&amp;ssl=1 680w" data-lazy-sizes="(max-width: 1140px) 100vw, 1140px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?fit=1024%2C576&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg"><noscript><img data-attachment-id="21639" data-permalink="https://philadelphiaweekly.com/the-rundown-july-30-aug-6/valleyforge-national-historical-park-2200vp/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?fit=2200%2C1237&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2200,1237" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ValleyForge-National-Historical-Park-2200VP" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?fit=300%2C169&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?fit=1024%2C576&amp;quality=70&amp;strip=all&amp;ssl=1" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?fit=1024%2C576&amp;quality=70&amp;strip=all&amp;ssl=1" alt="" class="wp-image-21639" srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?w=2200&amp;quality=70&amp;strip=all&amp;ssl=1 2200w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?resize=300%2C169&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?resize=1024%2C576&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?resize=770%2C433&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?resize=1536%2C864&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?resize=2048%2C1152&amp;quality=70&amp;strip=all&amp;ssl=1 2048w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1 1200w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?resize=622%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 622w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?resize=1240%2C697&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/ValleyForge-National-Historical-Park-2200VP.jpg?resize=680%2C382&amp;quality=70&amp;strip=all&amp;ssl=1 680w" sizes="(max-width: 1140px) 100vw, 1140px" /></noscript><figcaption>Have you ever considered listening to the history that is Valley Forge National Park? This weekend, consider taking a drive, loading up an audio tour of the park and get educated. | Image courtesy: Visit Philadelphia</figcaption></figure><h4><strong>How we’re exploring Philly, on our own</strong></h4><p>Everybody has their own schedules to keep – especially these days. So why not make your own itinerary when it comes to exploring some of the history around the region? Visit Philly just released a list of self-guided tours to help you do just that. Go to visitphilly.com for the complete list, links and details, but here are a few tours worth checking out.</p><p><a href="https://encampmentstore.org/audio-tours/"><strong>Audio Tour of Valley Forge National Historical Park</strong></a></p><p>No battles were fought in <a href="https://www.visitphilly.com/things-to-do/attractions/valley-forge-national-historical-park/">Valley Forge</a>, but the time the Continental Army encamped here in 1777 and 1778 went down as one of the Revolutionary War’s most trying periods. Take a deep dive into Valley Forge’s history at your own pace via the park’s official audio tour, available for purchase <a href="https://encampmentstore.org/audio-tours/">to stream</a> or <a href="https://encampmentstore.org/product/official-audio-tour-of-valley-forge-nhp/">on CD</a>. Drive through the park, accompanied by period music, while character voices help you envision the 18th-century encampment during a 60-minute tour.</p><p><a href="https://www.inquirer.com/things-to-do/philly-walking-tour-black-history-sites-underground-railroad-anti-slavery-audio-tour-20200213.html"><strong>Anti-Slavery Walking Tours from The Philadelphia Inquirer</strong></a></p><p>Philadelphians were heavily involved in the abolitionist movement, and the <a href="https://www.visitphilly.com/articles/philadelphia/underground-railroad-in-philadelphia/">Underground Railroad</a> passed through the city, helping enslaved people find freedom here and north into Canada. <a href="https://www.inquirer.com/things-to-do/philly-walking-tour-black-history-sites-underground-railroad-anti-slavery-audio-tour-20200213.html">Two free audio tours</a> from The Philadelphia Inquirer guide people through <a href="https://www.visitphilly.com/areas/philadelphia-neighborhoods/old-city/">Old City</a> and <a href="https://www.visitphilly.com/areas/philadelphia-neighborhoods/society-hill/">Society Hill</a> and around Northwest Philadelphia to visit anti-slavery landmarks like Congo Square (now <a href="https://www.visitphilly.com/things-to-do/attractions/washington-square/">Washington Square</a>), a convening space and burial ground for the Black community; and Germantown’s <a href="https://www.visitphilly.com/things-to-do/attractions/the-johnson-house-historical-site-inc/">Johnson House Historic Site</a>, which served as an Underground Railroad stop and may have hosted Harriet Tubman.</p><p><strong>T</strong><a href="http://www.preservationalliance.com/explore-philadelphia/self-guided-walking-tours/"><strong>he Preservation Alliance of Greater Philadelphia</strong></a></p><p>Known for their in-depth guided tours of Philly architecture, the Preservation Alliance for Greater Philadelphia also offers <a href="http://www.preservationalliance.com/explore-philadelphia/self-guided-walking-tours/">three free self-guided tours</a> available online. The <a href="https://www.visitphilly.com/areas/philadelphia-neighborhoods/rittenhouse-square/">Rittenhouse Square neighborhood</a> is so history-dense that separate tours are needed to cover the <a href="http://www.preservationalliance.com/wp-content/uploads/2014/09/RE-Layout5_061809.pdf">east</a> and <a href="http://www.preservationalliance.com/wp-content/uploads/2014/09/RW.pdf">west</a> parts of the area. And don’t sleep on a walk through roomy <a href="http://www.preservationalliance.com/wp-content/uploads/2014/09/GE-Layout6_061809.pdf">Girard Estate</a> in deep South Philly, complete with an engrossing story involving the richest man in America and a rare planned community in the city.</p><p><a href="https://www.tripadvisor.com/AttractionProductReview-g60795-d17349827-Operation_City_Quest_Scavenger_Hunt_Philadelphia_PA-Philadelphia_Pennsylvania.html"><strong>Operation City Quest Scavenger Hunt</strong></a></p><p>Charge up your mobile device (consider bringing a portable charger!) and put on your detective’s hat for this <a href="https://www.tripadvisor.com/AttractionProductReview-g60795-d17349827-Operation_City_Quest_Scavenger_Hunt_Philadelphia_PA-Philadelphia_Pennsylvania.html">outdoor scavenger hunt</a> that starts on Independence Mall. Great for solo adventure seekers or small groups, this 150-object hunt is a game, knowledge test and history lesson all rolled into one. Take photos of your finds to score points and complete the challenge.</p><p><a href="https://www.visitphilly.com/articles/philadelphia/essential-lgbt-sites-things-to-do-philadelphia/#john-fryer-historical-marker"><strong>LGBTQ Sites in Greater Philadelphia</strong></a></p><p>Philadelphia hosted the country’s first major demonstration for LGBTQ rights, the <a href="https://www.visitphilly.com/articles/philadelphia/essential-lgbt-sites-things-to-do-philadelphia/#reminder-day-marker">Annual Reminders</a>, in 1965. But the city’s history of equality activism long predates that and continues today, as evidenced by public art, historical markers and notable attractions. A <a href="https://www.visitphilly.com/articles/philadelphia/essential-lgbt-sites-things-to-do-philadelphia/#a-tribute-to-gloria-casarez-mural">colorful mural</a> pays tribute to the late Gloria Casarez, Philadelphia’s first director of the Office of LGBTQ Affairs; and historical markers recall the contributions of <a href="https://www.visitphilly.com/articles/philadelphia/essential-lgbt-sites-things-to-do-philadelphia/#john-fryer-historical-marker">John Fryer</a>, who helped declassify homosexuality as a mental illness, and <a href="https://www.visitphilly.com/articles/philadelphia/essential-lgbt-sites-things-to-do-philadelphia/#barbara-gittings-home">Barbara Gittings</a>, who edited the nation’s first lesbian magazine. The <a href="https://www.visitphilly.com/articles/philadelphia/essential-lgbt-sites-things-to-do-philadelphia/">guide</a> to Philly’s LGBTQ history includes many more sites, including some that are in the public space or don’t require admission fees.</p><p><a href="https://thelaurelhillcemetery.org/visit/tours-activities"><strong>Self-Guided Tours of Laurel Hill Cemetery</strong></a></p><p>This circa-1836 <a href="https://www.visitphilly.com/things-to-do/attractions/laurel-hill-and-west-laurel-hill-cemeteries/">Northwest Philly cemetery</a> with picturesque views of the Schuylkill River offers more than pleasant outdoor strolling. Download the <a href="https://thelaurelhillcemetery.org/visit/tours-activities">cemetery’s free app</a> and venture out on one of three themed tours – Art &amp; Architecture; Pop Culture &amp; Contemporary Stories; and Lore &amp; Legends – to visit permanent residents like Sarah Josepha Hale (author of “Mary Had a Little Lamb”) and former Philadelphia Phillies announcer Harry Kalas. Pair a visit with gorgeous bike- and pedestrian-friendly Kelly Drive via the park’s southwest entrance, or explore nearby East Falls’ dining offerings (like fried chicken from Foghorn or pizza from In Riva).</p><figure class="wp-block-image size-large"><img data-attachment-id="21644" data-permalink="https://philadelphiaweekly.com/the-rundown-july-30-aug-6/fringe-rundown-1/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Fringe-Rundown-1" data-image-description data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" alt class="wp-image-21644 jetpack-lazy-image" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?w=2560&amp;quality=70&amp;strip=all&amp;ssl=1 2560w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?resize=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?resize=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?resize=770%2C513&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?resize=1536%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?resize=2048%2C1365&amp;quality=70&amp;strip=all&amp;ssl=1 2048w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?resize=525%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 525w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?resize=1240%2C827&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?resize=680%2C453&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?w=2280&amp;quality=70&amp;strip=all&amp;ssl=1 2280w" data-lazy-sizes="(max-width: 1140px) 100vw, 1140px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg"><noscript><img data-attachment-id="21644" data-permalink="https://philadelphiaweekly.com/the-rundown-july-30-aug-6/fringe-rundown-1/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Fringe-Rundown-1" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" alt="" class="wp-image-21644" srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?w=2560&amp;quality=70&amp;strip=all&amp;ssl=1 2560w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?resize=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?resize=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?resize=770%2C513&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?resize=1536%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?resize=2048%2C1365&amp;quality=70&amp;strip=all&amp;ssl=1 2048w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?resize=525%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 525w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?resize=1240%2C827&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?resize=680%2C453&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Fringe-Rundown-1-scaled.jpg?w=2280&amp;quality=70&amp;strip=all&amp;ssl=1 2280w" sizes="(max-width: 1140px) 100vw, 1140px" /></noscript><figcaption>The Fringe Festival which kicks off Sept. 10-Oct. 4 is going entirely virtual this year, with over 125 events to choose from. A massive undertaking, but not the first rodeo doing things virtually for this annual fest. | Image provided</figcaption></figure><h4><strong>How we’re getting ready for Fringe Festival this year</strong></h4><p>FringeArts has announced the artists participating in the 2020 Philadelphia Fringe Festival. The 24th annual Fringe Festival runs Sept. 10 through Oct. 4, and the 125-plus works will take place largely online, with a handful of outdoor, distanced performances, health conditions permitting. Full festival details, including show, schedule, and ticketing information, will be announced in mid-August. Head over to <a href="http://www.fringearts.com/">FringeArts.com</a> for more information, both now and when all the details are released, and a list of curated and independent artists. In the meantime, here’s a quick look at what we know now.</p><p><strong>Curated productions</strong></p><p>FringeArts will present 12 productions as part of this year’s curated slate, including works by The Bearded Ladies Cabaret; Nichole Canuso Dance Company; David Gordon; Jaamil Olawale Kosoko; Trey Lyford, Geoff Sobelle, and Steve Cuiffo; and Swim Pony, the Philadelphia Environmental Council, Toasterlab, and Mike Kiley.&nbsp;</p><p><strong>Additional artists</strong></p><p>Also participating in this year’s festival are the artists from FringeArts’ 2020 High Pressure Fire Service series – Nell Bang-Jensen, Emily Bate, Kyle Dacuyan + Antigravity Performance Project, James Allister Sprang and Alexandra Tatarsky – whose spring performances were not able to be presented as scheduled due to the pandemic. The Philadelphia School of Circus Arts, originally scheduled to participate in FringeArts’ 2020 Hand to Hand Circus Festival, completes the lineup for this year’s Curated Fringe.</p><p><strong>The Bookstore</strong></p><p>The Fringe Festival Bookstore will return this year in a virtual capacity, featuring talks with artists and community partners to provide context for the works in the curated slate, and reflect on the current moment in the arts and society at large. All talks will take place online and will be free of charge.</p><p><strong>Digital performances</strong></p><p>The Philadelphia Fringe Festival has featured a Digital Fringe component since 2015, but this year, digital shows make up over 80 percent of the lineup. The majority of these works will be presented virtually via Zoom, YouTube, Discord and Twitch, among others. Some will be available to watch throughout the festival, while others will have specific viewing times and involve a degree of interactivity between performers and audiences.&nbsp;</p><p><strong>Virtual town hall</strong></p><p>FringeArts will host a virtual town hall via Zoom in mid-August following the full programming announcement to go over the many changes to this year’s festival, including health and safety practices, how best to engage with the festival, access digital content, and more, as well as answer any questions audience members might have.</p><p><strong>In-person performances</strong></p><p>There are currently 24 shows in the 2020 Fringe Festival scheduled to take place with in-person, outdoor components. There will be no indoor performances, as directed by the Philadelphia Department of Health. Audience size for all outdoor shows will be limited, and ticket reservations must be made in advance to maintain capacity and ensure hands-free transactions. Attendees will be required to wear masks and observe social distancing regulations. Staff will monitor the local outbreak numbers daily and are prepared to adjust or cancel in-person presentations should health conditions worsen and Philadelphia shift or change its guidelines.</p><h5 class="related-posts__title">Related</h5><ul class="related-posts"><li><a href="https://philadelphiaweekly.com/calendar-march-5-12/" rel="bookmark" title="Permanent Link to Calendar | March 5-12">Calendar | March 5-12</a></li><li><a href="https://philadelphiaweekly.com/the-rundown-july-23-30/" rel="bookmark" title="Permanent Link to The Rundown | July 23-30">The Rundown | July 23-30</a></li><li><a href="https://philadelphiaweekly.com/the-rundown-may-28-june-4/" rel="bookmark" title="Permanent Link to The Rundown | May 28-June 4">The Rundown | May 28-June 4</a></li><li><a href="https://philadelphiaweekly.com/calendar-feb-27-march-5/" rel="bookmark" title="Permanent Link to Calendar | Feb. 27-March 5">Calendar | Feb. 27-March 5</a></li></ul><ul class="Meta"><li class="Meta-item Meta-item--tags"><ul><li><a href="https://philadelphiaweekly.com/tag/citizens-bank-park/" title=" Citizens Bank Park ">Citizens Bank Park</a></li><li><a href="https://philadelphiaweekly.com/tag/events/" title=" events ">events</a></li><li><a href="https://philadelphiaweekly.com/tag/fairmount-park/" title=" fairmount park ">fairmount park</a></li><li><a href="https://philadelphiaweekly.com/tag/fringe-festival/" title=" fringe festival ">fringe festival</a></li><li><a href="https://philadelphiaweekly.com/tag/philliyes/" title=" Philliyes ">Philliyes</a></li></ul></li></ul></div></article><ul class="author-article-bio"><li class="author-bio__item"> <a class="author-bio__headshot" href="https://philadelphiaweekly.com/writer/eugene-zenyatta/"><figure><img width="200" height="200" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-headshot size-headshot wp-post-image jetpack-lazy-image" alt="" data-attachment-id="16719" data-permalink="https://philadelphiaweekly.com/writer/eugene-zenyatta/joe-hernandez-oebdsi0q4f0-unsplash/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="joe-hernandez-OebdsI0Q4F0-unsplash" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 200w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=680%2C680&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=1472%2C1472&amp;quality=70&amp;strip=all&amp;ssl=1 1472w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=1104%2C1104&amp;quality=70&amp;strip=all&amp;ssl=1 1104w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=912%2C912&amp;quality=70&amp;strip=all&amp;ssl=1 912w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=550%2C550&amp;quality=70&amp;strip=all&amp;ssl=1 550w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=470%2C470&amp;quality=70&amp;strip=all&amp;ssl=1 470w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?zoom=2&amp;resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 400w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?zoom=3&amp;resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 600w" data-lazy-sizes="(max-width: 200px) 100vw, 200px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></figure> </a><div class="author-name__container"> <a class="author-bio__name" href="https://philadelphiaweekly.com/writer/eugene-zenyatta/"><h6>Eugene Zenyatta</h6> </a></div><div class="author-bio__info"><p>Eugene Zenyatta was raised on old-time Memphis 'rasslin' and strongly prefers the company of dogs to people. His greatest heartbreak came in the 2010 Breeders' Cup Classic.</p></div></li></ul></main></div><section class="RelatedPosts"><div class="category-row__bar"><h2 class="category-row__title">Up Next in Arts</h2></div><ul class="posts-row"><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/america-by-way-of-nairobi-singer-songwriter-j-s-ondara-welcomes-you-to-his-american-dream/" title="America, by way of Nairobi: Singer-songwriter J.S. Ondara welcomes you to his American dream"> <img width="680" height="480" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/8303ef0063351474dd1249c8d6511068.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="" data-attachment-id="4609" data-permalink="https://philadelphiaweekly.com/america-by-way-of-nairobi-singer-songwriter-j-s-ondara-welcomes-you-to-his-american-dream/8303ef0063351474dd1249c8d6511068/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/8303ef0063351474dd1249c8d6511068.jpg?fit=1176%2C1761&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1176,1761" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="8303ef0063351474dd1249c8d6511068" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/8303ef0063351474dd1249c8d6511068.jpg?fit=200%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/8303ef0063351474dd1249c8d6511068.jpg?fit=684%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/8303ef0063351474dd1249c8d6511068.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/america-by-way-of-nairobi-singer-songwriter-j-s-ondara-welcomes-you-to-his-american-dream/" title="America, by way of Nairobi: Singer-songwriter J.S. Ondara welcomes you to his American dream"><h5 class="RecentPosts-title">America, by way of Nairobi: Singer-songwriter J.S. Ondara welcomes you to his American dream</h5> </a><div class="posts-teaser"><p>It’s good to be J.S. Ondara right now.The Kenyan-born singer-songwriter just wrapped a successful show at SXSW in Austin, Texas in a victory lap promoting his newly released debut album, Tales of America. His next stop on a nationwide tour&hellip;</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Mar 22, 2019</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/behind-the-lens/" title="Behind the lens"> <img width="680" height="480" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Antonio1-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Antonio Paris" data-attachment-id="21010" data-permalink="https://philadelphiaweekly.com/behind-the-lens/antonio1/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Antonio1-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;3.5&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;Canon EOS 5D Mark III&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1592034156&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;35&quot;,&quot;iso&quot;:&quot;100&quot;,&quot;shutter_speed&quot;:&quot;0.02&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Antonio1" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Antonio1-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Antonio1-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Antonio1-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Antonio1-scaled.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Antonio1-scaled.jpg?zoom=3&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 2040w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/07/Antonio1-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/behind-the-lens/" title="Behind the lens"><h5 class="RecentPosts-title">Behind the lens</h5> </a><div class="posts-teaser"><p>The social and cultural issues of today, as portrayed by Philly's Antonio Paris</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Jul 6, 2020</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/color-rich-museums-are-great-but-its-summer-yall-take-your-art-gazing-outdoors/" title="Color-rich: Museums are great but it&#8217;s summer, y&#8217;all. Take your art gazing outdoors"> <img width="680" height="480" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/1c6ba0bb1454c42f07dfe6fcf07d5f41.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="" data-attachment-id="2297" data-permalink="https://philadelphiaweekly.com/color-rich-museums-are-great-but-its-summer-yall-take-your-art-gazing-outdoors/1c6ba0bb1454c42f07dfe6fcf07d5f41/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/1c6ba0bb1454c42f07dfe6fcf07d5f41.jpg?fit=1620%2C1080&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1620,1080" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="1c6ba0bb1454c42f07dfe6fcf07d5f41" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/1c6ba0bb1454c42f07dfe6fcf07d5f41.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/1c6ba0bb1454c42f07dfe6fcf07d5f41.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/1c6ba0bb1454c42f07dfe6fcf07d5f41.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/1c6ba0bb1454c42f07dfe6fcf07d5f41.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/1c6ba0bb1454c42f07dfe6fcf07d5f41.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/color-rich-museums-are-great-but-its-summer-yall-take-your-art-gazing-outdoors/" title="Color-rich: Museums are great but it&#8217;s summer, y&#8217;all. Take your art gazing outdoors"><h5 class="RecentPosts-title">Color-rich: Museums are great but it&#8217;s summer, y&#8217;all. Take your art gazing outdoors</h5> </a><div class="posts-teaser"><p>One of the best things about the spring and summer months making our area parks come alive again with all the colors from flora is the multitude of weekend art festivals, shows and other arts-related events that weave their way&hellip;</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Jun 10, 2019</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/true-to-life-when-they-see-us-is-latest-in-fascinating-yet-infuriating-must-watch-television/" title="True to life: &#8216;When They See Us&#8217; is latest in fascinating yet infuriating must-watch television"> <img width="680" height="480" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/91571df2603f9a68b24ec0db9e02ee7c.png?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="" data-attachment-id="2299" data-permalink="https://philadelphiaweekly.com/true-to-life-when-they-see-us-is-latest-in-fascinating-yet-infuriating-must-watch-television/91571df2603f9a68b24ec0db9e02ee7c/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/91571df2603f9a68b24ec0db9e02ee7c.png?fit=1077%2C718&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1077,718" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="91571df2603f9a68b24ec0db9e02ee7c" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/91571df2603f9a68b24ec0db9e02ee7c.png?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/91571df2603f9a68b24ec0db9e02ee7c.png?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/91571df2603f9a68b24ec0db9e02ee7c.png?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/true-to-life-when-they-see-us-is-latest-in-fascinating-yet-infuriating-must-watch-television/" title="True to life: &#8216;When They See Us&#8217; is latest in fascinating yet infuriating must-watch television"><h5 class="RecentPosts-title">True to life: &#8216;When They See Us&#8217; is latest in fascinating yet infuriating must-watch television</h5> </a><div class="posts-teaser"><p>“When They See Us,” the four-part, four-hour dramatization of the notorious Central Park Five case, debuted on Netflix at the end of May.It's one of those projects that's both highly ambitious and absolutely equal to the task of what it&hellip;</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Jun 20, 2019</li></ul></footer></li></ul></section><div class="Columns-row columns-even"><div class="Columns-column"><div class="most-popular"><h2>Most Popular This Week</h2><ol class="most-popular-list"><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a>, <a href="https://philadelphiaweekly.com/sections/people/" class="category category-91">People</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/stripper-strike/">Stripper strike</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/food-festivities-and-all-the-fireworks-planned-for-this-summers-wawa-welcome-america-celebration/">Food, festivities and ALL the fireworks planned for this summer’s Wawa Welcome America celebration</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a>, <a href="https://philadelphiaweekly.com/sections/people/" class="category category-91">People</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/delayed-grief/">&#039;Delayed grief&#039;</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/music/" class="category category-89">Music</a>, <a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a>, <a href="https://philadelphiaweekly.com/sections/people/" class="category category-91">People</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/soul-searching/">Soul searching</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/arts/" class="category category-88">Arts</a>, <a href="https://philadelphiaweekly.com/sections/people/" class="category category-91">People</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/godfather-of-graffiti/">Godfather of graffiti</a></li></ol></div> <a class="Button" href="/popular">More Popular Articles</a></div><div class="Columns-column columns-even__right"><div class="calendar-events-teaser"><h2>Upcoming Philly Events</h2><ul class="calendar-events"><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/pericles-prince-of-tyre/2020-07-31/"> <time class="calendar-events__date">Fri, Jul 31</time><h6 class="calendar-events__title">Pericles, Prince of Tyre</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Clark Park</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/pericles-prince-of-tyre/2020-08-01/"> <time class="calendar-events__date">Sat, Aug 01</time><h6 class="calendar-events__title">Pericles, Prince of Tyre</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Clark Park</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/watson-adventures-virtual-trivia-slam-game/"> <time class="calendar-events__date">Sat, Aug 01</time><h6 class="calendar-events__title">Watson Adventures’ Virtual Trivia Slam Game</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Virtual Trivia Slam Game</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/virtual-philadelphia-craft-tour-with-the-james-renwick-alliance-craftnow/"> <time class="calendar-events__date">Sun, Aug 02</time><h6 class="calendar-events__title">Virtual Philadelphia Craft Tour with the James Renwick Alliance &amp; CraftNOW</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">On Zoom</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/pericles-prince-of-tyre/2020-08-02/"> <time class="calendar-events__date">Sun, Aug 02</time><h6 class="calendar-events__title">Pericles, Prince of Tyre</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Clark Park</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/jfcs-caregivers-support-group/2020-08-03/"> <time class="calendar-events__date">Mon, Aug 03</time><h6 class="calendar-events__title">JFCS - Caregivers Support Group</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">On Zoom</li></ul></li></ul> <a class="Button" href="/calendar">More Events</a></div></div></div></div></div></div><footer class="footer"><div class="footer-section footer-section--primary"><div class="footer-container"></div></div><div class="footer-section footer-section--secondary"><div class="footer-container"><div class="footer-inner"><div class="footer-inner__branding"><div class="footer-inner__logo"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_social"><p>Follow @PhillyWeekly</p><ul class="footer-inner__social__list"><li> <a href="https://www.facebook.com/pg/phillyweekly/posts/"> <i class="fa fa-facebook-square" aria-hidden="true"></i> <span>Facebook</span> </a></li><li> <a href="https://twitter.com/PhillyWeekly/"> <i class="fa fa-twitter" aria-hidden="true"></i> <span>Twitter</span> </a></li><li> <a href="https://www.instagram.com/phillyweekly/"> <i class="fa fa-instagram" aria-hidden="true"></i> <span>Instagram</span> </a></li><li> <a href="https://philadelphiaweekly.com/feeds"> <i class="fa fa-rss" aria-hidden="true"></i> <span>Your News Reader</span> </a></li></ul></div></div><nav class="Navigation Navigation--footer"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-133"><a href="#">About PW</a><ul class="sub-menu"><li id="menu-item-334" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334"><a href="https://philadelphiaweekly.com/about/">About Us</a></li><li id="menu-item-386" class="menu-item menu-item-type-post_type_archive menu-item-object-writer menu-item-386"><a href="https://philadelphiaweekly.com/writer/">Our Writers</a></li><li id="menu-item-336" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-336"><a href="/advertising">Advertising &#038; Partnerships</a></li><li id="menu-item-338" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-338"><a href="/events/community/add">Submit an Event</a></li></ul></li><li id="menu-item-134" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-134"><a href="#">Explore PW</a><ul class="sub-menu"><li id="menu-item-228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-228"><a href="https://philadelphiaweekly.com/sections/">Sections</a></li><li id="menu-item-137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-136" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-335"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></li></ul></div></nav><div class="footer-inner_contact-text"><div class="footer-inner__logo--desktop"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_contact"><p>1520 Locust Street, Fifth Floor</p><p>Philadelphia, PA 19102</p></div><div class="footer-inner_contact footer-inner_contact__phone"><p>215-543-3743</p><p><a href="mailto:mail@philadelphiaweekly.com">mail@philadelphiaweekly.com</a></p></div><div class="footer-info"> &copy; Copyright Philadelphia Weekly</div></div></div></div></footer></div> <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <script type="text/javascript">(function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();</script> <script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/philadelphiaweekly.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript'>var wpaComplementary = [""];</script> <script type='text/javascript'>var customizer = {"sliderSlideCount":"1","sliderLoop":"0","sliderAutoPlay":"0","sliderAutoPlaySpeed":"7000","sliderArrows":"1","sliderDots":"1"};</script> <script type='text/javascript'>var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/philadelphiaweekly.com\/wp-admin\/admin-ajax.php","nonce":"b08d619d06","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/philadelphiaweekly.com\/wp-login.php?redirect_to=https%3A%2F%2Fphiladelphiaweekly.com%2Fthe-rundown-july-30-aug-6%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};</script> <link rel="stylesheet" href="https://use.typekit.net/cgg8jik.css"> <script defer src="https://philadelphiaweekly.com/wp-content/cache/autoptimize/js/autoptimize_a1e8f9df2608775ba9c2d4053a86adcf.js"></script><script data-cfasync='false'>!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){function e(){t.media=a}var a=t.media||"all";t.addEventListener?t.addEventListener("load",e):t.attachEvent&&t.attachEvent("onload",e),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(e,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);</script></body></html>