<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="stylesheet" media="print" onload="this.onload=null;this.media='all';" id="ao_optimized_gfonts" href="https://fonts.googleapis.com/css?family=Lora%3A400%2C400i%2C700&amp;display=swap" /><link rel="profile" href="http://gmpg.org/xfn/11"><meta property="fb:pages" content="23117126720" /><link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png"><link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png"><link rel="manifest" href="/site.webmanifest"><link rel="mask-icon" href="/safari-pinned-tab.svg" color="#ffc414"><meta name="msapplication-TileColor" content="#231f20"><meta name="theme-color" content="#231f20"> <style type="text/css">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</style><link rel="stylesheet" media="print" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_e6cc637955b3d6d8d29a7ddfef0d6440.css" onload="this.onload=null;this.media='all';" /><noscript id="aonoscrcss"><link media="all" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_e6cc637955b3d6d8d29a7ddfef0d6440.css" rel="stylesheet" /></noscript><title>How to maintain long-distance love - Philadelphia Weekly</title><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://philadelphiaweekly.com/how-to-maintain-long-distance-love/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="How to maintain long-distance love - Philadelphia Weekly" /><meta property="og:description" content="Timaree answers your questions about sex, love and relationships" /><meta property="og:url" content="https://philadelphiaweekly.com/how-to-maintain-long-distance-love/" /><meta property="og:site_name" content="Philadelphia Weekly" /><meta property="article:publisher" content="https://www.facebook.com/phillyweekly/" /><meta property="article:published_time" content="2021-01-22T00:49:55+00:00" /><meta property="article:modified_time" content="2021-01-22T00:50:07+00:00" /><meta property="og:image" content="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Timaree-headshot.jpg?fit=1591%2C1091&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta property="og:image:width" content="1591" /><meta property="og:image:height" content="1091" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@phillyweekly" /><meta name="twitter:site" content="@phillyweekly" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://philadelphiaweekly.com/#organization","name":"Philadelphia Weekly","url":"https://philadelphiaweekly.com/","sameAs":["https://www.facebook.com/phillyweekly/","https://www.instagram.com/phillyweekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://twitter.com/phillyweekly"],"logo":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#logo","inLanguage":"en-US","url":"https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&quality=70&strip=all&ssl=1","width":500,"height":500,"caption":"Philadelphia Weekly"},"image":{"@id":"https://philadelphiaweekly.com/#logo"}},{"@type":"WebSite","@id":"https://philadelphiaweekly.com/#website","url":"https://philadelphiaweekly.com/","name":"Philadelphia Weekly","description":"","publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://philadelphiaweekly.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/how-to-maintain-long-distance-love/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Timaree-headshot.jpg?fit=1591%2C1091&quality=70&strip=all&ssl=1","width":1591,"height":1091,"caption":"Sex advice shouldn't be syndicated. We wanted a local feel to ours so we've enlisted the sound advice of resident sex professor Timaree Schmit. Have a question about your love life that needs answers? Email her at asktimaree@philadelphiaweekly.com. | Image: Redlite photos"},{"@type":"WebPage","@id":"https://philadelphiaweekly.com/how-to-maintain-long-distance-love/#webpage","url":"https://philadelphiaweekly.com/how-to-maintain-long-distance-love/","name":"How to maintain long-distance love - Philadelphia Weekly","isPartOf":{"@id":"https://philadelphiaweekly.com/#website"},"primaryImageOfPage":{"@id":"https://philadelphiaweekly.com/how-to-maintain-long-distance-love/#primaryimage"},"datePublished":"2021-01-22T00:49:55+00:00","dateModified":"2021-01-22T00:50:07+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://philadelphiaweekly.com/how-to-maintain-long-distance-love/"]}]},{"@type":"Article","@id":"https://philadelphiaweekly.com/how-to-maintain-long-distance-love/#article","isPartOf":{"@id":"https://philadelphiaweekly.com/how-to-maintain-long-distance-love/#webpage"},"author":{"@id":"https://philadelphiaweekly.com/#/schema/person/6d10bb5ac4140a42ca14aa4e8065e28d"},"headline":"How to maintain long-distance love","datePublished":"2021-01-22T00:49:55+00:00","dateModified":"2021-01-22T00:50:07+00:00","mainEntityOfPage":{"@id":"https://philadelphiaweekly.com/how-to-maintain-long-distance-love/#webpage"},"publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"image":{"@id":"https://philadelphiaweekly.com/how-to-maintain-long-distance-love/#primaryimage"},"keywords":"advice,love,philly,Sex,sex with timaree","articleSection":"LGBTQ / Sex,Sex with Timaree","inLanguage":"en-US"},{"@type":"Person","@id":"https://philadelphiaweekly.com/#/schema/person/6d10bb5ac4140a42ca14aa4e8065e28d","name":"Philly Editor","image":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/a2af5953cb6b5d09567512df874c23dd?s=96&d=mm&r=g","caption":"Philly Editor"}}]}</script> <link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//c0.wp.com' /><link rel='dns-prefetch' href='//i0.wp.com' /><link rel='dns-prefetch' href='//i1.wp.com' /><link rel='dns-prefetch' href='//i2.wp.com' /><link href='https://use.typekit.net' rel='preconnect' /><link href='https://www.google-analytics.com' rel='preconnect' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Feed" href="https://philadelphiaweekly.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Comments Feed" href="https://philadelphiaweekly.com/comments/feed/" /><link rel="alternate" type="text/calendar" title="Philadelphia Weekly &raquo; iCal Feed" href="https://philadelphiaweekly.com/events/?ical=1" /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify;}</style> <script type='application/json' id='wpp-json'>{"sampling_active":0,"sampling_rate":50,"ajax_url":"https:\/\/philadelphiaweekly.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":26114,"token":"4c6316e090","lang":0,"debug":0}</script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-700394-5' id='google_gtagjs-js' async></script> <script type='text/javascript' id='google_gtagjs-js-after'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["philadelphiaweekly.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-700394-5", {"anonymize_ip":true});</script> <link rel="https://api.w.org/" href="https://philadelphiaweekly.com/wp-json/" /><link rel="alternate" type="application/json" href="https://philadelphiaweekly.com/wp-json/wp/v2/posts/26114" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://philadelphiaweekly.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://philadelphiaweekly.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.6" /><link rel='shortlink' href='https://philadelphiaweekly.com/?p=26114' /><link rel="alternate" type="application/json+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fhow-to-maintain-long-distance-love%2F" /><link rel="alternate" type="text/xml+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fhow-to-maintain-long-distance-love%2F&#038;format=xml" /><meta name="generator" content="Site Kit by Google 1.24.0" /><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://philadelphiaweekly.com"><link rel="https://theeventscalendar.com/" href="https://philadelphiaweekly.com/wp-json/tribe/events/v1/" /><style type="text/css">.header{background-color: #0a0a0a;}.header .SearchForm-button{color: #ffffff;}.Navigation--primary{color: #ffffff;}</style><style type="text/css">/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}</style> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=32%2C21&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=192%2C128&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=180%2C120&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=270%2C180&#038;quality=70&#038;strip=all&#038;ssl=1" /> <script>window.dataLayer = window.dataLayer || [];
	  function gtag(){dataLayer.push(arguments);}
	  gtag('js', new Date());

	  gtag('config', 'UA-700394-5');</script> </head><body class="post-template-default single single-post postid-26114 single-format-standard tribe-no-js tribe-theme-parent-truro tribe-theme-child-truro-pw-child"> <a class="skip-link screen-reader-text" href="#Content">Skip to content</a><header class="header header--four"><div class="header-section header-section--primary"><div class="header-container"><div class="header-sectionInner"><div class="header-part"><div class="Branding"> <a href="https://philadelphiaweekly.com/" rel="home"> <img class="Branding-logo" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/PW-weekly-white-horizontal-1-1.svg" alt="Philadelphia Weekly" width="200px" /> </a></div></div><div class="header-part header-part__navigation"><nav class="Navigation Navigation--primary"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation" class="menu"><li id="menu-item-227" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li id="menu-item-221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li id="menu-item-188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li id="menu-item-191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li id="menu-item-192" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li id="menu-item-193" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li id="menu-item-194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li id="menu-item-7201" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li id="menu-item-195" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li id="menu-item-222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li id="menu-item-518" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li id="menu-item-375" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li id="menu-item-377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li id="menu-item-385" class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li id="menu-item-384" class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li id="menu-item-543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-128" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></nav><div class="utility-navigation"><form class="SearchForm SearchForm--header" method="get" action="https://philadelphiaweekly.com/"> <span class="screen-reader-text">Search for:</span> <input class="SearchForm-field" type="text" placeholder="Type &amp; press enter" value="" name="s" title="Search for:" /> <button type="submit" class="screen-reader-text" aria-label="Search">Search</button> <button class="SearchForm-button" aria-label="Submit"><i class="fa fa-search" aria-hidden="true"></i></button></form></div></div></div></div></div></header><nav class="Navigation Navigation--mobile"><div class="container"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></div></nav><div class="content content--fullWidth" id="content"><div class="content-inner"><div class="content-container"><div class="content-row content-row--article"><main class="content-main"><header class="article-header"><div class="meta-tags"> <span class="Meta-item"><li class="Meta-item Meta-item--categories"><ul class="Meta Meta--banner"><li class="Meta-item Meta-item--categories"><ul><li><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/" title="LGBTQ / Sex">LGBTQ / Sex</a></li><li><a href="https://philadelphiaweekly.com/sections/featured-sections/sex-with-timaree-featured-sections/" title="Sex with Timaree">Sex with Timaree</a></li></ul></li></ul></li> </span></div><h1>How to maintain long-distance love</h1><div class="posts-teaser"><p>Timaree answers your questions about sex, love and relationships</p></div><footer class="Post-footer"><ul class="Meta Meta--article"><li class="Meta-item Meta-item--author"> <a class="meta-author-article" href="https://philadelphiaweekly.com/writer/timaree-schmit/"><figure class="meta-author-headshot"><img width="100" height="100" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/Timaree-Schmit.jpg?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-headshot size-headshot wp-post-image jetpack-lazy-image" alt="Timaree Schmit Headshot" loading="lazy" data-attachment-id="9737" data-permalink="https://philadelphiaweekly.com/writer/timaree-schmit/timaree-schmit-2/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/Timaree-Schmit.jpg?fit=1169%2C994&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1169,994" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;3.5&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;Canon EOS 70D&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1432552881&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;18&quot;,&quot;iso&quot;:&quot;320&quot;,&quot;shutter_speed&quot;:&quot;0.033333333333333&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Timaree Schmit" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/Timaree-Schmit.jpg?fit=300%2C255&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/Timaree-Schmit.jpg?fit=1024%2C871&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/Timaree-Schmit.jpg?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/Timaree-Schmit.jpg?resize=680%2C680&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/Timaree-Schmit.jpg?zoom=2&amp;resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 200w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/Timaree-Schmit.jpg?zoom=3&amp;resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/Timaree-Schmit.jpg?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></figure> <span class="meta-author-name">Timaree Schmit</span></a></li><li class="Meta-item Meta-item--date">January 21st, 2021</li></ul><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/how-to-maintain-long-distance-love/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20How to maintain long-distance love%20-%20https://philadelphiaweekly.com/how-to-maintain-long-distance-love/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20How to maintain long-distance love%20-%20https://philadelphiaweekly.com/how-to-maintain-long-distance-love/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: How to maintain long-distance love%20https://philadelphiaweekly.com/how-to-maintain-long-distance-love/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></footer></header><header class="Post-header"><figure class="Post-thumbnail"> <a data-fancybox="gallery" data-caption="Sex advice shouldn&#8217;t be syndicated. We wanted a local feel to ours so we&#8217;ve enlisted the sound advice of resident sex professor Timaree Schmit. Have a question about your love life that needs answers? Email her at asktimaree@philadelphiaweekly.com. | Image: Redlite photos" href="https://philadelphiaweekly.com/wp-content/uploads/2020/10/Timaree-headshot.jpg"><img width="1200" height="675" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Timaree-headshot.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-feature-image size-feature-image wp-post-image jetpack-lazy-image" alt="Timaree headshot" loading="lazy" data-attachment-id="23262" data-permalink="https://philadelphiaweekly.com/voting-while-trans/timaree-headshot/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Timaree-headshot.jpg?fit=1591%2C1091&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1591,1091" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Timaree headshot" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Timaree-headshot.jpg?fit=300%2C206&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Timaree-headshot.jpg?fit=1024%2C702&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Timaree-headshot.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></a><figcaption>Sex advice shouldn&#8217;t be syndicated. We wanted a local feel to ours so we&#8217;ve enlisted the sound advice of resident sex professor Timaree Schmit. Have a question about your love life that needs answers? Email her at asktimaree@philadelphiaweekly.com. | Image: Redlite photos</figcaption></figure></header><div class="sharing-desktop"><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/how-to-maintain-long-distance-love/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20How to maintain long-distance love%20-%20https://philadelphiaweekly.com/how-to-maintain-long-distance-love/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20How to maintain long-distance love%20-%20https://philadelphiaweekly.com/how-to-maintain-long-distance-love/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: How to maintain long-distance love%20https://philadelphiaweekly.com/how-to-maintain-long-distance-love/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></div><article id="Post-26114"  class="Post Post--single post-26114 post type-post status-publish format-standard has-post-thumbnail hentry category-lgbtq-sex category-sex-with-timaree-featured-sections tag-advice tag-love tag-philly tag-sex tag-sex-with-timaree"><div class="Post-content"><h4>Whether you met a hottie while traveling, are moving temporarily for school, or simply can’t be in physical proximity to your lover because there’s a barely-controlled pandemic, it’s a good idea to know about maintaining relationships over distance. </h4><p>I checked in with a few folks who have sustained love over the miles.</p><p><strong>KR and partner (together for several years, partner is 3,700 miles away):&nbsp;</strong></p><p>A long-distance relationship is definitely not my first choice for a relationship style. Once you&#8217;ve made the conscious decision to be emotionally or sexually connected to someone from a distance, then you can actually have a lot of freedom to define how the relationship works best for you and your partner.</p><p>In my circumstance, my partner and I were separated because of immigration. The beginning was full of longing, wistful texts of &#8220;I love you&#8221; and &#8220;I can&#8217;t stop thinking of you.&#8221; There was just so much emotion that we wanted to stay as connected as possible. We told each other that we would always be in each other&#8217;s pocket.&nbsp;</p><p>Similarly, feelings of sexual frustration ran high, but video chats were new and exciting, so this satisfied our craving for sexual intimacy. As time went on, we had to continually check-in and explore how we wanted our intimacy and sexuality to evolve in a way that allowed us to actually live our separate day-to-day lives.</p><blockquote class="wp-block-quote"><p>“As time went on, we had to continually check-in and explore how we wanted our intimacy and sexuality to evolve in a way that allowed us to actually live our separate day-to-day lives.”</p></blockquote><p>To maintain our emotional intimacy, we always start the day with a video chat to share any joys or worries about the day ahead. For sexual connectedness, we have explored sending suggestive photos throughout the day, planning sexy video chat dates, and talking all about things we are interested in as well as things we are curious about trying or learning about when we are together next. These open and frank conversations have allowed us to reach a deeper level of understanding each other as well as ourselves so that when we do someday get to live together that we might just be way ahead of the curve communication-wise.</p><p><strong>RT &amp; partner (together 8 years, 1,960 miles away)</strong>:</p><p>It probably makes a difference that our long-distance sexual relationship is grounded in an in-person sexual relationship. We do a lot of texting each other sexy things and talking about sex on text. When we have sex, it sometimes is on video chat, but more often a combination of text and audio recordings. For us, a lot of what we do from afar is also shaped by our D/s dynamic.</p><p>We text all day, and we used to have set date nights to talk, but now we make sure to say hi and hear each other&#8217;s voices every day. We send a lot of audio messages, pictures of our day, from the mundane to the exciting to sexy. And after a lot of practice, we&#8217;ve done prolonged scenes essentially that involve, honestly, what just feels like fucking from afar, where it&#8217;s not doing it for yourself at all, it&#8217;s because the other person is really guiding whatever it is, giving instructions, and responding.</p><p><strong>Stephanie and Johan (together 1 year, 4,000 miles apart)</strong>:</p><p>We envision dates we would like to have, and then go on them! Bring the other over video chat and share the experience. Once I took Johan to a Swedish goods shop in Lancaster, and he advised me of all the best candy and treats to buy. It was very special. Sending little surprise gifts to each other helps your partner feel thought of. We recommend doing a little research into your partner&#8217;s hometown and supporting the small businesses there. All of this develops and nurtures a special bond, and sets the stage for a feeling of love, safety, and most importantly TRUST.&nbsp;</p><blockquote class="wp-block-quote"><p>“Ultimately, what matters is that you are able to communicate your needs and wants and build the relationship that works for you.”</p></blockquote><p>There is SO much trust that needs to be maintained. People need to trust that they are loved, and that their partner is being faithful (including ethical non-monogamy if that’s what you’re practicing). Also, with the amount of digital content being shared, and video chat sex, you have to trust that your partner wouldn’t act maliciously with it.&nbsp;</p><p>Share your emotions and needs. Do not hide that you are having a bad day. You’re not doing yourself or your relationship any favors by dealing with life alone. They are called partners for a reason. Lastly, do your Gods damned best to be patient. Always keep in mind that you both are experiencing desire and loneliness together. In these special times, there’s no choice but to quit, or stick it out for love. It will happen, one very special and VERY SEXY day.&nbsp;</p><p><strong>JL:</strong>&nbsp;</p><p>A majority of my relationships are long distance. I&#8217;m poly. Each of my relationships differ. The two that are in a way the most active, we text each other pretty frequently and FaceTime at least once or twice a month. Our lives are very busy and we try our best to respect that. For my partner in the same state as me, we see each at one weekend or one week a month. Communication and compassion has been key. Also recognizing that we have to trust each other to know the boundaries in the relationship and willingness to discuss the changes with boundaries frequently.</p><p>We can see that meaningful and regular interaction is a big piece, and something that even people who share a house can take into consideration. What are some other things that are recommended?</p><p><strong>Be clear on boundaries and needs:</strong> What level of contact do you expect? Will you travel to see each other? What kind of romantic or sexual options do you each have with other people? Will this remain at a distance? Do you expect that eventually you will be in the same place and how will that change things?</p><p><strong>Embrace technological options:</strong> Texting, video chats and sharing porn links and saucy pics are obvious upsides of LDRs in the modern era. There are also <a href="https://www.ryanandalex.com/apps-for-married-couples/">apps designed</a> for partners and don’t forget about products that allow lovers to share <a href="https://www.uncommongoods.com/product/long-distance-touch-bracelet-set">physical touch</a> over Bluetooth or even engage directly in <a href="https://www.kiiroo.com/collections/for-couples/products/kiiroo%C2%AE-onyx-%E2%84%A2-pearl2%E2%84%A2-purple-couples-set">sexual acts</a> using <a href="https://surviveldr.com/intimacy/long-distance-relationship-sex-toys/">teledildonics</a>.&nbsp;</p><p><strong>Go Old School:</strong> Who sends a letter anymore? Maybe you do – because it’s extra special to get handwritten smut through the mail, as a belated fuck you to Anthony Comstock. Same with some good, old-fashioned phone sex.&nbsp;</p><p>Another upside of long-distance love is the possibly extended spark of novelty. Since it’s so exceptional to get to be together, and you don’t get tired of each other, this model of dating might be ideal for particularly busy folks. Ultimately, what matters is that you are able to communicate your needs and wants and build the relationship that works for you.&nbsp;</p><p><strong><em>Have a question for Timaree? Send an email to asktimaree@philadelphiaweekly.com.</em></strong></p><h5 class="related-posts__title">Related</h5><ul class="related-posts"><li><a href="https://philadelphiaweekly.com/pw-weekend-picks-aug-2-4/" rel="bookmark" title="Permanent Link to PW weekend picks: Aug. 2-4">PW weekend picks: Aug. 2-4</a></li><li><a href="https://philadelphiaweekly.com/state-of-our-city-dec-10-17/" rel="bookmark" title="Permanent Link to State of Our City | Dec. 10-17">State of Our City | Dec. 10-17</a></li><li><a href="https://philadelphiaweekly.com/april-quickies/" rel="bookmark" title="Permanent Link to April quickies">April quickies</a></li><li><a href="https://philadelphiaweekly.com/the-girls/" rel="bookmark" title="Permanent Link to The girls">The girls</a></li></ul><ul class="Meta"><li class="Meta-item Meta-item--tags"><ul><li><a href="https://philadelphiaweekly.com/tag/advice/" title=" advice ">advice</a></li><li><a href="https://philadelphiaweekly.com/tag/love/" title=" love ">love</a></li><li><a href="https://philadelphiaweekly.com/tag/philly/" title=" philly ">philly</a></li><li><a href="https://philadelphiaweekly.com/tag/sex/" title=" Sex ">Sex</a></li><li><a href="https://philadelphiaweekly.com/tag/sex-with-timaree/" title=" sex with timaree ">sex with timaree</a></li></ul></li></ul></div></article><ul class="author-article-bio"><li class="author-bio__item"> <a class="author-bio__headshot" href="https://philadelphiaweekly.com/writer/timaree-schmit/"><figure><img width="100" height="100" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/Timaree-Schmit.jpg?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-headshot size-headshot wp-post-image jetpack-lazy-image" alt="Timaree Schmit Headshot" loading="lazy" data-attachment-id="9737" data-permalink="https://philadelphiaweekly.com/writer/timaree-schmit/timaree-schmit-2/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/Timaree-Schmit.jpg?fit=1169%2C994&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1169,994" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;3.5&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;Canon EOS 70D&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1432552881&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;18&quot;,&quot;iso&quot;:&quot;320&quot;,&quot;shutter_speed&quot;:&quot;0.033333333333333&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Timaree Schmit" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/Timaree-Schmit.jpg?fit=300%2C255&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/Timaree-Schmit.jpg?fit=1024%2C871&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/Timaree-Schmit.jpg?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/Timaree-Schmit.jpg?resize=680%2C680&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/Timaree-Schmit.jpg?zoom=2&amp;resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 200w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/Timaree-Schmit.jpg?zoom=3&amp;resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/Timaree-Schmit.jpg?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></figure> </a><div class="author-name__container"> <a class="author-bio__name" href="https://philadelphiaweekly.com/writer/timaree-schmit/"><h6>Timaree Schmit</h6> </a><ul class="author-bio__social"><li class="author-bio__social__item"> <a href="https://www.twitter.com/Timaree_Leigh"> <i class="author-bio__social__icon fa fa-twitter" aria-hidden="true"></i><div class="author-bio__social__handle">@Timaree_Leigh</div> </a></li></ul></div><div class="author-bio__info"><p>Timaree Schmit is basically an episode of Adam Ruins Everything, but in the shape of a person. She has a PhD in Human Sexuality Education and years of experience in community organizing, performance art, and finding the extra weird pockets of Philly.</p></div></li></ul></main></div><section class="RelatedPosts"><div class="category-row__bar"><h2 class="category-row__title">Up Next in LGBTQ / Sex</h2></div><ul class="posts-row"><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/bloody-business/" title="Bloody business"> <img width="680" height="480" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Image of Dan Savage" loading="lazy" data-attachment-id="534" data-permalink="https://philadelphiaweekly.com/5cba3c4bd7528-image-4/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?fit=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1200,675" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="5cba3c4bd7528.image" data-image-description="&lt;p&gt;Savage Love&lt;/p&gt;
" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?fit=300%2C169&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?fit=1024%2C576&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/bloody-business/" title="Bloody business"><h5 class="RecentPosts-title">Bloody business</h5> </a><div class="posts-teaser"><p>Sex guru Dan Savage is here to answer your burning questions</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Dec 20, 2019</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/long-game/" title="Long game"> <img width="680" height="480" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Image of Dan Savage" loading="lazy" data-attachment-id="534" data-permalink="https://philadelphiaweekly.com/5cba3c4bd7528-image-4/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?fit=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1200,675" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="5cba3c4bd7528.image" data-image-description="&lt;p&gt;Savage Love&lt;/p&gt;
" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?fit=300%2C169&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?fit=1024%2C576&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/long-game/" title="Long game"><h5 class="RecentPosts-title">Long game</h5> </a><div class="posts-teaser"><p>Advice for those who want a little "cuck" in their life</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Jan 22, 2020</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/queens-of-the-city/" title="Queens of the city"> <img width="680" height="480" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/DragEric-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Drag queen Eric Jaffe" loading="lazy" data-attachment-id="16094" data-permalink="https://philadelphiaweekly.com/queens-of-the-city/drageric/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/DragEric-scaled.jpg?fit=2560%2C1812&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1812" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;4.5&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D810&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;35&quot;,&quot;iso&quot;:&quot;400&quot;,&quot;shutter_speed&quot;:&quot;0.01&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="DragEric" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/DragEric-scaled.jpg?fit=300%2C212&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/DragEric-scaled.jpg?fit=1024%2C725&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/DragEric-scaled.jpg?w=2560&amp;quality=70&amp;strip=all&amp;ssl=1 2560w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/DragEric-scaled.jpg?resize=300%2C212&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/DragEric-scaled.jpg?resize=1024%2C725&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/DragEric-scaled.jpg?resize=770%2C545&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/DragEric-scaled.jpg?resize=1536%2C1087&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/DragEric-scaled.jpg?resize=2048%2C1449&amp;quality=70&amp;strip=all&amp;ssl=1 2048w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/DragEric-scaled.jpg?resize=495%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 495w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/DragEric-scaled.jpg?resize=1240%2C878&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/DragEric-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/DragEric-scaled.jpg?w=2280&amp;quality=70&amp;strip=all&amp;ssl=1 2280w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/DragEric-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/queens-of-the-city/" title="Queens of the city"><h5 class="RecentPosts-title">Queens of the city</h5> </a><div class="posts-teaser"><p>The present, bright and colorful future of the Philly drag world</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Jan 29, 2020</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/unplugged/" title="Unplugged"> <img width="680" height="480" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Image of Dan Savage" loading="lazy" data-attachment-id="534" data-permalink="https://philadelphiaweekly.com/5cba3c4bd7528-image-4/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?fit=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1200,675" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="5cba3c4bd7528.image" data-image-description="&lt;p&gt;Savage Love&lt;/p&gt;
" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?fit=300%2C169&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?fit=1024%2C576&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/unplugged/" title="Unplugged"><h5 class="RecentPosts-title">Unplugged</h5> </a><div class="posts-teaser"><p>Sex guru Dan Savage with answers to burning questions from readers</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Jul 15, 2020</li></ul></footer></li></ul></section><div class="Columns-row columns-even"><div class="Columns-column"><div class="most-popular"><h2>Most Popular This Week</h2><ol class="most-popular-list"><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/interests/" class="category category-4892">Interests</a>, <a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/meet-carlos-vega/">Meet Carlos Vega</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/" class="category category-93">LGBTQ / Sex</a>, <a href="https://philadelphiaweekly.com/sections/sex-with-timaree/" class="category category-13116">Sex with Timaree</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/the-war-on-sexual-content/">The war on sexual content</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/food-festivities-and-all-the-fireworks-planned-for-this-summers-wawa-welcome-america-celebration/">Food, festivities and ALL the fireworks planned for this summer’s Wawa Welcome America celebration</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a>, <a href="https://philadelphiaweekly.com/sections/featured-sections/events/" class="category category-165">The Scene</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/running-off-the-rails/">Running off the rails</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/interests/" class="category category-4892">Interests</a>, <a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a>, <a href="https://philadelphiaweekly.com/sections/people/" class="category category-91">People</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/granny-get-your-gun-seniors-lead-the-way-as-local-gun-sales-spike/">Granny, get your gun: Seniors lead the way as local gun sales spike</a></li></ol></div> <a class="Button" href="/popular">More Popular Articles</a></div><div class="Columns-column columns-even__right"><div class="calendar-events-teaser"><h2>Upcoming Philly Events</h2><ul class="calendar-events"><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/uhuru-furniture-philly-is-open-and-live-on-facebook-and-instagram-11am-every-saturday/2021-01-23/"> <time class="calendar-events__date">Sat, Jan 23</time><h6 class="calendar-events__title">Uhuru Furniture Philly is OPEN and LIVE on Facebook and Instagram 11am every Saturday</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author"></li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/old-bethlehem-walking-tour/2021-01-23/"> <time class="calendar-events__date">Sat, Jan 23</time><h6 class="calendar-events__title">Old Bethlehem Walking Tour</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Historic Bethlehem Visitor Center</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/old-bethlehem-walking-tour/2021-01-23/2/"> <time class="calendar-events__date">Sat, Jan 23</time><h6 class="calendar-events__title">Old Bethlehem Walking Tour</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Historic Bethlehem Visitor Center</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/old-bethlehem-walking-tour/2021-01-24/"> <time class="calendar-events__date">Sun, Jan 24</time><h6 class="calendar-events__title">Old Bethlehem Walking Tour</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Historic Bethlehem Visitor Center</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/old-bethlehem-walking-tour/2021-01-24/2/"> <time class="calendar-events__date">Sun, Jan 24</time><h6 class="calendar-events__title">Old Bethlehem Walking Tour</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Historic Bethlehem Visitor Center</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/winter-2021-virtual-music-programs/2021-01-25/"> <time class="calendar-events__date">Mon, Jan 25</time><h6 class="calendar-events__title">Winter 2021 Virtual Music Programs</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Online</li></ul></li></ul> <a class="Button" href="/calendar">More Events</a></div></div></div></div></div></div><footer class="footer"><div class="footer-section footer-section--primary"><div class="footer-container"></div></div><div class="footer-section footer-section--secondary"><div class="footer-container"><div class="footer-inner"><div class="footer-inner__branding"><div class="footer-inner__logo"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_social"><p>Follow @PhillyWeekly</p><ul class="footer-inner__social__list"><li> <a href="https://www.facebook.com/pg/phillyweekly/posts/"> <i class="fa fa-facebook-square" aria-hidden="true"></i> <span>Facebook</span> </a></li><li> <a href="https://twitter.com/PhillyWeekly/"> <i class="fa fa-twitter" aria-hidden="true"></i> <span>Twitter</span> </a></li><li> <a href="https://www.instagram.com/phillyweekly/"> <i class="fa fa-instagram" aria-hidden="true"></i> <span>Instagram</span> </a></li><li> <a href="https://philadelphiaweekly.com/feeds"> <i class="fa fa-rss" aria-hidden="true"></i> <span>Your News Reader</span> </a></li></ul></div></div><nav class="Navigation Navigation--footer"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-133"><a href="#">About PW</a><ul class="sub-menu"><li id="menu-item-334" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334"><a href="https://philadelphiaweekly.com/about/">About Us</a></li><li id="menu-item-386" class="menu-item menu-item-type-post_type_archive menu-item-object-writer menu-item-386"><a href="https://philadelphiaweekly.com/writer/">Our Writers</a></li><li id="menu-item-25676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25676"><a href="https://philadelphiaweekly.com/locations/">Dropbox Locations</a></li><li id="menu-item-336" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-336"><a href="/advertising">Advertising &#038; Partnerships</a></li><li id="menu-item-338" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-338"><a href="/events/community/add">Submit an Event</a></li></ul></li><li id="menu-item-134" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-134"><a href="#">Explore PW</a><ul class="sub-menu"><li id="menu-item-228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-228"><a href="https://philadelphiaweekly.com/sections/">Sections</a></li><li id="menu-item-137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-136" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-335"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></li></ul></div></nav><div class="footer-inner_contact-text"><div class="footer-inner__logo--desktop"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_contact"><p>1520 Locust Street, Fifth Floor</p><p>Philadelphia, PA 19102</p></div><div class="footer-inner_contact footer-inner_contact__phone"><p>215-543-3743</p><p><a href="mailto:mail@philadelphiaweekly.com">mail@philadelphiaweekly.com</a></p></div><div class="footer-info"> &copy; Copyright Philadelphia Weekly</div></div></div></div></footer></div> <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script> <script type='text/javascript' id='contact-form-7-js-extra'>var wpcf7 = {"apiSettings":{"root":"https:\/\/philadelphiaweekly.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript' id='wpa-complementary-js-extra'>var wpaComplementary = [""];</script> <script type='text/javascript' id='longdesc.button-js-extra'>var wparest = "https:\/\/philadelphiaweekly.com\/wp-json\/wp\/v2\/media";
var wpatext = "<span>Long Description<\/span>";</script> <script type='text/javascript' id='truro-scripts-js-extra'>var customizer = {"sliderSlideCount":"1","sliderLoop":"0","sliderAutoPlay":"0","sliderAutoPlaySpeed":"7000","sliderArrows":"1","sliderDots":"1"};</script> <script type='text/javascript' id='jetpack-lazy-images-js-extra'>var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};</script> <link rel="stylesheet" href="https://use.typekit.net/cgg8jik.css"> <script defer src="https://philadelphiaweekly.com/wp-content/cache/autoptimize/js/autoptimize_39e3cc307489ec16832bdb799d128cf6.js"></script></body></html>