<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="stylesheet" media="print" onload="this.onload=null;this.media='all';" id="ao_optimized_gfonts" href="https://fonts.googleapis.com/css?family=Lora%3A400%2C400i%2C700&amp;display=swap" /><link rel="profile" href="http://gmpg.org/xfn/11"><meta property="fb:pages" content="23117126720" /><link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png"><link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png"><link rel="manifest" href="/site.webmanifest"><link rel="mask-icon" href="/safari-pinned-tab.svg" color="#ffc414"><meta name="msapplication-TileColor" content="#231f20"><meta name="theme-color" content="#231f20"> <style type="text/css">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</style><link rel="stylesheet" media="print" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_7925ae92bf57eb155ff62927ef947909.css" onload="this.onload=null;this.media='all';" /><noscript id="aonoscrcss"><link media="all" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_7925ae92bf57eb155ff62927ef947909.css" rel="stylesheet" /></noscript><title>Voices | Dec. 3-10 - Philadelphia Weekly</title><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://philadelphiaweekly.com/voices-dec-3-10/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Voices | Dec. 3-10 - Philadelphia Weekly" /><meta property="og:description" content="Reactions, rants and other random musings from you, our readers" /><meta property="og:url" content="https://philadelphiaweekly.com/voices-dec-3-10/" /><meta property="og:site_name" content="Philadelphia Weekly" /><meta property="article:publisher" content="https://www.facebook.com/phillyweekly/" /><meta property="article:published_time" content="2020-12-06T18:46:39+00:00" /><meta property="article:modified_time" content="2020-12-06T18:49:53+00:00" /><meta property="og:image" content="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/12/Shoutout-scaled.jpg?fit=1707%2C2560&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta property="og:image:width" content="1707" /><meta property="og:image:height" content="2560" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@phillyweekly" /><meta name="twitter:site" content="@phillyweekly" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://philadelphiaweekly.com/#organization","name":"Philadelphia Weekly","url":"https://philadelphiaweekly.com/","sameAs":["https://www.facebook.com/phillyweekly/","https://www.instagram.com/phillyweekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://twitter.com/phillyweekly"],"logo":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#logo","inLanguage":"en-US","url":"https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&quality=70&strip=all&ssl=1","width":500,"height":500,"caption":"Philadelphia Weekly"},"image":{"@id":"https://philadelphiaweekly.com/#logo"}},{"@type":"WebSite","@id":"https://philadelphiaweekly.com/#website","url":"https://philadelphiaweekly.com/","name":"Philadelphia Weekly","description":"","publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://philadelphiaweekly.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/voices-dec-3-10/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/12/Shoutout-scaled.jpg?fit=1707%2C2560&quality=70&strip=all&ssl=1","width":1707,"height":2560,"caption":"In 'Voices' this week, a former Philly ADA laments the current state of the city and how dangerous it has become with our current D.A. in charge of prosecuting criminals. | Image: David von Diemar"},{"@type":"WebPage","@id":"https://philadelphiaweekly.com/voices-dec-3-10/#webpage","url":"https://philadelphiaweekly.com/voices-dec-3-10/","name":"Voices | Dec. 3-10 - Philadelphia Weekly","isPartOf":{"@id":"https://philadelphiaweekly.com/#website"},"primaryImageOfPage":{"@id":"https://philadelphiaweekly.com/voices-dec-3-10/#primaryimage"},"datePublished":"2020-12-06T18:46:39+00:00","dateModified":"2020-12-06T18:49:53+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://philadelphiaweekly.com/voices-dec-3-10/"]}]},{"@type":"Article","@id":"https://philadelphiaweekly.com/voices-dec-3-10/#article","isPartOf":{"@id":"https://philadelphiaweekly.com/voices-dec-3-10/#webpage"},"author":{"@id":"https://philadelphiaweekly.com/#/schema/person/6d10bb5ac4140a42ca14aa4e8065e28d"},"headline":"Voices | Dec. 3-10","datePublished":"2020-12-06T18:46:39+00:00","dateModified":"2020-12-06T18:49:53+00:00","mainEntityOfPage":{"@id":"https://philadelphiaweekly.com/voices-dec-3-10/#webpage"},"publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"image":{"@id":"https://philadelphiaweekly.com/voices-dec-3-10/#primaryimage"},"keywords":"Jenny DeHuff,Larry Krasner,opinion,philly,readers,Voices of our City","articleSection":"Opinion,Voices of Our City","inLanguage":"en-US"},{"@type":"Person","@id":"https://philadelphiaweekly.com/#/schema/person/6d10bb5ac4140a42ca14aa4e8065e28d","name":"Philly Editor","image":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/a2af5953cb6b5d09567512df874c23dd?s=96&d=mm&r=g","caption":"Philly Editor"}}]}</script> <link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//c0.wp.com' /><link rel='dns-prefetch' href='//i0.wp.com' /><link rel='dns-prefetch' href='//i1.wp.com' /><link rel='dns-prefetch' href='//i2.wp.com' /><link href='https://use.typekit.net' rel='preconnect' /><link href='https://www.google-analytics.com' rel='preconnect' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Feed" href="https://philadelphiaweekly.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Comments Feed" href="https://philadelphiaweekly.com/comments/feed/" /><link rel="alternate" type="text/calendar" title="Philadelphia Weekly &raquo; iCal Feed" href="https://philadelphiaweekly.com/events/?ical=1" /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify;}</style> <script type='application/json' id='wpp-json'>{"sampling_active":0,"sampling_rate":50,"ajax_url":"https:\/\/philadelphiaweekly.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":24656,"token":"2fb0899aac","lang":0,"debug":0}</script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-700394-5' id='google_gtagjs-js' async></script> <script type='text/javascript' id='google_gtagjs-js-after'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["philadelphiaweekly.com"]} );
gtag('js', new Date());
gtag('set', 'developer_id.dZTNiMT', true);
gtag('config', 'UA-700394-5', {"anonymize_ip":true} );</script> <link rel="https://api.w.org/" href="https://philadelphiaweekly.com/wp-json/" /><link rel="alternate" type="application/json" href="https://philadelphiaweekly.com/wp-json/wp/v2/posts/24656" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://philadelphiaweekly.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://philadelphiaweekly.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.5.3" /><link rel='shortlink' href='https://philadelphiaweekly.com/?p=24656' /><link rel="alternate" type="application/json+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fvoices-dec-3-10%2F" /><link rel="alternate" type="text/xml+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fvoices-dec-3-10%2F&#038;format=xml" /><meta name="generator" content="Site Kit by Google 1.21.0" /><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://philadelphiaweekly.com"><link rel="https://theeventscalendar.com/" href="https://philadelphiaweekly.com/wp-json/tribe/events/v1/" /><style type="text/css">.header{background-color: #0a0a0a;}.header .SearchForm-button{color: #ffffff;}.Navigation--primary{color: #ffffff;}</style><style type="text/css">/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}</style> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=32%2C21&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=192%2C128&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=180%2C120&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=270%2C180&#038;quality=70&#038;strip=all&#038;ssl=1" /> <script>window.dataLayer = window.dataLayer || [];
	  function gtag(){dataLayer.push(arguments);}
	  gtag('js', new Date());

	  gtag('config', 'UA-700394-5');</script> </head><body class="post-template-default single single-post postid-24656 single-format-standard tribe-no-js tribe-theme-parent-truro tribe-theme-child-truro-pw-child"> <a class="skip-link screen-reader-text" href="#Content">Skip to content</a><header class="header header--four"><div class="header-section header-section--primary"><div class="header-container"><div class="header-sectionInner"><div class="header-part"><div class="Branding"> <a href="https://philadelphiaweekly.com/" rel="home"> <img class="Branding-logo" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/PW-weekly-white-horizontal-1-1.svg" alt="Philadelphia Weekly" width="200px" /> </a></div></div><div class="header-part header-part__navigation"><nav class="Navigation Navigation--primary"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation" class="menu"><li id="menu-item-227" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li id="menu-item-221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li id="menu-item-188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li id="menu-item-191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li id="menu-item-192" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li id="menu-item-193" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li id="menu-item-194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li id="menu-item-7201" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li id="menu-item-195" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li id="menu-item-222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li id="menu-item-518" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li id="menu-item-375" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li id="menu-item-377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li id="menu-item-385" class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li id="menu-item-366" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-366"><a href="https://philadelphiaweekly.com/sections/featured-sections/savage-love/">Savage Love</a></li><li id="menu-item-384" class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li id="menu-item-543" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-128" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></nav><div class="utility-navigation"><form class="SearchForm SearchForm--header" method="get" action="https://philadelphiaweekly.com/"> <span class="screen-reader-text">Search for:</span> <input class="SearchForm-field" type="text" placeholder="Type &amp; press enter" value="" name="s" title="Search for:" /> <button type="submit" class="screen-reader-text" aria-label="Search">Search</button> <button class="SearchForm-button" aria-label="Submit"><i class="fa fa-search" aria-hidden="true"></i></button></form></div></div></div></div></div></header><nav class="Navigation Navigation--mobile"><div class="container"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-366"><a href="https://philadelphiaweekly.com/sections/featured-sections/savage-love/">Savage Love</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></div></nav><div class="content content--fullWidth" id="content"><div class="content-inner"><div class="content-container"><div class="content-row content-row--article"><main class="content-main"><header class="article-header"><div class="meta-tags"> <span class="Meta-item"><li class="Meta-item Meta-item--categories"><ul class="Meta Meta--banner"><li class="Meta-item Meta-item--categories"><ul><li><a href="https://philadelphiaweekly.com/sections/opinion/" title="Opinion">Opinion</a></li><li><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/" title="Voices of Our City">Voices of Our City</a></li></ul></li></ul></li> </span></div><h1>Voices | Dec. 3-10</h1><div class="posts-teaser"><p>Reactions, rants and other random musings from you, our readers</p></div><footer class="Post-footer"><ul class="Meta Meta--article"><li class="Meta-item Meta-item--author"> <a class="meta-author-article" href="https://philadelphiaweekly.com/writer/philly-weekly-staff/"><figure class="meta-author-headshot"><img width="100" height="100" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-headshot size-headshot wp-post-image jetpack-lazy-image" alt="Philadelphia Weekly" loading="lazy" data-attachment-id="13" data-permalink="https://philadelphiaweekly.com/favicon/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="500,500" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="favicon" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=300%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?w=500&amp;quality=70&amp;strip=all&amp;ssl=1 500w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=300%2C300&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=350%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 350w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=150%2C150&amp;quality=70&amp;strip=all&amp;ssl=1 150w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></figure> <span class="meta-author-name">Philly Weekly Staff</span></a></li><li class="Meta-item Meta-item--date">December 6th, 2020</li></ul><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/voices-dec-3-10/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20Voices | Dec. 3-10%20-%20https://philadelphiaweekly.com/voices-dec-3-10/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20Voices | Dec. 3-10%20-%20https://philadelphiaweekly.com/voices-dec-3-10/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: Voices | Dec. 3-10%20https://philadelphiaweekly.com/voices-dec-3-10/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></footer></header><header class="Post-header"><figure class="Post-thumbnail"> <a data-fancybox="gallery" data-caption="In &#8216;Voices&#8217; this week, a former Philly ADA laments the current state of the city and how dangerous it has become with our current D.A. in charge of prosecuting criminals. | Image: David von Diemar " href="https://philadelphiaweekly.com/wp-content/uploads/2020/12/Shoutout-scaled.jpg"><img width="1200" height="675" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/12/Shoutout-scaled.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-feature-image size-feature-image wp-post-image jetpack-lazy-image" alt="Caution tape" loading="lazy" data-attachment-id="24657" data-permalink="https://philadelphiaweekly.com/voices-dec-3-10/shoutout-9/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/12/Shoutout-scaled.jpg?fit=1707%2C2560&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1707,2560" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Shoutout" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/12/Shoutout-scaled.jpg?fit=200%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/12/Shoutout-scaled.jpg?fit=683%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/12/Shoutout-scaled.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></a><figcaption>In &#8216;Voices&#8217; this week, a former Philly ADA laments the current state of the city and how dangerous it has become with our current D.A. in charge of prosecuting criminals. | Image: David von Diemar</figcaption></figure></header><div class="sharing-desktop"><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/voices-dec-3-10/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20Voices | Dec. 3-10%20-%20https://philadelphiaweekly.com/voices-dec-3-10/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20Voices | Dec. 3-10%20-%20https://philadelphiaweekly.com/voices-dec-3-10/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: Voices | Dec. 3-10%20https://philadelphiaweekly.com/voices-dec-3-10/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></div><article id="Post-24656"  class="Post Post--single post-24656 post type-post status-publish format-standard has-post-thumbnail hentry category-opinion category-voices-of-our-city tag-jenny-dehuff tag-larry-krasner tag-opinion tag-philly tag-readers tag-voices-of-our-city"><div class="Post-content"><h4>The Shout out: In Voices this week, former Philadelphia Assistant District Attorney Reeve Swainston writes about how dangerous the city has become.</h4><p>Your turn: Do you feel safe in Philadelphia? If not, who’s to blame?</p><p>Send your thoughts to <a href="mailto:voices@philadelphiaweekly.com">voices@philadelphiaweekly.com</a></p><h4><strong>Thanksgiving Eve booze ban definitely made sense</strong></h4><p><strong><em>Editor’s note: This is in response to PW editor Jenny DeHuff&#8217;s Nov. 26 column: “State booze ban on Thanksgiving Eve a real bummer”</em></strong></p><p>Did you ever think that when people are buzzed they are not as vigilant? I don’t think this is a stupid restriction at all, people could have stocked up in advance. The more restrictions, the better – my husband almost died from COVID. Your commentary is cavalier.</p><p><strong><em>Fran Pollock | Philadelphia</em></strong></p><h4><strong>Costly projects won’t be missed</strong></h4><p>Because of distance learning, teachers can’t assign extravagant and costly physical projects, and I, for one, am glad. I did not learn a thing from any of them. Not from the elaborate diorama of a biome, the three-dimensional depiction of a cell made from cake, nor from the life-sized medieval shield that I had to create. The same is true for many of my peers. So why, pre-pandemic, were we assigned them?</p><p>I asked some of my teachers that question, and often they’d justify those assignments by emphasizing a need for creativity. And that seemed to be a fair explanation. That is until I considered what class we were talking about. When a need for creativity was offered as justification, it was for every class but art. So, what else could&#8217;ve been the reason?</p><p>In each of the aforementioned instances (though, there are many more) of physical projects being assigned, student understanding could’ve been demonstrated in other ways. Ways that did not require the creation of something costly and time-consuming. And given their use of some of the alternatives, like quizzes, essays, and oral presentations, teachers know – and knew – that there are other ways. This means that they were choosing to assign physical projects in the face of resource-sparing alternatives, knowing that it will cost students and their parents.&nbsp;</p><p>In all fairness, some schools mandate project assignments; not all teachers had a choice. But for the teachers that did or who favor project assignments, why? For free wall décor? I have a lot of respect for teachers, and that is the last thing I’d want to believe. But when you’ve had multiple teachers that have prefaced their pronouncement of an upcoming project with, “my walls are bare,” you are given no choice but to believe that was true.&nbsp;</p><p>Deeper in the abyss of wrong is that students were forced to do it using their own materials. Teachers rarely provided what was needed.&nbsp;</p><p>For five days of every week, we woke up early in the morning, got dressed, and chased after our bus or train to get to school. We spent eight hours in school, and even after we left, we were still doing school-related work. Then we went to sleep, woke up, and repeated. One would hope that everything done in that mundane, school-induced cycle was to the benefit of the student. That was not the case. Time was wasted regularly, and among the most flagrant wastes of time was the assignment of physical projects that did not represent data. The silver-lining of distance-learning has been the absence of that waste.</p><p><em>Jemille Q. Duncan | Philadelphia</em></p><h4><strong>A letter to my beloved Philadelphia</strong></h4><p>Dear Philadelphia,</p><p>I was an assistant district attorney in Philly in the 1990s. Over the past two decades, I have prosecuted countless violent offenders, insidious Mexican cartels, hostile gangs, and much more as a federal prosecutor in New Mexico. I am now retired.</p><p>I write to express my sadness for a once great city. Over the past two years, I have traveled to Philly numerous times for medical procedures at Jefferson Hospital. You are fortunate to have some of the best hospitals and doctors in the country. During a recent visit, I left knowing I would never return. Philadelphia has simply become too dangerous. It broke my heart to realize that the risks to my family and I are just not worth the upside to securing high-quality medical care in a city I truly love.&nbsp;&nbsp;</p><p>As a federal prosecutor, I know firsthand that effective prosecutions of dangerous and violent offenders will unquestionably result in safer communities. It is often recidivists who commit the vast majority of crimes, thus the effective strategy of prosecuting and imprisoning the “worst of the worst” by itself can have a dramatic impact for even the most vulnerable communities.&nbsp;&nbsp;&nbsp;&nbsp;</p><p>During my visits, I met with some of your exhausted police officers, criminal defense attorneys (some of whom I worked with many years ago), and regular citizens who are innocent victims of your crime epidemic. What I learned from these discussions is that Philadelphia has become a lawless city where violent, repeat offenders know that their cases are unlikely to be prosecuted. Should your useless district attorney, Larry Krasner, actually decide to prosecute a particular case, those arrested know full well that they will likely be released within hours of their arrest, able to offend again. Perhaps worse, even if they are actually prosecuted and convicted, these offenders also know their sentences will likely be so lenient that even they come away surprised by their good fortune. I was told that many of the cases referred to the district attorney for prosecution end up being dismissed for non-prosecution, an utterly disgraceful way for any criminal case to end.</p><p>As I walked around the city, I saw private security officers everywhere. You are so overrun with crime that even Wawa has security, something I found quite staggering. Some of the defense attorneys I know personally told me they are effectively useless since those arrested for even violent offenses know that Krasner is the only lawyer they really need – his formula for prosecution being non-prosecution. I have a feeling criminal defense attorneys have had to either reduce their fees or pursue other kinds of cases since Krasner took office. Why even bother getting a lawyer if your case is likely to be dismissed anyway? Just show up to court – nothing will happen.</p><p>The officers I talked to were utterly distraught by what’s happening in the communities they serve. They explained how they see the same offenders they’ve previously arrested over and over again. As long as drug cases, robberies, property crime, and crimes of violence go unprosecuted (like the recent, appalling assault on an innocent woman at the Cathedral Basilica of SS. Peter and Paul), and such offenders are treated like victims instead of criminals, Philadelphia has no hope to dig its way out of this chaos. By the way, do not believe Krasner and others who use the term “non-violent drug offender,” which is often used as an excuse not to prosecute or under-prosecute drug criminals. I assure you, from years of experience, that there is no such thing. One of the lessons I learned from prosecuting the cartels is that all drug offenders belong to an inherently violent occupation, and all must be prosecuted aggressively to make a difference.</p><p>I am praying for you, Philadelphia. I love you and hope that you can find your way out of this madness. But sadly, until you rid yourself of your crime-friendly radical representatives in your city government, including Krasner and your equally apathetic mayor, Philadelphia will continue to drown in this maddening wave of crime and violence.&nbsp;&nbsp;</p><p><strong><em>Reeve Swainston is a former Philadelphia Assistant District Attorney under Lynn Abraham, a former Assistant U.S. Attorney, District of New Mexico, and a former U.S. Marine machine-gunner. This article was originally published at Broad + Liberty. Follow them on Twitter <a href="http://@BroadAndLiberty">@BroadAndLiberty</a></em></strong></p><h5 class="related-posts__title">Related</h5><ul class="related-posts"><li><a href="https://philadelphiaweekly.com/easier-said-than-done/" rel="bookmark" title="Permanent Link to Easier said than done">Easier said than done</a></li><li><a href="https://philadelphiaweekly.com/soft-spot/" rel="bookmark" title="Permanent Link to Soft spot">Soft spot</a></li><li><a href="https://philadelphiaweekly.com/pw-weekend-picks-aug-2-4/" rel="bookmark" title="Permanent Link to PW weekend picks: Aug. 2-4">PW weekend picks: Aug. 2-4</a></li><li><a href="https://philadelphiaweekly.com/crime-beat-dec-3-10/" rel="bookmark" title="Permanent Link to Crime Beat | Dec. 3-10">Crime Beat | Dec. 3-10</a></li></ul><ul class="Meta"><li class="Meta-item Meta-item--tags"><ul><li><a href="https://philadelphiaweekly.com/tag/jenny-dehuff/" title=" Jenny DeHuff ">Jenny DeHuff</a></li><li><a href="https://philadelphiaweekly.com/tag/larry-krasner/" title=" Larry Krasner ">Larry Krasner</a></li><li><a href="https://philadelphiaweekly.com/tag/opinion/" title=" opinion ">opinion</a></li><li><a href="https://philadelphiaweekly.com/tag/philly/" title=" philly ">philly</a></li><li><a href="https://philadelphiaweekly.com/tag/readers/" title=" readers ">readers</a></li><li><a href="https://philadelphiaweekly.com/tag/voices-of-our-city/" title=" Voices of our City ">Voices of our City</a></li></ul></li></ul></div></article><ul class="author-article-bio"><li class="author-bio__item"> <a class="author-bio__headshot" href="https://philadelphiaweekly.com/writer/philly-weekly-staff/"><figure><img width="100" height="100" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-headshot size-headshot wp-post-image jetpack-lazy-image" alt="Philadelphia Weekly" loading="lazy" data-attachment-id="13" data-permalink="https://philadelphiaweekly.com/favicon/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="500,500" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="favicon" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=300%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?w=500&amp;quality=70&amp;strip=all&amp;ssl=1 500w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=300%2C300&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=350%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 350w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=150%2C150&amp;quality=70&amp;strip=all&amp;ssl=1 150w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></figure> </a><div class="author-name__container"> <a class="author-bio__name" href="https://philadelphiaweekly.com/writer/philly-weekly-staff/"><h6>Philly Weekly Staff</h6> </a><ul class="author-bio__social"><li class="author-bio__social__item"> <a href="https://www.twitter.com/phillyweekly"> <i class="author-bio__social__icon fa fa-twitter" aria-hidden="true"></i><div class="author-bio__social__handle">@phillyweekly</div> </a></li></ul></div><div class="author-bio__info"><p>Articles compiled by Philly Weekly&#8217;s editorial team.</p></div></li></ul></main></div><section class="RelatedPosts"><div class="category-row__bar"><h2 class="category-row__title">Up Next in Opinion</h2></div><ul class="posts-row"><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/voices-oct-8-15/" title="Voices | Oct. 8-15"> <img width="680" height="480" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/cdc-Ek8oxbjnJtQ-unsplash.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="CDC scientists" loading="lazy" data-attachment-id="23236" data-permalink="https://philadelphiaweekly.com/voices-oct-8-15/cdc-ek8oxbjnjtq-unsplash/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/cdc-Ek8oxbjnJtQ-unsplash.jpg?fit=1920%2C1324&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1920,1324" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="cdc-Ek8oxbjnJtQ-unsplash" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/cdc-Ek8oxbjnJtQ-unsplash.jpg?fit=300%2C207&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/cdc-Ek8oxbjnJtQ-unsplash.jpg?fit=1024%2C706&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/cdc-Ek8oxbjnJtQ-unsplash.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/cdc-Ek8oxbjnJtQ-unsplash.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/cdc-Ek8oxbjnJtQ-unsplash.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/voices-oct-8-15/" title="Voices | Oct. 8-15"><h5 class="RecentPosts-title">Voices | Oct. 8-15</h5> </a><div class="posts-teaser"><p>Reactions, rants and other random musings from you, our readers</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Oct 9, 2020</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/read-all-about-it/" title="Icepack | Nov. 19-26"> <img width="680" height="480" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/11/Icenewspaper-1-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Newspaper" loading="lazy" data-attachment-id="24216" data-permalink="https://philadelphiaweekly.com/read-all-about-it/icenewspaper-2/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/11/Icenewspaper-1-scaled.jpg?fit=2560%2C1496&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1496" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Icenewspaper" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/11/Icenewspaper-1-scaled.jpg?fit=300%2C175&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/11/Icenewspaper-1-scaled.jpg?fit=1024%2C598&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/11/Icenewspaper-1-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/11/Icenewspaper-1-scaled.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/11/Icenewspaper-1-scaled.jpg?zoom=3&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 2040w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/11/Icenewspaper-1-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/read-all-about-it/" title="Icepack | Nov. 19-26"><h5 class="RecentPosts-title">Icepack | Nov. 19-26</h5> </a><div class="posts-teaser"><p>Read all about it, y'all. It’s a new day for Philadelphia media</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Nov 19, 2020</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/teen-whisperer/" title="Teen whisperer"> <img width="680" height="480" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/daniel-ruyter-JFA2vSpEUMY-unsplash-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Downward spiral at playground" loading="lazy" data-attachment-id="15349" data-permalink="https://philadelphiaweekly.com/teen-whisperer/daniel-ruyter-jfa2vspeumy-unsplash/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/daniel-ruyter-JFA2vSpEUMY-unsplash-scaled.jpg?fit=2560%2C1706&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1706" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/daniel-ruyter-JFA2vSpEUMY-unsplash-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/daniel-ruyter-JFA2vSpEUMY-unsplash-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/daniel-ruyter-JFA2vSpEUMY-unsplash-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/daniel-ruyter-JFA2vSpEUMY-unsplash-scaled.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/daniel-ruyter-JFA2vSpEUMY-unsplash-scaled.jpg?zoom=3&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 2040w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/daniel-ruyter-JFA2vSpEUMY-unsplash-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/teen-whisperer/" title="Teen whisperer"><h5 class="RecentPosts-title">Teen whisperer</h5> </a><div class="posts-teaser"><p>Before you call the cops on Philly's teens, get some courage and talk to them</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Jan 15, 2020</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/friends-indeed/" title="Friends, indeed"> <img width="680" height="480" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Image of Dan Savage" loading="lazy" data-attachment-id="534" data-permalink="https://philadelphiaweekly.com/5cba3c4bd7528-image-4/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?fit=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1200,675" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="5cba3c4bd7528.image" data-image-description="&lt;p&gt;Savage Love&lt;/p&gt;
" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?fit=300%2C169&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?fit=1024%2C576&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/5cba3c4bd7528.image_-3.png?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/friends-indeed/" title="Friends, indeed"><h5 class="RecentPosts-title">Friends, indeed</h5> </a><div class="posts-teaser"><p>This week, Dan Savage weighs in on dating during COVID-19, lesbians and divorce</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Jul 30, 2020</li></ul></footer></li></ul></section><div class="Columns-row columns-even"><div class="Columns-column"><div class="most-popular"><h2>Most Popular This Week</h2><ol class="most-popular-list"><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/food-festivities-and-all-the-fireworks-planned-for-this-summers-wawa-welcome-america-celebration/">Food, festivities and ALL the fireworks planned for this summer’s Wawa Welcome America celebration</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/" class="category category-149">From the Editor</a>, <a href="https://philadelphiaweekly.com/sections/opinion/" class="category category-3039">Opinion</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/phillys-brand-new-pw/">Philly&#8217;s brand-new PW</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/food-drink/" class="category category-90">Food / Drink</a>, <a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a>, <a href="https://philadelphiaweekly.com/sections/people/" class="category category-91">People</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/check-please/">Check, please</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/" class="category category-93">LGBTQ / Sex</a>, <a href="https://philadelphiaweekly.com/sections/featured-sections/sex-with-timaree-featured-sections/" class="category category-13117">Sex with Timaree</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/its-dangerous-to-be-a-man/">It&#8217;s dangerous to be a man</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/" class="category category-93">LGBTQ / Sex</a>, <a href="https://philadelphiaweekly.com/sections/featured-sections/sex-with-timaree-featured-sections/" class="category category-13117">Sex with Timaree</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/nudes-from-an-ex/">Nudes from an ex</a></li></ol></div> <a class="Button" href="/popular">More Popular Articles</a></div><div class="Columns-column columns-even__right"><div class="calendar-events-teaser"><h2>Upcoming Philly Events</h2><ul class="calendar-events"><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/jkyog-free-adult-online-meditation-sessions/2020-12-06/"> <time class="calendar-events__date">Sun, Dec 06</time><h6 class="calendar-events__title">JKYog Free Adult  online Meditation Sessions</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Online</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/jkyog-free-adult-online-meditation-sessions/2020-12-07/"> <time class="calendar-events__date">Mon, Dec 07</time><h6 class="calendar-events__title">JKYog Free Adult  online Meditation Sessions</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Online</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/jkyog-free-adult-online-meditation-sessions/2020-12-08/"> <time class="calendar-events__date">Tue, Dec 08</time><h6 class="calendar-events__title">JKYog Free Adult  online Meditation Sessions</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Online</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/jkyog-free-adult-online-meditation-sessions/2020-12-09/"> <time class="calendar-events__date">Wed, Dec 09</time><h6 class="calendar-events__title">JKYog Free Adult  online Meditation Sessions</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Online</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/christmas-tales-in-the-backyard/"> <time class="calendar-events__date">Thu, Dec 10</time><h6 class="calendar-events__title">CHRISTMAS TALES IN THE BACKYARD</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">East Lynne Theater Company</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/volunteer-with-uhuru-furniture-and-support-black-self-determination-orientations-5pm-every-thursday/2020-12-10/"> <time class="calendar-events__date">Thu, Dec 10</time><h6 class="calendar-events__title">Volunteer with Uhuru Furniture and support black self-determination! Orientations 5pm every Thursday</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Uhuru Furniture &amp; Collectibles</li></ul></li></ul> <a class="Button" href="/calendar">More Events</a></div></div></div></div></div></div><footer class="footer"><div class="footer-section footer-section--primary"><div class="footer-container"></div></div><div class="footer-section footer-section--secondary"><div class="footer-container"><div class="footer-inner"><div class="footer-inner__branding"><div class="footer-inner__logo"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_social"><p>Follow @PhillyWeekly</p><ul class="footer-inner__social__list"><li> <a href="https://www.facebook.com/pg/phillyweekly/posts/"> <i class="fa fa-facebook-square" aria-hidden="true"></i> <span>Facebook</span> </a></li><li> <a href="https://twitter.com/PhillyWeekly/"> <i class="fa fa-twitter" aria-hidden="true"></i> <span>Twitter</span> </a></li><li> <a href="https://www.instagram.com/phillyweekly/"> <i class="fa fa-instagram" aria-hidden="true"></i> <span>Instagram</span> </a></li><li> <a href="https://philadelphiaweekly.com/feeds"> <i class="fa fa-rss" aria-hidden="true"></i> <span>Your News Reader</span> </a></li></ul></div></div><nav class="Navigation Navigation--footer"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-133"><a href="#">About PW</a><ul class="sub-menu"><li id="menu-item-334" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334"><a href="https://philadelphiaweekly.com/about/">About Us</a></li><li id="menu-item-386" class="menu-item menu-item-type-post_type_archive menu-item-object-writer menu-item-386"><a href="https://philadelphiaweekly.com/writer/">Our Writers</a></li><li id="menu-item-336" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-336"><a href="/advertising">Advertising &#038; Partnerships</a></li><li id="menu-item-338" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-338"><a href="/events/community/add">Submit an Event</a></li></ul></li><li id="menu-item-134" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-134"><a href="#">Explore PW</a><ul class="sub-menu"><li id="menu-item-228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-228"><a href="https://philadelphiaweekly.com/sections/">Sections</a></li><li id="menu-item-137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-136" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-335"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></li></ul></div></nav><div class="footer-inner_contact-text"><div class="footer-inner__logo--desktop"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_contact"><p>1520 Locust Street, Fifth Floor</p><p>Philadelphia, PA 19102</p></div><div class="footer-inner_contact footer-inner_contact__phone"><p>215-543-3743</p><p><a href="mailto:mail@philadelphiaweekly.com">mail@philadelphiaweekly.com</a></p></div><div class="footer-info"> &copy; Copyright Philadelphia Weekly</div></div></div></div></footer></div> <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script> <script type='text/javascript' id='contact-form-7-js-extra'>var wpcf7 = {"apiSettings":{"root":"https:\/\/philadelphiaweekly.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript' id='wpa-complementary-js-extra'>var wpaComplementary = [""];</script> <script type='text/javascript' id='truro-scripts-js-extra'>var customizer = {"sliderSlideCount":"1","sliderLoop":"0","sliderAutoPlay":"0","sliderAutoPlaySpeed":"7000","sliderArrows":"1","sliderDots":"1"};</script> <link rel="stylesheet" href="https://use.typekit.net/cgg8jik.css"> <script defer src="https://philadelphiaweekly.com/wp-content/cache/autoptimize/js/autoptimize_ad8b96b507415acbcafae3709c959c7f.js"></script></body></html>