<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="stylesheet" media="print" onload="this.onload=null;this.media='all';" id="ao_optimized_gfonts" href="https://fonts.googleapis.com/css?family=Lora%3A400%2C400i%2C700%7CLora%3A400%2C700%2Cbold%2Cregular&amp;display=swap" /><link rel="profile" href="http://gmpg.org/xfn/11"><meta property="fb:pages" content="23117126720" /><link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png"><link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png"><link rel="manifest" href="/site.webmanifest"><link rel="mask-icon" href="/safari-pinned-tab.svg" color="#ffc414"><meta name="msapplication-TileColor" content="#231f20"><meta name="theme-color" content="#231f20"> <style type="text/css">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</style><meta name='robots' content='max-image-preview:large' /><link rel="stylesheet" media="print" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_721734f108c5129c27a605a8d2301ce8.css" onload="this.onload=null;this.media='all';" /><noscript id="aonoscrcss"><link media="all" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_721734f108c5129c27a605a8d2301ce8.css" rel="stylesheet" /></noscript><title>Kickin’ it with the Sons of Ben - Philadelphia Weekly</title><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Kickin’ it with the Sons of Ben - Philadelphia Weekly" /><meta property="og:description" content="The Philadelphia Union’s traveling road show" /><meta property="og:url" content="https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/" /><meta property="og:site_name" content="Philadelphia Weekly" /><meta property="article:publisher" content="https://www.facebook.com/phillyweekly/" /><meta property="article:published_time" content="2021-07-07T20:02:31+00:00" /><meta property="article:modified_time" content="2021-07-07T20:02:33+00:00" /><meta property="og:image" content="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Sons-of-Ben-scaled.jpg?fit=2560%2C1753&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta property="og:image:width" content="2560" /><meta property="og:image:height" content="1753" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@phillyweekly" /><meta name="twitter:site" content="@phillyweekly" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://philadelphiaweekly.com/#organization","name":"Philadelphia Weekly","url":"https://philadelphiaweekly.com/","sameAs":["https://www.facebook.com/phillyweekly/","https://www.instagram.com/phillyweekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://twitter.com/phillyweekly"],"logo":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#logo","inLanguage":"en-US","url":"https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&quality=70&strip=all&ssl=1","width":500,"height":500,"caption":"Philadelphia Weekly"},"image":{"@id":"https://philadelphiaweekly.com/#logo"}},{"@type":"WebSite","@id":"https://philadelphiaweekly.com/#website","url":"https://philadelphiaweekly.com/","name":"Philadelphia Weekly","description":"","publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://philadelphiaweekly.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Sons-of-Ben-scaled.jpg?fit=2560%2C1753&quality=70&strip=all&ssl=1","width":2560,"height":1753,"caption":"The Sons of Ben faithful are a cross-section of generations, neighborhoods, and backgrounds. To Nashville, they brought a kaleidoscope family of city dwellers and country dwellers tied together by a team. Image | Megan Swanick"},{"@type":"WebPage","@id":"https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/#webpage","url":"https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/","name":"Kickin\u2019 it with the Sons of Ben - Philadelphia Weekly","isPartOf":{"@id":"https://philadelphiaweekly.com/#website"},"primaryImageOfPage":{"@id":"https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/#primaryimage"},"datePublished":"2021-07-07T20:02:31+00:00","dateModified":"2021-07-07T20:02:33+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/"]}]},{"@type":"Article","@id":"https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/#article","isPartOf":{"@id":"https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/#webpage"},"author":{"@id":"https://philadelphiaweekly.com/#/schema/person/6d10bb5ac4140a42ca14aa4e8065e28d"},"headline":"Kickin\u2019 it with the Sons of Ben","datePublished":"2021-07-07T20:02:31+00:00","dateModified":"2021-07-07T20:02:33+00:00","mainEntityOfPage":{"@id":"https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/#webpage"},"publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"image":{"@id":"https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/#primaryimage"},"keywords":"soccer,sons of ben","articleSection":"News","inLanguage":"en-US"},{"@type":"Person","@id":"https://philadelphiaweekly.com/#/schema/person/6d10bb5ac4140a42ca14aa4e8065e28d","name":"Philly Editor","image":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/a2af5953cb6b5d09567512df874c23dd?s=96&d=mm&r=g","caption":"Philly Editor"}}]}</script> <link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//c0.wp.com' /><link rel='dns-prefetch' href='//i0.wp.com' /><link rel='dns-prefetch' href='//i1.wp.com' /><link rel='dns-prefetch' href='//i2.wp.com' /><link href='https://use.typekit.net' rel='preconnect' /><link href='https://www.google-analytics.com' rel='preconnect' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Feed" href="https://philadelphiaweekly.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Comments Feed" href="https://philadelphiaweekly.com/comments/feed/" /><link rel="alternate" type="text/calendar" title="Philadelphia Weekly &raquo; iCal Feed" href="https://philadelphiaweekly.com/events/?ical=1" /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify;}</style> <script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/plugins/jquery-manager/assets/js/jquery-3.5.1.min.js' id='jquery-core-js'></script> <script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/plugins/jquery-manager/assets/js/jquery-migrate-3.3.0.min.js' id='jquery-migrate-js'></script> <script type='application/json' id='wpp-json'>{"sampling_active":0,"sampling_rate":50,"ajax_url":"https:\/\/philadelphiaweekly.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":30843,"token":"531b01cf2b","lang":0,"debug":0}</script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-700394-5' id='google_gtagjs-js' async></script> <script type='text/javascript' id='google_gtagjs-js-after'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["philadelphiaweekly.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-700394-5", {"anonymize_ip":true});</script> <link rel="https://api.w.org/" href="https://philadelphiaweekly.com/wp-json/" /><link rel="alternate" type="application/json" href="https://philadelphiaweekly.com/wp-json/wp/v2/posts/30843" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://philadelphiaweekly.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://philadelphiaweekly.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.7.2" /><link rel='shortlink' href='https://philadelphiaweekly.com/?p=30843' /><link rel="alternate" type="application/json+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fkickin-it-with-the-sons-of-ben%2F" /><link rel="alternate" type="text/xml+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fkickin-it-with-the-sons-of-ben%2F&#038;format=xml" />  <script>"use strict";

!function() {
  var t = window.driftt = window.drift = window.driftt || [];
  if (!t.init) {
    if (t.invoked) return void (window.console && console.error && console.error("Drift snippet included twice."));
    t.invoked = !0, t.methods = [ "identify", "config", "track", "reset", "debug", "show", "ping", "page", "hide", "off", "on" ], 
    t.factory = function(e) {
      return function() {
        var n = Array.prototype.slice.call(arguments);
        return n.unshift(e), t.push(n), t;
      };
    }, t.methods.forEach(function(e) {
      t[e] = t.factory(e);
    }), t.load = function(t) {
      var e = 3e5, n = Math.ceil(new Date() / e) * e, o = document.createElement("script");
      o.type = "text/javascript", o.async = !0, o.crossorigin = "anonymous", o.src = "https://js.driftt.com/include/" + n + "/" + t + ".js";
      var i = document.getElementsByTagName("script")[0];
      i.parentNode.insertBefore(o, i);
    };
  }
}();
drift.SNIPPET_VERSION = '0.3.1';
drift.load('rk5uegyicbzi');</script> <meta name="generator" content="Site Kit by Google 1.31.0" /><script type="text/javascript">window.MemberfulOptions = {
    site: "https://philadelphiaweekly.memberful.com",
    intercept: [
            "http://philadelphiaweekly.com/?memberful_endpoint=auth",
            "https://philadelphiaweekly.com/?memberful_endpoint=auth",
            "http://philadelphiaweekly.com?memberful_endpoint=auth",
            "https://philadelphiaweekly.com?memberful_endpoint=auth",
          ],
    memberSignedIn: false  };

  (function() {
    var s = document.createElement('script');
    s.type = 'text/javascript';
    s.async = true;
    s.src = 'https://d35xxde4fgg0cx.cloudfront.net/assets/embedded.js';

    setup = function() { window.MemberfulEmbedded.setup(); };

    s.addEventListener("load", setup, false);

    ( document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0] ).appendChild( s );
  })();</script> <meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://philadelphiaweekly.com"><link rel="https://theeventscalendar.com/" href="https://philadelphiaweekly.com/wp-json/tribe/events/v1/" /><style>@-webkit-keyframes bgslide {
                from {
                    background-position-x: 0;
                }
                to {
                    background-position-x: -200%;
                }
            }

            @keyframes bgslide {
                    from {
                        background-position-x: 0;
                    }
                    to {
                        background-position-x: -200%;
                    }
            }

            .wpp-widget-placeholder {
                margin: 0 auto;
                width: 60px;
                height: 3px;
                background: #dd3737;
                background: -webkit-gradient(linear, left top, right top, from(#dd3737), color-stop(10%, #571313), to(#dd3737));
                background: linear-gradient(90deg, #dd3737 0%, #571313 10%, #dd3737 100%);
                background-size: 200% auto;
                border-radius: 3px;
                -webkit-animation: bgslide 1s infinite linear;
                animation: bgslide 1s infinite linear;
            }</style><style type="text/css">.header{background-color: #0a0a0a;}.header .SearchForm-button{color: #ffffff;}.Navigation--primary{color: #ffffff;}</style><style type="text/css">/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}</style> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link rel="amphtml" href="https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/amp/"><link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=32%2C21&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=192%2C128&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=180%2C120&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=270%2C180&#038;quality=70&#038;strip=all&#038;ssl=1" /> <script>window.dataLayer = window.dataLayer || [];
	  function gtag(){dataLayer.push(arguments);}
	  gtag('js', new Date());

	  gtag('config', 'UA-700394-5');</script> </head><body class="post-template-default single single-post postid-30843 single-format-standard tribe-no-js tribe-theme-parent-truro tribe-theme-child-truro-pw-child"> <a class="skip-link screen-reader-text" href="#Content">Skip to content</a><header class="header header--four"><div class="header-section header-section--primary"><div class="header-container"><div class="header-sectionInner"><div class="header-part"><div class="Branding"> <a href="https://philadelphiaweekly.com/" rel="home"> <img class="Branding-logo" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/PW-weekly-white-horizontal-1-1.svg" alt="Philadelphia Weekly" width="200px" /> </a></div></div><div class="header-part header-part__navigation"><nav class="Navigation Navigation--primary"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation" class="menu"><li id="menu-item-227" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li id="menu-item-221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li id="menu-item-188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li id="menu-item-191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li id="menu-item-192" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li id="menu-item-193" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li id="menu-item-194" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li id="menu-item-7201" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li id="menu-item-195" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li id="menu-item-222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li id="menu-item-27615" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27615"><a href="https://philadelphiaweekly.com/sections/altphilly/">AltPhilly</a></li><li id="menu-item-518" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li id="menu-item-375" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li id="menu-item-377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li id="menu-item-385" class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li id="menu-item-384" class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li id="menu-item-543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-128" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></nav><div class="utility-navigation"><nav class="Navigation Navigation--utility"><div class="menu-utility-navigation-container"><ul id="menu-utility-navigation" class="menu"><li id="menu-item-27636" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27636"><a href="https://philadelphiaweekly.com/join/">Join</a></li><li id="menu-item-132" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-132"><a href="https://philadelphiaweekly.com/?memberful_endpoint=auth"><span>Sign In</span></a></li></ul></div></nav><form class="SearchForm SearchForm--header" method="get" action="https://philadelphiaweekly.com/"> <span class="screen-reader-text">Search for:</span> <input class="SearchForm-field" type="text" placeholder="Type &amp; press enter" value="" name="s" title="Search for:" /> <button type="submit" class="screen-reader-text" aria-label="Search">Search</button> <button class="SearchForm-button" aria-label="Submit"><i class="fa fa-search" aria-hidden="true"></i></button></form></div></div></div></div></div></header><nav class="Navigation Navigation--mobile"><div class="container"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27615"><a href="https://philadelphiaweekly.com/sections/altphilly/">AltPhilly</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></div></nav><div class="content content--fullWidth" id="content"><div class="content-inner"><div class="content-container"><div class="header-promotional-message"><div class="header-promotional-message__inner"><div class="header-promotional-message__graphic"> <img src="/wp-content/themes/truro-pw-child/ui/hand-graphic.jpg" alt="Pointing Hand" /></div><div class="header-promotional-message__content"> Join the altPhilly membership program for exclusive content and awesome perks. <a class="header-promotional-message__link" href="https://philadelphiaweekly.com/join/"
 target="_self">Become a Member</a></div></div></div><div class="content-row content-row--article"><main class="content-main"><header class="article-header"><div class="meta-tags"> <span class="Meta-item"><li class="Meta-item Meta-item--categories"><ul class="Meta Meta--banner"><li class="Meta-item Meta-item--categories"><ul><li><a href="https://philadelphiaweekly.com/sections/news/" title="News">News</a></li></ul></li></ul></li> </span></div><h1>Kickin’ it with the Sons of Ben</h1><div class="posts-teaser"><p>The Philadelphia Union’s traveling road show</p></div><footer class="Post-footer"><ul class="Meta Meta--article"><li class="Meta-item Meta-item--author"> <a class="meta-author-article" href="https://philadelphiaweekly.com/writer/megan-swanick/"><figure class="meta-author-headshot"></figure> <span class="meta-author-name">Megan Swanick</span></a></li><li class="Meta-item Meta-item--date">July 7th, 2021</li></ul><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20Kickin’ it with the Sons of Ben%20-%20https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20Kickin’ it with the Sons of Ben%20-%20https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: Kickin’ it with the Sons of Ben%20https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></footer></header><header class="Post-header"><figure class="Post-thumbnail"> <a data-fancybox="gallery" data-caption="The Sons of Ben faithful are a cross-section of generations, neighborhoods, and backgrounds. To Nashville, they brought a kaleidoscope family of city dwellers and country dwellers tied together by a team. Image | Megan Swanick"
 href="https://philadelphiaweekly.com/wp-content/uploads/2021/07/Sons-of-Ben-scaled.jpg"><img width="1200" height="675" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Sons-of-Ben-scaled.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-feature-image size-feature-image wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="30847" data-permalink="https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/sons-of-ben/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Sons-of-Ben-scaled.jpg?fit=2560%2C1753&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1753" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;1.8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;iPhone 7 Plus&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1625338411&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;3.99&quot;,&quot;iso&quot;:&quot;20&quot;,&quot;shutter_speed&quot;:&quot;0.0010438413361169&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Sons of Ben" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Sons-of-Ben-scaled.jpg?fit=300%2C205&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Sons-of-Ben-scaled.jpg?fit=1024%2C701&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Sons-of-Ben-scaled.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1 1200w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Sons-of-Ben-scaled.jpg?zoom=2&amp;resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1 2400w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Sons-of-Ben-scaled.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></a><figcaption>The Sons of Ben faithful are a cross-section of generations, neighborhoods, and backgrounds. To Nashville, they brought a kaleidoscope family of city dwellers and country dwellers tied together by a team. Image | Megan Swanick</figcaption></figure></header><div class="sharing-desktop"><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20Kickin’ it with the Sons of Ben%20-%20https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20Kickin’ it with the Sons of Ben%20-%20https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: Kickin’ it with the Sons of Ben%20https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></div><article id="Post-30843" class="Post Post--single post-30843 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-soccer tag-sons-of-ben"><div class="Post-content"><h4>Sticking out in the sea of red, white, and blue patriots swallowing downtown Nashville this holiday weekend was a ragtag flock of Philadelphians dressed in light blue.</h4><p>Wearing scarves around their neck, locking their arms, and chanting, they cut through the honky-tonk madness, noisily making their way to a soccer match. For the Sons of Ben (SOB), the official supporters club of the Philadelphia Union, descending unannounced into opposing stadiums chanting “Philadelphia” is nothing new.&nbsp;</p><p>In fact, that’s precisely how Philadelphia got an MLS team in the first place. It was the Sons of Ben fanbase that brought the team to Philadelphia, rather than a team attracting fans.</p><p>Major League Soccer’s 1996 inaugural season featured just 10 teams, none in Philly. The ill-thought logic was that soccer fans in Philly would cheer for New York or D.C. But that was not to be, and the Sons of Ben made sure MLS noticed their mistake.&nbsp;</p><p>Soccer-mad Philadelphians came up with a plan to travel to<strong> </strong>stadiums across the northeast to lobby MLS and the city to create a team in Philly. The Sons of Ben would appear in New York and D.C. chanting, “We don’t have a team! We don’t have a team! We have as many cups as you and we don’t have a team!” along with cries of “Phil-a-delphia!” The fan club officially formed in 2007 and had a crest, chants, and leadership three years before the Philadelphia Union was announced.&nbsp;</p><p>They became notorious from the start.</p><p>That continues to the present day, as on last Saturday, when more than 60 members of the Sons of Ben united on a rooftop blocks away from where the Union would take on Nashville SC.</p><p>To be a soccer fan in Philadelphia you’ve got to muscle for space and wrestle for hearts in a crowded landscape of team loyalties. The Sons of Ben are up to the task: They know their mission is as much to cheer for Union victory as it is to spur forward its supporter base. They know it will take caring more and giving more than the rest of Philadelphia’s fanbases.&nbsp;</p><p>Philadelphia Union fans “are more dedicated because they have to be,” said Heather Reppert, the SOB’s director of travel, as we observed the rooftop party.&nbsp;</p><figure class="wp-block-image size-large"><img data-attachment-id="30848" data-permalink="https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/philadelphia-union/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?fit=2560%2C2406&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,2406" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;1.8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;iPhone 7 Plus&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1625339155&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;3.99&quot;,&quot;iso&quot;:&quot;20&quot;,&quot;shutter_speed&quot;:&quot;0.0037313432835821&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Philadelphia-Union" data-image-description data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?fit=300%2C282&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?fit=1024%2C963&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="1024" height="963" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union.jpg?resize=1024%2C963&#038;quality=70&#038;strip=all&#038;ssl=1" alt class="wp-image-30848 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?resize=1024%2C963&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?resize=300%2C282&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?resize=770%2C724&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?resize=1536%2C1444&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?resize=2048%2C1925&amp;quality=70&amp;strip=all&amp;ssl=1 2048w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?resize=372%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 372w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?resize=1240%2C1166&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?resize=680%2C639&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?w=2280&amp;quality=70&amp;strip=all&amp;ssl=1 2280w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union.jpg?resize=1024%2C963&amp;is-pending-load=1#038;quality=70&#038;strip=all&#038;ssl=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg"><noscript><img data-attachment-id="30848" data-permalink="https://philadelphiaweekly.com/kickin-it-with-the-sons-of-ben/philadelphia-union/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?fit=2560%2C2406&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,2406" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;1.8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;iPhone 7 Plus&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1625339155&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;3.99&quot;,&quot;iso&quot;:&quot;20&quot;,&quot;shutter_speed&quot;:&quot;0.0037313432835821&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Philadelphia-Union" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?fit=300%2C282&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?fit=1024%2C963&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="1024" height="963" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union.jpg?resize=1024%2C963&#038;quality=70&#038;strip=all&#038;ssl=1" alt="" class="wp-image-30848" srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?resize=1024%2C963&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?resize=300%2C282&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?resize=770%2C724&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?resize=1536%2C1444&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?resize=2048%2C1925&amp;quality=70&amp;strip=all&amp;ssl=1 2048w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?resize=372%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 372w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?resize=1240%2C1166&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?resize=680%2C639&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/07/Philadelphia-Union-scaled.jpg?w=2280&amp;quality=70&amp;strip=all&amp;ssl=1 2280w" sizes="(max-width: 1024px) 100vw, 1024px" data-recalc-dims="1" /></noscript><figcaption>The Sons of Ben introduced themselves to Music City this past weekend with their vocals, ‘No one likes, Oh! No one likes us, No one likes us, and we don’t care! We’re from Philly, fuckin’ Philly, no one likes us and we don’t care!’ Image | Megan Swanick</figcaption></figure><p>Vince Rizzuto, president of Philly Sports Trips and an organizer of the weekend’s Nashville invasion, has been traversing the country with Eagles, Phillies, and Union fans for years. “All Philly sports fans are passionate, but the SOB are the best organized supporters group/fan club of any of the five major teams,” he said.</p><p>With official annual memberships and 10 elected positions, the Sons of Ben are meticulously organized. They’re using that formal structure to get more Philadelphians invested in supporting the Union. The SOB faithful are a cross-section of generations, neighborhoods, and backgrounds. To Nashville, they brought a kaleidoscope family of city dwellers and country dwellers tied together by a team.&nbsp;</p><p>They also brought their chants.&nbsp;</p><p>While the streets of Music City filled with a cacophonous din of country music, the Sons of Ben warmed up their stadium vocals: “No one likes, Oh! No one likes us, No one likes us, and we don’t care! We’re from Philly, fuckin Philly, no one likes us and we don’t care!”</p><p>The chants started at the rooftop, led them into the street, and directed them through a sea of denim and cowboy boots, beyond the tents of yellow-clad Nashville fans, and into the stadium where they barely stopped cheering throughout the match.&nbsp;</p><p>The SOB held down section 104 in a sea of bright Nashville SC yellow. They looked and sounded like every kind of Philadelphia sports fan imaginable. Some were friendly, some were feisty. Some were loud, some watched silently, carefully analyzing each play. There were older couples and younger couples. There were Eagles fans seduced by SOB and an elderly man who captured snapshots with a vintage camera, alone, who said he attended nearly every game since the Union’s start – home or away.</p><p>When the opposing team came out of the tunnel it was backs turned, scarves up, and a few middle fingers toward the sky. Songs and cheers erupted when Union players ran past, the players acknowledging the SOB from the grass.&nbsp;</p><p>When Nashville scored in the second minute, fans were dismayed but not silenced. They held out hope and sang until the end. The game wasn’t lost until the final whistle, 1-0, and the fans were there throughout to cheer the Union along. Noise was what the SOB came to make, in that stadium, in that city – in their city – and relentless noise was what they made.&nbsp;</p><p>The result wasn’t what the fans wanted, but the score wasn’t the point. It was a 1-0 loss from a too-early goal to a lower-ranked team. But the trip itself still accomplished what the SOB set out to do.</p><p>In the coming year, the Sons of Ben will be back out on the road. They’ll hit the regular bus trips in the northeast, fly to Miami and Orlando, and go as far as Mexico City in August for a Champions League match against Club America. Of course, they’ll hold down the fort on the Delaware River, too, creating the atmosphere at Subaru Park for every home game, doing their part for their team and their sport.&nbsp;</p><p>“The Sons of Ben are true and true Philadelphia fans. Loyal and passionate about our team,” Sons of Ben President Matt Gendazsek said. “From smoke bombs, drums, and songs sung throughout the match, we provide an environment unlike any other in Philadelphia sports.”&nbsp;</p><p>Gendazsek is excited for the future, and welcomes all newcomers to check them out. The Philadelphia Union will play their next big match on Saturday, July 17 against their old rivals from D.C. The Sons of Ben, like always, will be there hosting a huge tailgate with food, drinks, and chants – of course – to get excited.</p><p>After a three-year wait for their team, and another 10 years until the team won their first Supporters Shield, they’re looking for a playoff run and beyond to an MLS cup.</p><p>No matter the outcome of the season, the Union’s dreams rest on the sturdy laurels of knowing they’ve grown a culture of soccer in Philadelphia as Everyman, underdog, diehard, and as foreboding as the city’s infamous vibe.</p><div class="article-promotional-message"><p>If you read this story and liked it, consider joining altPhilly, our membership program that offers exclusive content, instant access to the editor and awesome perks for like-minded Philadelphians. At PW, our coverage goes against the grain of the local mainstream media.</p> <a class="Button Button-subscribe" href="https://philadelphiaweekly.memberful.com/checkout?plan=62041"
 target="_self">Join altPhilly Now</a><div class="article-promotional-message__secondary__container"> <a class="article-promotional-message__secondary" href="https://philadelphiaweekly.com/join/"
 target="_self">Learn More</a></div></div><ul class="Meta"><li class="Meta-item Meta-item--tags"><ul><li><a href="https://philadelphiaweekly.com/tag/soccer/" title=" soccer ">soccer</a></li><li><a href="https://philadelphiaweekly.com/tag/sons-of-ben/" title=" sons of ben ">sons of ben</a></li></ul></li></ul></div></article><ul class="author-article-bio"><li class="author-bio__item"> <a class="author-bio__headshot" href="https://philadelphiaweekly.com/writer/megan-swanick/"><figure></figure> </a><div class="author-name__container"> <a class="author-bio__name" href="https://philadelphiaweekly.com/writer/megan-swanick/"><h6>Megan Swanick</h6> </a></div><div class="author-bio__info"></div></li></ul></main></div><section class="RelatedPosts"><div class="category-row__bar"><h2 class="category-row__title">Up Next in News</h2></div><ul class="posts-row"><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/inside-phillys-dea/" title="Inside Philly&#8217;s DEA"> <img width="640" height="480" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/CB.jpg?resize=640%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="drugs" loading="lazy" data-attachment-id="26486" data-permalink="https://philadelphiaweekly.com/inside-phillys-dea/cb/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/CB.jpg?fit=640%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="640,480" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="CB" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/CB.jpg?fit=300%2C225&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/CB.jpg?fit=640%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/CB.jpg?w=640&amp;quality=70&amp;strip=all&amp;ssl=1 640w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/CB.jpg?resize=300%2C225&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/CB.jpg?resize=467%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 467w" data-lazy-sizes="(max-width: 640px) 100vw, 640px" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/CB.jpg?resize=640%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/inside-phillys-dea/" title="Inside Philly&#8217;s DEA"><h5 class="RecentPosts-title">Inside Philly&#8217;s DEA</h5> </a><div class="posts-teaser"><p>Combating the nexus between drugs and violent crime</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Feb 4, 2021</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/money-and-mary-jane/" title="Money and Mary Jane"> <img width="680" height="480" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/06/My-first-post-in-this-sub-Nugs-texture-Treespaper.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="20645" data-permalink="https://philadelphiaweekly.com/money-and-mary-jane/my-first-post-in-this-sub-nugs-texture-treespaper/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/06/My-first-post-in-this-sub-Nugs-texture-Treespaper.jpg?fit=1920%2C1080&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1920,1080" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="My first post in this sub Nugs texture Treespaper" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/06/My-first-post-in-this-sub-Nugs-texture-Treespaper.jpg?fit=300%2C169&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/06/My-first-post-in-this-sub-Nugs-texture-Treespaper.jpg?fit=1024%2C576&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/06/My-first-post-in-this-sub-Nugs-texture-Treespaper.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/06/My-first-post-in-this-sub-Nugs-texture-Treespaper.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/06/My-first-post-in-this-sub-Nugs-texture-Treespaper.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/money-and-mary-jane/" title="Money and Mary Jane"><h5 class="RecentPosts-title">Money and Mary Jane</h5> </a><div class="posts-teaser"><p>A local look inside medical marijuana, the real cash crop of the 21st Century</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Jun 18, 2020</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/how-philly-responded-to-2020-protests/" title="How Philly responded to 2020 protests"> <img width="680" height="480" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Joseph-P.-Sullivan.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="30707" data-permalink="https://philadelphiaweekly.com/how-philly-responded-to-2020-protests/joseph-p-sullivan/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Joseph-P.-Sullivan.jpg?fit=1080%2C969&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1080,969" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Joseph P. Sullivan" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Joseph-P.-Sullivan.jpg?fit=300%2C269&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Joseph-P.-Sullivan.jpg?fit=1024%2C919&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Joseph-P.-Sullivan.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/how-philly-responded-to-2020-protests/" title="How Philly responded to 2020 protests"><h5 class="RecentPosts-title">How Philly responded to 2020 protests</h5> </a><div class="posts-teaser"><p>Retired official talks about police response to Philly protests</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Jun 29, 2021</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/poppin-off-from-fireworks-to-bubbly-ideas-to-ensure-you-do-the-most-to-ring-2019-in-right/" title="Poppin’ off: From fireworks to bubbly, ideas to ensure you do the most to ring 2019 in right"> <img width="357" height="357" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/9df37e8a8a7c531a11a6ecb12d3b11bc-1.jpg?resize=357%2C357&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="9149" data-permalink="https://philadelphiaweekly.com/9df37e8a8a7c531a11a6ecb12d3b11bc-2/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/9df37e8a8a7c531a11a6ecb12d3b11bc-1.jpg?fit=357%2C357&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="357,357" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="9df37e8a8a7c531a11a6ecb12d3b11bc" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/9df37e8a8a7c531a11a6ecb12d3b11bc-1.jpg?fit=300%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/9df37e8a8a7c531a11a6ecb12d3b11bc-1.jpg?fit=357%2C357&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/9df37e8a8a7c531a11a6ecb12d3b11bc-1.jpg?w=357&amp;quality=70&amp;strip=all&amp;ssl=1 357w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/9df37e8a8a7c531a11a6ecb12d3b11bc-1.jpg?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/9df37e8a8a7c531a11a6ecb12d3b11bc-1.jpg?resize=300%2C300&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/9df37e8a8a7c531a11a6ecb12d3b11bc-1.jpg?resize=350%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 350w" data-lazy-sizes="(max-width: 357px) 100vw, 357px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/9df37e8a8a7c531a11a6ecb12d3b11bc-1.jpg?resize=357%2C357&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/poppin-off-from-fireworks-to-bubbly-ideas-to-ensure-you-do-the-most-to-ring-2019-in-right/" title="Poppin’ off: From fireworks to bubbly, ideas to ensure you do the most to ring 2019 in right"><h5 class="RecentPosts-title">Poppin’ off: From fireworks to bubbly, ideas to ensure you do the most to ring 2019 in right</h5> </a><div class="posts-teaser"><p>It’s the countdown to the New Year’s countdown.But as 2018 makes its way out, how will you celebrate the entrance of 2019? Before the New Year’s Day Mummers Parade, a Philadelphia tradition dating back to 1901, the city will be&hellip;</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Dec 28, 2018</li></ul></footer></li></ul></section><div class="Columns-row columns-even"><div class="Columns-column"><div class="most-popular"><h2>Most Popular This Week</h2><ol class="most-popular-list"><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/opinion/" class="wpp-taxonomy category category-3039">Opinion</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/arts-and-money/">Arts and money</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="wpp-taxonomy category category-92">News</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/above-the-law/">Is Larry Krasner above the law?</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="wpp-taxonomy category category-92">News</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/food-festivities-and-all-the-fireworks-planned-for-this-summers-wawa-welcome-america-celebration/">Food, festivities and ALL the fireworks planned for this summer’s Wawa Welcome America celebration</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-rundown/" class="wpp-taxonomy category category-13165">The Rundown</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/music-civic-unity-and-indigenous-arts/">Music, civic unity and Indigenous arts</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/opinion/" class="wpp-taxonomy category category-3039">Opinion</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/the-dangers-of-being-afraid-to-offend/">The dangers of being afraid to offend</a></li></ol></div> <a class="Button" href="/popular">More Popular Articles</a></div><div class="Columns-column columns-even__right"><div class="calendar-events-teaser"><h2>Upcoming Philly Events</h2><ul class="calendar-events"><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/stroll-the-street-pop-up/2021-07-08/"> <time class="calendar-events__date">Thu, Jul 08</time><h6 class="calendar-events__title">Stroll the Street Pop-up</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Main Street, Manayunk</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/livestream-sunday-morning-meditation/2021-07-11/"> <time class="calendar-events__date">Sun, Jul 11</time><h6 class="calendar-events__title">Livestream Sunday Morning Meditation</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Kadampa Meditation Center Philadelphia</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/stroll-the-street-pop-up/2021-07-12/"> <time class="calendar-events__date">Mon, Jul 12</time><h6 class="calendar-events__title">Stroll the Street Pop-up</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Main Street, Manayunk</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/inspiring-solutions-for-difficult-times-livestream/2021-07-14/"> <time class="calendar-events__date">Wed, Jul 14</time><h6 class="calendar-events__title">Inspiring Solutions for Difficult Times | Livestream</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Kadampa Meditation Center Philadelphia</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/stroll-the-street-pop-up/2021-07-15/"> <time class="calendar-events__date">Thu, Jul 15</time><h6 class="calendar-events__title">Stroll the Street Pop-up</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Main Street, Manayunk</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/livestream-sunday-morning-meditation/2021-07-18/"> <time class="calendar-events__date">Sun, Jul 18</time><h6 class="calendar-events__title">Livestream Sunday Morning Meditation</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Kadampa Meditation Center Philadelphia</li></ul></li></ul> <a class="Button" href="/calendar">More Events</a></div></div></div></div></div></div><footer class="footer"><div class="footer-section footer-section--primary"><div class="footer-container"></div></div><div class="footer-section footer-section--secondary"><div class="footer-container"><div class="footer-inner"><div class="footer-inner__branding"><div class="footer-inner__logo"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_social"><p>Follow @PhillyWeekly</p><ul class="footer-inner__social__list"><li> <a href="https://www.facebook.com/pg/phillyweekly/posts/"> <i class="fa fa-facebook-square" aria-hidden="true"></i> <span>Facebook</span> </a></li><li> <a href="https://twitter.com/PhillyWeekly/"> <i class="fa fa-twitter" aria-hidden="true"></i> <span>Twitter</span> </a></li><li> <a href="https://www.instagram.com/phillyweekly/"> <i class="fa fa-instagram" aria-hidden="true"></i> <span>Instagram</span> </a></li><li> <a href="https://philadelphiaweekly.com/feeds"> <i class="fa fa-rss" aria-hidden="true"></i> <span>Your News Reader</span> </a></li></ul></div></div><nav class="Navigation Navigation--footer"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-133"><a href="#">About PW</a><ul class="sub-menu"><li id="menu-item-334" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334"><a href="https://philadelphiaweekly.com/about/">About Us</a></li><li id="menu-item-386" class="menu-item menu-item-type-post_type_archive menu-item-object-writer menu-item-386"><a href="https://philadelphiaweekly.com/writer/">Our Writers</a></li><li id="menu-item-25676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25676"><a href="https://philadelphiaweekly.com/locations/">Dropbox Locations</a></li><li id="menu-item-336" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-336"><a href="/advertising">Advertising &#038; Partnerships</a></li><li id="menu-item-338" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-338"><a href="/events/community/add">Submit an Event</a></li></ul></li><li id="menu-item-134" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-134"><a href="#">Explore PW</a><ul class="sub-menu"><li id="menu-item-228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-228"><a href="https://philadelphiaweekly.com/sections/">Sections</a></li><li id="menu-item-137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-136" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-335"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li><li id="menu-item-29460" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29460"><a href="https://philadelphiaweekly.com/sections/altphilly/">AltPhilly Exclusives</a></li></ul></li></ul></div></nav><div class="footer-inner_contact-text"><div class="footer-inner__logo--desktop"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_contact"><p>1520 Locust Street, Fifth Floor</p><p>Philadelphia, PA 19102</p></div><div class="footer-inner_contact footer-inner_contact__phone"><p>215-543-3743</p><p><a href="mailto:mail@philadelphiaweekly.com">mail@philadelphiaweekly.com</a></p></div><div class="footer-info"> &copy; Copyright Philadelphia Weekly</div></div></div></div></footer></div><div
 class="hustle-ui hustle-popup hustle-palette--gray_slate hustle_module_id_1 module_id_1  " 
 data-id="1"
 data-render-id="0"
 data-tracking="enabled" 
 data-intro="fadeIn"
 data-outro="fadeOut"
 data-overlay-close="1"
 data-close-delay="false" 
 style="opacity: 0;"
 ><div class="hustle-popup-mask hustle-optin-mask" aria-hidden="true"></div><div class="hustle-popup-content"><div class="hustle-info hustle-info--default"><button class="hustle-button-icon hustle-button-close"> <span class="hustle-icon-close" aria-hidden="true"></span> <span class="hustle-screen-reader">Close this module</span> </button><div class="hustle-layout"><div class="hustle-layout-header"><span class="hustle-title">Enjoying Philly Weekly?</span><span class="hustle-subtitle">Consider joining altPhilly, an exclusive community with access to members-only content and more. <a href="https://philadelphiaweekly.com/join">Learn More</a></span></div><div class="hustle-layout-content"><div class="hustle-image hustle-image-fit--contain" aria-hidden="true"><img src="https://philadelphiaweekly.com/wp-content/uploads/2021/03/altphilly.jpg" alt="Alt Philly" class="hustle-image-position--centercenter" /></div></div><div class="hustle-layout-footer"><div class="hustle-cta-container"><a class="hustle-button hustle-button-cta " href="https://philadelphiaweekly.memberful.com/checkout?plan=62041" target="_blank" data-cta-type="cta">Join Now</a></div></div></div><p class="hustle-nsa-link"><a href="#">Hide this message</a></p></div></div></div> <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script> <div
 class="jp-carousel-wrap jp-carousel-transitions"
 itemscope
 itemtype="https://schema.org/ImageGallery"
 style="display: none;"><div class="jp-carousel-overlay"></div><div class="jp-carousel"></div><div class="jp-carousel-fadeaway"></div><div class="jp-carousel-info"><div class="jp-carousel-photo-info"><h2 class="jp-carousel-caption" itemprop="caption description"></h2></div><div class="jp-carousel-info-columns"><div class="jp-carousel-left-column-wrapper"><div class="jp-carousel-titleanddesc"></div><div class="jp-carousel-photo-info"><h2 class="jp-carousel-caption" itemprop="caption description"></h2></div><div id="jp-carousel-comment-form-container"><form id="jp-carousel-comment-form"> <label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label><textarea
												name="comment"
												class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
												id="jp-carousel-comment-form-comment-field"
												placeholder="Write a Comment..."
											></textarea><div id="jp-carousel-comment-form-submit-and-info-wrapper"><div id="jp-carousel-comment-form-commenting-as"><fieldset> <label for="jp-carousel-comment-form-email-field">Email (Required)</label> <input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" /></fieldset><fieldset> <label for="jp-carousel-comment-form-author-field">Name (Required)</label> <input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" /></fieldset><fieldset> <label for="jp-carousel-comment-form-url-field">Website</label> <input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" /></fieldset></div> <input
 type="submit"
 name="submit"
 class="jp-carousel-comment-form-button"
 id="jp-carousel-comment-form-button-submit"
 value="Post Comment" /> <span id="jp-carousel-comment-form-spinner">&nbsp;</span><div id="jp-carousel-comment-post-results"></div></div></form></div><div class="jp-carousel-comments"></div><div id="jp-carousel-comments-loading"> <span>Loading Comments...</span></div></div><div class="jp-carousel-image-meta"><div class="jp-carousel-buttons"> <a class="jp-carousel-commentlink" href="#">Comment</a></div><ul class="jp-carousel-image-exif" style="display: none;"></ul> <a class="jp-carousel-image-download" style="display: none;"></a><div class="jp-carousel-image-map" style="display: none;"></div></div></div></div><div class="jp-carousel-next-button" style="display: none;"> <span></span></div><div class="jp-carousel-previous-button" style="display: none;"> <span></span></div><div class="jp-carousel-close-hint"><span>&times;</span></div></div> <script type='text/javascript' src='https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script> <script type='text/javascript' id='wp-polyfill-js-after'>( 'fetch' in window ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );( 'objectFit' in document.documentElement.style ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-object-fit.min.js?ver=2.3.4"></scr' + 'ipt>' );</script> <script type='text/javascript' id='contact-form-7-js-extra'>var wpcf7 = {"api":{"root":"https:\/\/philadelphiaweekly.com\/wp-json\/","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript' id='wpa-complementary-js-extra'>var wpaComplementary = {"container":""};</script> <script type='text/javascript' id='longdesc.button-js-extra'>var wparest = {"url":"https:\/\/philadelphiaweekly.com\/wp-json\/wp\/v2\/media","text":"<span>Long Description<\/span>"};</script> <script type='text/javascript' id='jquery-ui-datepicker-js-after'>jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});</script> <script type='text/javascript' id='hustle_front-js-extra'>var Modules = [{"settings":{"auto_close_success_message":"0","triggers":{"on_time_delay":"30","on_time_unit":"seconds","on_scroll":"scrolled","on_scroll_page_percent":20,"on_scroll_css_selector":"","enable_on_click_element":"1","on_click_element":"","enable_on_click_shortcode":"1","on_exit_intent_per_session":"1","on_exit_intent_delayed_time":"0","on_exit_intent_delayed_unit":"seconds","on_adblock_delay":"0","on_adblock_delay_unit":"seconds","trigger":["time"]},"animation_in":"fadeIn","animation_out":"fadeOut","after_close_trigger":["click_close_icon"],"after_close":"keep_show","expiration":365,"expiration_unit":"days","on_submit":"nothing","on_submit_delay":"5","on_submit_delay_unit":"seconds","close_cta":"0","close_cta_time":"0","close_cta_unit":"seconds","hide_after_cta":"keep_show","hide_after_subscription":"keep_show","is_schedule":"0","schedule":{"not_schedule_start":"1","start_date":"03\/15\/2021","start_hour":"12","start_minute":"00","start_meridiem_offset":"am","not_schedule_end":"1","end_date":"03\/21\/2021","end_hour":"11","end_minute":"59","end_meridiem_offset":"pm","active_days":"all","week_days":[],"is_active_all_day":"1","day_start_hour":"00","day_start_minute":"00","day_start_meridiem_offset":"am","day_end_hour":"11","day_end_minute":"59","day_end_meridiem_offset":"pm","time_to_use":"server","custom_timezone":"UTC"},"allow_scroll_page":"0","close_on_background_click":"1","auto_hide":"0","auto_hide_unit":"seconds","auto_hide_time":"5"},"module_id":"1","blog_id":"0","module_name":"AltPhilly","module_type":"popup","active":"1","module_mode":"informational"}];
var incOpt = {"is_admin":"","native_share_enpoints":{"facebook":"https:\/\/www.facebook.com\/sharer\/sharer.php?u=https%3A%2F%2Fphiladelphiaweekly.com%2Fkickin-it-with-the-sons-of-ben","twitter":"https:\/\/twitter.com\/intent\/tweet?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fkickin-it-with-the-sons-of-ben&text=Kickin%E2%80%99%20it%20with%20the%20Sons%20of%20Ben","pinterest":"https:\/\/www.pinterest.com\/pin\/create\/button\/?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fkickin-it-with-the-sons-of-ben","reddit":"https:\/\/www.reddit.com\/submit?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fkickin-it-with-the-sons-of-ben","linkedin":"https:\/\/www.linkedin.com\/shareArticle?mini=true&url=https%3A%2F%2Fphiladelphiaweekly.com%2Fkickin-it-with-the-sons-of-ben","vkontakte":"https:\/\/vk.com\/share.php?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fkickin-it-with-the-sons-of-ben","whatsapp":"https:\/\/api.whatsapp.com\/send?text=https%3A%2F%2Fphiladelphiaweekly.com%2Fkickin-it-with-the-sons-of-ben","email":"mailto:?subject=Kickin%E2%80%99%20it%20with%20the%20Sons%20of%20Ben&body=https%3A%2F%2Fphiladelphiaweekly.com%2Fkickin-it-with-the-sons-of-ben"},"ajaxurl":"https:\/\/philadelphiaweekly.com\/wp-admin\/admin-ajax.php","page_id":"30843","page_slug":"kickin-it-with-the-sons-of-ben","is_upfront":"","script_delay":"3000"};</script> <script type='text/javascript' id='truro-scripts-js-extra'>var customizer = {"sliderSlideCount":"1","sliderLoop":"0","sliderAutoPlay":"0","sliderAutoPlaySpeed":"7000","sliderArrows":"1","sliderDots":"1"};</script> <script type='text/javascript' id='jetpack-lazy-images-js-extra'>var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};</script> <script type='text/javascript' id='jetpack-carousel-js-extra'>var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/philadelphiaweekly.com\/wp-admin\/admin-ajax.php","nonce":"6f22562839","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/philadelphiaweekly.com\/wp-login.php?redirect_to=https%3A%2F%2Fphiladelphiaweekly.com%2Fkickin-it-with-the-sons-of-ben%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};</script> <style type="text/css" id="hustle-module-1-0-styles" class="hustle-module-styles hustle-module-styles-1">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</style><link rel="stylesheet" href="https://use.typekit.net/cgg8jik.css"> <script defer src="https://philadelphiaweekly.com/wp-content/cache/autoptimize/js/autoptimize_998a3b374c79b8ca7cf245250394f6ce.js"></script></body></html>