<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="stylesheet" media="print" onload="this.onload=null;this.media='all';" id="ao_optimized_gfonts" href="https://fonts.googleapis.com/css?family=Lora%3A400%2C400i%2C700&amp;display=swap" /><link rel="profile" href="http://gmpg.org/xfn/11"><meta property="fb:pages" content="23117126720" /><link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png"><link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png"><link rel="manifest" href="/site.webmanifest"><link rel="mask-icon" href="/safari-pinned-tab.svg" color="#ffc414"><meta name="msapplication-TileColor" content="#231f20"><meta name="theme-color" content="#231f20"> <style type="text/css">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</style><link rel="stylesheet" media="print" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_fd3a5542a39a8d519700eed8c16f0f56.css" onload="this.onload=null;this.media='all';" /><noscript id="aonoscrcss"><link media="all" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_fd3a5542a39a8d519700eed8c16f0f56.css" rel="stylesheet" /></noscript><title>Catching up with Close Cash - Philadelphia Weekly</title><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://philadelphiaweekly.com/catching-up-with-close-cash/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Catching up with Close Cash - Philadelphia Weekly" /><meta property="og:description" content="Philly-area rapper’s next project &#039;The Pregame&#039; drops this October" /><meta property="og:url" content="https://philadelphiaweekly.com/catching-up-with-close-cash/" /><meta property="og:site_name" content="Philadelphia Weekly" /><meta property="article:publisher" content="https://www.facebook.com/phillyweekly/" /><meta property="article:published_time" content="2020-09-28T15:52:38+00:00" /><meta property="article:modified_time" content="2020-09-28T15:52:52+00:00" /><meta property="og:image" content="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash2.jpeg?fit=1920%2C1242&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta property="og:image:width" content="1920" /><meta property="og:image:height" content="1242" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@phillyweekly" /><meta name="twitter:site" content="@phillyweekly" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://philadelphiaweekly.com/#organization","name":"Philadelphia Weekly","url":"https://philadelphiaweekly.com/","sameAs":["https://www.facebook.com/phillyweekly/","https://www.instagram.com/phillyweekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://twitter.com/phillyweekly"],"logo":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#logo","inLanguage":"en-US","url":"https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&quality=70&strip=all&ssl=1","width":500,"height":500,"caption":"Philadelphia Weekly"},"image":{"@id":"https://philadelphiaweekly.com/#logo"}},{"@type":"WebSite","@id":"https://philadelphiaweekly.com/#website","url":"https://philadelphiaweekly.com/","name":"Philadelphia Weekly","description":"","publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://philadelphiaweekly.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/catching-up-with-close-cash/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash2.jpeg?fit=1920%2C1242&quality=70&strip=all&ssl=1","width":1920,"height":1242,"caption":"Philly rapper Close Cash\u2019s next project, \u2018The Pregame,\u2019 is set to drop next month. | Image: Daquan Harris IG: @lost96er"},{"@type":"WebPage","@id":"https://philadelphiaweekly.com/catching-up-with-close-cash/#webpage","url":"https://philadelphiaweekly.com/catching-up-with-close-cash/","name":"Catching up with Close Cash - Philadelphia Weekly","isPartOf":{"@id":"https://philadelphiaweekly.com/#website"},"primaryImageOfPage":{"@id":"https://philadelphiaweekly.com/catching-up-with-close-cash/#primaryimage"},"datePublished":"2020-09-28T15:52:38+00:00","dateModified":"2020-09-28T15:52:52+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://philadelphiaweekly.com/catching-up-with-close-cash/"]}]},{"@type":"Article","@id":"https://philadelphiaweekly.com/catching-up-with-close-cash/#article","isPartOf":{"@id":"https://philadelphiaweekly.com/catching-up-with-close-cash/#webpage"},"author":{"@id":"https://philadelphiaweekly.com/#/schema/person/0bbb8857a1cdc1e605872247d0add2be"},"headline":"Catching up with Close Cash","datePublished":"2020-09-28T15:52:38+00:00","dateModified":"2020-09-28T15:52:52+00:00","mainEntityOfPage":{"@id":"https://philadelphiaweekly.com/catching-up-with-close-cash/#webpage"},"publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"image":{"@id":"https://philadelphiaweekly.com/catching-up-with-close-cash/#primaryimage"},"keywords":"Close cash,COVID-19,hip-hop,pandemic,rapper","articleSection":"Music,People","inLanguage":"en-US"},{"@type":"Person","@id":"https://philadelphiaweekly.com/#/schema/person/0bbb8857a1cdc1e605872247d0add2be","name":"stehaw22_7c8xrq","image":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/1a888a62eda4e21e5ce4b6c8a73d2e81?s=96&d=mm&r=g","caption":"stehaw22_7c8xrq"}}]}</script> <link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//c0.wp.com' /><link rel='dns-prefetch' href='//i0.wp.com' /><link rel='dns-prefetch' href='//i1.wp.com' /><link rel='dns-prefetch' href='//i2.wp.com' /><link href='https://use.typekit.net' rel='preconnect' /><link href='https://www.google-analytics.com' rel='preconnect' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Feed" href="https://philadelphiaweekly.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Comments Feed" href="https://philadelphiaweekly.com/comments/feed/" /><link rel="alternate" type="text/calendar" title="Philadelphia Weekly &raquo; iCal Feed" href="https://philadelphiaweekly.com/events/?ical=1" /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify;}</style> <script type='application/json' id="wpp-json">{"sampling_active":0,"sampling_rate":50,"ajax_url":"https:\/\/philadelphiaweekly.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":23042,"token":"6f83357edc","lang":0,"debug":0}</script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-700394-5'></script> <script type='text/javascript'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["philadelphiaweekly.com"]} );
gtag('js', new Date());
gtag('config', 'UA-700394-5', {"anonymize_ip":true} );</script> <link rel='https://api.w.org/' href='https://philadelphiaweekly.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://philadelphiaweekly.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://philadelphiaweekly.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.2" /><link rel='shortlink' href='https://philadelphiaweekly.com/?p=23042' /><link rel="alternate" type="application/json+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fcatching-up-with-close-cash%2F" /><link rel="alternate" type="text/xml+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fcatching-up-with-close-cash%2F&#038;format=xml" />  <script>"use strict";

!function() {
  var t = window.driftt = window.drift = window.driftt || [];
  if (!t.init) {
    if (t.invoked) return void (window.console && console.error && console.error("Drift snippet included twice."));
    t.invoked = !0, t.methods = [ "identify", "config", "track", "reset", "debug", "show", "ping", "page", "hide", "off", "on" ], 
    t.factory = function(e) {
      return function() {
        var n = Array.prototype.slice.call(arguments);
        return n.unshift(e), t.push(n), t;
      };
    }, t.methods.forEach(function(e) {
      t[e] = t.factory(e);
    }), t.load = function(t) {
      var e = 3e5, n = Math.ceil(new Date() / e) * e, o = document.createElement("script");
      o.type = "text/javascript", o.async = !0, o.crossorigin = "anonymous", o.src = "https://js.driftt.com/include/" + n + "/" + t + ".js";
      var i = document.getElementsByTagName("script")[0];
      i.parentNode.insertBefore(o, i);
    };
  }
}();
drift.SNIPPET_VERSION = '0.3.1';
drift.load('rk5uegyicbzi');</script> <meta name="generator" content="Site Kit by Google 1.14.0" /><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://philadelphiaweekly.com"><link rel="https://theeventscalendar.com/" href="https://philadelphiaweekly.com/wp-json/tribe/events/v1/" /><style type="text/css">.header{background-color: #0a0a0a;}.header .SearchForm-button{color: #ffffff;}.Navigation--primary{color: #ffffff;}</style><style type="text/css">/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}</style> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link rel="amphtml" href="https://philadelphiaweekly.com/catching-up-with-close-cash/amp/"><link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=32%2C21&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=192%2C128&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=180%2C120&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=270%2C180&#038;quality=70&#038;strip=all&#038;ssl=1" /> <script>window.dataLayer = window.dataLayer || [];
	  function gtag(){dataLayer.push(arguments);}
	  gtag('js', new Date());

	  gtag('config', 'UA-700394-5');</script> </head><body class="post-template-default single single-post postid-23042 single-format-standard tribe-no-js tribe-theme-parent-truro tribe-theme-child-truro-pw-child"> <a class="skip-link screen-reader-text" href="#Content">Skip to content</a><header class="header header--four"><div class="header-section header-section--primary"><div class="header-container"><div class="header-sectionInner"><div class="header-part"><div class="Branding"> <a href="https://philadelphiaweekly.com/" rel="home"> <img class="Branding-logo" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/PW-weekly-white-horizontal-1-1.svg" alt="Philadelphia Weekly" width="200px" /> </a></div></div><div class="header-part header-part__navigation"><nav class="Navigation Navigation--primary"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation" class="menu"><li id="menu-item-227" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li id="menu-item-221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li id="menu-item-188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li id="menu-item-191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li id="menu-item-192" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li id="menu-item-193" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li id="menu-item-194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li id="menu-item-7201" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li id="menu-item-195" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li id="menu-item-222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li id="menu-item-518" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li id="menu-item-375" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li id="menu-item-377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li id="menu-item-385" class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li id="menu-item-366" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-366"><a href="https://philadelphiaweekly.com/sections/featured-sections/savage-love/">Savage Love</a></li><li id="menu-item-384" class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li id="menu-item-543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-128" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></nav><div class="utility-navigation"><form class="SearchForm SearchForm--header" method="get" action="https://philadelphiaweekly.com/"> <span class="screen-reader-text">Search for:</span> <input class="SearchForm-field" type="text" placeholder="Type &amp; press enter" value="" name="s" title="Search for:" /> <button type="submit" class="screen-reader-text" aria-label="Search">Search</button> <button class="SearchForm-button" aria-label="Submit"><i class="fa fa-search" aria-hidden="true"></i></button></form></div></div></div></div></div></header><nav class="Navigation Navigation--mobile"><div class="container"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-366"><a href="https://philadelphiaweekly.com/sections/featured-sections/savage-love/">Savage Love</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></div></nav><div class="content content--fullWidth" id="content"><div class="content-inner"><div class="content-container"><div class="content-row content-row--article"><main class="content-main"><header class="article-header"><div class="meta-tags"> <span class="Meta-item"><li class="Meta-item Meta-item--categories"><ul class="Meta Meta--banner"><li class="Meta-item Meta-item--categories"><ul><li><a href="https://philadelphiaweekly.com/sections/music/" title="Music">Music</a></li><li><a href="https://philadelphiaweekly.com/sections/people/" title="People">People</a></li></ul></li></ul></li> </span></div><h1>Catching up with Close Cash</h1><div class="posts-teaser"><p>Philly-area rapper’s next project 'The Pregame' drops this October</p></div><footer class="Post-footer"><ul class="Meta Meta--article"><li class="Meta-item Meta-item--author"> <a class="meta-author-article" href="https://philadelphiaweekly.com/writer/eugene-zenyatta/"><figure class="meta-author-headshot"><img width="200" height="200" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-headshot size-headshot wp-post-image jetpack-lazy-image" alt="" data-attachment-id="16719" data-permalink="https://philadelphiaweekly.com/writer/eugene-zenyatta/joe-hernandez-oebdsi0q4f0-unsplash/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="joe-hernandez-OebdsI0Q4F0-unsplash" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 200w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=680%2C680&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=1472%2C1472&amp;quality=70&amp;strip=all&amp;ssl=1 1472w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=1104%2C1104&amp;quality=70&amp;strip=all&amp;ssl=1 1104w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=912%2C912&amp;quality=70&amp;strip=all&amp;ssl=1 912w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=550%2C550&amp;quality=70&amp;strip=all&amp;ssl=1 550w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=470%2C470&amp;quality=70&amp;strip=all&amp;ssl=1 470w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?zoom=2&amp;resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 400w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?zoom=3&amp;resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 600w" data-lazy-sizes="(max-width: 200px) 100vw, 200px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></figure> <span class="meta-author-name">Eugene Zenyatta</span></a></li><li class="Meta-item Meta-item--date">September 28th, 2020</li></ul><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/catching-up-with-close-cash/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20Catching up with Close Cash%20-%20https://philadelphiaweekly.com/catching-up-with-close-cash/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20Catching up with Close Cash%20-%20https://philadelphiaweekly.com/catching-up-with-close-cash/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: Catching up with Close Cash%20https://philadelphiaweekly.com/catching-up-with-close-cash/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></footer></header><header class="Post-header"><figure class="Post-thumbnail"> <a data-fancybox="gallery" data-caption="Philly rapper Close Cash’s next project, ‘The Pregame,’ is set to drop next month. | Image: Daquan Harris IG: @lost96er" href="https://philadelphiaweekly.com/wp-content/uploads/2020/09/Cash2.jpeg"><img width="1200" height="675" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash2.jpeg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-feature-image size-feature-image wp-post-image jetpack-lazy-image" alt="Rapper Close Cash" data-attachment-id="23046" data-permalink="https://philadelphiaweekly.com/catching-up-with-close-cash/cash2/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash2.jpeg?fit=1920%2C1242&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1920,1242" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Cash2" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash2.jpeg?fit=300%2C194&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash2.jpeg?fit=1024%2C662&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash2.jpeg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></a><figcaption>Philly rapper Close Cash’s next project, ‘The Pregame,’ is set to drop next month. | Image: Daquan Harris IG: @lost96er</figcaption></figure></header><div class="sharing-desktop"><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/catching-up-with-close-cash/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20Catching up with Close Cash%20-%20https://philadelphiaweekly.com/catching-up-with-close-cash/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20Catching up with Close Cash%20-%20https://philadelphiaweekly.com/catching-up-with-close-cash/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: Catching up with Close Cash%20https://philadelphiaweekly.com/catching-up-with-close-cash/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></div><article id="Post-23042"  class="Post Post--single post-23042 post type-post status-publish format-standard has-post-thumbnail hentry category-music category-people tag-close-cash tag-covid-19 tag-hip-hop-3 tag-pandemic tag-rapper"><div class="Post-content"><h4>Philadelphia rapper Close Cash is preparing for the release of his upcoming project entitled “The Pregame,” a five-single masterpiece set to drop in mid-October.&nbsp;</h4><p>Since the pandemic started, Cash has been working hard in the studio. Back in August, he dropped a video from a joint project featuring local creative Hashland. The single “Flavors” racked up more than 20,000 streams on Spotify. He was also most recently featured on Holland producer Teeze’s Meditape, with his track, “Whats da Vision?”</p><p>Cash’s first taste of music was with a children&#8217;s choir, and later adolescent choir, at Willingboro Presbyterian Church in New Jersey. Cash began to learn piano in the second grade and then percussion (via Cherokee High School band and orchestra) from his sophomore to senior years of high school. His first start in rap was with the &#8220;Rhyme Soul-Jahs&#8221; in the sixth grade.</p><p>He released his first mixtape, &#8220;Smooth Sailings&#8221;<em> </em>in January 2012 under the name of Alovett. After taking a hiatus from music, he released his first self-produced project, <em>&#8220;</em>Neck Of The Woods (Part One)&#8221; in November 2017.&nbsp;</p><p>In May 2018, he relocated to Philadelphia, where he met Hashland (an artist and DJ) via an iffe Lifted show at Kung Fu Necktie. <a href="https://www.google.com/search?q=Close+Cash&amp;kgmid=/g/11f2jsy10c&amp;hl=en&amp;gl=us">Close Cash</a> became fully immersed in the Philadelphia music scene and released his first album, &#8220;4:08,&#8221; a year later on May 30, 2019.</p><p>This January, <a href="https://www.google.com/search?q=Close+Cash&amp;kgmid=/g/11f2jsy10c&amp;hl=en&amp;gl=us">Cash</a> teamed up with Hashland and Myka to create the supergroup known as TIL-3. All three mesh together to create an alternative hip-hop sound that embodies the true spirit of underground nightlife and all it has to offer.</p><p><a href="https://www.google.com/search?q=Close+Cash&amp;kgmid=/g/11f2jsy10c&amp;hl=en&amp;gl=us">Close Cash</a> tributes his singing influences to the likes of Michael Jackson, Justin Timberlake, T-Pain, Kid Cudi, The Weeknd and Travis Scott. He also tributes his rapping influences to the likes of Lil Wayne, Kanye West, Drake, Big Sean and A$AP Rocky.</p><p>PW recently caught up with him to talk about the Philly music scene and his upcoming projects.</p><blockquote class="wp-block-quote"><p>&#8216;Philadelphia’s music scene is the most slept on in the world.  But it’s fated with the same “egosystem” as many other places. To which there’s a commonality of mindset that it’s “one vs. other” as opposed to everyone can win.&#8221;</p><cite>– Philadelphia hip hop artist Close Cash</cite></blockquote><p><strong>How did the pandemic and all of its closures affect you? Other than working in the studio, how did you spend your self-isolation time?</strong></p><p>More than anything, this pandemic has given me a new mindset and expanded my purpose. Having the time to really stretch my versatility and exercise all avenues of my potential has been crucial to sharpening my sound and brand. I’ve really been able to get better with my workflow, what sounds I add to give the music more texture, and being recognizant of how different flows appropriate to certain parts of the instrumental.&nbsp;</p><p>My last project, “4:08” was a lot less organized. If I had to compare the next two projects, they really blow it out of the water. We’re at the point now where making a hit record is pretty effortless, all that’s lacking is the exposure. Working with NoCap215, my visuals are now going to be shot with both a camera and a drone.</p><p>Allowing for a solid step up in quality as of recent. I want to stay in the lane of making films, not necessarily music videos. Something that tells a story, makes you feel something and grips you from start to finish.</p><figure class="wp-block-image size-large"><img data-attachment-id="23047" data-permalink="https://philadelphiaweekly.com/catching-up-with-close-cash/cash1-1/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?fit=1608%2C1136&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1608,1136" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1600177973&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Cash1-1" data-image-description data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?fit=300%2C212&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?fit=1024%2C723&amp;quality=70&amp;strip=all&amp;ssl=1" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?resize=1024%2C723&#038;quality=70&#038;strip=all&#038;ssl=1" alt class="wp-image-23047 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?resize=1024%2C723&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?resize=300%2C212&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?resize=770%2C544&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?resize=1536%2C1085&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?resize=495%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 495w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?resize=1240%2C876&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?w=1608&amp;quality=70&amp;strip=all&amp;ssl=1 1608w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?resize=1024%2C723&amp;is-pending-load=1#038;quality=70&#038;strip=all&#038;ssl=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg"><noscript><img data-attachment-id="23047" data-permalink="https://philadelphiaweekly.com/catching-up-with-close-cash/cash1-1/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?fit=1608%2C1136&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1608,1136" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1600177973&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Cash1-1" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?fit=300%2C212&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?fit=1024%2C723&amp;quality=70&amp;strip=all&amp;ssl=1" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?resize=1024%2C723&#038;quality=70&#038;strip=all&#038;ssl=1" alt="" class="wp-image-23047" srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?resize=1024%2C723&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?resize=300%2C212&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?resize=770%2C544&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?resize=1536%2C1085&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?resize=495%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 495w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?resize=1240%2C876&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Cash1-1.jpg?w=1608&amp;quality=70&amp;strip=all&amp;ssl=1 1608w" sizes="(max-width: 1024px) 100vw, 1024px" data-recalc-dims="1" /></noscript><figcaption>Close Cash has been working hard in the studio since the pandemic started He does this suggesting that Philly&#8217;s scene doesn&#8217;t get the respect it deserves. | Image: Daquan Harris IG: @lost96er</figcaption></figure><p><strong>How would you describe the Philadelphia music scene? Is this the place you want to be right now?</strong></p><p>In terms of hip-hop? Philadelphia’s music scene is the most slept on in the world. Like when you want to talk about talent per capita, I don’t see a city higher than Philly to be honest. But it’s fated with the same “egosystem” as many other places. To which there’s a commonality of the mindset that it’s “one vs. other” as opposed to everyone can win.</p><p>Shoutout to the many beacons speaking out against this though and I believe the city is (slowly but surely) getting closer to a point where all the artists will share a similar page.</p><p>Either way, competitive nature isn’t bad either and it’s needed for everyone to want to be the best they can. I believe the only difference is how you carry your wins and how you carry your losses.</p><p><strong>Other than the release of “The Pregame” in mid-October, what’s ahead for you? Assuming the pandemic clears up at some point, what do you want to be doing and working on?</strong></p><p>More clothing in my store! That’s one of my low-key, yet high-key priorities right now alongside my music. Before November, expect a plethora of items to be dropped on my website. Also going to be doing some more giveaways.</p><p>Also, we’re planning to not only drop “The Pregame” but also my next album “Private Party” before the year is up as well. Depending on the status of COVID, I would like to try some album-release events because that is something I never got to do with the release of “4:08.”</p><p>I miss doing shows more than life itself. That’s really my favorite part of being a musician.</p><p>Performing live is really an adrenaline like no other. My people know how crazy we get when the gloves are off. Soon as that kick hits, it’s go time. Energy at 10, I don’t like any dead silence… like none whatsoever. I need it to be controlled mayhem, like you could lose your life but you’re in heaven at the same time. I really hope live shows aren’t a thing of the past, that would be devastating and really make me question my career. Until then, it’s just about creating the best content imaginable and finding out all the ways that we can continue to personally push the envelope.</p><p><strong>What are the best ways for your fans to keep up with what you’re doing?</strong></p><p>Easily, my website and Instagram! My website is simple: www.close.cash and all of social media handles are @closecash.</p><h5 class="related-posts__title">Related</h5><ul class="related-posts"><li><a href="https://philadelphiaweekly.com/life-on-the-fringe/" rel="bookmark" title="Permanent Link to Life on the Fringe">Life on the Fringe</a></li><li><a href="https://philadelphiaweekly.com/she-who-struggles-is-a-warrior/" rel="bookmark" title="Permanent Link to ‘She who struggles is a warrior’">‘She who struggles is a warrior’</a></li><li><a href="https://philadelphiaweekly.com/facing-the-music/" rel="bookmark" title="Permanent Link to Facing the music">Facing the music</a></li><li><a href="https://philadelphiaweekly.com/social-distortion/" rel="bookmark" title="Permanent Link to Social distortion">Social distortion</a></li></ul><ul class="Meta"><li class="Meta-item Meta-item--tags"><ul><li><a href="https://philadelphiaweekly.com/tag/close-cash/" title=" Close cash ">Close cash</a></li><li><a href="https://philadelphiaweekly.com/tag/covid-19/" title=" COVID-19 ">COVID-19</a></li><li><a href="https://philadelphiaweekly.com/tag/hip-hop-3/" title=" hip-hop ">hip-hop</a></li><li><a href="https://philadelphiaweekly.com/tag/pandemic/" title=" pandemic ">pandemic</a></li><li><a href="https://philadelphiaweekly.com/tag/rapper/" title=" rapper ">rapper</a></li></ul></li></ul></div></article><ul class="author-article-bio"><li class="author-bio__item"> <a class="author-bio__headshot" href="https://philadelphiaweekly.com/writer/eugene-zenyatta/"><figure><img width="200" height="200" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-headshot size-headshot wp-post-image jetpack-lazy-image" alt="" data-attachment-id="16719" data-permalink="https://philadelphiaweekly.com/writer/eugene-zenyatta/joe-hernandez-oebdsi0q4f0-unsplash/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="joe-hernandez-OebdsI0Q4F0-unsplash" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 200w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=680%2C680&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=1472%2C1472&amp;quality=70&amp;strip=all&amp;ssl=1 1472w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=1104%2C1104&amp;quality=70&amp;strip=all&amp;ssl=1 1104w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=912%2C912&amp;quality=70&amp;strip=all&amp;ssl=1 912w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=550%2C550&amp;quality=70&amp;strip=all&amp;ssl=1 550w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=470%2C470&amp;quality=70&amp;strip=all&amp;ssl=1 470w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?zoom=2&amp;resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 400w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?zoom=3&amp;resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 600w" data-lazy-sizes="(max-width: 200px) 100vw, 200px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></figure> </a><div class="author-name__container"> <a class="author-bio__name" href="https://philadelphiaweekly.com/writer/eugene-zenyatta/"><h6>Eugene Zenyatta</h6> </a></div><div class="author-bio__info"><p>Eugene Zenyatta was raised on old-time Memphis 'rasslin' and strongly prefers the company of dogs to people. His greatest heartbreak came in the 2010 Breeders' Cup Classic.</p></div></li></ul></main></div><section class="RelatedPosts"><div class="category-row__bar"><h2 class="category-row__title">Up Next in Music</h2></div><ul class="posts-row"><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/calendar-march-5-12/" title="Calendar | March 5-12"> <img width="680" height="480" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/10-kinkyquizzo.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="" data-attachment-id="18273" data-permalink="https://philadelphiaweekly.com/calendar-march-5-12/10-kinkyquizzo/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/10-kinkyquizzo.jpg?fit=1599%2C1066&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1599,1066" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="10-kinkyquizzo" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/10-kinkyquizzo.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/10-kinkyquizzo.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/10-kinkyquizzo.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/10-kinkyquizzo.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/10-kinkyquizzo.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/calendar-march-5-12/" title="Calendar | March 5-12"><h5 class="RecentPosts-title">Calendar | March 5-12</h5> </a><div class="posts-teaser"><p>This week, consider exploring your inner kink or hanging with some kitties.</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Mar 6, 2020</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/popping-the-cork/" title="Popping the cork"> <img width="680" height="480" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/12/NYE-efren-barahona-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="New Years Eve partiers" data-attachment-id="14278" data-permalink="https://philadelphiaweekly.com/popping-the-cork/nye-efren-barahona/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/12/NYE-efren-barahona-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="NYE efren barahona" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/12/NYE-efren-barahona-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/12/NYE-efren-barahona-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/12/NYE-efren-barahona-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/12/NYE-efren-barahona-scaled.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/12/NYE-efren-barahona-scaled.jpg?zoom=3&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 2040w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/12/NYE-efren-barahona-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/popping-the-cork/" title="Popping the cork"><h5 class="RecentPosts-title">Popping the cork</h5> </a><div class="posts-teaser"><p>Last chance to make Philadelphia Weekly's ultimate NYE party list</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Dec 21, 2019</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/changing-lives/" title="Changing lives"> <img width="680" height="480" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/noel2.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="" data-attachment-id="16307" data-permalink="https://philadelphiaweekly.com/changing-lives/noel2/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/noel2.jpg?fit=1125%2C783&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1125,783" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="noel2" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/noel2.jpg?fit=300%2C209&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/noel2.jpg?fit=1024%2C713&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/noel2.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/changing-lives/" title="Changing lives"><h5 class="RecentPosts-title">Changing lives</h5> </a><div class="posts-teaser"><p>Trainer Noel Davis on why you shouldn't play games with your body</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Feb 3, 2020</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/philly-pianist-uri-caine-vocalist-barbara-walker-and-conductor-andre-raphael-bring-activist-educator-and-provocateur-octavius-catto-to-life/" title="Philly pianist Uri Caine, vocalist Barbara Walker and conductor Andre Raphael bring activist-educator and provocateur Octavius Catto to life"> <img width="680" height="480" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/a0dc08aca3a65c3f72f6382a474a81a7.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="" data-attachment-id="11630" data-permalink="https://philadelphiaweekly.com/philly-pianist-uri-caine-vocalist-barbara-walker-and-conductor-andre-raphael-bring-activist-educator-and-provocateur-octavius-catto-to-life/a0dc08aca3a65c3f72f6382a474a81a7/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/a0dc08aca3a65c3f72f6382a474a81a7.jpg?fit=1662%2C1247&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1662,1247" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="a0dc08aca3a65c3f72f6382a474a81a7" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/a0dc08aca3a65c3f72f6382a474a81a7.jpg?fit=300%2C225&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/a0dc08aca3a65c3f72f6382a474a81a7.jpg?fit=1024%2C768&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/a0dc08aca3a65c3f72f6382a474a81a7.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/a0dc08aca3a65c3f72f6382a474a81a7.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/a0dc08aca3a65c3f72f6382a474a81a7.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/philly-pianist-uri-caine-vocalist-barbara-walker-and-conductor-andre-raphael-bring-activist-educator-and-provocateur-octavius-catto-to-life/" title="Philly pianist Uri Caine, vocalist Barbara Walker and conductor Andre Raphael bring activist-educator and provocateur Octavius Catto to life"><h5 class="RecentPosts-title">Philly pianist Uri Caine, vocalist Barbara Walker and conductor Andre Raphael bring activist-educator and provocateur Octavius Catto to life</h5> </a><div class="posts-teaser"><p>If you live, work, dine or drink in Center City, you’ve seen Octavius Catto’s 12-foot bronze statue at City Hall’s southern corner. The memorial known as “A Quest for Parity” is homage to Philadelphia’s most noted civil rights activist, educator, abolitionist&hellip;</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Oct 4, 2019</li></ul></footer></li></ul></section><div class="Columns-row columns-even"><div class="Columns-column"><div class="most-popular"><h2>Most Popular This Week</h2><ol class="most-popular-list"><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/opinion/" class="category category-3039">Opinion</a>, <a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/" class="category category-166">Voices of Our City</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/2020-when-conservative-became-alt-in-philly/">2020: When conservative became alt in Philly</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/" class="category category-149">From the Editor</a>, <a href="https://philadelphiaweekly.com/sections/opinion/" class="category category-3039">Opinion</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/you-had-me-at-conservative/">You had me at “conservative”</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/food-festivities-and-all-the-fireworks-planned-for-this-summers-wawa-welcome-america-celebration/">Food, festivities and ALL the fireworks planned for this summer’s Wawa Welcome America celebration</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/some-people-are-afraid/">&#8216;Some people are afraid&#8217;</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/summer-camps/">Summer camps</a></li></ol></div> <a class="Button" href="/popular">More Popular Articles</a></div><div class="Columns-column columns-even__right"><div class="calendar-events-teaser"><h2>Upcoming Philly Events</h2><ul class="calendar-events"><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/jkyog-free-adult-online-meditation-sessions/2020-09-30/"> <time class="calendar-events__date">Wed, Sep 30</time><h6 class="calendar-events__title">JKYog Free Adult  online Meditation Sessions</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Online</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/midday-arts-series-an-afternoon-of-poetry-and-music-with-sharon-rhinesmith-and-david-moolten/"> <time class="calendar-events__date">Thu, Oct 01</time><h6 class="calendar-events__title">Midday Arts Series: An Afternoon of Poetry and Music with Sharon Rhinesmith and David Moolten</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">https://temple.zoom.us/j/99078474272</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/volunteer-with-uhuru-furniture-and-support-black-self-determination-orientations-5pm-every-thursday/2020-10-01/"> <time class="calendar-events__date">Thu, Oct 01</time><h6 class="calendar-events__title">Volunteer with Uhuru Furniture and support black self-determination! Orientations 5pm every Thursday</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Uhuru Furniture &amp; Collectibles</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/jkyog-free-adult-online-meditation-sessions/2020-10-01/"> <time class="calendar-events__date">Thu, Oct 01</time><h6 class="calendar-events__title">JKYog Free Adult  online Meditation Sessions</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Online</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/jkyog-free-adult-online-meditation-sessions/2020-10-02/"> <time class="calendar-events__date">Fri, Oct 02</time><h6 class="calendar-events__title">JKYog Free Adult  online Meditation Sessions</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Online</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/jkyog-free-adult-online-meditation-sessions/2020-10-03/"> <time class="calendar-events__date">Sat, Oct 03</time><h6 class="calendar-events__title">JKYog Free Adult  online Meditation Sessions</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Online</li></ul></li></ul> <a class="Button" href="/calendar">More Events</a></div></div></div></div></div></div><footer class="footer"><div class="footer-section footer-section--primary"><div class="footer-container"></div></div><div class="footer-section footer-section--secondary"><div class="footer-container"><div class="footer-inner"><div class="footer-inner__branding"><div class="footer-inner__logo"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_social"><p>Follow @PhillyWeekly</p><ul class="footer-inner__social__list"><li> <a href="https://www.facebook.com/pg/phillyweekly/posts/"> <i class="fa fa-facebook-square" aria-hidden="true"></i> <span>Facebook</span> </a></li><li> <a href="https://twitter.com/PhillyWeekly/"> <i class="fa fa-twitter" aria-hidden="true"></i> <span>Twitter</span> </a></li><li> <a href="https://www.instagram.com/phillyweekly/"> <i class="fa fa-instagram" aria-hidden="true"></i> <span>Instagram</span> </a></li><li> <a href="https://philadelphiaweekly.com/feeds"> <i class="fa fa-rss" aria-hidden="true"></i> <span>Your News Reader</span> </a></li></ul></div></div><nav class="Navigation Navigation--footer"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-133"><a href="#">About PW</a><ul class="sub-menu"><li id="menu-item-334" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334"><a href="https://philadelphiaweekly.com/about/">About Us</a></li><li id="menu-item-386" class="menu-item menu-item-type-post_type_archive menu-item-object-writer menu-item-386"><a href="https://philadelphiaweekly.com/writer/">Our Writers</a></li><li id="menu-item-336" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-336"><a href="/advertising">Advertising &#038; Partnerships</a></li><li id="menu-item-338" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-338"><a href="/events/community/add">Submit an Event</a></li></ul></li><li id="menu-item-134" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-134"><a href="#">Explore PW</a><ul class="sub-menu"><li id="menu-item-228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-228"><a href="https://philadelphiaweekly.com/sections/">Sections</a></li><li id="menu-item-137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-136" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-335"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></li></ul></div></nav><div class="footer-inner_contact-text"><div class="footer-inner__logo--desktop"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_contact"><p>1520 Locust Street, Fifth Floor</p><p>Philadelphia, PA 19102</p></div><div class="footer-inner_contact footer-inner_contact__phone"><p>215-543-3743</p><p><a href="mailto:mail@philadelphiaweekly.com">mail@philadelphiaweekly.com</a></p></div><div class="footer-info"> &copy; Copyright Philadelphia Weekly</div></div></div></div></footer></div> <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/philadelphiaweekly.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript'>var wpaComplementary = [""];</script> <script type='text/javascript'>var customizer = {"sliderSlideCount":"1","sliderLoop":"0","sliderAutoPlay":"0","sliderAutoPlaySpeed":"7000","sliderArrows":"1","sliderDots":"1"};</script> <script type='text/javascript'>var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/philadelphiaweekly.com\/wp-admin\/admin-ajax.php","nonce":"258b390320","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/philadelphiaweekly.com\/wp-login.php?redirect_to=https%3A%2F%2Fphiladelphiaweekly.com%2Fcatching-up-with-close-cash%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};</script> <link rel="stylesheet" href="https://use.typekit.net/cgg8jik.css"> <script defer src="https://philadelphiaweekly.com/wp-content/cache/autoptimize/js/autoptimize_5b9564dc74c000ca6c4f00c51b7b778a.js"></script></body></html>