<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="stylesheet" media="print" onload="this.onload=null;this.media='all';" id="ao_optimized_gfonts" href="https://fonts.googleapis.com/css?family=Lora%3A400%2C400i%2C700&amp;display=swap" /><link rel="profile" href="http://gmpg.org/xfn/11"><meta property="fb:pages" content="23117126720" /><link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png"><link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png"><link rel="manifest" href="/site.webmanifest"><link rel="mask-icon" href="/safari-pinned-tab.svg" color="#ffc414"><meta name="msapplication-TileColor" content="#231f20"><meta name="theme-color" content="#231f20"> <style type="text/css">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</style><link rel="stylesheet" media="print" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_ae84d5b718f44c75c4dc375084973c2f.css" onload="this.onload=null;this.media='all';" /><noscript id="aonoscrcss"><link media="all" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_ae84d5b718f44c75c4dc375084973c2f.css" rel="stylesheet" /></noscript><title>Voices | Feb. 25-March 4 - Philadelphia Weekly</title><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://philadelphiaweekly.com/voices-feb-25-march-4/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Voices | Feb. 25-March 4 - Philadelphia Weekly" /><meta property="og:description" content="Reactions, rants and other random musings from you, our readers." /><meta property="og:url" content="https://philadelphiaweekly.com/voices-feb-25-march-4/" /><meta property="og:site_name" content="Philadelphia Weekly" /><meta property="article:publisher" content="https://www.facebook.com/phillyweekly/" /><meta property="article:published_time" content="2021-02-26T20:14:07+00:00" /><meta property="article:modified_time" content="2021-02-26T20:14:33+00:00" /><meta property="og:image" content="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/jinyun-xBuu23uxarU-unsplash-scaled.jpg?fit=2560%2C1707&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta property="og:image:width" content="2560" /><meta property="og:image:height" content="1707" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@phillyweekly" /><meta name="twitter:site" content="@phillyweekly" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://philadelphiaweekly.com/#organization","name":"Philadelphia Weekly","url":"https://philadelphiaweekly.com/","sameAs":["https://www.facebook.com/phillyweekly/","https://www.instagram.com/phillyweekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://twitter.com/phillyweekly"],"logo":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#logo","inLanguage":"en-US","url":"https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&quality=70&strip=all&ssl=1","width":500,"height":500,"caption":"Philadelphia Weekly"},"image":{"@id":"https://philadelphiaweekly.com/#logo"}},{"@type":"WebSite","@id":"https://philadelphiaweekly.com/#website","url":"https://philadelphiaweekly.com/","name":"Philadelphia Weekly","description":"","publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://philadelphiaweekly.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/voices-feb-25-march-4/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/jinyun-xBuu23uxarU-unsplash-scaled.jpg?fit=2560%2C1707&quality=70&strip=all&ssl=1","width":2560,"height":1707,"caption":"Image: \u91d1 \u8fd0"},{"@type":"WebPage","@id":"https://philadelphiaweekly.com/voices-feb-25-march-4/#webpage","url":"https://philadelphiaweekly.com/voices-feb-25-march-4/","name":"Voices | Feb. 25-March 4 - Philadelphia Weekly","isPartOf":{"@id":"https://philadelphiaweekly.com/#website"},"primaryImageOfPage":{"@id":"https://philadelphiaweekly.com/voices-feb-25-march-4/#primaryimage"},"datePublished":"2021-02-26T20:14:07+00:00","dateModified":"2021-02-26T20:14:33+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://philadelphiaweekly.com/voices-feb-25-march-4/"]}]},{"@type":"Article","@id":"https://philadelphiaweekly.com/voices-feb-25-march-4/#article","isPartOf":{"@id":"https://philadelphiaweekly.com/voices-feb-25-march-4/#webpage"},"author":{"@id":"https://philadelphiaweekly.com/#/schema/person/6d10bb5ac4140a42ca14aa4e8065e28d"},"headline":"Voices | Feb. 25-March 4","datePublished":"2021-02-26T20:14:07+00:00","dateModified":"2021-02-26T20:14:33+00:00","mainEntityOfPage":{"@id":"https://philadelphiaweekly.com/voices-feb-25-march-4/#webpage"},"publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"image":{"@id":"https://philadelphiaweekly.com/voices-feb-25-march-4/#primaryimage"},"keywords":"government,opinion,opinion op-ed,people,philly,Voices of our City,Weather","articleSection":"Opinion,Voices of Our City","inLanguage":"en-US"},{"@type":"Person","@id":"https://philadelphiaweekly.com/#/schema/person/6d10bb5ac4140a42ca14aa4e8065e28d","name":"Philly Editor","image":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/a2af5953cb6b5d09567512df874c23dd?s=96&d=mm&r=g","caption":"Philly Editor"}}]}</script> <link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//c0.wp.com' /><link rel='dns-prefetch' href='//i0.wp.com' /><link rel='dns-prefetch' href='//i1.wp.com' /><link rel='dns-prefetch' href='//i2.wp.com' /><link href='https://use.typekit.net' rel='preconnect' /><link href='https://www.google-analytics.com' rel='preconnect' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Feed" href="https://philadelphiaweekly.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Comments Feed" href="https://philadelphiaweekly.com/comments/feed/" /><link rel="alternate" type="text/calendar" title="Philadelphia Weekly &raquo; iCal Feed" href="https://philadelphiaweekly.com/events/?ical=1" /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify;}</style> <script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/plugins/jquery-manager/assets/js/jquery-3.5.1.min.js' id='jquery-core-js'></script> <script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/plugins/jquery-manager/assets/js/jquery-migrate-3.3.0.min.js' id='jquery-migrate-js'></script> <script type='application/json' id='wpp-json'>{"sampling_active":0,"sampling_rate":50,"ajax_url":"https:\/\/philadelphiaweekly.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":27139,"token":"32b5f4e0e3","lang":0,"debug":0}</script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-700394-5' id='google_gtagjs-js' async></script> <script type='text/javascript' id='google_gtagjs-js-after'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["philadelphiaweekly.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-700394-5", {"anonymize_ip":true});</script> <link rel="https://api.w.org/" href="https://philadelphiaweekly.com/wp-json/" /><link rel="alternate" type="application/json" href="https://philadelphiaweekly.com/wp-json/wp/v2/posts/27139" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://philadelphiaweekly.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://philadelphiaweekly.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.6.1" /><link rel='shortlink' href='https://philadelphiaweekly.com/?p=27139' /><link rel="alternate" type="application/json+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fvoices-feb-25-march-4%2F" /><link rel="alternate" type="text/xml+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fvoices-feb-25-march-4%2F&#038;format=xml" />  <script>"use strict";

!function() {
  var t = window.driftt = window.drift = window.driftt || [];
  if (!t.init) {
    if (t.invoked) return void (window.console && console.error && console.error("Drift snippet included twice."));
    t.invoked = !0, t.methods = [ "identify", "config", "track", "reset", "debug", "show", "ping", "page", "hide", "off", "on" ], 
    t.factory = function(e) {
      return function() {
        var n = Array.prototype.slice.call(arguments);
        return n.unshift(e), t.push(n), t;
      };
    }, t.methods.forEach(function(e) {
      t[e] = t.factory(e);
    }), t.load = function(t) {
      var e = 3e5, n = Math.ceil(new Date() / e) * e, o = document.createElement("script");
      o.type = "text/javascript", o.async = !0, o.crossorigin = "anonymous", o.src = "https://js.driftt.com/include/" + n + "/" + t + ".js";
      var i = document.getElementsByTagName("script")[0];
      i.parentNode.insertBefore(o, i);
    };
  }
}();
drift.SNIPPET_VERSION = '0.3.1';
drift.load('rk5uegyicbzi');</script> <meta property="fb:pages" content="23117126720" /><meta property="ia:markup_url" content="https://philadelphiaweekly.com/voices-feb-25-march-4/?ia_markup=1" /><meta name="generator" content="Site Kit by Google 1.26.0" /><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://philadelphiaweekly.com"><link rel="https://theeventscalendar.com/" href="https://philadelphiaweekly.com/wp-json/tribe/events/v1/" /><style type="text/css">.header{background-color: #0a0a0a;}.header .SearchForm-button{color: #ffffff;}.Navigation--primary{color: #ffffff;}</style><style type="text/css">/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}</style> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=32%2C21&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=192%2C128&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=180%2C120&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=270%2C180&#038;quality=70&#038;strip=all&#038;ssl=1" /> <script>window.dataLayer = window.dataLayer || [];
	  function gtag(){dataLayer.push(arguments);}
	  gtag('js', new Date());

	  gtag('config', 'UA-700394-5');</script> </head><body class="post-template-default single single-post postid-27139 single-format-standard tribe-no-js tribe-theme-parent-truro tribe-theme-child-truro-pw-child"> <a class="skip-link screen-reader-text" href="#Content">Skip to content</a><header class="header header--four"><div class="header-section header-section--primary"><div class="header-container"><div class="header-sectionInner"><div class="header-part"><div class="Branding"> <a href="https://philadelphiaweekly.com/" rel="home"> <img class="Branding-logo" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/PW-weekly-white-horizontal-1-1.svg" alt="Philadelphia Weekly" width="200px" /> </a></div></div><div class="header-part header-part__navigation"><nav class="Navigation Navigation--primary"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation" class="menu"><li id="menu-item-227" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li id="menu-item-221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li id="menu-item-188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li id="menu-item-191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li id="menu-item-192" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li id="menu-item-193" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li id="menu-item-194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li id="menu-item-7201" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li id="menu-item-195" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li id="menu-item-222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li id="menu-item-518" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li id="menu-item-375" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li id="menu-item-377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li id="menu-item-385" class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li id="menu-item-384" class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li id="menu-item-543" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-128" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></nav><div class="utility-navigation"><form class="SearchForm SearchForm--header" method="get" action="https://philadelphiaweekly.com/"> <span class="screen-reader-text">Search for:</span> <input class="SearchForm-field" type="text" placeholder="Type &amp; press enter" value="" name="s" title="Search for:" /> <button type="submit" class="screen-reader-text" aria-label="Search">Search</button> <button class="SearchForm-button" aria-label="Submit"><i class="fa fa-search" aria-hidden="true"></i></button></form></div></div></div></div></div></header><nav class="Navigation Navigation--mobile"><div class="container"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></div></nav><div class="content content--fullWidth" id="content"><div class="content-inner"><div class="content-container"><div class="content-row content-row--article"><main class="content-main"><header class="article-header"><div class="meta-tags"> <span class="Meta-item"><li class="Meta-item Meta-item--categories"><ul class="Meta Meta--banner"><li class="Meta-item Meta-item--categories"><ul><li><a href="https://philadelphiaweekly.com/sections/opinion/" title="Opinion">Opinion</a></li><li><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/" title="Voices of Our City">Voices of Our City</a></li></ul></li></ul></li> </span></div><h1>Voices | Feb. 25-March 4</h1><div class="posts-teaser"><p>Reactions, rants and other random musings from you, our readers.</p></div><footer class="Post-footer"><ul class="Meta Meta--article"><li class="Meta-item Meta-item--author"> <a class="meta-author-article" href="https://philadelphiaweekly.com/writer/philly-weekly-staff/"><figure class="meta-author-headshot"><img width="100" height="100" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-headshot size-headshot wp-post-image jetpack-lazy-image" alt="Philadelphia Weekly" loading="lazy" data-attachment-id="13" data-permalink="https://philadelphiaweekly.com/favicon/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="500,500" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="favicon" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=300%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?w=500&amp;quality=70&amp;strip=all&amp;ssl=1 500w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=300%2C300&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=350%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 350w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=150%2C150&amp;quality=70&amp;strip=all&amp;ssl=1 150w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></figure> <span class="meta-author-name">Philly Weekly Staff</span></a></li><li class="Meta-item Meta-item--date">February 26th, 2021</li></ul><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/voices-feb-25-march-4/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20Voices | Feb. 25-March 4%20-%20https://philadelphiaweekly.com/voices-feb-25-march-4/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20Voices | Feb. 25-March 4%20-%20https://philadelphiaweekly.com/voices-feb-25-march-4/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: Voices | Feb. 25-March 4%20https://philadelphiaweekly.com/voices-feb-25-march-4/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></footer></header><header class="Post-header"><figure class="Post-thumbnail"> <a data-fancybox="gallery" data-caption="Image: 金 运" href="https://philadelphiaweekly.com/wp-content/uploads/2021/02/jinyun-xBuu23uxarU-unsplash-scaled.jpg"><img width="1200" height="675" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/jinyun-xBuu23uxarU-unsplash-scaled.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-feature-image size-feature-image wp-post-image jetpack-lazy-image" alt="money" loading="lazy" data-attachment-id="27140" data-permalink="https://philadelphiaweekly.com/voices-feb-25-march-4/jinyun-xbuu23uxaru-unsplash/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/jinyun-xBuu23uxarU-unsplash-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="jinyun-xBuu23uxarU-unsplash" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/jinyun-xBuu23uxarU-unsplash-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/jinyun-xBuu23uxarU-unsplash-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/jinyun-xBuu23uxarU-unsplash-scaled.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1 1200w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/jinyun-xBuu23uxarU-unsplash-scaled.jpg?zoom=2&amp;resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1 2400w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/jinyun-xBuu23uxarU-unsplash-scaled.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></a><figcaption>Image: 金 运</figcaption></figure></header><div class="sharing-desktop"><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/voices-feb-25-march-4/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20Voices | Feb. 25-March 4%20-%20https://philadelphiaweekly.com/voices-feb-25-march-4/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20Voices | Feb. 25-March 4%20-%20https://philadelphiaweekly.com/voices-feb-25-march-4/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: Voices | Feb. 25-March 4%20https://philadelphiaweekly.com/voices-feb-25-march-4/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></div><article id="Post-27139"  class="Post Post--single post-27139 post type-post status-publish format-standard has-post-thumbnail hentry category-opinion category-voices-of-our-city tag-government tag-opinion tag-opinion-op-ed tag-people tag-philly tag-voices-of-our-city tag-weather"><div class="Post-content"><h4>The Shout Out</h4><blockquote class="wp-block-quote"><p>President Biden’s stimulus package continued to wind its way through Congress this week. If approved, it could provide checks of up to $1,400 for many Americans.</p></blockquote><h4>Your turn:</h4><p>What would you do with your $1,400? Do you even think this stimulus package is needed or the right thing to do?</p><p>Send your thoughts to <a href="mailto:voices@philadelphiaweekly.com">voices@philadelphiaweekly.com</a>.</p><h4>Shout back</h4><p>PW asked last week if you enjoyed all of the recent snowfall in the city or if you were ready for spring-like weather to arrive. Here are a couple of your responses.</p><figure class="wp-block-image size-large"><img data-attachment-id="27142" data-permalink="https://philadelphiaweekly.com/voices-feb-25-march-4/sback/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?fit=1920%2C2560&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1920,2560" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;2.4&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;LM-X210APM&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1596983757&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;3.1&quot;,&quot;iso&quot;:&quot;50&quot;,&quot;shutter_speed&quot;:&quot;0.0021881838074398&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="SBack" data-image-description data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?fit=225%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?fit=768%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="768" height="1024" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack.jpg?resize=768%2C1024&#038;quality=70&#038;strip=all&#038;ssl=1" alt class="wp-image-27142 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?resize=768%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1 768w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?resize=225%2C300&amp;quality=70&amp;strip=all&amp;ssl=1 225w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?resize=770%2C1027&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?resize=1152%2C1536&amp;quality=70&amp;strip=all&amp;ssl=1 1152w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?resize=1536%2C2048&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?resize=263%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 263w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?resize=1240%2C1653&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?resize=680%2C907&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?w=1920&amp;quality=70&amp;strip=all&amp;ssl=1 1920w" data-lazy-sizes="(max-width: 768px) 100vw, 768px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack.jpg?resize=768%2C1024&amp;is-pending-load=1#038;quality=70&#038;strip=all&#038;ssl=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg"><noscript><img data-attachment-id="27142" data-permalink="https://philadelphiaweekly.com/voices-feb-25-march-4/sback/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?fit=1920%2C2560&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1920,2560" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;2.4&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;LM-X210APM&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1596983757&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;3.1&quot;,&quot;iso&quot;:&quot;50&quot;,&quot;shutter_speed&quot;:&quot;0.0021881838074398&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="SBack" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?fit=225%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?fit=768%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="768" height="1024" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack.jpg?resize=768%2C1024&#038;quality=70&#038;strip=all&#038;ssl=1" alt="" class="wp-image-27142" srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?resize=768%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1 768w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?resize=225%2C300&amp;quality=70&amp;strip=all&amp;ssl=1 225w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?resize=770%2C1027&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?resize=1152%2C1536&amp;quality=70&amp;strip=all&amp;ssl=1 1152w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?resize=1536%2C2048&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?resize=263%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 263w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?resize=1240%2C1653&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?resize=680%2C907&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/SBack-scaled.jpg?w=1920&amp;quality=70&amp;strip=all&amp;ssl=1 1920w" sizes="(max-width: 768px) 100vw, 768px" data-recalc-dims="1" /></noscript><figcaption>Image: Courtesy of Jason Love</figcaption></figure><p><strong>Looking forward to the Phillies</strong></p><p>Despite there still being snow on the ground as I type this, the Phillies open spring training in less than a week. As more vaccines roll out and the infection rate trends downward, Philadelphia needs to look at allowing fans into Citizens Bank Park this year.&nbsp; I don&#8217;t think there should be a packed ballpark until the virus is totally under control; however, I believe the city should permit the Phillies to allow a safe number of fans inside CBP.&nbsp;</p><p>My fear is that Mayor Kenney is going to handle this situation much the way he handled the vaccination rollout in Philadelphia. I don&#8217;t live in the city, but from what I see and read about the mayor, he seems out of touch. Eventually, we need to start getting back to our everyday lives.&nbsp; The ballpark provides a lot of jobs for people in the area, including the food vendors, parking, and ticket ushers. As long as people wear masks, wash their hands, and use common sense, we should be able to sit at the ballpark and take in a baseball game this summer.&nbsp;</p><p>As much as I enjoyed spending time last year with the Phandemic Krew, I really hope to be able to enjoy a ball game or two this year in the ballpark. I think Zach Eflin is going to have a breakout year. Thank you.&nbsp;</p><p><strong><em>Jason Love | Somerdale, NJ</em></strong></p><figure class="wp-block-image size-large"><img data-attachment-id="27143" data-permalink="https://philadelphiaweekly.com/voices-feb-25-march-4/philadelphia-257085_1920-1-1/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?fit=1920%2C1440&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1920,1440" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="philadelphia-257085_1920-1-1" data-image-description data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?fit=300%2C225&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?fit=1024%2C768&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="1024" height="768" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=1024%2C768&#038;quality=70&#038;strip=all&#038;ssl=1" alt class="wp-image-27143 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=1024%2C768&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=300%2C225&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=770%2C578&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=1536%2C1152&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=800%2C600&amp;quality=70&amp;strip=all&amp;ssl=1 800w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=467%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 467w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=1240%2C930&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=680%2C510&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?w=1920&amp;quality=70&amp;strip=all&amp;ssl=1 1920w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=1024%2C768&amp;is-pending-load=1#038;quality=70&#038;strip=all&#038;ssl=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg"><noscript><img data-attachment-id="27143" data-permalink="https://philadelphiaweekly.com/voices-feb-25-march-4/philadelphia-257085_1920-1-1/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?fit=1920%2C1440&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1920,1440" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="philadelphia-257085_1920-1-1" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?fit=300%2C225&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?fit=1024%2C768&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="1024" height="768" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=1024%2C768&#038;quality=70&#038;strip=all&#038;ssl=1" alt="" class="wp-image-27143" srcset="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=1024%2C768&amp;quality=70&amp;strip=all&amp;ssl=1 1024w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=300%2C225&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=770%2C578&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=1536%2C1152&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=800%2C600&amp;quality=70&amp;strip=all&amp;ssl=1 800w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=467%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 467w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=1240%2C930&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?resize=680%2C510&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/02/philadelphia-257085_1920-1-1.jpg?w=1920&amp;quality=70&amp;strip=all&amp;ssl=1 1920w" sizes="(max-width: 1024px) 100vw, 1024px" data-recalc-dims="1" /></noscript><figcaption>Image: Provided</figcaption></figure><p><strong>Happy with the snow</strong></p><p>I love it when it snows. That&#8217;s what winter is supposed to be. I only wish that we would get more.</p><p><strong><em>Irene Gleba | Philadelphia</em></strong></p><p><strong>Article misses the mark on Board of Ethics</strong></p><p>Although it was not the main point of his article (“Where’s the watchdog?” Feb. 18), A. Benjamin Mannes claims that the Philadelphia Board of Ethics does not have independent authority to investigate and act on public integrity matters. That claim is false. The Ethics Board is independent of the administration and has the authority under the city&#8217;s Home Rule Charter to administer and enforce the city&#8217;s Public Integrity Laws, which include the Ethics Code, Campaign Finance and Lobbying Laws and political activity restrictions in the <a href="http://§ 4-1100. Powers and Duties. (amlegal.com">Charter</a>. The Board has subpoena power and a dual enforcement track, meaning it can either enforce the City&#8217;s Public Integrity Laws by Administrative Adjudication or by going to the Philadelphia Court of Common Pleas. As an independent Charter agency, the Board has jurisdiction over all of city government.</p><p>Mr. Mannes also suggests that the Ethics Board&#8217;s fines are limited only to campaign finance and that the fines are &#8220;normally negligible.&#8221; This claim is not accurate. Apart from the fact that any City agency&#8217;s fines – including the Ethics Board&#8217;s and any future independent inspector general that Mr. Mannes argues for – are limited to $2,000 per violation by state law, the Ethics Board has leveled significant fines for campaign finance, ethics, lobbying and political activity violations <em>when appropriate</em>.&nbsp;</p><p>Perhaps more important than the amount of any fine, the Ethics Board has held elected and top government officials and others accountable for violations of the City&#8217;s Public Integrity Laws since it was established 14 years ago. Before the Ethics Board was established, no City agency, department or office had that authority. All 173 of the Ethics Board&#8217;s settlement agreements, in which the Board has collectively assessed $541,625 in penalties and required $181,089 in disgorgements to the city, are available to the public on the Board&#8217;s <a href="http://City of Philadelphia: Settlement Agreements">website</a>.</p><p>In the future, I&#8217;d be happy to speak with anyone before an article is published about the jurisdiction and actions of the Ethics Board to ensure a more accurate description.</p><p><strong><em>J. Shane Creamer, Jr. is the executive director of the Philadelphia Board of Ethics.</em></strong></p><p><strong>Wolf’s budget hits Philly while it’s still down</strong></p><p>It’s no secret that Philadelphia has been hit hard by the coronavirus and lockdowns. It was one of the first counties to lock down and one of the last counties to begin taking steps toward reopening through <a href="https://www.governor.pa.gov/process-to-reopen-pennsylvania/">Gov. Wolf’s phased plan</a>. That means local businesses and workers in the state’s most populated municipality have endured the most time without making money.</p><p>And just when many were starting to think the worst was behind us, Wolf gave his annual budget address recently. Based on his proposals, the city’s residents and businesses might be hit again.</p><p>As it stands, the governor’s <a href="https://www.governor.pa.gov/newsroom/governor-wolf-delivers-2021-budget-address/">budget proposal</a> includes a plan to increase the personal income tax (PIT) from the current rate of <a href="https://www.pennlive.com/news/2021/02/gov-wolfs-proposes-pas-biggest-tax-increase-ever-is-a-tax-cut-for-many.html">3.07 percent to 4.49 percent</a>. He includes increases in income “allowances,” which he says will result in a tax reduction for the “working class.” In reality, according to U.S. Census data, the median household would see a tax increase across most major household categories.</p><p>For Philadelphians, a state income tax hike is an even bigger worry than it is for most other Pennsylvanians. Philadelphia is the <a href="https://www.pewtrusts.org/en/research-and-analysis/reports/2019/03/20/the-cost-of-local-government-in-philadelphia">fifth highest-taxed</a> urban area in the country, barely lower than places like New York City and San Francisco. Apart from the local sales tax, Wolf’s proposal would increase the maximum income tax for <a href="https://www.phila.gov/services/payments-assistance-taxes/business-taxes/wage-tax-employers/">Philadelphians</a> from under 7 percent to over 8 percent.</p><p>During his address, <a href="https://www.governor.pa.gov/newsroom/governor-wolf-delivers-2021-budget-address/">Wolf said</a>, “the question isn’t whether taxes are unpleasant or necessary. They’re both.” While most people would accept that some taxes are necessary, that isn’t the same as justifying increasing them, especially considering how hard this tax increase will hit Philadelphia’s already struggling small businesses in addition to workers.</p><p>According to an <a href="https://assets.nfib.com/nfibcom/Covid-19-14-Questionnaire-Write-up-FINAL-Web.pdf">NFIB December survey</a>, one-quarter of small businesses nationally will have to close if current economic conditions don’t improve over the next six months. Last August, more than 1,000 Philly businesses had already closed, according to <a href="https://www.bizjournals.com/philadelphia/news/2020/08/19/yelp-1000-philadelphia-businesses-closed-since.html">Yelp data</a>. Wolf’s proposed tax hike would disproportionately affect businesses and households that are already struggling.</p><p>Despite the name, the PIT isn’t only personal. It’s also the way that 85 percent of the approximately 1 <a href="https://www.pasbdc.org/resources/small-biz-stats">million</a> businesses in the state are taxed. This is because businesses such as Limited Liability Companies, Partnerships, and S Corporations file under the PIT rather than the much higher Corporate Net Income Tax (CNIT).</p><p>This simple fact goes against Wolf’s claim that he recognizes how important businesses are to our communities’ economic revival. Even though he proposed that the CNIT be reduced by 25 percent in his address, an increase in the PIT will hit many more businesses. This doesn’t make sense if you want to improve the business climate of the state.</p><p>Lawmakers in the General Assembly should reject Wolf’s bad ideas and instead implement policies that would actually improve the business climate and make life easier for workers.</p><p>One such reform is permitting all businesses – not just corporations – the ability to carry forward and deduct operating losses. Additionally, Pennsylvania has the 11th highest number of business regulations in the country, with almost <a href="https://www.quantgov.org/regcensus-explorer">163,000 individual rules</a>. And that doesn’t include COVID-specific regulations. These rules alone result in huge time costs to businesses, <a href="https://www.sba.gov/sites/default/files/The%20Impact%20of%20Regulatory%20Costs%20on%20Small%20Firms%20(Full).pdf">especially small</a> ones.</p><p>Reducing the myriad of rules and eliminating harmful or needless regulations would not only make it easier for businesses to operate but also make it easier to ensure compliance with the regulations that do matter. Thankfully, there are already many bills introduced that address both these areas and would represent a vast improvement over the status quo.</p><p>Wolf was right that the state should make things easier for Pennsylvanians, especially those struggling; however, his tax plan doesn’t do that. Raising taxes on individuals and businesses is not the way to improve job opportunities and economic growth. For Philadelphians who have been hit the hardest during the COVID pandemic, the governor’s budget address wasn’t the message of relief and support they needed to hear.&nbsp;&nbsp;</p><p>We can build back better as Philadelphians and Pennsylvanians, but that involves removing barriers and creating opportunity, not adding to existing hardship.</p><p><strong><em>Tirzah Duren is a Policy Analyst for the Commonwealth Foundation, Pennsylvania’s free market think tank</em></strong><strong>. </strong><a href="http://www.twitter.com/tzduren"><strong><em>@tzduren</em></strong></a><strong><em>. </em></strong><strong><em>This article was originally published at </em></strong><strong><em>Broad + Liberty</em></strong><strong><em>. Follow them on Twitter </em></strong><strong><em>@BroadAndLiberty.</em></strong></p><h5 class="related-posts__title">Related</h5><ul class="related-posts"><li><a href="https://philadelphiaweekly.com/granny-get-your-gun-seniors-lead-the-way-as-local-gun-sales-spike/" rel="bookmark" title="Permanent Link to Granny, get your gun: Seniors lead the way as local gun sales spike">Granny, get your gun: Seniors lead the way as local gun sales spike</a></li><li><a href="https://philadelphiaweekly.com/were-all-a-little-punk/" rel="bookmark" title="Permanent Link to We&#8217;re all a little punk">We&#8217;re all a little punk</a></li><li><a href="https://philadelphiaweekly.com/seven-philadelphians-who-would-make-a-better-mayor/" rel="bookmark" title="Permanent Link to Seven Philadelphians who would make a better mayor">Seven Philadelphians who would make a better mayor</a></li><li><a href="https://philadelphiaweekly.com/philly-fighting-philly-fighting-covid/" rel="bookmark" title="Permanent Link to Philly fighting Philly Fighting COVID">Philly fighting Philly Fighting COVID</a></li></ul><ul class="Meta"><li class="Meta-item Meta-item--tags"><ul><li><a href="https://philadelphiaweekly.com/tag/government/" title=" government ">government</a></li><li><a href="https://philadelphiaweekly.com/tag/opinion/" title=" opinion ">opinion</a></li><li><a href="https://philadelphiaweekly.com/tag/opinion-op-ed/" title=" opinion op-ed ">opinion op-ed</a></li><li><a href="https://philadelphiaweekly.com/tag/people/" title=" people ">people</a></li><li><a href="https://philadelphiaweekly.com/tag/philly/" title=" philly ">philly</a></li><li><a href="https://philadelphiaweekly.com/tag/voices-of-our-city/" title=" Voices of our City ">Voices of our City</a></li><li><a href="https://philadelphiaweekly.com/tag/weather/" title=" Weather ">Weather</a></li></ul></li></ul></div></article><ul class="author-article-bio"><li class="author-bio__item"> <a class="author-bio__headshot" href="https://philadelphiaweekly.com/writer/philly-weekly-staff/"><figure><img width="100" height="100" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-headshot size-headshot wp-post-image jetpack-lazy-image" alt="Philadelphia Weekly" loading="lazy" data-attachment-id="13" data-permalink="https://philadelphiaweekly.com/favicon/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="500,500" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="favicon" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=300%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?w=500&amp;quality=70&amp;strip=all&amp;ssl=1 500w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=300%2C300&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=350%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 350w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=150%2C150&amp;quality=70&amp;strip=all&amp;ssl=1 150w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></figure> </a><div class="author-name__container"> <a class="author-bio__name" href="https://philadelphiaweekly.com/writer/philly-weekly-staff/"><h6>Philly Weekly Staff</h6> </a><ul class="author-bio__social"><li class="author-bio__social__item"> <a href="https://www.twitter.com/phillyweekly"> <i class="author-bio__social__icon fa fa-twitter" aria-hidden="true"></i><div class="author-bio__social__handle">@phillyweekly</div> </a></li></ul></div><div class="author-bio__info"><p>Articles compiled by Philly Weekly&#8217;s editorial team.</p></div></li></ul></main></div><section class="RelatedPosts"><div class="category-row__bar"><h2 class="category-row__title">Up Next in Opinion</h2></div><ul class="posts-row"><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/voices-may-21-28/" title="Voices | May 21-28"> <img width="680" height="480" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/05/Shoutout-1-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="COVID closure" loading="lazy" data-attachment-id="20079" data-permalink="https://philadelphiaweekly.com/voices-may-21-28/shoutout-4/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/05/Shoutout-1-scaled.jpg?fit=2560%2C1709&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1709" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Shoutout" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/05/Shoutout-1-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/05/Shoutout-1-scaled.jpg?fit=1024%2C684&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/05/Shoutout-1-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/05/Shoutout-1-scaled.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/05/Shoutout-1-scaled.jpg?zoom=3&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 2040w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/05/Shoutout-1-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/voices-may-21-28/" title="Voices | May 21-28"><h5 class="RecentPosts-title">Voices | May 21-28</h5> </a><div class="posts-teaser"><p>Reactions, rants and other random musings from you, our readers</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">May 21, 2020</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/icepack-jan-30-feb-6/" title="Icepack | Jan. 30-Feb. 6"> <img width="680" height="480" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/erik-witsoe-GF8VvBgcJ4o-unsplash-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Theater" loading="lazy" data-attachment-id="16117" data-permalink="https://philadelphiaweekly.com/icepack-jan-30-feb-6/erik-witsoe-gf8vvbgcj4o-unsplash/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/erik-witsoe-GF8VvBgcJ4o-unsplash-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="erik-witsoe-GF8VvBgcJ4o-unsplash" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/erik-witsoe-GF8VvBgcJ4o-unsplash-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/erik-witsoe-GF8VvBgcJ4o-unsplash-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/erik-witsoe-GF8VvBgcJ4o-unsplash-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/erik-witsoe-GF8VvBgcJ4o-unsplash-scaled.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/erik-witsoe-GF8VvBgcJ4o-unsplash-scaled.jpg?zoom=3&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 2040w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/erik-witsoe-GF8VvBgcJ4o-unsplash-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/icepack-jan-30-feb-6/" title="Icepack | Jan. 30-Feb. 6"><h5 class="RecentPosts-title">Icepack | Jan. 30-Feb. 6</h5> </a><div class="posts-teaser"><p>B. Coop, Meek Mill, movies at the Ritz and more in this ice cold edition</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Jan 29, 2020</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/icepack-death-and-parties/" title="Icepack: Death and parties"> <img width="680" height="480" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/cheese-steak-629342_1920.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Philly cheesesteak" loading="lazy" data-attachment-id="14765" data-permalink="https://philadelphiaweekly.com/icepack-death-and-parties/cheese-steak-629342_1920/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/cheese-steak-629342_1920.jpg?fit=1920%2C1440&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1920,1440" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="cheese-steak-629342_1920" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/cheese-steak-629342_1920.jpg?fit=300%2C225&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/cheese-steak-629342_1920.jpg?fit=1024%2C768&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/cheese-steak-629342_1920.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/cheese-steak-629342_1920.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/cheese-steak-629342_1920.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/icepack-death-and-parties/" title="Icepack: Death and parties"><h5 class="RecentPosts-title">Icepack: Death and parties</h5> </a><div class="posts-teaser"><p>Eras end and a ‘thank you’ mayoral shindig</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Jan 2, 2020</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/voices-aug-27-sept-3/" title="Voices | Aug. 27-Sept. 3"> <img width="680" height="480" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/08/Encampteddy-scaled.jpeg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Encampment" loading="lazy" data-attachment-id="22022" data-permalink="https://philadelphiaweekly.com/summer-camps/encampteddy/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/08/Encampteddy-scaled.jpeg?fit=2560%2C1920&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1920" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Encampteddy" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/08/Encampteddy-scaled.jpeg?fit=300%2C225&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/08/Encampteddy-scaled.jpeg?fit=1024%2C768&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/08/Encampteddy-scaled.jpeg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/08/Encampteddy-scaled.jpeg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/08/Encampteddy-scaled.jpeg?zoom=3&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 2040w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/08/Encampteddy-scaled.jpeg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/voices-aug-27-sept-3/" title="Voices | Aug. 27-Sept. 3"><h5 class="RecentPosts-title">Voices | Aug. 27-Sept. 3</h5> </a><div class="posts-teaser"><p>Reactions, rants and other random musings from you, our readers</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Aug 27, 2020</li></ul></footer></li></ul></section><div class="Columns-row columns-even"><div class="Columns-column"><div class="most-popular"><h2>Most Popular This Week</h2><ol class="most-popular-list"><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/interests/" class="category category-4892">Interests</a>, <a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/philly-cops-are-defunding-themselves/">Philly cops are defunding themselves</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/opinion/" class="category category-3039">Opinion</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/time-to-resign/">Time to resign</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/food-festivities-and-all-the-fireworks-planned-for-this-summers-wawa-welcome-america-celebration/">Food, festivities and ALL the fireworks planned for this summer’s Wawa Welcome America celebration</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/interests/" class="category category-4892">Interests</a>, <a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/meet-carlos-vega/">Meet Carlos Vega</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a>, <a href="https://philadelphiaweekly.com/sections/people/" class="category category-91">People</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/undaunted-martina-white/">Undaunted: Martina White</a></li></ol></div> <a class="Button" href="/popular">More Popular Articles</a></div><div class="Columns-column columns-even__right"><div class="calendar-events-teaser"><h2>Upcoming Philly Events</h2><ul class="calendar-events"><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/theatre-exile-presents-anna-moenchs-sin-eaters/2021-02-26/"> <time class="calendar-events__date">Fri, Feb 26</time><h6 class="calendar-events__title">Theatre Exile Presents Anna Moench’s ‘Sin Eaters’</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Theatre Exile</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/moravian-story-walking-tour/2021-02-27/"> <time class="calendar-events__date">Sat, Feb 27</time><h6 class="calendar-events__title">Moravian Story Walking Tour</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Historic Bethlehem Visitor Center</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/moravian-story-walking-tour/2021-02-27/3/"> <time class="calendar-events__date">Sat, Feb 27</time><h6 class="calendar-events__title">Moravian Story Walking Tour</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Historic Bethlehem Visitor Center</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/philartdelphia-millard-exhibition-reception-members-event/"> <time class="calendar-events__date">Sat, Feb 27</time><h6 class="calendar-events__title">PhilARTdelphia Millard Exhibition Reception &amp; Members Event</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Woodmere Art Museum</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/gathering-seeds-2-1-northeast-woodlands-pottery-making-with-brenda-hill/"> <time class="calendar-events__date">Sat, Feb 27</time><h6 class="calendar-events__title">Gathering Seeds 2.1: Northeast Woodlands Pottery Making with Brenda Hill</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">online (virtual)</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/watson-adventures-virtual-ghost-hunt-the-haunted-online-scavenger-hunt/"> <time class="calendar-events__date">Sat, Feb 27</time><h6 class="calendar-events__title">Watson Adventures’ Virtual Ghost Hunt: The Haunted Online Scavenger Hunt</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Virtual</li></ul></li></ul> <a class="Button" href="/calendar">More Events</a></div></div></div></div></div></div><footer class="footer"><div class="footer-section footer-section--primary"><div class="footer-container"></div></div><div class="footer-section footer-section--secondary"><div class="footer-container"><div class="footer-inner"><div class="footer-inner__branding"><div class="footer-inner__logo"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_social"><p>Follow @PhillyWeekly</p><ul class="footer-inner__social__list"><li> <a href="https://www.facebook.com/pg/phillyweekly/posts/"> <i class="fa fa-facebook-square" aria-hidden="true"></i> <span>Facebook</span> </a></li><li> <a href="https://twitter.com/PhillyWeekly/"> <i class="fa fa-twitter" aria-hidden="true"></i> <span>Twitter</span> </a></li><li> <a href="https://www.instagram.com/phillyweekly/"> <i class="fa fa-instagram" aria-hidden="true"></i> <span>Instagram</span> </a></li><li> <a href="https://philadelphiaweekly.com/feeds"> <i class="fa fa-rss" aria-hidden="true"></i> <span>Your News Reader</span> </a></li></ul></div></div><nav class="Navigation Navigation--footer"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-133"><a href="#">About PW</a><ul class="sub-menu"><li id="menu-item-334" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334"><a href="https://philadelphiaweekly.com/about/">About Us</a></li><li id="menu-item-386" class="menu-item menu-item-type-post_type_archive menu-item-object-writer menu-item-386"><a href="https://philadelphiaweekly.com/writer/">Our Writers</a></li><li id="menu-item-25676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25676"><a href="https://philadelphiaweekly.com/locations/">Dropbox Locations</a></li><li id="menu-item-336" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-336"><a href="/advertising">Advertising &#038; Partnerships</a></li><li id="menu-item-338" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-338"><a href="/events/community/add">Submit an Event</a></li></ul></li><li id="menu-item-134" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-134"><a href="#">Explore PW</a><ul class="sub-menu"><li id="menu-item-228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-228"><a href="https://philadelphiaweekly.com/sections/">Sections</a></li><li id="menu-item-137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-136" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-335"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></li></ul></div></nav><div class="footer-inner_contact-text"><div class="footer-inner__logo--desktop"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_contact"><p>1520 Locust Street, Fifth Floor</p><p>Philadelphia, PA 19102</p></div><div class="footer-inner_contact footer-inner_contact__phone"><p>215-543-3743</p><p><a href="mailto:mail@philadelphiaweekly.com">mail@philadelphiaweekly.com</a></p></div><div class="footer-info"> &copy; Copyright Philadelphia Weekly</div></div></div></div></footer></div> <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script> <script type='text/javascript' src='https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script> <script type='text/javascript' id='wp-polyfill-js-after'>( 'fetch' in window ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );</script> <script type='text/javascript' src='https://philadelphiaweekly.com/wp-includes/js/dist/i18n.min.js' id='wp-i18n-js'></script> <script type='text/javascript' src='https://philadelphiaweekly.com/wp-includes/js/dist/vendor/lodash.min.js' id='lodash-js'></script> <script type='text/javascript' id='lodash-js-after'>window.lodash = _.noConflict();</script> <script type='text/javascript' src='https://philadelphiaweekly.com/wp-includes/js/dist/url.min.js' id='wp-url-js'></script> <script type='text/javascript' src='https://philadelphiaweekly.com/wp-includes/js/dist/hooks.min.js' id='wp-hooks-js'></script> <script type='text/javascript' id='wp-api-fetch-js-translations'>( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );</script> <script type='text/javascript' src='https://philadelphiaweekly.com/wp-includes/js/dist/api-fetch.min.js' id='wp-api-fetch-js'></script> <script type='text/javascript' id='wp-api-fetch-js-after'>wp.apiFetch.use( wp.apiFetch.createRootURLMiddleware( "https://philadelphiaweekly.com/wp-json/" ) );
wp.apiFetch.nonceMiddleware = wp.apiFetch.createNonceMiddleware( "32b5f4e0e3" );
wp.apiFetch.use( wp.apiFetch.nonceMiddleware );
wp.apiFetch.use( wp.apiFetch.mediaUploadMiddleware );
wp.apiFetch.nonceEndpoint = "https://philadelphiaweekly.com/wp-admin/admin-ajax.php?action=rest-nonce";</script> <script type='text/javascript' id='contact-form-7-js-extra'>var wpcf7 = [];</script> <script type='text/javascript' id='wpa-complementary-js-extra'>var wpaComplementary = [""];</script> <script type='text/javascript' id='longdesc.button-js-extra'>var wparest = "https:\/\/philadelphiaweekly.com\/wp-json\/wp\/v2\/media";
var wpatext = "<span>Long Description<\/span>";</script> <script type='text/javascript' id='truro-scripts-js-extra'>var customizer = {"sliderSlideCount":"1","sliderLoop":"0","sliderAutoPlay":"0","sliderAutoPlaySpeed":"7000","sliderArrows":"1","sliderDots":"1"};</script> <script type='text/javascript' id='jetpack-lazy-images-js-extra'>var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};</script> <script type='text/javascript' id='jetpack-carousel-js-extra'>var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/philadelphiaweekly.com\/wp-admin\/admin-ajax.php","nonce":"cf6ee265e4","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/philadelphiaweekly.com\/wp-login.php?redirect_to=https%3A%2F%2Fphiladelphiaweekly.com%2Fvoices-feb-25-march-4%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};</script> <link rel="stylesheet" href="https://use.typekit.net/cgg8jik.css"> <script defer src="https://philadelphiaweekly.com/wp-content/cache/autoptimize/js/autoptimize_06e95bfd6de8abb42e623d3e5eed0fb3.js"></script></body></html>