<!DOCTYPE html>

<html lang="en-US">

<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<meta property="fb:pages" content="23117126720" />
	<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
	<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png">
	<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png">
	<link rel="manifest" href="/site.webmanifest">
	<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#ffc414">
	<meta name="msapplication-TileColor" content="#231f20">
	<meta name="theme-color" content="#231f20">
	<!--Critical CSS-->
	<style type="text/css">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</style>
	<!-- End Critical CSS -->
	<meta name='robots' content='max-image-preview:large' />

	<!-- This site is optimized with the Yoast SEO Premium plugin v14.8 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>&quot;I occupy a niche simply by existing&quot; - We Speak to Trans Male OnlyFans Star Trip Richards - Philadelphia Weekly</title>
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://philadelphiaweekly.com/trip-richards-onlyfans-interview/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="&quot;I occupy a niche simply by existing&quot; - We Speak to Trans Male OnlyFans Star Trip Richards - Philadelphia Weekly" />
	<meta property="og:description" content="Introducing Trip Richards - Adult Entertainment extraordinaire, OnlyFans content creator, and body-positive influencer." />
	<meta property="og:url" content="https://philadelphiaweekly.com/trip-richards-onlyfans-interview/" />
	<meta property="og:site_name" content="Philadelphia Weekly" />
	<meta property="article:publisher" content="https://www.facebook.com/phillyweekly/" />
	<meta property="article:published_time" content="2022-02-21T15:07:21+00:00" />
	<meta property="article:modified_time" content="2022-02-21T17:36:53+00:00" />
	<meta property="og:image" content="https://philadelphiaweekly.com/wp-content/uploads/2022/02/Trip-Richards-Yes-3.jpg" />
	<meta property="og:image:width" content="734" />
	<meta property="og:image:height" content="833" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@jrblackwell" />
	<meta name="twitter:site" content="@phillyweekly" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://philadelphiaweekly.com/#organization","name":"Philadelphia Weekly","url":"https://philadelphiaweekly.com/","sameAs":["https://www.facebook.com/phillyweekly/","https://www.instagram.com/phillyweekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://twitter.com/phillyweekly"],"logo":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#logo","inLanguage":"en-US","url":"https://philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png","width":500,"height":500,"caption":"Philadelphia Weekly"},"image":{"@id":"https://philadelphiaweekly.com/#logo"}},{"@type":"WebSite","@id":"https://philadelphiaweekly.com/#website","url":"https://philadelphiaweekly.com/","name":"Philadelphia Weekly","description":"","publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://philadelphiaweekly.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/trip-richards-onlyfans-interview/#primaryimage","inLanguage":"en-US","url":"https://philadelphiaweekly.com/wp-content/uploads/2022/02/Trip-Richards-Yes-3.jpg","width":734,"height":833},{"@type":"WebPage","@id":"https://philadelphiaweekly.com/trip-richards-onlyfans-interview/#webpage","url":"https://philadelphiaweekly.com/trip-richards-onlyfans-interview/","name":"\"I occupy a niche simply by existing\" - We Speak to Trans Male OnlyFans Star Trip Richards - Philadelphia Weekly","isPartOf":{"@id":"https://philadelphiaweekly.com/#website"},"primaryImageOfPage":{"@id":"https://philadelphiaweekly.com/trip-richards-onlyfans-interview/#primaryimage"},"datePublished":"2022-02-21T15:07:21+00:00","dateModified":"2022-02-21T17:36:53+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://philadelphiaweekly.com/trip-richards-onlyfans-interview/"]}]},{"@type":"Article","@id":"https://philadelphiaweekly.com/trip-richards-onlyfans-interview/#article","isPartOf":{"@id":"https://philadelphiaweekly.com/trip-richards-onlyfans-interview/#webpage"},"author":{"@id":"https://philadelphiaweekly.com/#/schema/person/4dc25ddf6ecf7a9e4b337a72993c5c21"},"headline":"&#8220;I occupy a niche simply by existing&#8221; &#8211; We Speak to Trans Male OnlyFans Star Trip Richards","datePublished":"2022-02-21T15:07:21+00:00","dateModified":"2022-02-21T17:36:53+00:00","mainEntityOfPage":{"@id":"https://philadelphiaweekly.com/trip-richards-onlyfans-interview/#webpage"},"publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"image":{"@id":"https://philadelphiaweekly.com/trip-richards-onlyfans-interview/#primaryimage"},"keywords":"lgbtq,onlyfans,Sex","articleSection":"LGBTQ,Sex","inLanguage":"en-US"},{"@type":"Person","@id":"https://philadelphiaweekly.com/#/schema/person/4dc25ddf6ecf7a9e4b337a72993c5c21","name":"Joseph Hallas","image":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/297683f51b92909aebe3feacf1c9d4da?s=96&d=mm&r=g","caption":"Joseph Hallas"},"sameAs":["https://twitter.com/jrblackwell"]}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Feed" href="https://philadelphiaweekly.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Comments Feed" href="https://philadelphiaweekly.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Philadelphia Weekly &raquo; iCal Feed" href="https://philadelphiaweekly.com/events/?ical=1" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/philadelphiaweekly.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='tribe-common-skeleton-style-css'  href='https://philadelphiaweekly.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css?ver=4.13.2' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-tooltip-css'  href='https://philadelphiaweekly.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css?ver=4.13.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://philadelphiaweekly.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='block-gallery-frontend-css'  href='https://philadelphiaweekly.com/wp-content/plugins/block-gallery/dist/blocks.style.build.css?ver=1.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://philadelphiaweekly.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpa-style-css'  href='https://philadelphiaweekly.com/wp-content/plugins/wp-accessibility/css/wpa-style.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://philadelphiaweekly.com/wp-content/themes/truro/style.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://philadelphiaweekly.com/wp-content/themes/truro-pw-child/style.css?ver=1.0.0' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='google-css'  href='https://fonts.googleapis.com/css?family=Lora%3A400%2C400i%2C700&#038;ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://philadelphiaweekly.com/wp-content/themes/truro/assets/css/font-awesome.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='truro-style-css'  href='https://philadelphiaweekly.com/wp-content/themes/truro-pw-child/style.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://philadelphiaweekly.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.14' type='text/css' media='all' />
<script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/plugins/jquery-manager/assets/js/jquery-3.5.1.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/plugins/jquery-manager/assets/js/jquery-migrate-3.3.0.min.js' id='jquery-migrate-js'></script>
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":50,"ajax_url":"https:\/\/philadelphiaweekly.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":37500,"token":"7576d10ded","lang":0,"debug":0}
</script>
<script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.3.3' id='wpp-js-js'></script>
<link rel="https://api.w.org/" href="https://philadelphiaweekly.com/wp-json/" /><link rel="alternate" type="application/json" href="https://philadelphiaweekly.com/wp-json/wp/v2/posts/37500" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://philadelphiaweekly.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://philadelphiaweekly.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://philadelphiaweekly.com/?p=37500' />
<link rel="alternate" type="application/json+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Ftrip-richards-onlyfans-interview" />
<link rel="alternate" type="text/xml+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Ftrip-richards-onlyfans-interview&#038;format=xml" />
<!-- Start Drift By WP-Plugin: Drift -->
<!-- Start of Async Drift Code -->
<script>
"use strict";

!function() {
  var t = window.driftt = window.drift = window.driftt || [];
  if (!t.init) {
    if (t.invoked) return void (window.console && console.error && console.error("Drift snippet included twice."));
    t.invoked = !0, t.methods = [ "identify", "config", "track", "reset", "debug", "show", "ping", "page", "hide", "off", "on" ], 
    t.factory = function(e) {
      return function() {
        var n = Array.prototype.slice.call(arguments);
        return n.unshift(e), t.push(n), t;
      };
    }, t.methods.forEach(function(e) {
      t[e] = t.factory(e);
    }), t.load = function(t) {
      var e = 3e5, n = Math.ceil(new Date() / e) * e, o = document.createElement("script");
      o.type = "text/javascript", o.async = !0, o.crossorigin = "anonymous", o.src = "https://js.driftt.com/include/" + n + "/" + t + ".js";
      var i = document.getElementsByTagName("script")[0];
      i.parentNode.insertBefore(o, i);
    };
  }
}();
drift.SNIPPET_VERSION = '0.3.1';
drift.load('rk5uegyicbzi');
</script>
<!-- End of Async Drift Code --><!-- end: Drift Code. -->
<!-- HFCM by 99 Robots - Snippet # 1: MemberSpace install -->
 <meta name="fo-verify" content="295945c5-1548-4cb2-8790-7a318a229e43">
<!-- /end HFCM by 99 Robots -->
<script type="text/javascript">
  window.MemberfulOptions = {
    site: "https:\/\/philadelphiaweekly.memberful.com",
    memberSignedIn: false  };

  (function() {
    var s = document.createElement('script');
    s.type = 'text/javascript';
    s.async = true;
    s.src = 'https://d35xxde4fgg0cx.cloudfront.net/assets/embedded.js';

    setup = function() { window.MemberfulEmbedded.setup(); };

    s.addEventListener("load", setup, false);

    ( document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0] ).appendChild( s );
  })();
</script>
<meta name="google-site-verification" content="hZDTG5TwkKxAp1w_uYHnacLTQJz7bcfH2k6IT3YF2aw" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://philadelphiaweekly.com"><link rel="https://theeventscalendar.com/" href="https://philadelphiaweekly.com/wp-json/tribe/events/v1/" />        <style>
            @-webkit-keyframes bgslide {
                from {
                    background-position-x: 0;
                }
                to {
                    background-position-x: -200%;
                }
            }

            @keyframes bgslide {
                    from {
                        background-position-x: 0;
                    }
                    to {
                        background-position-x: -200%;
                    }
            }

            .wpp-widget-placeholder {
                margin: 0 auto;
                width: 60px;
                height: 3px;
                background: #dd3737;
                background: -webkit-gradient(linear, left top, right top, from(#dd3737), color-stop(10%, #571313), to(#dd3737));
                background: linear-gradient(90deg, #dd3737 0%, #571313 10%, #dd3737 100%);
                background-size: 200% auto;
                border-radius: 3px;
                -webkit-animation: bgslide 1s infinite linear;
                animation: bgslide 1s infinite linear;
            }
        </style>
        <style type="text/css">.header{background-color: #0a0a0a;}.header .SearchForm-button{color: #ffffff;}.Navigation--primary{color: #ffffff;}</style><link rel="amphtml" href="https://philadelphiaweekly.com/trip-richards-onlyfans-interview?amp"><link rel="icon" href="https://philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c-100x100.jpg" sizes="32x32" />
<link rel="icon" href="https://philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg" />
<meta name="msapplication-TileImage" content="https://philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg" />
	<script async src="https://philadelphiaweekly.com/wp-content/themes/truro-pw-child/ga-script.js"></script>
	<script>
	  window.dataLayer = window.dataLayer || [];
	  function gtag(){dataLayer.push(arguments);}
	  gtag('js', new Date());

	  gtag('config', 'UA-700394-5');
	</script>
</head>

<body class="post-template-default single single-post postid-37500 single-format-standard tribe-no-js tribe-theme-parent-truro tribe-theme-child-truro-pw-child">

	<a class="skip-link screen-reader-text" href="#Content">Skip to content</a>

	<header class="header header--four">

    <div class="header-section header-section--primary">

        <div class="header-container">

            <div class="header-sectionInner">

                <div class="header-part">
                    <div class="Branding">
        <a href="https://philadelphiaweekly.com/" rel="home">
      <img class="Branding-logo" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/PW-weekly-white-horizontal-1-1.svg" alt="Philadelphia Weekly" width="200px" />
    </a>

</div><!-- .Branding -->
                </div><!-- .header-part -->

                <div class="header-part header-part__navigation">

                    <nav class="Navigation Navigation--primary">
  <div class="menu-primary-navigation-container"><ul id="menu-primary-navigation" class="menu"><li id="menu-item-227" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a>
<ul class="sub-menu">
	<li id="menu-item-221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a>
	<ul class="sub-menu">
		<li id="menu-item-188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li>
		<li id="menu-item-191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li>
		<li id="menu-item-192" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">Sex</a></li>
		<li id="menu-item-37251" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-37251"><a href="https://philadelphiaweekly.com/sections/lgbtq/">LGBTQ</a></li>
		<li id="menu-item-193" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li>
		<li id="menu-item-194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li>
		<li id="menu-item-7201" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li>
		<li id="menu-item-195" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li>
		<li id="menu-item-34469" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34469"><a href="https://philadelphiaweekly.com/sections/sports-outdoors/">Sports</a></li>
		<li id="menu-item-34471" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34471"><a href="https://philadelphiaweekly.com/sections/gambling/">Betting / Casino</a></li>
	</ul>
</li>
	<li id="menu-item-222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a>
	<ul class="sub-menu">
		<li id="menu-item-27615" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27615"><a href="https://philadelphiaweekly.com/sections/altphilly/">AltPhilly</a></li>
		<li id="menu-item-518" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li>
		<li id="menu-item-375" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li>
		<li id="menu-item-377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li>
		<li id="menu-item-385" class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li>
		<li id="menu-item-384" class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li>
		<li id="menu-item-543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li>
<li id="menu-item-128" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li>
<li id="menu-item-240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li>
</ul></div></nav><!-- .NavigationPrimary -->
                    <div class="utility-navigation">
                        <nav class="Navigation Navigation--utility">
  <div class="menu-utility-navigation-container"><ul id="menu-utility-navigation" class="menu"><li id="menu-item-27636" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27636"><a href="https://philadelphiaweekly.com/join/">Join</a></li>
<li id="menu-item-132" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-132"><a href="https://philadelphiaweekly.com/?memberful_endpoint=auth"><span>Sign In</span></a></li>
</ul></div></nav><!-- .NavigationUtility -->
                        
  <form class="SearchForm SearchForm--header" method="get" action="https://philadelphiaweekly.com/">

    <span class="screen-reader-text">Search for:</span>

    <input class="SearchForm-field" type="text" placeholder="Type &amp; press enter" value="" name="s" title="Search for:" />

    <button type="submit" class="screen-reader-text" aria-label="Search">Search</button>

    <button class="SearchForm-button" aria-label="Submit"><i class="fa fa-search" aria-hidden="true"></i></button>

  </form><!-- .SearchForm -->

                    </div>

                </div><!-- .header-part -->

            </div><!-- .header-sectionInner -->

        </div><!-- .header-container -->

    </div><!-- .header-section -->

</header><!-- .header -->  <nav class="Navigation Navigation--mobile">

  <div class="container">
    <div class="menu-primary-navigation-container"><ul id="menu-primary-navigation-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">Sex</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-37251"><a href="https://philadelphiaweekly.com/sections/lgbtq/">LGBTQ</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34469"><a href="https://philadelphiaweekly.com/sections/sports-outdoors/">Sports</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34471"><a href="https://philadelphiaweekly.com/sections/gambling/">Betting / Casino</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27615"><a href="https://philadelphiaweekly.com/sections/altphilly/">AltPhilly</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li>
		<li class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li>
		<li class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li>
</ul></div>  </div><!-- .Navigation-inner -->

</nav><!-- .Navigation-mobile -->

	
<div class="content content--fullWidth" id="content">
    <div class="content-inner">
        <div class="content-container">
                         <div class="content-row content-row--article">

                <main class="content-main">


                    <header class="article-header">
                        
                                                <div class="meta-tags">
                                                        <span class="Meta-item">
                                <li class="Meta-item Meta-item--categories">
                                    <ul class="Meta Meta--banner"><li class="Meta-item Meta-item--categories"><ul><li><a href="https://philadelphiaweekly.com/sections/lgbtq/" title="LGBTQ">LGBTQ</a></li><li><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/" title="Sex">Sex</a></li></ul></li></ul>                                </li>
                            </span>
                                                    </div>
<!-- 						<span class="disclaimer">
							Our content is reader-supported. We may receive commissions on purchases made through links on our site. Consider becoming a member to support local journalism.
						</span> -->
                        <h1>&#8220;I occupy a niche simply by existing&#8221; &#8211; We Speak to Trans Male OnlyFans Star Trip Richards</h1>

                                                <div class="posts-teaser"><p>Introducing Trip Richards - Adult Entertainment extraordinaire, OnlyFans content creator, and body-positive influencer.</p>
</div>

                        <footer class="Post-footer">
  <ul class="Meta Meta--article">
                            <li class="Meta-item Meta-item--author">
              <a class="meta-author-article" href="https://philadelphiaweekly.com/writer/joe-hallas/">
                <figure class="meta-author-headshot"></figure>
                <span class="meta-author-name">Joe Hallas</span></a>
            </li>
                                    <li class="Meta-item Meta-item--author">
              <a class="meta-author-article" href="https://philadelphiaweekly.com/writer/hannah-cooper/">
                <figure class="meta-author-headshot"></figure>
                <span class="meta-author-name">Hannah Cooper</span></a>
            </li>
                            <li class="Meta-item Meta-item--date">February 21st, 2022</li>
  </ul>
  <ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/trip-richards-onlyfans-interview&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20&#8220;I occupy a niche simply by existing&#8221; &#8211; We Speak to Trans Male OnlyFans Star Trip Richards%20-%20https://philadelphiaweekly.com/trip-richards-onlyfans-interview" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20&#8220;I occupy a niche simply by existing&#8221; &#8211; We Speak to Trans Male OnlyFans Star Trip Richards%20-%20https://philadelphiaweekly.com/trip-richards-onlyfans-interview" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: &#8220;I occupy a niche simply by existing&#8221; &#8211; We Speak to Trans Male OnlyFans Star Trip Richards%20https://philadelphiaweekly.com/trip-richards-onlyfans-interview" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul><!-- .Sharing --></footer>

                                            </header>

                                        <header class="Post-header">

                        <figure class="Post-thumbnail">
                            <a data-fancybox="gallery" data-caption=""
                                href="https://philadelphiaweekly.com/wp-content/uploads/2022/02/Trip-Richards-Yes-3.jpg"><img width="734" height="675" src="https://philadelphiaweekly.com/wp-content/uploads/2022/02/Trip-Richards-Yes-3-734x675.jpg" class="attachment-feature-image size-feature-image wp-post-image" alt="" loading="lazy" /></a>
                                                    </figure><!-- .Post-thumbnail -->

                    </header><!-- .Post-header -->
                    



<div class="sharing-desktop"><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/trip-richards-onlyfans-interview&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20&#8220;I occupy a niche simply by existing&#8221; &#8211; We Speak to Trans Male OnlyFans Star Trip Richards%20-%20https://philadelphiaweekly.com/trip-richards-onlyfans-interview" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20&#8220;I occupy a niche simply by existing&#8221; &#8211; We Speak to Trans Male OnlyFans Star Trip Richards%20-%20https://philadelphiaweekly.com/trip-richards-onlyfans-interview" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: &#8220;I occupy a niche simply by existing&#8221; &#8211; We Speak to Trans Male OnlyFans Star Trip Richards%20https://philadelphiaweekly.com/trip-richards-onlyfans-interview" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul><!-- .Sharing --></div>

<article id="Post-37500" class="Post Post--single post-37500 post type-post status-publish format-standard has-post-thumbnail hentry category-lgbtq category-lgbtq-sex tag-lgbtq tag-onlyfans tag-sex">

    <div class="Post-content">

                <p><span style="font-weight: 400;">Given our obsession with the OnlyFans platform, it’s only natural that we’d want to learn more about our favorite OnlyFans content creators.</span></p>
<p><i><span style="font-weight: 400;">Who are they? Why did they start OnlyFans? Do people recognize them in the grocery store?</span></i></p>
<p><span style="font-weight: 400;">Multi-award-winning Trans educator and entertainer, </span><b>Trip Richards</b><span style="font-weight: 400;">, aka </span><a href="https://mobile.twitter.com/triplextransman?lang=en"><span style="font-weight: 400;">@TripleXTransMan</span></a><span style="font-weight: 400;">, reveals his thoughts on OnlyFans, pansexuality, and being a transgender man in the Adult industry.</span></p>
<p><em><b>Find Trip here:</b></em></p>
<ul>
<li><em><a href="http://justfor.fans/triplextransman" target="_blank" rel="noopener"><span style="font-weight: 400;">JustFor.fans/triplextransman</span></a></em></li>
<li><em><a href="https://onlyfans.com/triplextransman" target="_blank" rel="noopener">Onlyfans.com/triplextransman</a></em></li>
<li><em><a href="https://www.instagram.com/triplextransman_" target="_blank" rel="noopener">Instagram.com/triplextransman_</a></em></li>
</ul>
<p><b>Tell us a little about yourself. When did you become a content creator? What made you take the leap?</b></p>
<p><span style="font-weight: 400;">I’m a 30-something-year-old transgender man. </span></p>
<p><span style="font-weight: 400;">I have been involved in the adult industry for over 8 years. I entered the industry just to make a little extra income and also explore aspects of my own gender and sexuality. Over the subsequent years, it has become my full-time career.</span></p>
<p><b>What sets you apart from other OnlyFans creators?</b></p>
<p><span style="font-weight: 400;">As a transgender man, I occupy a niche market simply by existing.</span></p>
<p><span style="font-weight: 400;">But what I think really sets me apart from other models are my consistent and high-quality postings. I upload new content daily, am highly interactive with fans, and intentionally showcase diverse co-stars in a wide variety of partnered scenes.</span></p>
<p><b>What are your favorite kinds of scenes to shoot?</b></p>
<p><span style="font-weight: 400;">It&#8217;s hard to choose, but I feel like I shine the most in group scenes. I enjoy the collaborative aspects, where I can feed off the energy of my co-stars.</span></p>
<figure id="attachment_37504" aria-describedby="caption-attachment-37504" style="width: 1043px" class="wp-caption alignnone"><img loading="lazy" class="size-full wp-image-37504" src="https://philadelphiaweekly.com/wp-content/uploads/2022/02/Trip-Richards-Yes-1-min.jpg" alt="Photo of Trans Male OnlyFans Creator Trip Richards" width="1043" height="1355" srcset="https://philadelphiaweekly.com/wp-content/uploads/2022/02/Trip-Richards-Yes-1-min.jpg 1043w, https://philadelphiaweekly.com/wp-content/uploads/2022/02/Trip-Richards-Yes-1-min-231x300.jpg 231w, https://philadelphiaweekly.com/wp-content/uploads/2022/02/Trip-Richards-Yes-1-min-788x1024.jpg 788w, https://philadelphiaweekly.com/wp-content/uploads/2022/02/Trip-Richards-Yes-1-min-770x1000.jpg 770w, https://philadelphiaweekly.com/wp-content/uploads/2022/02/Trip-Richards-Yes-1-min-269x350.jpg 269w, https://philadelphiaweekly.com/wp-content/uploads/2022/02/Trip-Richards-Yes-1-min-680x883.jpg 680w" sizes="(max-width: 1043px) 100vw, 1043px" /><figcaption id="caption-attachment-37504" class="wp-caption-text">&#8220;As a transgender man, I occupy a niche market simply by existing.&#8221;</figcaption></figure>
<p><b>Do you have a certain message or purpose you like to promote within your work?</b></p>
<p><span style="font-weight: 400;">I absolutely use my adult work to promote a message of inclusivity and body positivity.</span></p>
<p><span style="font-weight: 400;">While I am unapologetic about the fact that this is my livelihood, I think that adult models are in a unique position to push forward an atmosphere of sex positivity and destigmatization. </span></p>
<p><span style="font-weight: 400;">Whenever I hear from fans that I expanded their horizons or helped them be more comfortable with their own bodies and identities, it really warms my heart.</span></p>
<p><b>Do you find the queer community to be accepting of trans men in porn?</b></p>
<p><span style="font-weight: 400;">I encounter a mix of reactions from the broader LGBT community. Although the hateful transphobic people are a minority, unfortunately, they are a vocal one. </span></p>
<p><span style="font-weight: 400;">In addition, some people don&#8217;t believe that porn is a good path toward trans inclusion. I disagree with this; showing trans bodies as desirable is part of normalizing us.</span></p>
<p><span style="font-weight: 400;">Furthermore, no person should ever be judged for making money and improving their life simply by sharing sexual pleasure with others.</span></p>
<p><span style="font-weight: 400;">Although most of the negative comments I receive roll off my back, it&#8217;s still tough to confront them on a daily basis, when all I&#8217;m trying to do is share hot content with the world.</span></p>
<p><b>When did you realize you were pansexual?</b></p>
<p><span style="font-weight: 400;">I have always identified as bisexual, and once I encountered the term pansexual (which explicitly includes transgender and nonbinary people), I switched to using that label. </span></p>
<p><span style="font-weight: 400;">For me, it&#8217;s pretty straightforward; I have the capacity to be attracted to individual people regardless of their genitals or gender. </span></p>
<p><b>Do you think a lot of people are pansexual, but don’t realize it?</b></p>
<p><span style="font-weight: 400;">While I don&#8217;t presume to tell other people how to identify, I think that many people also have this capacity. </span></p>
<p><span style="font-weight: 400;">There&#8217;s still a lot of social stigma against exploring being bi/pan, paradoxically even within the broader queer community.</span></p>
<p><b>In your opinion, do you think that trans male performers would be affected negatively in the porn industry if they decided to get bottom surgery? (i.e. get a penis)</b></p>
<p><span style="font-weight: 400;">I know of only a very few post-op trans men in adult work, but I am unsure if this is because they don&#8217;t find a market, or because they choose to remove themselves from the public eye at this point in their transition.</span></p>
<p><span style="font-weight: 400;">If my 8 years in sex work has taught me anything, it&#8217;s that viewers have very broad tastes in porn, and that there&#8217;s space for diverse bodies in the industry. Although I am comfortable with my current body, I support all trans people taking whatever steps toward transition they need to feel aligned with their body.</span></p>
<p><img loading="lazy" class="alignnone size-full wp-image-37503" src="https://philadelphiaweekly.com/wp-content/uploads/2022/02/Trip-Richards-Yes-2.jpg" alt="Photo of Trip Richards 2" width="490" height="653" srcset="https://philadelphiaweekly.com/wp-content/uploads/2022/02/Trip-Richards-Yes-2.jpg 490w, https://philadelphiaweekly.com/wp-content/uploads/2022/02/Trip-Richards-Yes-2-225x300.jpg 225w, https://philadelphiaweekly.com/wp-content/uploads/2022/02/Trip-Richards-Yes-2-263x350.jpg 263w" sizes="(max-width: 490px) 100vw, 490px" /></p>
<p><b>You’ve won awards for Hottest Transman (FTM Performer) and Favorite FTM Star &#8211; how has that affected your porn career? Did it feel validating?</b></p>
<p><span style="font-weight: 400;">Although winning awards has never been my main focus, it is certainly nice to receive public recognition for my work. </span></p>
<p><span style="font-weight: 400;">When I began working as a transmale performer, I had no idea there would be any market for me, so it’s very validating to see that in fact people like what I do.</span></p>
<p><b>As someone who has lived experiences as both male-presenting and female-presenting, have you noticed differences in how people treat you since transitioning? Whether in the porn world or in general?</b></p>
<p><span style="font-weight: 400;">Outside of porn, being perceived as a cisgender man confers advantages to me such as receiving greater respect and experiencing greater safety. </span></p>
<p><span style="font-weight: 400;">It has also forced me to adjust my own actions in order to not be perceived as threatening to women, such as not accidentally following someone at night. </span></p>
<p><span style="font-weight: 400;">Within porn, the reaction is a little different because my body is obviously not cisgender male. I have to spend a significant amount of energy just explaining to people what I am and what body parts they are seeing, and that&#8217;s something that cisgender models don&#8217;t have to do.</span></p>
<p><b>Finally, where do you see your OnlyFans going in the future?</b></p>
<p><span style="font-weight: 400;">Going forward, I plan to continue expanding my fan pages, adding new pics and vids on a daily basis, and collaborating with as many other great models as I can. </span></p>
<p><span style="font-weight: 400;">I also want to continue showcasing people of diverse sizes, shapes, colors, and gender identities because I believe that porn should be as diverse as the people who watch it.</span></p>
<p><strong>RELATED READING: <a href="https://philadelphiaweekly.com/best-onlyfans/" target="_blank" rel="noopener">Best OnlyFans Accounts in 2022</a></strong></p>
<p><strong><em>Be sure to check out Trip on <a href="http://JustFor.fans/triplextransman" target="_blank" rel="noopener">Just For Fans</a>, <a href="https://onlyfans.com/triplextransman" target="_blank" rel="noopener">OnlyFans</a>, <a href="https://mobile.twitter.com/triplextransman?lang=en" target="_blank" rel="noopener">Twitter</a>, and <a href="https://www.instagram.com/triplextransman_" target="_blank" rel="noopener">Instagram.</a></em></strong></p>

        <div class="article-promotional-message">
    <p>If you read this story and liked it, consider joining altPhilly, our membership program that offers exclusive content, instant access to the editor and awesome perks for like-minded Philadelphians. At PW, our coverage goes against the grain of the local mainstream media.</p>
    <a class="Button Button-subscribe" href="https://philadelphiaweekly.memberful.com/checkout?plan=62041"
        target="_self">Join altPhilly Now</a>
            <div class="article-promotional-message__secondary__container">
        <a class="article-promotional-message__secondary" href="https://philadelphiaweekly.com/join/"
            target="_self">Learn More</a>
    </div>
    </div>

        
        
        <h5 class="related-posts__title">Related</h5><ul class="related-posts">        <li><a href="https://philadelphiaweekly.com/marijuana-and-sexuality/" rel="bookmark"
                title="Permanent Link to Marijuana and sexuality">Marijuana and sexuality</a></li>
                <li><a href="https://philadelphiaweekly.com/married-people/" rel="bookmark"
                title="Permanent Link to Married people">Married people</a></li>
                <li><a href="https://philadelphiaweekly.com/open-ended/" rel="bookmark"
                title="Permanent Link to Open-ended">Open-ended</a></li>
                <li><a href="https://philadelphiaweekly.com/open-and-shut/" rel="bookmark"
                title="Permanent Link to Open and shut">Open and shut</a></li>
        </ul>
        <ul class="Meta"><li class="Meta-item Meta-item--tags"><ul><li><a href="https://philadelphiaweekly.com/tag/lgbtq/" title=" lgbtq ">lgbtq</a></li><li><a href="https://philadelphiaweekly.com/tag/onlyfans/" title=" onlyfans ">onlyfans</a></li><li><a href="https://philadelphiaweekly.com/tag/sex/" title=" Sex ">Sex</a></li></ul></li></ul>

    </div><!-- .Post-content -->

</article><!-- .Post -->
<ul class="author-article-bio">
            <li class="author-bio__item">
        <a class="author-bio__headshot" href="https://philadelphiaweekly.com/writer/joe-hallas/">
            <figure></figure>
        </a>
        <div class="author-name__container">
            <a class="author-bio__name" href="https://philadelphiaweekly.com/writer/joe-hallas/">
                <h6>Joe Hallas</h6>
            </a>
                    </div>
                <div class="author-bio__info">
                    </div>
    </li>
            <li class="author-bio__item">
        <a class="author-bio__headshot" href="https://philadelphiaweekly.com/writer/hannah-cooper/">
            <figure></figure>
        </a>
        <div class="author-name__container">
            <a class="author-bio__name" href="https://philadelphiaweekly.com/writer/hannah-cooper/">
                <h6>Hannah Cooper</h6>
            </a>
                    </div>
                <div class="author-bio__info">
                    </div>
    </li>
    </ul>


</main><!-- #main -->
<!--<aside class="content-sidebar">
					</aside>-->

</div><!-- .content-row-->




  <section class="RelatedPosts">

    <div class="category-row__bar">
            <h2 class="category-row__title">Up Next in LGBTQ</h2>
    </div>

    <ul class="posts-row">

      
        <li class="posts-row__item">

                      <header class="Post-header">

              <figure class="RelatedPosts-postThumbnail">
                <a href="https://philadelphiaweekly.com/bumble-for-hookups-review-male/" title="Is Bumble For Hookups? A Man&#8217;s Perspective on the &#8220;Dating App For Women&#8221;">
                  <img width="680" height="480" src="https://philadelphiaweekly.com/wp-content/uploads/2022/02/bumble-for-hookups-680x480.jpg" class="attachment-related-post size-related-post wp-post-image" alt="Bumble For Hookups Review Featueed Image" loading="lazy" />                </a>
              </figure><!-- .RelatedPosts-postThumbnail -->

            </header><!-- .RelatedPosts-postHeader -->
                    <div class="Post-content">
            <a href="https://philadelphiaweekly.com/bumble-for-hookups-review-male/" title="Is Bumble For Hookups? A Man&#8217;s Perspective on the &#8220;Dating App For Women&#8221;">
              <h5 class="RecentPosts-title">Is Bumble For Hookups? A Man&#8217;s Perspective on the &#8220;Dating App For Women&#8221;</h5>
            </a>
            <div class="posts-teaser"><p>Can you use Bumble for hookups and casual sex? We look at the "dating app designed for women" from a straight man's perspective.</p>
</div>
          </div>

          <footer class="RelatedPosts-postFooter">
            <ul class="Meta">
            <li class="Meta-item Meta-item--date">Feb 16, 2022</li>
            </ul>
          </footer><!-- .RelatedPosts-postFooter -->

        </li><!-- .RelatedPosts-postFooter -->

      
        <li class="posts-row__item">

                      <header class="Post-header">

              <figure class="RelatedPosts-postThumbnail">
                <a href="https://philadelphiaweekly.com/hookups-vs-relationship-sex-which-is-better/" title="Hookups vs. Relationship Sex &#8211; Which is Better?">
                  <img width="680" height="480" src="https://philadelphiaweekly.com/wp-content/uploads/2022/02/Casual-Sex-vs-Relationship-Sex-yes-680x480.jpg" class="attachment-related-post size-related-post wp-post-image" alt="" loading="lazy" />                </a>
              </figure><!-- .RelatedPosts-postThumbnail -->

            </header><!-- .RelatedPosts-postHeader -->
                    <div class="Post-content">
            <a href="https://philadelphiaweekly.com/hookups-vs-relationship-sex-which-is-better/" title="Hookups vs. Relationship Sex &#8211; Which is Better?">
              <h5 class="RecentPosts-title">Hookups vs. Relationship Sex &#8211; Which is Better?</h5>
            </a>
            <div class="posts-teaser"><p>Is it better to hook up or be "tied down"? Is it about deep love or animalistic mating? Justin Perlman aims to find out.</p>
</div>
          </div>

          <footer class="RelatedPosts-postFooter">
            <ul class="Meta">
            <li class="Meta-item Meta-item--date">Feb 10, 2022</li>
            </ul>
          </footer><!-- .RelatedPosts-postFooter -->

        </li><!-- .RelatedPosts-postFooter -->

      
        <li class="posts-row__item">

                      <header class="Post-header">

              <figure class="RelatedPosts-postThumbnail">
                <a href="https://philadelphiaweekly.com/sex-toys-valentines-day/" title="7 Sultry Sex Toys You Can Buy In Time For Valentine’s Day">
                  <img width="680" height="480" src="https://philadelphiaweekly.com/wp-content/uploads/2022/02/valentines-feature-680x480.jpg" class="attachment-related-post size-related-post wp-post-image" alt="" loading="lazy" srcset="https://philadelphiaweekly.com/wp-content/uploads/2022/02/valentines-feature-680x480.jpg 680w, https://philadelphiaweekly.com/wp-content/uploads/2022/02/valentines-feature-800x563.jpg 800w" sizes="(max-width: 680px) 100vw, 680px" />                </a>
              </figure><!-- .RelatedPosts-postThumbnail -->

            </header><!-- .RelatedPosts-postHeader -->
                    <div class="Post-content">
            <a href="https://philadelphiaweekly.com/sex-toys-valentines-day/" title="7 Sultry Sex Toys You Can Buy In Time For Valentine’s Day">
              <h5 class="RecentPosts-title">7 Sultry Sex Toys You Can Buy In Time For Valentine’s Day</h5>
            </a>
            <div class="posts-teaser"><p>Need a sexy Valentine's gift in 1-4 days? Keep reading...</p>
</div>
          </div>

          <footer class="RelatedPosts-postFooter">
            <ul class="Meta">
            <li class="Meta-item Meta-item--date">Feb 2, 2022</li>
            </ul>
          </footer><!-- .RelatedPosts-postFooter -->

        </li><!-- .RelatedPosts-postFooter -->

      
        <li class="posts-row__item">

                      <header class="Post-header">

              <figure class="RelatedPosts-postThumbnail">
                <a href="https://philadelphiaweekly.com/best-swinger-sites/" title="10 Best Swinger Sites for Meeting Local Swingers Near You">
                  <img width="514" height="480" src="https://philadelphiaweekly.com/wp-content/uploads/2021/11/best-swingers-sites-514x480.jpg" class="attachment-related-post size-related-post wp-post-image" alt="" loading="lazy" />                </a>
              </figure><!-- .RelatedPosts-postThumbnail -->

            </header><!-- .RelatedPosts-postHeader -->
                    <div class="Post-content">
            <a href="https://philadelphiaweekly.com/best-swinger-sites/" title="10 Best Swinger Sites for Meeting Local Swingers Near You">
              <h5 class="RecentPosts-title">10 Best Swinger Sites for Meeting Local Swingers Near You</h5>
            </a>
            <div class="posts-teaser"><p>We look at the best swinger sites where you can find open-minded singles, couples, and groups online!</p>
</div>
          </div>

          <footer class="RelatedPosts-postFooter">
            <ul class="Meta">
            <li class="Meta-item Meta-item--date">Jan 14, 2022</li>
            </ul>
          </footer><!-- .RelatedPosts-postFooter -->

        </li><!-- .RelatedPosts-postFooter -->

      
    </ul><!-- .RelatedPosts-inner -->

  </section><!-- .RelatedPosts -->

  
<div class="Columns-row columns-even">
    <div class="Columns-column">
        <!-- Most Popular -->
        <div class="most-popular">
	<h2>Most Popular This Week</h2>
	


<ol class="most-popular-list">
<li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/" class="wpp-taxonomy category category-93">Sex</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/best-swinger-sites/">10 Best Swinger Sites for Meeting Local Swingers Near You</a></li>
<li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/opinion/" class="wpp-taxonomy category category-3039">Opinion</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/arts-and-money/">Arts and money</a></li>
<li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/opinion/" class="wpp-taxonomy category category-3039">Opinion</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/record-homicides-ranking-who-should-is-accountable/">Record Homicides: Ranking who should be held accountable</a></li>
<li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/featured-sections/" class="wpp-taxonomy category category-135">Featured Sections</a>, <a href="https://philadelphiaweekly.com/sections/featured-sections/sex-with-timaree-featured-sections/" class="wpp-taxonomy category category-13117">Sex with Timaree</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/why-arent-people-having-sex/">Why Aren’t People Having Sex?</a></li>
<li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/featured-sections/" class="wpp-taxonomy category category-135">Featured Sections</a>, <a href="https://philadelphiaweekly.com/sections/news/" class="wpp-taxonomy category category-92">News</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/the-cartesian-approach/">The Cartesian Approach</a></li>

</ol>
	
<!-- 	<ol class="most-popular-list">
		<li class="most-popular-list__item">
			<span class="Meta most-popular__category">
				<a href="https://philadelphiaweekly.com/sections/lgbtq-sex/" class="wpp-taxonomy category category-93">LGBTQ / Sex</a>
			</span>
			<a class="most-popular__link" href="https://philadelphiaweekly.com/best-vr-porn-sites">Top VR Porn Sites for The Best Virtual Reality Sex Experience</a>
		</li>
	</ol> -->
</div>

<!-- End most popular articles -->
<a class="Button" href="/popular">More Popular Articles</a>    </div>
    <div class="Columns-column columns-even__right">
        <!-- Recent Posts -->
        <div class="calendar-events-teaser">
            <h2>Upcoming Philly Events</h2>
            <ul class="calendar-events">

</li>
</ul>
<a class="Button" href="/calendar">More Events</a>
        </div>
    </div>
</div>

</div><!-- .content-container -->

</div><!-- .content-inner -->

</div><!-- .content -->


	
	<footer class="footer">

		<div class="footer-section footer-section--primary">

			<div class="footer-container">

				
			</div><!-- .footer-inner -->

		</div><!-- .footer-section--primary -->

		<div class="footer-section footer-section--secondary">

			<div class="footer-container">

					<div class="footer-inner">

						<div class="footer-inner__branding">
							<div class="footer-inner__logo">
								<img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" />
							</div>
							<div class="footer-inner_social">
								<p>Follow @PhillyWeekly</p>
																    <ul class="footer-inner__social__list">
								    								        <li>
													<a href="https://www.facebook.com/pg/phillyweekly/posts/">
																												<i class="fa fa-facebook-square" aria-hidden="true"></i>
														<span>Facebook</span>
													</a>
												</li>
								    								        <li>
													<a href="https://twitter.com/PhillyWeekly/">
																												<i class="fa fa-twitter" aria-hidden="true"></i>
														<span>Twitter</span>
													</a>
												</li>
								    								        <li>
													<a href="https://www.instagram.com/phillyweekly/">
																												<i class="fa fa-instagram" aria-hidden="true"></i>
														<span>Instagram</span>
													</a>
												</li>
								    								        <li>
													<a href="https://philadelphiaweekly.com/feeds">
																												<i class="fa fa-rss" aria-hidden="true"></i>
														<span>Your News Reader</span>
													</a>
												</li>
								    								    </ul>
															</div>
						</div>


						
<nav class="Navigation Navigation--footer">
  <div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-133"><a href="#">About PW</a>
<ul class="sub-menu">
	<li id="menu-item-334" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334"><a href="https://philadelphiaweekly.com/about/">About Us</a></li>
	<li id="menu-item-386" class="menu-item menu-item-type-post_type_archive menu-item-object-writer menu-item-386"><a href="https://philadelphiaweekly.com/writer/">Our Writers</a></li>
	<li id="menu-item-25676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25676"><a href="https://philadelphiaweekly.com/locations/">Dropbox Locations</a></li>
	<li id="menu-item-336" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-336"><a href="/advertising">Advertising &#038; Partnerships</a></li>
	<li id="menu-item-338" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-338"><a href="/events/community/add">Submit an Event</a></li>
</ul>
</li>
<li id="menu-item-134" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-134"><a href="#">Explore PW</a>
<ul class="sub-menu">
	<li id="menu-item-228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-228"><a href="https://philadelphiaweekly.com/sections/">Sections</a></li>
	<li id="menu-item-137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li>
	<li id="menu-item-136" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li>
	<li id="menu-item-335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-335"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li>
	<li id="menu-item-29460" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29460"><a href="https://philadelphiaweekly.com/sections/altphilly/">AltPhilly Exclusives</a></li>
</ul>
</li>
</ul></div></nav><!-- .NavigationPrimary -->

						<div class="footer-inner_contact-text">
							<div class="footer-inner__logo--desktop">
								<img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" />
							</div>
							<div class="footer-inner_contact">
								<p>1520 Locust Street, Fifth Floor</p>
								<p>Philadelphia, PA 19102</p>
							</div>
							<div class="footer-inner_contact footer-inner_contact__phone">
								<p>215-543-3743</p>
								<p><a href="mailto:mail@philadelphiaweekly.com">mail@philadelphiaweekly.com</a></p>
							</div>
							<div class="footer-info">
								&copy; Copyright Philadelphia Weekly							</div><!-- .footer-info -->
						</div>

			</div><!-- .footer-inner -->

		</div><!-- .footer-lower -->

</footer><!-- .footer -->

	</div>

			<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><script type='text/javascript' src='https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script type='text/javascript' id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );( 'objectFit' in document.documentElement.style ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-object-fit.min.js?ver=2.3.4"></scr' + 'ipt>' );
</script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/philadelphiaweekly.com\/wp-json\/","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.5.3' id='contact-form-7-js'></script>
<script type='text/javascript' id='ta_main_js-js-extra'>
/* <![CDATA[ */
var thirsty_global_vars = {"home_url":"\/\/philadelphiaweekly.com","ajax_url":"https:\/\/philadelphiaweekly.com\/wp-admin\/admin-ajax.php","link_fixer_enabled":"yes","link_prefix":"go","link_prefixes":["recommends","go"],"post_id":"37500","enable_record_stats":"yes","enable_js_redirect":"yes","disable_thirstylink_class":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/plugins/thirstyaffiliates/js/app/ta.js?ver=3.10.3' id='ta_main_js-js'></script>
<script type='text/javascript' id='wpa-complementary-js-extra'>
/* <![CDATA[ */
var wpaComplementary = {"container":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/plugins/wp-accessibility/js/roles.jquery.js?ver=1.0' id='wpa-complementary-js'></script>
<script type='text/javascript' id='longdesc.button-js-extra'>
/* <![CDATA[ */
var wparest = {"url":"https:\/\/philadelphiaweekly.com\/wp-json\/wp\/v2\/media","text":"<span>Long Description<\/span>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/plugins/wp-accessibility/js/longdesc.button.js?ver=1.0' id='longdesc.button-js'></script>
<script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/plugins/wp-accessibility/js/current-menu-item.js?ver=1.0' id='current.menu-js'></script>
<script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/themes/truro-pw-child/js/fancybox.js?ver=1.1' id='script-js'></script>
<script type='text/javascript' src='https://philadelphiaweekly.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://philadelphiaweekly.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script>
<script type='text/javascript' src='https://philadelphiaweekly.com/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b' id='jquery-masonry-js'></script>
<script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/themes/truro/assets/js/helper-functions.js?ver=1' id='helper-functions-js'></script>
<script type='text/javascript' id='truro-scripts-js-extra'>
/* <![CDATA[ */
var customizer = {"sliderSlideCount":"1","sliderLoop":"0","sliderAutoPlay":"0","sliderAutoPlaySpeed":"7000","sliderArrows":"1","sliderDots":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/themes/truro/assets/js/scripts.js?ver=1' id='truro-scripts-js'></script>
<script type='text/javascript' src='https://philadelphiaweekly.com/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
	<!-- Load Typekit in Non Blocking Manner -->
	<link rel="stylesheet" href="https://use.typekit.net/cgg8jik.css">
	</body>

</html>
