<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="stylesheet" media="print" onload="this.onload=null;this.media='all';" id="ao_optimized_gfonts" href="https://fonts.googleapis.com/css?family=Lora%3A400%2C400i%2C700&amp;display=swap" /><link rel="profile" href="http://gmpg.org/xfn/11"><meta property="fb:pages" content="23117126720" /><link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png"><link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png"><link rel="manifest" href="/site.webmanifest"><link rel="mask-icon" href="/safari-pinned-tab.svg" color="#ffc414"><meta name="msapplication-TileColor" content="#231f20"><meta name="theme-color" content="#231f20"> <style type="text/css">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</style><link rel="stylesheet" media="print" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_1c6724fe3edda3d44826bb3d7fd9b6c1.css" onload="this.onload=null;this.media='all';" /><noscript id="aonoscrcss"><link media="all" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_1c6724fe3edda3d44826bb3d7fd9b6c1.css" rel="stylesheet" /></noscript><title>Do you know Jo? - Philadelphia Weekly</title><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://philadelphiaweekly.com/do-you-know-jo/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Do you know Jo? - Philadelphia Weekly" /><meta property="og:description" content="Libertarian presidential candidate talks War on Drugs, poverty, more" /><meta property="og:url" content="https://philadelphiaweekly.com/do-you-know-jo/" /><meta property="og:site_name" content="Philadelphia Weekly" /><meta property="article:publisher" content="https://www.facebook.com/phillyweekly/" /><meta property="article:published_time" content="2020-10-16T13:56:29+00:00" /><meta property="article:modified_time" content="2020-10-16T13:56:37+00:00" /><meta property="og:image" content="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Jo-Jorgensen-Speaking-scaled-1.jpg?fit=1697%2C1253&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta property="og:image:width" content="1697" /><meta property="og:image:height" content="1253" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@phillyweekly" /><meta name="twitter:site" content="@phillyweekly" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://philadelphiaweekly.com/#organization","name":"Philadelphia Weekly","url":"https://philadelphiaweekly.com/","sameAs":["https://www.facebook.com/phillyweekly/","https://www.instagram.com/phillyweekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://twitter.com/phillyweekly"],"logo":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#logo","inLanguage":"en-US","url":"https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&quality=70&strip=all&ssl=1","width":500,"height":500,"caption":"Philadelphia Weekly"},"image":{"@id":"https://philadelphiaweekly.com/#logo"}},{"@type":"WebSite","@id":"https://philadelphiaweekly.com/#website","url":"https://philadelphiaweekly.com/","name":"Philadelphia Weekly","description":"","publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://philadelphiaweekly.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/do-you-know-jo/#primaryimage","inLanguage":"en-US","url":"https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Jo-Jorgensen-Speaking-scaled-1.jpg?fit=1697%2C1253&quality=70&strip=all&ssl=1","width":1697,"height":1253,"caption":"Libertarian presidential candidate Jo Jorgensen said that, on day one of her presidency, she would pardon the 80,000 people serving federal time for nonviolent drug convictions and send them home to their families. | Image courtesy: Jorgensen campaign"},{"@type":"WebPage","@id":"https://philadelphiaweekly.com/do-you-know-jo/#webpage","url":"https://philadelphiaweekly.com/do-you-know-jo/","name":"Do you know Jo? - Philadelphia Weekly","isPartOf":{"@id":"https://philadelphiaweekly.com/#website"},"primaryImageOfPage":{"@id":"https://philadelphiaweekly.com/do-you-know-jo/#primaryimage"},"datePublished":"2020-10-16T13:56:29+00:00","dateModified":"2020-10-16T13:56:37+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://philadelphiaweekly.com/do-you-know-jo/"]}]},{"@type":"Article","@id":"https://philadelphiaweekly.com/do-you-know-jo/#article","isPartOf":{"@id":"https://philadelphiaweekly.com/do-you-know-jo/#webpage"},"author":{"@id":"https://philadelphiaweekly.com/#/schema/person/282ff16c532b49021b406ba1bf996e4c"},"headline":"Do you know Jo?","datePublished":"2020-10-16T13:56:29+00:00","dateModified":"2020-10-16T13:56:37+00:00","mainEntityOfPage":{"@id":"https://philadelphiaweekly.com/do-you-know-jo/#webpage"},"publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"image":{"@id":"https://philadelphiaweekly.com/do-you-know-jo/#primaryimage"},"keywords":"jo jorgensen,philadelphia,president,united states","articleSection":"News,People","inLanguage":"en-US"},{"@type":"Person","@id":"https://philadelphiaweekly.com/#/schema/person/282ff16c532b49021b406ba1bf996e4c","name":"Kerith Gabriel","image":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/50d5b7c2c3083d03c8a7f19f166ec1fe?s=96&d=mm&r=g","caption":"Kerith Gabriel"}}]}</script> <link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//c0.wp.com' /><link rel='dns-prefetch' href='//i0.wp.com' /><link rel='dns-prefetch' href='//i1.wp.com' /><link rel='dns-prefetch' href='//i2.wp.com' /><link href='https://use.typekit.net' rel='preconnect' /><link href='https://www.google-analytics.com' rel='preconnect' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Feed" href="https://philadelphiaweekly.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Comments Feed" href="https://philadelphiaweekly.com/comments/feed/" /><link rel="alternate" type="text/calendar" title="Philadelphia Weekly &raquo; iCal Feed" href="https://philadelphiaweekly.com/events/?ical=1" /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify;}</style> <script type='application/json' id='wpp-json'>{"sampling_active":0,"sampling_rate":50,"ajax_url":"https:\/\/philadelphiaweekly.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":23468,"token":"ea419f1503","lang":0,"debug":0}</script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-700394-5' id='google_gtagjs-js' async></script> <script type='text/javascript' id='google_gtagjs-js-after'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["philadelphiaweekly.com"]} );
gtag('js', new Date());
gtag('set', 'developer_id.dZTNiMT', true);
gtag('config', 'UA-700394-5', {"anonymize_ip":true} );</script> <link rel="https://api.w.org/" href="https://philadelphiaweekly.com/wp-json/" /><link rel="alternate" type="application/json" href="https://philadelphiaweekly.com/wp-json/wp/v2/posts/23468" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://philadelphiaweekly.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://philadelphiaweekly.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.5.1" /><link rel='shortlink' href='https://philadelphiaweekly.com/?p=23468' /><link rel="alternate" type="application/json+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fdo-you-know-jo%2F" /><link rel="alternate" type="text/xml+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Fdo-you-know-jo%2F&#038;format=xml" />  <script>"use strict";

!function() {
  var t = window.driftt = window.drift = window.driftt || [];
  if (!t.init) {
    if (t.invoked) return void (window.console && console.error && console.error("Drift snippet included twice."));
    t.invoked = !0, t.methods = [ "identify", "config", "track", "reset", "debug", "show", "ping", "page", "hide", "off", "on" ], 
    t.factory = function(e) {
      return function() {
        var n = Array.prototype.slice.call(arguments);
        return n.unshift(e), t.push(n), t;
      };
    }, t.methods.forEach(function(e) {
      t[e] = t.factory(e);
    }), t.load = function(t) {
      var e = 3e5, n = Math.ceil(new Date() / e) * e, o = document.createElement("script");
      o.type = "text/javascript", o.async = !0, o.crossorigin = "anonymous", o.src = "https://js.driftt.com/include/" + n + "/" + t + ".js";
      var i = document.getElementsByTagName("script")[0];
      i.parentNode.insertBefore(o, i);
    };
  }
}();
drift.SNIPPET_VERSION = '0.3.1';
drift.load('rk5uegyicbzi');</script> <meta name="generator" content="Site Kit by Google 1.18.0" /><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://philadelphiaweekly.com"><link rel="https://theeventscalendar.com/" href="https://philadelphiaweekly.com/wp-json/tribe/events/v1/" /><style type="text/css">.header{background-color: #0a0a0a;}.header .SearchForm-button{color: #ffffff;}.Navigation--primary{color: #ffffff;}</style><style type="text/css">/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}</style> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link rel="amphtml" href="https://philadelphiaweekly.com/do-you-know-jo/amp/"><link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=32%2C21&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=192%2C128&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=180%2C120&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=270%2C180&#038;quality=70&#038;strip=all&#038;ssl=1" /> <script>window.dataLayer = window.dataLayer || [];
	  function gtag(){dataLayer.push(arguments);}
	  gtag('js', new Date());

	  gtag('config', 'UA-700394-5');</script> </head><body class="post-template-default single single-post postid-23468 single-format-standard tribe-no-js tribe-theme-parent-truro tribe-theme-child-truro-pw-child"> <a class="skip-link screen-reader-text" href="#Content">Skip to content</a><header class="header header--four"><div class="header-section header-section--primary"><div class="header-container"><div class="header-sectionInner"><div class="header-part"><div class="Branding"> <a href="https://philadelphiaweekly.com/" rel="home"> <img class="Branding-logo" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/PW-weekly-white-horizontal-1-1.svg" alt="Philadelphia Weekly" width="200px" /> </a></div></div><div class="header-part header-part__navigation"><nav class="Navigation Navigation--primary"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation" class="menu"><li id="menu-item-227" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li id="menu-item-221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li id="menu-item-188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li id="menu-item-191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li id="menu-item-192" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li id="menu-item-193" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li id="menu-item-194" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li id="menu-item-7201" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li id="menu-item-195" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li id="menu-item-222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li id="menu-item-518" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li id="menu-item-375" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li id="menu-item-377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li id="menu-item-385" class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li id="menu-item-366" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-366"><a href="https://philadelphiaweekly.com/sections/featured-sections/savage-love/">Savage Love</a></li><li id="menu-item-384" class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li id="menu-item-543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-128" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></nav><div class="utility-navigation"><form class="SearchForm SearchForm--header" method="get" action="https://philadelphiaweekly.com/"> <span class="screen-reader-text">Search for:</span> <input class="SearchForm-field" type="text" placeholder="Type &amp; press enter" value="" name="s" title="Search for:" /> <button type="submit" class="screen-reader-text" aria-label="Search">Search</button> <button class="SearchForm-button" aria-label="Submit"><i class="fa fa-search" aria-hidden="true"></i></button></form></div></div></div></div></div></header><nav class="Navigation Navigation--mobile"><div class="container"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-366"><a href="https://philadelphiaweekly.com/sections/featured-sections/savage-love/">Savage Love</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></div></nav><div class="content content--fullWidth" id="content"><div class="content-inner"><div class="content-container"><div class="content-row content-row--article"><main class="content-main"><header class="article-header"><div class="meta-tags"> <span class="Meta-item"><li class="Meta-item Meta-item--categories"><ul class="Meta Meta--banner"><li class="Meta-item Meta-item--categories"><ul><li><a href="https://philadelphiaweekly.com/sections/news/" title="News">News</a></li><li><a href="https://philadelphiaweekly.com/sections/people/" title="People">People</a></li></ul></li></ul></li> </span></div><h1>Do you know Jo?</h1><div class="posts-teaser"><p>Libertarian presidential candidate talks War on Drugs, poverty, more</p></div><footer class="Post-footer"><ul class="Meta Meta--article"><li class="Meta-item Meta-item--author"> <a class="meta-author-article" href="https://philadelphiaweekly.com/writer/eugene-zenyatta/"><figure class="meta-author-headshot"><img width="200" height="200" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-headshot size-headshot wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="16719" data-permalink="https://philadelphiaweekly.com/writer/eugene-zenyatta/joe-hernandez-oebdsi0q4f0-unsplash/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="joe-hernandez-OebdsI0Q4F0-unsplash" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 200w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=680%2C680&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=1472%2C1472&amp;quality=70&amp;strip=all&amp;ssl=1 1472w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=1104%2C1104&amp;quality=70&amp;strip=all&amp;ssl=1 1104w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=912%2C912&amp;quality=70&amp;strip=all&amp;ssl=1 912w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=550%2C550&amp;quality=70&amp;strip=all&amp;ssl=1 550w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=470%2C470&amp;quality=70&amp;strip=all&amp;ssl=1 470w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?zoom=2&amp;resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 400w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?zoom=3&amp;resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 600w" data-lazy-sizes="(max-width: 200px) 100vw, 200px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></figure> <span class="meta-author-name">Eugene Zenyatta</span></a></li><li class="Meta-item Meta-item--date">October 16th, 2020</li></ul><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/do-you-know-jo/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20Do you know Jo?%20-%20https://philadelphiaweekly.com/do-you-know-jo/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20Do you know Jo?%20-%20https://philadelphiaweekly.com/do-you-know-jo/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: Do you know Jo?%20https://philadelphiaweekly.com/do-you-know-jo/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></footer></header><header class="Post-header"><figure class="Post-thumbnail"> <a data-fancybox="gallery" data-caption=" Libertarian presidential candidate Jo Jorgensen said that, on day one of her presidency, she would pardon the 80,000 people serving federal time for nonviolent drug convictions and send them home to their families. | Image courtesy: Jorgensen campaign" href="https://philadelphiaweekly.com/wp-content/uploads/2020/10/Jo-Jorgensen-Speaking-scaled-1.jpg"><img width="1200" height="675" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Jo-Jorgensen-Speaking-scaled-1.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-feature-image size-feature-image wp-post-image jetpack-lazy-image" alt="Jo Jorgensen" loading="lazy" data-attachment-id="23470" data-permalink="https://philadelphiaweekly.com/do-you-know-jo/jo-jorgensen-speaking-scaled/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Jo-Jorgensen-Speaking-scaled-1.jpg?fit=1697%2C1253&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1697,1253" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1602355552&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Jo-Jorgensen-Speaking-scaled" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Jo-Jorgensen-Speaking-scaled-1.jpg?fit=300%2C222&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Jo-Jorgensen-Speaking-scaled-1.jpg?fit=1024%2C756&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Jo-Jorgensen-Speaking-scaled-1.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></a><figcaption> Libertarian presidential candidate Jo Jorgensen said that, on day one of her presidency, she would pardon the 80,000 people serving federal time for nonviolent drug convictions and send them home to their families. | Image courtesy: Jorgensen campaign</figcaption></figure></header><div class="sharing-desktop"><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/do-you-know-jo/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20Do you know Jo?%20-%20https://philadelphiaweekly.com/do-you-know-jo/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20Do you know Jo?%20-%20https://philadelphiaweekly.com/do-you-know-jo/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: Do you know Jo?%20https://philadelphiaweekly.com/do-you-know-jo/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></div><article id="Post-23468"  class="Post Post--single post-23468 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-people tag-jo-jorgensen tag-philadelphia tag-president tag-united-states"><div class="Post-content"><h4>You know Trump, Biden and even Kanye are running for president. But have you met Dr. Jo Jorgensen?</h4><p>She’s the presidential candidate of the Libertarian Party – the third-largest political party, according to voter registration. Its 2016 candidate, Gary Johnson, pulled in just over 3 percent of the popular vote. According to its website, lp.org, “Libertarians strongly oppose any government interference into their personal, family, and business decisions. Essentially, we believe all Americans should be free to live their lives and pursue their interests as they see fit as long as they do no harm to another.”</p><p>Jorgensen, a senior lecturer in psychology at Clemson University since 2006 and the party’s vice presidential candidate in 1996, made a campaign stop in Philly recently, and PW caught up with her to talk about the issues of the day.&nbsp;</p><p><strong>Philadelphia only recently expanded its indoor dining capacity for restaurants from 25 percent to 50 percent, and many other restrictions and closures remain in place. What are your thoughts about governments forcing businesses to close during the pandemic?&nbsp;</strong></p><p>The shutdown of our economy to stop COVID-19 is a classic case of government “solutions” being potentially worse than the problem they intended to solve. Millions have lost their jobs, and an estimated one-sixth of small businesses will close their doors for good. Others have lost their homes.&nbsp;&nbsp;</p><p>The sensible way to handle the COVID-19 pandemic was to focus on protecting the most vulnerable, while encouraging individuals and organizations to make the choices best suited to their level of risk. Instead, the “solution” damaged our overall health, as shown by rising rates of alcoholism, mental illness, depression, suicide and domestic violence under “lockdown” orders. Fear of contracting coronavirus also led individuals to skip necessary medical treatments, including chemotherapy, and even stay home when they were showing signs of a heart attack or stroke.&nbsp;&nbsp;</p><p>CDC and FDA didn&#8217;t protect us – they lied about the advisability of masks and blocked test kits and PPE from being produced. The $2.2 trillion CARES Act provided a pittance to working families and the unemployed, but 90 percent of the “relief” went to big business, government cronies and special interests.</p><p>On the other hand, retailers and local communities stepped in where government failed. They delivered hand sanitizer, personal protective equipment, food and water to those in need. They set special hours to help vulnerable populations access basic staples, and developed new protocols to protect employees. While the pandemic brought out the worst in government, it brought out the best in everyday people.</p><p>When I am president, I will make sure that the federal government does not bungle and worsen a situation like this ever again. We must reduce red tape and regulation so that medicine and treatments, as well as testing, can get to patients at all times, but particularly in the direst of times. As we have seen, days, weeks and months can mean dozens, hundreds and thousands of lives saved or lost.</p><figure class="wp-block-image size-large"><img data-attachment-id="23471" data-permalink="https://philadelphiaweekly.com/do-you-know-jo/convention-jo-3/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?fit=800%2C448&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="800,448" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Convention-Jo-3" data-image-description data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?fit=300%2C168&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?fit=800%2C448&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="800" height="448" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?resize=800%2C448&#038;quality=70&#038;strip=all&#038;ssl=1" alt class="wp-image-23471 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?w=800&amp;quality=70&amp;strip=all&amp;ssl=1 800w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?resize=300%2C168&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?resize=770%2C431&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?resize=625%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 625w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?resize=680%2C381&amp;quality=70&amp;strip=all&amp;ssl=1 680w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?resize=800%2C448&amp;is-pending-load=1#038;quality=70&#038;strip=all&#038;ssl=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg"><noscript><img data-attachment-id="23471" data-permalink="https://philadelphiaweekly.com/do-you-know-jo/convention-jo-3/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?fit=800%2C448&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="800,448" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Convention-Jo-3" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?fit=300%2C168&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?fit=800%2C448&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="800" height="448" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?resize=800%2C448&#038;quality=70&#038;strip=all&#038;ssl=1" alt="" class="wp-image-23471" srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?w=800&amp;quality=70&amp;strip=all&amp;ssl=1 800w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?resize=300%2C168&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?resize=770%2C431&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?resize=625%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 625w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/10/Convention-Jo-3.jpg?resize=680%2C381&amp;quality=70&amp;strip=all&amp;ssl=1 680w" sizes="(max-width: 800px) 100vw, 800px" data-recalc-dims="1" /></noscript><figcaption>Libertarian presidential candidate Jo Jorgensen was in Philly recently on a campaign stop. | Image courtesy: Jorgensen campaign</figcaption></figure><p><strong>Philadelphia recently resolved a months-long standoff with a homeless encampment by providing the protesters with vacant homes. What role should governments play in addressing homelessness?</strong></p><p>The U.S. government has barely made a dent in poverty in the past 50 years despite massive spending on programs to aid the poor. Throwing more money at a problem creates what&#8217;s been called a Homeless Industrial Complex, where bureaucrats, nonprofit executives and city planners siphon off most of the money into salaries and overhead, with little incentive to fix a problem which is providing them a comfortable living.&nbsp;</p><p>Most people who are chronically homeless face some other major barrier: untreated mental illness (including veterans facing PTSD) unresolved immigration status, substance abuse issues, or criminal records. Each of these groups would benefit from the libertarian solutions of the Jorgensen presidency: lower barriers to housing and employment, a more vibrant economy, better access to health care including behavioral health support, more expungements, and less incarceration.</p><p><strong>Philadelphia recently launched seven satellite election offices – with more to come – as kind of one-stop-shopping spots for voters. What are your thoughts on mail-in voting and the voting process in general in 2020?</strong></p><p>While it is the purview of the states to set election rules, I will encourage them to make voting fair and easily accessible for all voters. Voting methods should be transparent and provide a means for voters to ensure their vote was properly counted.&nbsp;</p><p><strong>This summer, President Trump said he would consider sending federal agents to several cities – including Philadelphia – to deal with protesters and unrest. As president, under what circumstances, if any, would you consider sending federal troops into cities?</strong></p><p>President Trump had the legal authority to deploy National Guard troops, ICE, Border Patrol, U.S. Marshals, or other federal agents to control the population of U.S. cities. That authority – illegitimate, but for now, legal – comes from the 2007 and 2008 National Defense Authorization Acts (NDAA), which libertarians opposed, partially because the law treats American citizens as enemy combatants within their own neighborhoods.&nbsp;</p><p>As president, I would not deploy federal troops or law enforcement to any locality or state that hadn&#8217;t specifically asked for help with a situation. Governors and mayors can effectively handle situations on the ground. Ending such over-use of federal agents to harass and terrorize Americans (often “excused” by the War on Drugs or immigration enforcement) has been a centerpiece of my campaign.&nbsp;</p><p><strong>You have called the War on Drugs “racist,” and vowed to end federal civil asset forfeiture prior to conviction and to pardon people convicted of nonviolent, victimless crimes. Why do you think these issues will resonate with voters in 2020?&nbsp;</strong></p><p>The War on Drugs provides a pretense to target and harass the poor and people of color, to violate our civil liberties, ruin lives and corrupt our police and courts. Neither Republicans nor Democrats have the courage to change the status-quo: 74 percent of Americans already believe marijuana should be legal in every state. The War on Drugs has led directly to no-knock raids, Stop and Frisk, civil asset forfeiture abuses, federally sponsored militarization of local police, and other violations of our sacred liberties. Each has disproportionately victimized people of color and devalued their lives.</p><p>On my first day as president, I will pardon the 80,000 people serving federal time for nonviolent drug convictions and send them home to their families. I will dismantle the racist War on Drugs by decriminalizing all substances at the federal level. The Libertarian Party, in its almost 50-year history, has consistently advocated for justice and the rights of individuals. We continue to fight the abusive government policies that perpetuate racism and inequality.</p><p><strong><em>Learn more at jo20.com.&nbsp;</em></strong></p><h5 class="related-posts__title">Related</h5><ul class="related-posts"><li><a href="https://philadelphiaweekly.com/2020-when-conservative-became-alt-in-philly/" rel="bookmark" title="Permanent Link to 2020: When conservative became alt in Philly">2020: When conservative became alt in Philly</a></li><li><a href="https://philadelphiaweekly.com/shot-in-the-dark-a-highly-unconventional-look-at-the-life-of-former-vice-president-dick-cheney/" rel="bookmark" title="Permanent Link to Shot in the dark: A highly unconventional look at the life of former Vice President Dick Cheney">Shot in the dark: A highly unconventional look at the life of former Vice President Dick Cheney</a></li><li><a href="https://philadelphiaweekly.com/coming-up-irish/" rel="bookmark" title="Permanent Link to Coming up Irish">Coming up Irish</a></li><li><a href="https://philadelphiaweekly.com/emilys-had-enough/" rel="bookmark" title="Permanent Link to Emily&#8217;s had &#8216;Enough&#8217;">Emily&#8217;s had &#8216;Enough&#8217;</a></li></ul><ul class="Meta"><li class="Meta-item Meta-item--tags"><ul><li><a href="https://philadelphiaweekly.com/tag/jo-jorgensen/" title=" jo jorgensen ">jo jorgensen</a></li><li><a href="https://philadelphiaweekly.com/tag/philadelphia/" title=" philadelphia ">philadelphia</a></li><li><a href="https://philadelphiaweekly.com/tag/president/" title=" president ">president</a></li><li><a href="https://philadelphiaweekly.com/tag/united-states/" title=" united states ">united states</a></li></ul></li></ul></div></article><ul class="author-article-bio"><li class="author-bio__item"> <a class="author-bio__headshot" href="https://philadelphiaweekly.com/writer/eugene-zenyatta/"><figure><img width="200" height="200" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-headshot size-headshot wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="16719" data-permalink="https://philadelphiaweekly.com/writer/eugene-zenyatta/joe-hernandez-oebdsi0q4f0-unsplash/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="joe-hernandez-OebdsI0Q4F0-unsplash" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 200w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=680%2C680&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=1472%2C1472&amp;quality=70&amp;strip=all&amp;ssl=1 1472w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=1104%2C1104&amp;quality=70&amp;strip=all&amp;ssl=1 1104w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=912%2C912&amp;quality=70&amp;strip=all&amp;ssl=1 912w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=550%2C550&amp;quality=70&amp;strip=all&amp;ssl=1 550w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=470%2C470&amp;quality=70&amp;strip=all&amp;ssl=1 470w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?zoom=2&amp;resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 400w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?zoom=3&amp;resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 600w" data-lazy-sizes="(max-width: 200px) 100vw, 200px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/joe-hernandez-OebdsI0Q4F0-unsplash-scaled.jpg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></figure> </a><div class="author-name__container"> <a class="author-bio__name" href="https://philadelphiaweekly.com/writer/eugene-zenyatta/"><h6>Eugene Zenyatta</h6> </a></div><div class="author-bio__info"><p>Eugene Zenyatta was raised on old-time Memphis 'rasslin' and strongly prefers the company of dogs to people. His greatest heartbreak came in the 2010 Breeders' Cup Classic.</p></div></li></ul></main></div><section class="RelatedPosts"><div class="category-row__bar"><h2 class="category-row__title">Up Next in News</h2></div><ul class="posts-row"><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/keepin-it-real-sdp-fundraising-arm-schools-city-residents-who-benefit-from-tax-abatement/" title="Keepin&#8217; it real: SDP fundraising arm schools city residents who benefit from tax abatement"> <img width="680" height="480" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/ddc93b253e25347b778c3742d4016fe6.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="5797" data-permalink="https://philadelphiaweekly.com/keepin-it-real-sdp-fundraising-arm-schools-city-residents-who-benefit-from-tax-abatement/ddc93b253e25347b778c3742d4016fe6/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/ddc93b253e25347b778c3742d4016fe6.jpg?fit=1280%2C851&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1280,851" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ddc93b253e25347b778c3742d4016fe6" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/ddc93b253e25347b778c3742d4016fe6.jpg?fit=300%2C199&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/ddc93b253e25347b778c3742d4016fe6.jpg?fit=1024%2C681&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/ddc93b253e25347b778c3742d4016fe6.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/keepin-it-real-sdp-fundraising-arm-schools-city-residents-who-benefit-from-tax-abatement/" title="Keepin&#8217; it real: SDP fundraising arm schools city residents who benefit from tax abatement"><h5 class="RecentPosts-title">Keepin&#8217; it real: SDP fundraising arm schools city residents who benefit from tax abatement</h5> </a><div class="posts-teaser"><p>If you can’t beat em’, guilt em’.</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Jan 10, 2019</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/icepack-is-back/" title="Icepack is back!"> <img width="680" height="480" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/12/Icepackpitbull-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Pit bull" loading="lazy" data-attachment-id="14230" data-permalink="https://philadelphiaweekly.com/icepack-is-back/icepackpitbull/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/12/Icepackpitbull-scaled.jpg?fit=2560%2C1696&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1696" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Icepackpitbull" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/12/Icepackpitbull-scaled.jpg?fit=300%2C199&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/12/Icepackpitbull-scaled.jpg?fit=1024%2C678&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/12/Icepackpitbull-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/12/Icepackpitbull-scaled.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/12/Icepackpitbull-scaled.jpg?zoom=3&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 2040w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/12/Icepackpitbull-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/icepack-is-back/" title="Icepack is back!"><h5 class="RecentPosts-title">Icepack is back!</h5> </a><div class="posts-teaser"><p>All the rumor, rants, innuendo, gossip and all-around babble you remember – or don't</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Dec 20, 2019</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/changing-lives/" title="Changing lives"> <img width="680" height="480" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/noel2.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="16307" data-permalink="https://philadelphiaweekly.com/changing-lives/noel2/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/noel2.jpg?fit=1125%2C783&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1125,783" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="noel2" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/noel2.jpg?fit=300%2C209&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/noel2.jpg?fit=1024%2C713&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/02/noel2.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/changing-lives/" title="Changing lives"><h5 class="RecentPosts-title">Changing lives</h5> </a><div class="posts-teaser"><p>Trainer Noel Davis on why you shouldn't play games with your body</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Feb 3, 2020</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/he-is-risen/" title="He is risen"> <img width="680" height="480" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/PJ4-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Michael Grant with arms folded" loading="lazy" data-attachment-id="15717" data-permalink="https://philadelphiaweekly.com/he-is-risen/pj4/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/PJ4-scaled.jpg?fit=2560%2C1762&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1762" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;Canon EOS REBEL T3i&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1577513168&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;27&quot;,&quot;iso&quot;:&quot;200&quot;,&quot;shutter_speed&quot;:&quot;0.02&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="PJ4" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/PJ4-scaled.jpg?fit=300%2C206&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/PJ4-scaled.jpg?fit=1024%2C705&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/PJ4-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/PJ4-scaled.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/PJ4-scaled.jpg?zoom=3&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 2040w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/01/PJ4-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/he-is-risen/" title="He is risen"><h5 class="RecentPosts-title">He is risen</h5> </a><div class="posts-teaser"><p>How real faith helped Philly Jesus beat drug addiction</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Jan 22, 2020</li></ul></footer></li></ul></section><div class="Columns-row columns-even"><div class="Columns-column"><div class="most-popular"><h2>Most Popular This Week</h2><ol class="most-popular-list"><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/opinion/" class="category category-3039">Opinion</a>, <a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/" class="category category-166">Voices of Our City</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/2020-when-conservative-became-alt-in-philly/">2020: When conservative became alt in Philly</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/" class="category category-149">From the Editor</a>, <a href="https://philadelphiaweekly.com/sections/opinion/" class="category category-3039">Opinion</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/you-had-me-at-conservative/">You had me at “conservative”</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/food-festivities-and-all-the-fireworks-planned-for-this-summers-wawa-welcome-america-celebration/">Food, festivities and ALL the fireworks planned for this summer’s Wawa Welcome America celebration</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/" class="category category-93">LGBTQ / Sex</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/voting-while-trans/">Voting while trans</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/arts/" class="category category-88">Arts</a>, <a href="https://philadelphiaweekly.com/sections/lgbtq-sex/" class="category category-93">LGBTQ / Sex</a>, <a href="https://philadelphiaweekly.com/sections/people/" class="category category-91">People</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/queens-of-the-city/">Queens of the city</a></li></ol></div> <a class="Button" href="/popular">More Popular Articles</a></div><div class="Columns-column columns-even__right"><div class="calendar-events-teaser"><h2>Upcoming Philly Events</h2><ul class="calendar-events"><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/boozy-bake-sale-at-sunset-social/"> <time class="calendar-events__date">Fri, Oct 16</time><h6 class="calendar-events__title">Boozy Bake Sale at Sunset Social</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author"></li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/jkyog-free-adult-online-meditation-sessions/2020-10-16/"> <time class="calendar-events__date">Fri, Oct 16</time><h6 class="calendar-events__title">JKYog Free Adult  online Meditation Sessions</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Online</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/hobart-2020-indoor-outdoor-art-show/2020-10-17/"> <time class="calendar-events__date">Sat, Oct 17</time><h6 class="calendar-events__title">HOBART 2020, Indoor/Outdoor Art Show</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Steinbeiser&#8217;s Farm</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/one-africa-one-nation-uhuru-pop-up-marketplace/"> <time class="calendar-events__date">Sat, Oct 17</time><h6 class="calendar-events__title">One Africa! One Nation! Uhuru Pop Up Marketplace</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Uhuru Furniture &amp; Collectibles</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/jkyog-free-adult-online-meditation-sessions/2020-10-17/"> <time class="calendar-events__date">Sat, Oct 17</time><h6 class="calendar-events__title">JKYog Free Adult  online Meditation Sessions</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Online</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/hobart-2020-indoor-outdoor-art-show/2020-10-18/"> <time class="calendar-events__date">Sun, Oct 18</time><h6 class="calendar-events__title">HOBART 2020, Indoor/Outdoor Art Show</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Steinbeiser&#8217;s Farm</li></ul></li></ul> <a class="Button" href="/calendar">More Events</a></div></div></div></div></div></div><footer class="footer"><div class="footer-section footer-section--primary"><div class="footer-container"></div></div><div class="footer-section footer-section--secondary"><div class="footer-container"><div class="footer-inner"><div class="footer-inner__branding"><div class="footer-inner__logo"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_social"><p>Follow @PhillyWeekly</p><ul class="footer-inner__social__list"><li> <a href="https://www.facebook.com/pg/phillyweekly/posts/"> <i class="fa fa-facebook-square" aria-hidden="true"></i> <span>Facebook</span> </a></li><li> <a href="https://twitter.com/PhillyWeekly/"> <i class="fa fa-twitter" aria-hidden="true"></i> <span>Twitter</span> </a></li><li> <a href="https://www.instagram.com/phillyweekly/"> <i class="fa fa-instagram" aria-hidden="true"></i> <span>Instagram</span> </a></li><li> <a href="https://philadelphiaweekly.com/feeds"> <i class="fa fa-rss" aria-hidden="true"></i> <span>Your News Reader</span> </a></li></ul></div></div><nav class="Navigation Navigation--footer"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-133"><a href="#">About PW</a><ul class="sub-menu"><li id="menu-item-334" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334"><a href="https://philadelphiaweekly.com/about/">About Us</a></li><li id="menu-item-386" class="menu-item menu-item-type-post_type_archive menu-item-object-writer menu-item-386"><a href="https://philadelphiaweekly.com/writer/">Our Writers</a></li><li id="menu-item-336" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-336"><a href="/advertising">Advertising &#038; Partnerships</a></li><li id="menu-item-338" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-338"><a href="/events/community/add">Submit an Event</a></li></ul></li><li id="menu-item-134" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-134"><a href="#">Explore PW</a><ul class="sub-menu"><li id="menu-item-228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-228"><a href="https://philadelphiaweekly.com/sections/">Sections</a></li><li id="menu-item-137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-136" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-335"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></li></ul></div></nav><div class="footer-inner_contact-text"><div class="footer-inner__logo--desktop"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_contact"><p>1520 Locust Street, Fifth Floor</p><p>Philadelphia, PA 19102</p></div><div class="footer-inner_contact footer-inner_contact__phone"><p>215-543-3743</p><p><a href="mailto:mail@philadelphiaweekly.com">mail@philadelphiaweekly.com</a></p></div><div class="footer-info"> &copy; Copyright Philadelphia Weekly</div></div></div></div></footer></div> <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script> <script type='text/javascript' id='contact-form-7-js-extra'>var wpcf7 = {"apiSettings":{"root":"https:\/\/philadelphiaweekly.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript' id='wpa-complementary-js-extra'>var wpaComplementary = [""];</script> <script type='text/javascript' id='truro-scripts-js-extra'>var customizer = {"sliderSlideCount":"1","sliderLoop":"0","sliderAutoPlay":"0","sliderAutoPlaySpeed":"7000","sliderArrows":"1","sliderDots":"1"};</script> <script type='text/javascript' id='jetpack-carousel-js-extra'>var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/philadelphiaweekly.com\/wp-admin\/admin-ajax.php","nonce":"bfbd8b490a","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/philadelphiaweekly.com\/wp-login.php?redirect_to=https%3A%2F%2Fphiladelphiaweekly.com%2Fdo-you-know-jo%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};</script> <link rel="stylesheet" href="https://use.typekit.net/cgg8jik.css"> <script defer src="https://philadelphiaweekly.com/wp-content/cache/autoptimize/js/autoptimize_be48861ee3498efd076950f8750547b4.js"></script></body></html>