<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="stylesheet" media="print" onload="this.onload=null;this.media='all';" id="ao_optimized_gfonts" href="https://fonts.googleapis.com/css?family=Lora%3A400%2C400i%2C700%7CLora%3A400%2C700%2Cbold%2Cregular&amp;display=swap" /><link rel="profile" href="http://gmpg.org/xfn/11"><meta property="fb:pages" content="23117126720" /><link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png"><link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png"><link rel="manifest" href="/site.webmanifest"><link rel="mask-icon" href="/safari-pinned-tab.svg" color="#ffc414"><meta name="msapplication-TileColor" content="#231f20"><meta name="theme-color" content="#231f20"> <style type="text/css">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</style><meta name='robots' content='max-image-preview:large' /><link rel="stylesheet" media="print" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_721734f108c5129c27a605a8d2301ce8.css" onload="this.onload=null;this.media='all';" /><noscript id="aonoscrcss"><link media="all" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_721734f108c5129c27a605a8d2301ce8.css" rel="stylesheet" /></noscript><title>Arts and money - Philadelphia Weekly</title><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://philadelphiaweekly.com/arts-and-money/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Arts and money - Philadelphia Weekly" /><meta property="og:description" content="Proposed city budget another blow to arts community" /><meta property="og:url" content="https://philadelphiaweekly.com/arts-and-money/" /><meta property="og:site_name" content="Philadelphia Weekly" /><meta property="article:publisher" content="https://www.facebook.com/phillyweekly/" /><meta property="article:published_time" content="2021-06-10T14:02:14+00:00" /><meta property="article:modified_time" content="2021-06-10T14:02:17+00:00" /><meta property="og:image" content="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Philadelphia-city-budget-scaled.jpg?fit=2560%2C1707&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta property="og:image:width" content="2560" /><meta property="og:image:height" content="1707" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@phillyweekly" /><meta name="twitter:site" content="@phillyweekly" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://philadelphiaweekly.com/#organization","name":"Philadelphia Weekly","url":"https://philadelphiaweekly.com/","sameAs":["https://www.facebook.com/phillyweekly/","https://www.instagram.com/phillyweekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://twitter.com/phillyweekly"],"logo":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#logo","inLanguage":"en-US","url":"https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&quality=70&strip=all&ssl=1","width":500,"height":500,"caption":"Philadelphia Weekly"},"image":{"@id":"https://philadelphiaweekly.com/#logo"}},{"@type":"WebSite","@id":"https://philadelphiaweekly.com/#website","url":"https://philadelphiaweekly.com/","name":"Philadelphia Weekly","description":"","publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://philadelphiaweekly.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/arts-and-money/#primaryimage","inLanguage":"en-US","url":"https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Philadelphia-city-budget-scaled.jpg?fit=2560%2C1707&quality=70&strip=all&ssl=1","width":2560,"height":1707},{"@type":"WebPage","@id":"https://philadelphiaweekly.com/arts-and-money/#webpage","url":"https://philadelphiaweekly.com/arts-and-money/","name":"Arts and money - Philadelphia Weekly","isPartOf":{"@id":"https://philadelphiaweekly.com/#website"},"primaryImageOfPage":{"@id":"https://philadelphiaweekly.com/arts-and-money/#primaryimage"},"datePublished":"2021-06-10T14:02:14+00:00","dateModified":"2021-06-10T14:02:17+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://philadelphiaweekly.com/arts-and-money/"]}]},{"@type":"Article","@id":"https://philadelphiaweekly.com/arts-and-money/#article","isPartOf":{"@id":"https://philadelphiaweekly.com/arts-and-money/#webpage"},"author":{"@id":"https://philadelphiaweekly.com/#/schema/person/6d10bb5ac4140a42ca14aa4e8065e28d"},"headline":"Arts and money","datePublished":"2021-06-10T14:02:14+00:00","dateModified":"2021-06-10T14:02:17+00:00","mainEntityOfPage":{"@id":"https://philadelphiaweekly.com/arts-and-money/#webpage"},"publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"image":{"@id":"https://philadelphiaweekly.com/arts-and-money/#primaryimage"},"keywords":"city budget","articleSection":"Opinion","inLanguage":"en-US"},{"@type":"Person","@id":"https://philadelphiaweekly.com/#/schema/person/6d10bb5ac4140a42ca14aa4e8065e28d","name":"Philly Editor","image":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/a2af5953cb6b5d09567512df874c23dd?s=96&d=mm&r=g","caption":"Philly Editor"}}]}</script> <link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//c0.wp.com' /><link rel='dns-prefetch' href='//i0.wp.com' /><link rel='dns-prefetch' href='//i1.wp.com' /><link rel='dns-prefetch' href='//i2.wp.com' /><link href='https://use.typekit.net' rel='preconnect' /><link href='https://www.google-analytics.com' rel='preconnect' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Feed" href="https://philadelphiaweekly.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Comments Feed" href="https://philadelphiaweekly.com/comments/feed/" /><link rel="alternate" type="text/calendar" title="Philadelphia Weekly &raquo; iCal Feed" href="https://philadelphiaweekly.com/events/?ical=1" /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify;}</style> <script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/plugins/jquery-manager/assets/js/jquery-3.5.1.min.js' id='jquery-core-js'></script> <script type='text/javascript' src='https://philadelphiaweekly.com/wp-content/plugins/jquery-manager/assets/js/jquery-migrate-3.3.0.min.js' id='jquery-migrate-js'></script> <script type='application/json' id='wpp-json'>{"sampling_active":0,"sampling_rate":50,"ajax_url":"https:\/\/philadelphiaweekly.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":30338,"token":"63d55a8ecd","lang":0,"debug":0}</script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-700394-5' id='google_gtagjs-js' async></script> <script type='text/javascript' id='google_gtagjs-js-after'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["philadelphiaweekly.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-700394-5", {"anonymize_ip":true});</script> <link rel="https://api.w.org/" href="https://philadelphiaweekly.com/wp-json/" /><link rel="alternate" type="application/json" href="https://philadelphiaweekly.com/wp-json/wp/v2/posts/30338" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://philadelphiaweekly.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://philadelphiaweekly.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.7.2" /><link rel='shortlink' href='https://philadelphiaweekly.com/?p=30338' /><link rel="alternate" type="application/json+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Farts-and-money%2F" /><link rel="alternate" type="text/xml+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2Farts-and-money%2F&#038;format=xml" />  <script>"use strict";

!function() {
  var t = window.driftt = window.drift = window.driftt || [];
  if (!t.init) {
    if (t.invoked) return void (window.console && console.error && console.error("Drift snippet included twice."));
    t.invoked = !0, t.methods = [ "identify", "config", "track", "reset", "debug", "show", "ping", "page", "hide", "off", "on" ], 
    t.factory = function(e) {
      return function() {
        var n = Array.prototype.slice.call(arguments);
        return n.unshift(e), t.push(n), t;
      };
    }, t.methods.forEach(function(e) {
      t[e] = t.factory(e);
    }), t.load = function(t) {
      var e = 3e5, n = Math.ceil(new Date() / e) * e, o = document.createElement("script");
      o.type = "text/javascript", o.async = !0, o.crossorigin = "anonymous", o.src = "https://js.driftt.com/include/" + n + "/" + t + ".js";
      var i = document.getElementsByTagName("script")[0];
      i.parentNode.insertBefore(o, i);
    };
  }
}();
drift.SNIPPET_VERSION = '0.3.1';
drift.load('rk5uegyicbzi');</script> <meta name="generator" content="Site Kit by Google 1.31.0" /><script type="text/javascript">window.MemberfulOptions = {
    site: "https://philadelphiaweekly.memberful.com",
    intercept: [
            "http://philadelphiaweekly.com/?memberful_endpoint=auth",
            "https://philadelphiaweekly.com/?memberful_endpoint=auth",
            "http://philadelphiaweekly.com?memberful_endpoint=auth",
            "https://philadelphiaweekly.com?memberful_endpoint=auth",
          ],
    memberSignedIn: false  };

  (function() {
    var s = document.createElement('script');
    s.type = 'text/javascript';
    s.async = true;
    s.src = 'https://d35xxde4fgg0cx.cloudfront.net/assets/embedded.js';

    setup = function() { window.MemberfulEmbedded.setup(); };

    s.addEventListener("load", setup, false);

    ( document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0] ).appendChild( s );
  })();</script> <meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://philadelphiaweekly.com"><link rel="https://theeventscalendar.com/" href="https://philadelphiaweekly.com/wp-json/tribe/events/v1/" /><style>@-webkit-keyframes bgslide {
                from {
                    background-position-x: 0;
                }
                to {
                    background-position-x: -200%;
                }
            }

            @keyframes bgslide {
                    from {
                        background-position-x: 0;
                    }
                    to {
                        background-position-x: -200%;
                    }
            }

            .wpp-widget-placeholder {
                margin: 0 auto;
                width: 60px;
                height: 3px;
                background: #dd3737;
                background: -webkit-gradient(linear, left top, right top, from(#dd3737), color-stop(10%, #571313), to(#dd3737));
                background: linear-gradient(90deg, #dd3737 0%, #571313 10%, #dd3737 100%);
                background-size: 200% auto;
                border-radius: 3px;
                -webkit-animation: bgslide 1s infinite linear;
                animation: bgslide 1s infinite linear;
            }</style><style type="text/css">.header{background-color: #0a0a0a;}.header .SearchForm-button{color: #ffffff;}.Navigation--primary{color: #ffffff;}</style><style type="text/css">/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}</style> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link rel="amphtml" href="https://philadelphiaweekly.com/arts-and-money/amp/"><link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=32%2C21&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=192%2C128&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=180%2C120&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=270%2C180&#038;quality=70&#038;strip=all&#038;ssl=1" /> <script>window.dataLayer = window.dataLayer || [];
	  function gtag(){dataLayer.push(arguments);}
	  gtag('js', new Date());

	  gtag('config', 'UA-700394-5');</script> </head><body class="post-template-default single single-post postid-30338 single-format-standard tribe-no-js tribe-theme-parent-truro tribe-theme-child-truro-pw-child"> <a class="skip-link screen-reader-text" href="#Content">Skip to content</a><header class="header header--four"><div class="header-section header-section--primary"><div class="header-container"><div class="header-sectionInner"><div class="header-part"><div class="Branding"> <a href="https://philadelphiaweekly.com/" rel="home"> <img class="Branding-logo" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/PW-weekly-white-horizontal-1-1.svg" alt="Philadelphia Weekly" width="200px" /> </a></div></div><div class="header-part header-part__navigation"><nav class="Navigation Navigation--primary"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation" class="menu"><li id="menu-item-227" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li id="menu-item-221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li id="menu-item-188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li id="menu-item-191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li id="menu-item-192" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li id="menu-item-193" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li id="menu-item-194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li id="menu-item-7201" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li id="menu-item-195" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li id="menu-item-222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li id="menu-item-27615" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27615"><a href="https://philadelphiaweekly.com/sections/altphilly/">AltPhilly</a></li><li id="menu-item-518" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li id="menu-item-375" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li id="menu-item-377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li id="menu-item-385" class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li id="menu-item-384" class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li id="menu-item-543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-128" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></nav><div class="utility-navigation"><nav class="Navigation Navigation--utility"><div class="menu-utility-navigation-container"><ul id="menu-utility-navigation" class="menu"><li id="menu-item-27636" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27636"><a href="https://philadelphiaweekly.com/join/">Join</a></li><li id="menu-item-132" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-132"><a href="https://philadelphiaweekly.com/?memberful_endpoint=auth"><span>Sign In</span></a></li></ul></div></nav><form class="SearchForm SearchForm--header" method="get" action="https://philadelphiaweekly.com/"> <span class="screen-reader-text">Search for:</span> <input class="SearchForm-field" type="text" placeholder="Type &amp; press enter" value="" name="s" title="Search for:" /> <button type="submit" class="screen-reader-text" aria-label="Search">Search</button> <button class="SearchForm-button" aria-label="Submit"><i class="fa fa-search" aria-hidden="true"></i></button></form></div></div></div></div></div></header><nav class="Navigation Navigation--mobile"><div class="container"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27615"><a href="https://philadelphiaweekly.com/sections/altphilly/">AltPhilly</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></div></nav><div class="content content--fullWidth" id="content"><div class="content-inner"><div class="content-container"><div class="header-promotional-message"><div class="header-promotional-message__inner"><div class="header-promotional-message__graphic"> <img src="/wp-content/themes/truro-pw-child/ui/hand-graphic.jpg" alt="Pointing Hand" /></div><div class="header-promotional-message__content"> Join the altPhilly membership program for exclusive content and awesome perks. <a class="header-promotional-message__link" href="https://philadelphiaweekly.com/join/"
 target="_self">Become a Member</a></div></div></div><div class="content-row content-row--article"><main class="content-main"><header class="article-header"><div class="meta-tags"> <span class="Meta-item"><li class="Meta-item Meta-item--categories"><ul class="Meta Meta--banner"><li class="Meta-item Meta-item--categories"><ul><li><a href="https://philadelphiaweekly.com/sections/opinion/" title="Opinion">Opinion</a></li></ul></li></ul></li> </span></div><h1>Arts and money</h1><div class="posts-teaser"><p>Proposed city budget another blow to arts community</p></div><footer class="Post-footer"><ul class="Meta Meta--article"><li class="Meta-item Meta-item--author"> <a class="meta-author-article" href="https://philadelphiaweekly.com/writer/a-d-amorosi/"><figure class="meta-author-headshot"><img width="100" height="100" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/mGlBxQ_A_400x400.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-headshot size-headshot wp-post-image jetpack-lazy-image" alt="A.D. Amarosi&#039;s Headshot" loading="lazy" data-attachment-id="199" data-permalink="https://philadelphiaweekly.com/writer/a-d-amorosi/mglbxq_a_400x400/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/mGlBxQ_A_400x400.png?fit=400%2C400&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="400,400" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="mGlBxQ_A_400x400" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/mGlBxQ_A_400x400.png?fit=300%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/mGlBxQ_A_400x400.png?fit=400%2C400&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/mGlBxQ_A_400x400.png?w=400&amp;quality=70&amp;strip=all&amp;ssl=1 400w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/mGlBxQ_A_400x400.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/mGlBxQ_A_400x400.png?resize=300%2C300&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/mGlBxQ_A_400x400.png?resize=350%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 350w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/mGlBxQ_A_400x400.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></figure> <span class="meta-author-name">A.D. Amorosi</span></a></li><li class="Meta-item Meta-item--date">June 10th, 2021</li></ul><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/arts-and-money/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20Arts and money%20-%20https://philadelphiaweekly.com/arts-and-money/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20Arts and money%20-%20https://philadelphiaweekly.com/arts-and-money/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: Arts and money%20https://philadelphiaweekly.com/arts-and-money/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></footer></header><header class="Post-header"><figure class="Post-thumbnail"> <a data-fancybox="gallery" data-caption=""
 href="https://philadelphiaweekly.com/wp-content/uploads/2021/06/Philadelphia-city-budget-scaled.jpg"><img width="1200" height="675" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Philadelphia-city-budget-scaled.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-feature-image size-feature-image wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="30339" data-permalink="https://philadelphiaweekly.com/arts-and-money/philadelphia-city-budget/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Philadelphia-city-budget-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Philadelphia city budget" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Philadelphia-city-budget-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Philadelphia-city-budget-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Philadelphia-city-budget-scaled.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1 1200w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Philadelphia-city-budget-scaled.jpg?zoom=2&amp;resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1 2400w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Philadelphia-city-budget-scaled.jpg?resize=1200%2C675&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></a></figure></header><div class="sharing-desktop"><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/arts-and-money/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%20Arts and money%20-%20https://philadelphiaweekly.com/arts-and-money/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%20Arts and money%20-%20https://philadelphiaweekly.com/arts-and-money/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: Arts and money%20https://philadelphiaweekly.com/arts-and-money/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></div><article id="Post-30338" class="Post Post--single post-30338 post type-post status-publish format-standard has-post-thumbnail hentry category-opinion tag-city-budget"><div class="Post-content"><h4>Hey, Philly. How’s your quality of life, that special, increasingly unusual, soon-to-be unattainable thing where you can exist without being jostled if you so desire and not-so-neighborly people don’t get to pee on your doorstep at will?&nbsp;</h4><p>I ask because after the city smartly and correctly slowed down racist stop-and-frisk practices, a three-month pilot program in Northwest Philly ordered by a federal judge furthered that wise cause, weirdly, seconded that emotion, and made it so police can no longer stop people from urinating in public as of Aug. 1. (Why Aug. 1 and why, singularly Philly’s Northwest corridor is as arbitrary as it is ridiculous.) Funny thing is, most of the court orders sound solid – why should a cop stop you from smoking dope or holding open liquor containers on the street like they allow in New Orleans? People are high and drunk all the time. Why not make it convenient? The peeing thing though, that riles me probably even more than the gear-grinding roar of a thousand ATVs barreling down Broad Street, and the fact that all the Philly cops are allowed to do when confronting a racehorse-like pee-er is say, “move along,” as if we are eternally grumpy old neighbors stuck in a comic strip like Mr. Wilson or Marty Burns. (Expect flashy, hand-crafted “Move along” T-shirts to hit Etsy by the time this column goes online.)&nbsp;</p><p>Considering that most of Philly, from downtown to uptown, smells like a million Porta Potties after their habitues have eaten raw asparagus and drunk red wine vinegar during the already sweltering 90-degree heat of June’s mid-spring, I was really hoping they could keep the always-active, live-streaming, lyrical-flowing street urination in Philly to a minimum. And so, I’m pissed.&nbsp;</p><p><strong>Fireworks advertising</strong>&nbsp;</p><p>And speaking of exploiting the most annoying quality of life issues for political or financial gain: the Washington Avenue billboard for Philly Fireworks. Like the old Chris Rock joke about crack sales (“Drug dealers don&#8217;t sell drugs. Drugs sell themselves. It&#8217;s crack. It&#8217;s not an encyclopedia”), firecracker users need no provoking or advertising. Stupid nuisance and the rush of low expectation sells itself.&nbsp;&nbsp;</p><p><strong>Arts funding</strong></p><p>Arts in Philly. Moving beyond COVID and quarantines, you’re still fucked. Since this mayor can only have one good thing on his budget agenda at a time, this session finds Kenney proposing a budget with only $10 million in cultural spending for the next fiscal year – famously including just $2 million for the Philadelphia Cultural Fund, $2.1 million for the Mural Arts Program, $2.04 million for the Philadelphia Museum of Art, $500,000 for the African American Museum, $470,407 for the Office of Arts, Culture, and the Creative Economy and certainly some cold hard cash in a black leather Tom Ford valise for Jay-Z for bringing Made in America to Philly just because Hova asked, and why not? Anyway, the $2 mil for Philadelphia Cultural Fund is an insult. Like bringing only $50 to Steak 48 while wearing a tube top insulting. We know David Oh, at-large member of City Council and the chair of Council’s Committee on Global Opportunities and the Creative/Innovative Economy wants Kenney to tuck into its still unused $1.4 billion of federal stimulus cash for at least $45 million of a total arts bailout, and is proposing as much this week. Bravo. Now let’s see how far that conversation gets.</p><p><strong>Crime of the week</strong>&nbsp;&nbsp;</p><p>Crime o’ the week: the verrrrrrry slow-moving carjacking of a DiBruno’s customer at its homespun Italian Market cheese salon on Sunday by two guys looking for more than rare capicola. Considering that Ninth Street on a Sunday is a crowded mess, balanced against a block filled with vendors, customers and burning barrels, and that the jacked car couldn’t have moved more than two miles an hour, it’s a weird one. That said, maybe the Italian Market Business Association will bring back the private rifle toting armed guards that it did in 2020 between COVID quarantine and spring’s boarded up protests.&nbsp;</p><p><strong>Philly in NYC</strong></p><p>Expect Philly’s Geoff Gordon to be part of the August NYC in Central Park “welcome back” to live everything in celebration of that city’s reopening. Music biz producer and executive Clive Davis will help organize the talent, (eight “iconic” stars performing a three-hour show for 60,000 attendees and a worldwide television viewership) and Gordon’s East Coast division of Live Nation will run the entire game, tentative for Aug. 21, according to the New York Times. Mayor de Blasio is part of this too, but fuck him. He’s worse than Kenney.</p><p><strong>The mundane is fun?</strong></p><p>Headline of the week:&nbsp; “The mundane is fun again with reopening,” went the Inquirer on Sunday, before going on to tout Celine Dion’s “It’s All Coming Back to Me Now” and Wrigley’s gum commercials. Odd time warp, that. Plus, the “mundane” is never ever “fun,” unless one’s tedium always includes popping Molly, riding unicycles without pants and listening to old Nicki Minaj mixtapes, loud. Then again, if Celine Dion and Wrigley’s gum commercials from 1974 are your thing, maybe…….</p><p>‘Summer of Soul’</p><p>A pre-recorded talkback with first-time film director, top Sundance documentary seller of all time (plus the 2021 winner of both the Grand Jury Prize and Audience Award at this year’s film fest) and Philadelphia native Ahmir-Khalib Thompson is the totally cool kick off to this year’s PFF SpringFest with Quest’s “Summer of Soul” being the opening night film, June 11, at the PFS Bourse Theater. Having already viewed Questlove’s look at old footage from 1969’s Harlem Cultural Festival in all its Black glory, it’s a stunning piece of history, culturally and cinematically.</p><figure class="wp-block-image size-large"><img data-attachment-id="30340" data-permalink="https://philadelphiaweekly.com/arts-and-money/icemask-17/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?fit=1920%2C2560&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1920,2560" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;2&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;iPhone 12 Pro&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1622913291&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;6&quot;,&quot;iso&quot;:&quot;400&quot;,&quot;shutter_speed&quot;:&quot;0.033333333333333&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Icemask" data-image-description data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?fit=225%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?fit=768%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="768" height="1024" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask.jpg?resize=768%2C1024&#038;quality=70&#038;strip=all&#038;ssl=1" alt class="wp-image-30340 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?resize=768%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1 768w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?resize=225%2C300&amp;quality=70&amp;strip=all&amp;ssl=1 225w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?resize=770%2C1027&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?resize=1152%2C1536&amp;quality=70&amp;strip=all&amp;ssl=1 1152w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?resize=1536%2C2048&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?resize=263%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 263w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?resize=1240%2C1653&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?resize=680%2C907&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?w=1920&amp;quality=70&amp;strip=all&amp;ssl=1 1920w" data-lazy-sizes="(max-width: 768px) 100vw, 768px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask.jpg?resize=768%2C1024&amp;is-pending-load=1#038;quality=70&#038;strip=all&#038;ssl=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg"><noscript><img data-attachment-id="30340" data-permalink="https://philadelphiaweekly.com/arts-and-money/icemask-17/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?fit=1920%2C2560&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1920,2560" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;2&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;iPhone 12 Pro&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1622913291&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;6&quot;,&quot;iso&quot;:&quot;400&quot;,&quot;shutter_speed&quot;:&quot;0.033333333333333&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Icemask" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?fit=225%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?fit=768%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1" loading="lazy" width="768" height="1024" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask.jpg?resize=768%2C1024&#038;quality=70&#038;strip=all&#038;ssl=1" alt="" class="wp-image-30340" srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?resize=768%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1 768w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?resize=225%2C300&amp;quality=70&amp;strip=all&amp;ssl=1 225w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?resize=770%2C1027&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?resize=1152%2C1536&amp;quality=70&amp;strip=all&amp;ssl=1 1152w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?resize=1536%2C2048&amp;quality=70&amp;strip=all&amp;ssl=1 1536w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?resize=263%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 263w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?resize=1240%2C1653&amp;quality=70&amp;strip=all&amp;ssl=1 1240w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?resize=680%2C907&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2021/06/Icemask-scaled.jpg?w=1920&amp;quality=70&amp;strip=all&amp;ssl=1 1920w" sizes="(max-width: 768px) 100vw, 768px" data-recalc-dims="1" /></noscript><figcaption>Image | Courtesy of Christopher Kearse</figcaption></figure><p><strong>Masked Philly: Christopher Kearse</strong></p><p>In Icepack’s continuing saga of asking mask-donning local celebrities what they’ve been up to, beyond the pale, during C-19 – from lockdown to the current, heightened reopening and still-evolving unmasking – I reached out this week to Christopher Kearse. Famously, Kearse is the chef-owner and heavy metal head behind the intimate, molecular gastronomical palace, Will BYOB, which commenced the East Passyunk Avenue Restaurant Renaissance 20 years ago, THEN revived Old City 2.0 with his hearty, sensuous Franco-inspired Forsythia dining-and-drinking boite on Chestnut at 2<sup>nd</sup>.</p><p>Sure, Kearse and Forsythia got hit hard with the pandemic’s quarantines, so Chef Chris found himself developing and re-developing in so many ways: an already jacked fitness lover, Kearse simply got more pumped. With no less than 44 tattoos in a pre-COVID mode, Kearse got new ink in new places. His motorcycle – he loves that bike as much as he does his 98 house plants, and 700 cookbooks.&nbsp; “I repotted all of my house plants, learned how to work on my motorcycle, figured out how to play the entire Black Album by Metallica on guitar, and got to hang out in New York City quite a bit,” says Kearse.&nbsp;&nbsp;</p><p>It is, however, on a more existential level that Kearse existed through the pandemic; “not a sense of abandonment; but a more cerebral reassessment of priorities and what’s worth spending time and headspace on. Pursuit of excellence? Always. Carving a unique culinary space? Absolutely. But reassessment is more about finding life balance and finding peace in well-being than fast bikes and ink. More Zen than abandon. I had a lot of time to reevaluate my life and myself in general. I learned to truly love myself and appreciate my strengths and accept my shortcomings. I felt like life and the world in general was moving way too fast to stop and smell those roses. Then I asked myself, do these roses even smell so good? I’ve been working in the industry for 22 years now and it’s the first time I had this much down time.”</p><p>With all that, Kearse was not about to sweat the mask.&nbsp;</p><p>“Life’s hard enough, so I didn’t try to make a big deal about the mask. It was just a temporary annoyance, and sometimes a discomfort. But I have other things to really worry about, ya know? Working out while wearing a mask was challenging at first, but I’d rather have to wear one than not have gyms open.”&nbsp;</p><p>BRAVO. Feel the burn.</p><p>As for Forsythia, Chef Kearse and the revival of normalcy and new culinary seasons a la spring and summer 2021, Chris will get a fine chance to expand the menu, and have fresh French adventures.</p><p>“A frosé machine is being talked about by Jen (Forsythia’s general manager) and Tomas (Forsythia’s lead bartender). I’m really looking forward to bringing back more canapés (my favorite part of the menu, fun tapas-style dishes, how I like to eat). We’re also looking forward to the return of happy hour.”</p><p>I’m personally looking forward to his foie gras and hearing him play Metallica back-to-front, but that’s another story.</p><p>@ADAMOROSI</p><div class="article-promotional-message"><p>If you read this story and liked it, consider joining altPhilly, our membership program that offers exclusive content, instant access to the editor and awesome perks for like-minded Philadelphians. At PW, our coverage goes against the grain of the local mainstream media.</p> <a class="Button Button-subscribe" href="https://philadelphiaweekly.memberful.com/checkout?plan=62041"
 target="_self">Join altPhilly Now</a><div class="article-promotional-message__secondary__container"> <a class="article-promotional-message__secondary" href="https://philadelphiaweekly.com/join/"
 target="_self">Learn More</a></div></div><ul class="Meta"><li class="Meta-item Meta-item--tags"><ul><li><a href="https://philadelphiaweekly.com/tag/city-budget/" title=" city budget ">city budget</a></li></ul></li></ul></div></article><ul class="author-article-bio"><li class="author-bio__item"> <a class="author-bio__headshot" href="https://philadelphiaweekly.com/writer/a-d-amorosi/"><figure><img width="100" height="100" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/mGlBxQ_A_400x400.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-headshot size-headshot wp-post-image jetpack-lazy-image" alt="A.D. Amarosi&#039;s Headshot" loading="lazy" data-attachment-id="199" data-permalink="https://philadelphiaweekly.com/writer/a-d-amorosi/mglbxq_a_400x400/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/mGlBxQ_A_400x400.png?fit=400%2C400&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="400,400" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="mGlBxQ_A_400x400" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/mGlBxQ_A_400x400.png?fit=300%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/mGlBxQ_A_400x400.png?fit=400%2C400&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/mGlBxQ_A_400x400.png?w=400&amp;quality=70&amp;strip=all&amp;ssl=1 400w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/mGlBxQ_A_400x400.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/mGlBxQ_A_400x400.png?resize=300%2C300&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/mGlBxQ_A_400x400.png?resize=350%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 350w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/09/mGlBxQ_A_400x400.png?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></figure> </a><div class="author-name__container"> <a class="author-bio__name" href="https://philadelphiaweekly.com/writer/a-d-amorosi/"><h6>A.D. Amorosi</h6> </a><ul class="author-bio__social"><li class="author-bio__social__item"> <a href="https://www.twitter.com/adamorosi"> <i class="author-bio__social__icon fa fa-twitter"
 aria-hidden="true"></i><div class="author-bio__social__handle">@adamorosi</div> </a></li></ul></div><div class="author-bio__info"><p>A.D. Amorosi is a Philadelphia-based journalist who, along with Philadelphia Weekly, writes for numerous local, national and international publications including Variety and the Philadelphia Inquirer.</p></div></li></ul></main></div><section class="RelatedPosts"><div class="category-row__bar"><h2 class="category-row__title">Up Next in Opinion</h2></div><ul class="posts-row"><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/voices-sept-10-17/" title="Voices | Sept. 10-17"> <img width="680" height="480" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Shoutout-2-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Marijuana" loading="lazy" data-attachment-id="22615" data-permalink="https://philadelphiaweekly.com/voices-sept-10-17/shoutout-2-3/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Shoutout-2-scaled.jpg?fit=2560%2C1707&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1707" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Shoutout (2)" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Shoutout-2-scaled.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Shoutout-2-scaled.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Shoutout-2-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Shoutout-2-scaled.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Shoutout-2-scaled.jpg?zoom=3&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 2040w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/09/Shoutout-2-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/voices-sept-10-17/" title="Voices | Sept. 10-17"><h5 class="RecentPosts-title">Voices | Sept. 10-17</h5> </a><div class="posts-teaser"><p>Reactions, rants and other random musings from you, our readers</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Sep 10, 2020</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/covids-gonna-covid/" title="COVID&#8217;s gonna COVID, y&#8217;all"> <img width="680" height="480" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/11/Column-11-19-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Covid mask wearer" loading="lazy" data-attachment-id="24234" data-permalink="https://philadelphiaweekly.com/covids-gonna-covid/column-11-19/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/11/Column-11-19-scaled.jpg?fit=2560%2C1896&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1896" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Column 11-19" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/11/Column-11-19-scaled.jpg?fit=300%2C222&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/11/Column-11-19-scaled.jpg?fit=1024%2C758&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/11/Column-11-19-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/11/Column-11-19-scaled.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/11/Column-11-19-scaled.jpg?zoom=3&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 2040w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/11/Column-11-19-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/covids-gonna-covid/" title="COVID&#8217;s gonna COVID, y&#8217;all"><h5 class="RecentPosts-title">COVID&#8217;s gonna COVID, y&#8217;all</h5> </a><div class="posts-teaser"><p>Philadelphia, maybe it's time we learn to live with it?</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Nov 19, 2020</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/seeing-both-sides/" title="Seeing both sides"> <img width="680" height="480" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-20-at-2.12.46-PM.png?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Protest" loading="lazy" data-attachment-id="19477" data-permalink="https://philadelphiaweekly.com/seeing-both-sides/screen-shot-2020-04-20-at-2-12-46-pm/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-20-at-2.12.46-PM.png?fit=1439%2C802&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1439,802" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screen Shot 2020-04-20 at 2.12.46 PM" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-20-at-2.12.46-PM.png?fit=300%2C167&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-20-at-2.12.46-PM.png?fit=1024%2C571&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-20-at-2.12.46-PM.png?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-20-at-2.12.46-PM.png?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-20-at-2.12.46-PM.png?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/seeing-both-sides/" title="Seeing both sides"><h5 class="RecentPosts-title">Seeing both sides</h5> </a><div class="posts-teaser"><p>It's easy to ridicule those who protest COVID-19 restrictions, but is there some merit?</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Apr 22, 2020</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/crime-beat-dec-3-10/" title="Crime Beat | Dec. 3-10"> <img width="680" height="480" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/12/Mafia-image-Susana-O-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="telephone booth" loading="lazy" data-attachment-id="24590" data-permalink="https://philadelphiaweekly.com/crime-beat-dec-3-10/mafia-image-susana-o/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/12/Mafia-image-Susana-O-scaled.jpg?fit=2560%2C1536&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2560,1536" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Mafia image-Susana O" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/12/Mafia-image-Susana-O-scaled.jpg?fit=300%2C180&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/12/Mafia-image-Susana-O-scaled.jpg?fit=1024%2C614&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/12/Mafia-image-Susana-O-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/12/Mafia-image-Susana-O-scaled.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/12/Mafia-image-Susana-O-scaled.jpg?zoom=3&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 2040w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/12/Mafia-image-Susana-O-scaled.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/crime-beat-dec-3-10/" title="Crime Beat | Dec. 3-10"><h5 class="RecentPosts-title">Crime Beat | Dec. 3-10</h5> </a><div class="posts-teaser"><p>The Feds’ takedown of the South Philly mob</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Dec 3, 2020</li></ul></footer></li></ul></section><div class="Columns-row columns-even"><div class="Columns-column"><div class="most-popular"><h2>Most Popular This Week</h2><ol class="most-popular-list"><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="wpp-taxonomy category category-92">News</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/food-festivities-and-all-the-fireworks-planned-for-this-summers-wawa-welcome-america-celebration/">Food, festivities and ALL the fireworks planned for this summer’s Wawa Welcome America celebration</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/interests/" class="wpp-taxonomy category category-4892">Interests</a>, <a href="https://philadelphiaweekly.com/sections/news/" class="wpp-taxonomy category category-92">News</a>, <a href="https://philadelphiaweekly.com/sections/opinion/" class="wpp-taxonomy category category-3039">Opinion</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/national-progressives-are-watching-phillys-d-a-race/">National progressives are watching Philly’s D.A. race</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/opinion/" class="wpp-taxonomy category category-3039">Opinion</a>, <a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/" class="wpp-taxonomy category category-166">Voices of Our City</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/voices-may-13-20/">Voices | May 13-20</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/" class="wpp-taxonomy category category-149">From the Editor</a>, <a href="https://philadelphiaweekly.com/sections/opinion/" class="wpp-taxonomy category category-3039">Opinion</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/i-gotta-go-but-ill-miss-raising-hell-at-pw/">I gotta go, but I’ll miss raising hell at PW</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/" class="wpp-taxonomy category category-93">LGBTQ / Sex</a>, <a href="https://philadelphiaweekly.com/sections/featured-sections/sex-with-timaree-featured-sections/" class="wpp-taxonomy category category-13117">Sex with Timaree</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/will-philly-be-next-to-decriminalize-sex-work/">Will Philly be next to decriminalize sex work?</a></li></ol></div> <a class="Button" href="/popular">More Popular Articles</a></div><div class="Columns-column columns-even__right"><div class="calendar-events-teaser"><h2>Upcoming Philly Events</h2><ul class="calendar-events"><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/stroll-the-street-pop-up/2021-06-10/"> <time class="calendar-events__date">Thu, Jun 10</time><h6 class="calendar-events__title">Stroll the Street Pop-up</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Main Street, Manayunk</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/eventide/2021-06-11/"> <time class="calendar-events__date">Fri, Jun 11</time><h6 class="calendar-events__title">Eventide</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">FringeArts</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/historic-bethlehem-museums-sites-garden-tour/"> <time class="calendar-events__date">Sat, Jun 12</time><h6 class="calendar-events__title">Historic Bethlehem Museums &amp; Sites Garden Tour</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Kemerer Museum of Decorative Arts</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/chestnut-hill-second-saturdays/"> <time class="calendar-events__date">Sat, Jun 12</time><h6 class="calendar-events__title">Chestnut Hill Second Saturdays</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Chestnut Hill</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/stiftungsfest-96th-annual-spring-oktoberfest/"> <time class="calendar-events__date">Sat, Jun 12</time><h6 class="calendar-events__title">"STIFTUNGSFEST", 96th ANNUAL SPRING OKTOBERFEST</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">CANNSTATTER VOLKFEST VEREIN</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/livestream-sunday-morning-meditation/2021-06-13/"> <time class="calendar-events__date">Sun, Jun 13</time><h6 class="calendar-events__title">Livestream Sunday Morning Meditation</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Kadampa Meditation Center Philadelphia</li></ul></li></ul> <a class="Button" href="/calendar">More Events</a></div></div></div></div></div></div><footer class="footer"><div class="footer-section footer-section--primary"><div class="footer-container"></div></div><div class="footer-section footer-section--secondary"><div class="footer-container"><div class="footer-inner"><div class="footer-inner__branding"><div class="footer-inner__logo"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_social"><p>Follow @PhillyWeekly</p><ul class="footer-inner__social__list"><li> <a href="https://www.facebook.com/pg/phillyweekly/posts/"> <i class="fa fa-facebook-square" aria-hidden="true"></i> <span>Facebook</span> </a></li><li> <a href="https://twitter.com/PhillyWeekly/"> <i class="fa fa-twitter" aria-hidden="true"></i> <span>Twitter</span> </a></li><li> <a href="https://www.instagram.com/phillyweekly/"> <i class="fa fa-instagram" aria-hidden="true"></i> <span>Instagram</span> </a></li><li> <a href="https://philadelphiaweekly.com/feeds"> <i class="fa fa-rss" aria-hidden="true"></i> <span>Your News Reader</span> </a></li></ul></div></div><nav class="Navigation Navigation--footer"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-133"><a href="#">About PW</a><ul class="sub-menu"><li id="menu-item-334" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334"><a href="https://philadelphiaweekly.com/about/">About Us</a></li><li id="menu-item-386" class="menu-item menu-item-type-post_type_archive menu-item-object-writer menu-item-386"><a href="https://philadelphiaweekly.com/writer/">Our Writers</a></li><li id="menu-item-25676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25676"><a href="https://philadelphiaweekly.com/locations/">Dropbox Locations</a></li><li id="menu-item-336" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-336"><a href="/advertising">Advertising &#038; Partnerships</a></li><li id="menu-item-338" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-338"><a href="/events/community/add">Submit an Event</a></li></ul></li><li id="menu-item-134" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-134"><a href="#">Explore PW</a><ul class="sub-menu"><li id="menu-item-228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-228"><a href="https://philadelphiaweekly.com/sections/">Sections</a></li><li id="menu-item-137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-136" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-335"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li><li id="menu-item-29460" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29460"><a href="https://philadelphiaweekly.com/sections/altphilly/">AltPhilly Exclusives</a></li></ul></li></ul></div></nav><div class="footer-inner_contact-text"><div class="footer-inner__logo--desktop"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_contact"><p>1520 Locust Street, Fifth Floor</p><p>Philadelphia, PA 19102</p></div><div class="footer-inner_contact footer-inner_contact__phone"><p>215-543-3743</p><p><a href="mailto:mail@philadelphiaweekly.com">mail@philadelphiaweekly.com</a></p></div><div class="footer-info"> &copy; Copyright Philadelphia Weekly</div></div></div></div></footer></div><div
 class="hustle-ui hustle-popup hustle-palette--gray_slate hustle_module_id_1 module_id_1  " 
 data-id="1"
 data-render-id="0"
 data-tracking="enabled" 
 data-intro="fadeIn"
 data-outro="fadeOut"
 data-overlay-close="1"
 data-close-delay="false" 
 style="opacity: 0;"
 ><div class="hustle-popup-mask hustle-optin-mask" aria-hidden="true"></div><div class="hustle-popup-content"><div class="hustle-info hustle-info--default"><button class="hustle-button-icon hustle-button-close"> <span class="hustle-icon-close" aria-hidden="true"></span> <span class="hustle-screen-reader">Close this module</span> </button><div class="hustle-layout"><div class="hustle-layout-header"><span class="hustle-title">Enjoying Philly Weekly?</span><span class="hustle-subtitle">Consider joining altPhilly, an exclusive community with access to members-only content and more. <a href="https://philadelphiaweekly.com/join">Learn More</a></span></div><div class="hustle-layout-content"><div class="hustle-image hustle-image-fit--contain" aria-hidden="true"><img src="https://philadelphiaweekly.com/wp-content/uploads/2021/03/altphilly.jpg" alt="Alt Philly" class="hustle-image-position--centercenter" /></div></div><div class="hustle-layout-footer"><div class="hustle-cta-container"><a class="hustle-button hustle-button-cta " href="https://philadelphiaweekly.memberful.com/checkout?plan=62041" target="_blank" data-cta-type="cta">Join Now</a></div></div></div><p class="hustle-nsa-link"><a href="#">Hide this message</a></p></div></div></div> <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script> <div
 class="jp-carousel-wrap jp-carousel-transitions"
 itemscope
 itemtype="https://schema.org/ImageGallery"
 style="display: none;"><div class="jp-carousel-overlay"></div><div class="jp-carousel"></div><div class="jp-carousel-fadeaway"></div><div class="jp-carousel-info"><div class="jp-carousel-photo-info"><h2 class="jp-carousel-caption" itemprop="caption description"></h2></div><div class="jp-carousel-info-columns"><div class="jp-carousel-left-column-wrapper"><div class="jp-carousel-titleanddesc"></div><div class="jp-carousel-photo-info"><h2 class="jp-carousel-caption" itemprop="caption description"></h2></div><div id="jp-carousel-comment-form-container"><form id="jp-carousel-comment-form"> <label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label><textarea
												name="comment"
												class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
												id="jp-carousel-comment-form-comment-field"
												placeholder="Write a Comment..."
											></textarea><div id="jp-carousel-comment-form-submit-and-info-wrapper"><div id="jp-carousel-comment-form-commenting-as"><fieldset> <label for="jp-carousel-comment-form-email-field">Email (Required)</label> <input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" /></fieldset><fieldset> <label for="jp-carousel-comment-form-author-field">Name (Required)</label> <input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" /></fieldset><fieldset> <label for="jp-carousel-comment-form-url-field">Website</label> <input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" /></fieldset></div> <input
 type="submit"
 name="submit"
 class="jp-carousel-comment-form-button"
 id="jp-carousel-comment-form-button-submit"
 value="Post Comment" /> <span id="jp-carousel-comment-form-spinner">&nbsp;</span><div id="jp-carousel-comment-post-results"></div></div></form></div><div class="jp-carousel-comments"></div><div id="jp-carousel-comments-loading"> <span>Loading Comments...</span></div></div><div class="jp-carousel-image-meta"><div class="jp-carousel-buttons"> <a class="jp-carousel-commentlink" href="#">Comment</a></div><ul class="jp-carousel-image-exif" style="display: none;"></ul> <a class="jp-carousel-image-download" style="display: none;"></a><div class="jp-carousel-image-map" style="display: none;"></div></div></div></div><div class="jp-carousel-next-button" style="display: none;"> <span></span></div><div class="jp-carousel-previous-button" style="display: none;"> <span></span></div><div class="jp-carousel-close-hint"><span>&times;</span></div></div> <script type='text/javascript' src='https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script> <script type='text/javascript' id='wp-polyfill-js-after'>( 'fetch' in window ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );( 'objectFit' in document.documentElement.style ) || document.write( '<script src="https://philadelphiaweekly.com/wp-includes/js/dist/vendor/wp-polyfill-object-fit.min.js?ver=2.3.4"></scr' + 'ipt>' );</script> <script type='text/javascript' id='contact-form-7-js-extra'>var wpcf7 = {"api":{"root":"https:\/\/philadelphiaweekly.com\/wp-json\/","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript' id='wpa-complementary-js-extra'>var wpaComplementary = {"container":""};</script> <script type='text/javascript' id='longdesc.button-js-extra'>var wparest = {"url":"https:\/\/philadelphiaweekly.com\/wp-json\/wp\/v2\/media","text":"<span>Long Description<\/span>"};</script> <script type='text/javascript' id='jquery-ui-datepicker-js-after'>jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});</script> <script type='text/javascript' id='hustle_front-js-extra'>var Modules = [{"settings":{"auto_close_success_message":"0","triggers":{"on_time_delay":"30","on_time_unit":"seconds","on_scroll":"scrolled","on_scroll_page_percent":20,"on_scroll_css_selector":"","enable_on_click_element":"1","on_click_element":"","enable_on_click_shortcode":"1","on_exit_intent_per_session":"1","on_exit_intent_delayed_time":"0","on_exit_intent_delayed_unit":"seconds","on_adblock_delay":"0","on_adblock_delay_unit":"seconds","trigger":["time"]},"animation_in":"fadeIn","animation_out":"fadeOut","after_close_trigger":["click_close_icon"],"after_close":"keep_show","expiration":365,"expiration_unit":"days","on_submit":"nothing","on_submit_delay":"5","on_submit_delay_unit":"seconds","close_cta":"0","close_cta_time":"0","close_cta_unit":"seconds","hide_after_cta":"keep_show","hide_after_subscription":"keep_show","is_schedule":"0","schedule":{"not_schedule_start":"1","start_date":"03\/15\/2021","start_hour":"12","start_minute":"00","start_meridiem_offset":"am","not_schedule_end":"1","end_date":"03\/21\/2021","end_hour":"11","end_minute":"59","end_meridiem_offset":"pm","active_days":"all","week_days":[],"is_active_all_day":"1","day_start_hour":"00","day_start_minute":"00","day_start_meridiem_offset":"am","day_end_hour":"11","day_end_minute":"59","day_end_meridiem_offset":"pm","time_to_use":"server","custom_timezone":"UTC"},"allow_scroll_page":"0","close_on_background_click":"1","auto_hide":"0","auto_hide_unit":"seconds","auto_hide_time":"5"},"module_id":"1","blog_id":"0","module_name":"AltPhilly","module_type":"popup","active":"1","module_mode":"informational"}];
var incOpt = {"is_admin":"","native_share_enpoints":{"facebook":"https:\/\/www.facebook.com\/sharer\/sharer.php?u=https%3A%2F%2Fphiladelphiaweekly.com%2Farts-and-money","twitter":"https:\/\/twitter.com\/intent\/tweet?url=https%3A%2F%2Fphiladelphiaweekly.com%2Farts-and-money&text=Arts%20and%20money","pinterest":"https:\/\/www.pinterest.com\/pin\/create\/button\/?url=https%3A%2F%2Fphiladelphiaweekly.com%2Farts-and-money","reddit":"https:\/\/www.reddit.com\/submit?url=https%3A%2F%2Fphiladelphiaweekly.com%2Farts-and-money","linkedin":"https:\/\/www.linkedin.com\/shareArticle?mini=true&url=https%3A%2F%2Fphiladelphiaweekly.com%2Farts-and-money","vkontakte":"https:\/\/vk.com\/share.php?url=https%3A%2F%2Fphiladelphiaweekly.com%2Farts-and-money","whatsapp":"https:\/\/api.whatsapp.com\/send?text=https%3A%2F%2Fphiladelphiaweekly.com%2Farts-and-money","email":"mailto:?subject=Arts%20and%20money&body=https%3A%2F%2Fphiladelphiaweekly.com%2Farts-and-money"},"ajaxurl":"https:\/\/philadelphiaweekly.com\/wp-admin\/admin-ajax.php","page_id":"30338","page_slug":"arts-and-money","is_upfront":"","script_delay":"3000"};</script> <script type='text/javascript' id='truro-scripts-js-extra'>var customizer = {"sliderSlideCount":"1","sliderLoop":"0","sliderAutoPlay":"0","sliderAutoPlaySpeed":"7000","sliderArrows":"1","sliderDots":"1"};</script> <script type='text/javascript' id='jetpack-lazy-images-js-extra'>var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};</script> <script type='text/javascript' id='jetpack-carousel-js-extra'>var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/philadelphiaweekly.com\/wp-admin\/admin-ajax.php","nonce":"8e45c6ad7f","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/philadelphiaweekly.com\/wp-login.php?redirect_to=https%3A%2F%2Fphiladelphiaweekly.com%2Farts-and-money%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};</script> <style type="text/css" id="hustle-module-1-0-styles" class="hustle-module-styles hustle-module-styles-1">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</style><link rel="stylesheet" href="https://use.typekit.net/cgg8jik.css"> <script defer src="https://philadelphiaweekly.com/wp-content/cache/autoptimize/js/autoptimize_998a3b374c79b8ca7cf245250394f6ce.js"></script></body></html>