<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id="ao_optimized_gfonts" href="https://fonts.googleapis.com/css?family=Lora%3A400%2C400i%2C700" /><link rel="profile" href="http://gmpg.org/xfn/11"><meta property="fb:pages" content="23117126720" /><link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png"><link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png"><link rel="manifest" href="/site.webmanifest"><link rel="mask-icon" href="/safari-pinned-tab.svg" color="#ffc414"><meta name="msapplication-TileColor" content="#231f20"><meta name="theme-color" content="#231f20"> <style type="text/css">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</style><link rel="preload" as="style" media="all" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_d9f55513893621aea33777e26e9e32df.css" onload="this.onload=null;this.rel='stylesheet'" /><noscript id="aonoscrcss"><link type="text/css" media="all" href="https://philadelphiaweekly.com/wp-content/cache/autoptimize/css/autoptimize_d9f55513893621aea33777e26e9e32df.css" rel="stylesheet" /></noscript><title>10 under $10 | March 12-19 - Philadelphia Weekly</title><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="https://philadelphiaweekly.com/10-under-10-march-12-19/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="10 under $10 | March 12-19 - Philadelphia Weekly" /><meta property="og:description" content="Low on dough? All good, these events can still get you out of the house" /><meta property="og:url" content="https://philadelphiaweekly.com/10-under-10-march-12-19/" /><meta property="og:site_name" content="Philadelphia Weekly" /><meta property="article:publisher" content="https://www.facebook.com/phillyweekly/" /><meta property="article:tag" content="10 under 10" /><meta property="article:tag" content="events" /><meta property="article:tag" content="fun" /><meta property="article:tag" content="philadelphia" /><meta property="article:tag" content="things to do" /><meta property="article:section" content="Arts" /><meta property="article:published_time" content="2020-03-12T11:47:29+00:00" /><meta property="article:modified_time" content="2020-03-12T11:47:33+00:00" /><meta property="og:updated_time" content="2020-03-12T11:47:33+00:00" /><meta property="og:image" content="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-7.42.49-AM.png?fit=880%2C585&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta property="og:image:secure_url" content="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-7.42.49-AM.png?fit=880%2C585&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta property="og:image:width" content="880" /><meta property="og:image:height" content="585" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Low on dough? All good, these events can still get you out of the house" /><meta name="twitter:title" content="10 under $10 | March 12-19 - Philadelphia Weekly" /><meta name="twitter:site" content="@phillyweekly" /><meta name="twitter:image" content="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-7.42.49-AM.png?fit=880%2C585&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta name="twitter:creator" content="@phillyweekly" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://philadelphiaweekly.com/#organization","name":"Philadelphia Weekly","url":"https://philadelphiaweekly.com/","sameAs":["https://www.facebook.com/phillyweekly/","https://www.instagram.com/phillyweekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://www.linkedin.com/company/philadelphia-weekly/","https://twitter.com/phillyweekly"],"logo":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#logo","url":"https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/08/favicon.png?fit=500%2C500&quality=70&strip=all&ssl=1","width":500,"height":500,"caption":"Philadelphia Weekly"},"image":{"@id":"https://philadelphiaweekly.com/#logo"}},{"@type":"WebSite","@id":"https://philadelphiaweekly.com/#website","url":"https://philadelphiaweekly.com/","name":"Philadelphia Weekly","publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://philadelphiaweekly.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/10-under-10-march-12-19/#primaryimage","url":"https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-7.42.49-AM.png?fit=880%2C585&quality=70&strip=all&ssl=1","width":880,"height":585,"caption":"Waffle"},{"@type":"WebPage","@id":"https://philadelphiaweekly.com/10-under-10-march-12-19/#webpage","url":"https://philadelphiaweekly.com/10-under-10-march-12-19/","inLanguage":"en-US","name":"10 under $10 | March 12-19 - Philadelphia Weekly","isPartOf":{"@id":"https://philadelphiaweekly.com/#website"},"primaryImageOfPage":{"@id":"https://philadelphiaweekly.com/10-under-10-march-12-19/#primaryimage"},"datePublished":"2020-03-12T11:47:29+00:00","dateModified":"2020-03-12T11:47:33+00:00"},{"@type":"Article","@id":"https://philadelphiaweekly.com/10-under-10-march-12-19/#article","isPartOf":{"@id":"https://philadelphiaweekly.com/10-under-10-march-12-19/#webpage"},"author":{"@id":"https://philadelphiaweekly.com/#/schema/person/6d10bb5ac4140a42ca14aa4e8065e28d"},"headline":"10 under $10 | March 12-19","datePublished":"2020-03-12T11:47:29+00:00","dateModified":"2020-03-12T11:47:33+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://philadelphiaweekly.com/10-under-10-march-12-19/#webpage"},"publisher":{"@id":"https://philadelphiaweekly.com/#organization"},"image":{"@id":"https://philadelphiaweekly.com/10-under-10-march-12-19/#primaryimage"},"keywords":"10 under 10,events,fun,philadelphia,things to do","articleSection":"Arts,Comedy,Food / Drink,Interests"},{"@type":["Person"],"@id":"https://philadelphiaweekly.com/#/schema/person/6d10bb5ac4140a42ca14aa4e8065e28d","name":"Philly Editor","image":{"@type":"ImageObject","@id":"https://philadelphiaweekly.com/#authorlogo","url":"https://secure.gravatar.com/avatar/a2af5953cb6b5d09567512df874c23dd?s=96&d=mm&r=g","caption":"Philly Editor"},"sameAs":[]}]}</script> <link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//www.googletagmanager.com' /><link href='https://use.typekit.net' rel='preconnect' /><link href='https://www.google-analytics.com' rel='preconnect' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Feed" href="https://philadelphiaweekly.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Philadelphia Weekly &raquo; Comments Feed" href="https://philadelphiaweekly.com/comments/feed/" /><link rel="alternate" type="text/calendar" title="Philadelphia Weekly &raquo; iCal Feed" href="https://philadelphiaweekly.com/events/?ical=1" /> <script type='text/javascript'>var wpp_params = {"sampling_active":"0","sampling_rate":"50","ajax_url":"https:\/\/philadelphiaweekly.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"18538","token":"5bc36b8815","debug":""};</script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-700394-5' async></script> <script type='text/javascript'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag('js', new Date());
gtag('config', 'UA-700394-5', {"useAmpClientId":true} );</script> <link rel='https://api.w.org/' href='https://philadelphiaweekly.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://philadelphiaweekly.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://philadelphiaweekly.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.3.1" /><link rel='shortlink' href='https://philadelphiaweekly.com/?p=18538' /><link rel="alternate" type="application/json+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2F10-under-10-march-12-19%2F" /><link rel="alternate" type="text/xml+oembed" href="https://philadelphiaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphiladelphiaweekly.com%2F10-under-10-march-12-19%2F&#038;format=xml" /><meta name="generator" content="Site Kit by Google 1.1.3" /><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://philadelphiaweekly.com"><link rel="https://theeventscalendar.com/" href="https://philadelphiaweekly.com/wp-json/tribe/events/v1/" /><link rel='dns-prefetch' href='//c0.wp.com'/><link rel='dns-prefetch' href='//i0.wp.com'/><link rel='dns-prefetch' href='//i1.wp.com'/><link rel='dns-prefetch' href='//i2.wp.com'/><style type="text/css">.header{background-color: #0a0a0a;}.header .SearchForm-button{color: #ffffff;}.Navigation--primary{color: #ffffff;}</style><style type="text/css">/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}</style> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link rel="amphtml" href="https://philadelphiaweekly.com/10-under-10-march-12-19/amp/"><link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=32%2C21&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=192%2C128&#038;quality=70&#038;strip=all&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=180%2C120&#038;quality=70&#038;strip=all&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/7da8d22a0233ef6245e3ea23c264a84c.jpg?fit=270%2C180&#038;quality=70&#038;strip=all&#038;ssl=1" /> <script>window.dataLayer = window.dataLayer || [];
	  function gtag(){dataLayer.push(arguments);}
	  gtag('js', new Date());

	  gtag('config', 'UA-700394-5');</script> </head><body class="post-template-default single single-post postid-18538 single-format-standard tribe-no-js tribe-theme-parent-truro tribe-theme-child-truro-pw-child"> <a class="skip-link screen-reader-text" href="#Content">Skip to content</a><header class="header header--four"><div class="header-section header-section--primary"><div class="header-container"><div class="header-sectionInner"><div class="header-part"><div class="Branding"> <a href="https://philadelphiaweekly.com/" rel="home"> <img class="Branding-logo" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/PW-weekly-white-horizontal-1-1.svg" alt="Philadelphia Weekly" width="200px" /> </a></div></div><div class="header-part header-part__navigation"><nav class="Navigation Navigation--primary"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation" class="menu"><li id="menu-item-227" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li id="menu-item-221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li id="menu-item-188" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li id="menu-item-191" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li id="menu-item-192" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li id="menu-item-193" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li id="menu-item-194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li id="menu-item-7201" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li id="menu-item-195" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li id="menu-item-222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li id="menu-item-518" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li id="menu-item-375" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li id="menu-item-377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li id="menu-item-385" class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li id="menu-item-366" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-366"><a href="https://philadelphiaweekly.com/sections/featured-sections/savage-love/">Savage Love</a></li><li id="menu-item-384" class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li id="menu-item-543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-128" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></nav><div class="utility-navigation"><form class="SearchForm SearchForm--header" method="get" action="https://philadelphiaweekly.com/"> <span class="screen-reader-text">Search for:</span> <input class="SearchForm-field" type="text" placeholder="Type &amp; press enter" value="" name="s" title="Search for:" /> <button type="submit" class="screen-reader-text" aria-label="Search">Search</button> <button class="SearchForm-button" aria-label="Submit"><i class="fa fa-search" aria-hidden="true"></i></button></form></div></div></div></div></div></header><nav class="Navigation Navigation--mobile"><div class="container"><div class="menu-primary-navigation-container"><ul id="menu-primary-navigation-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-227"><a href="https://philadelphiaweekly.com/sections/">Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-221"><a href="#">Topics</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-188"><a href="https://philadelphiaweekly.com/sections/arts/">Arts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-191"><a href="https://philadelphiaweekly.com/sections/food-drink/">Food / Drink</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192"><a href="https://philadelphiaweekly.com/sections/lgbtq-sex/">LGBTQ / Sex</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://philadelphiaweekly.com/sections/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-194"><a href="https://philadelphiaweekly.com/sections/news/">News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7201"><a href="https://philadelphiaweekly.com/sections/opinion/">Opinion</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-195"><a href="https://philadelphiaweekly.com/sections/people/">People</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-222"><a href="#">Featured Sections</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://philadelphiaweekly.com/sections/featured-sections/events/">The Scene</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="https://philadelphiaweekly.com/sections/featured-sections/the-big-picture/">The Big Picture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="https://philadelphiaweekly.com/sections/featured-sections/from-the-editor/">From the Editor</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-print menu-item-385"><a href="https://philadelphiaweekly.com/print/">In Print</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-366"><a href="https://philadelphiaweekly.com/sections/featured-sections/savage-love/">Savage Love</a></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-state menu-item-384"><a href="https://philadelphiaweekly.com/state/">State of Our City</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://philadelphiaweekly.com/sections/featured-sections/voices-of-our-city/">Voices of Our City</a></li></ul></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></div></div></nav><div class="content content--fullWidth" id="content"><div class="content-inner"><div class="content-container"><div class="content-row content-row--article"><main class="content-main"><header class="article-header"><div class="meta-tags"> <span class="Meta-item"><li class="Meta-item Meta-item--categories"><ul class="Meta Meta--banner"><li class="Meta-item Meta-item--categories"><ul><li><a href="https://philadelphiaweekly.com/sections/arts/" title="Arts">Arts</a></li><li><a href="https://philadelphiaweekly.com/sections/comedy/" title="Comedy">Comedy</a></li><li><a href="https://philadelphiaweekly.com/sections/food-drink/" title="Food / Drink">Food / Drink</a></li><li><a href="https://philadelphiaweekly.com/sections/interests/" title="Interests">Interests</a></li></ul></li></ul></li> </span></div><h1>10 under $10 | March 12-19</h1><div class="posts-teaser"><p>Low on dough? All good, these events can still get you out of the house</p></div><footer class="Post-footer"><ul class="Meta Meta--article"><li class="Meta-item Meta-item--author"> <a class="meta-author-article" href="https://philadelphiaweekly.com/writer/tom-beck/"><figure class="meta-author-headshot"><img width="200" height="200" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-headshot size-headshot wp-post-image jetpack-lazy-image" alt="Tom Beck Headshot" data-attachment-id="9751" data-permalink="https://philadelphiaweekly.com/writer/tom-beck/tom_beck/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?fit=2662%2C2789&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2662,2789" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Tom_Beck" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?fit=286%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?fit=977%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 200w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?resize=680%2C680&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?zoom=2&amp;resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 400w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?zoom=3&amp;resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 600w" data-lazy-sizes="(max-width: 200px) 100vw, 200px" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></figure> <span class="meta-author-name">Tom Beck</span></a></li><li class="Meta-item Meta-item--date">March 12th, 2020</li></ul><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/10-under-10-march-12-19/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%2010 under $10 | March 12-19%20-%20https://philadelphiaweekly.com/10-under-10-march-12-19/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%2010 under $10 | March 12-19%20-%20https://philadelphiaweekly.com/10-under-10-march-12-19/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: 10 under $10 | March 12-19%20https://philadelphiaweekly.com/10-under-10-march-12-19/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></footer></header><header class="Post-header"><figure class="Post-thumbnail"> <a data-fancybox="gallery" data-caption="Eat waffles for a great cause this weekend at Waffle Sunday at the Kensington CO-OP. | Image provided" href="https://philadelphiaweekly.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-7.42.49-AM.png"><img width="880" height="585" src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-7.42.49-AM.png?resize=880%2C585&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-feature-image size-feature-image wp-post-image jetpack-lazy-image" alt="Waffle" data-attachment-id="18544" data-permalink="https://philadelphiaweekly.com/10-under-10-march-12-19/screen-shot-2020-03-12-at-7-42-49-am/" data-orig-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-7.42.49-AM.png?fit=880%2C585&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="880,585" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screen Shot 2020-03-12 at 7.42.49 AM" data-image-description="" data-medium-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-7.42.49-AM.png?fit=300%2C199&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-7.42.49-AM.png?fit=880%2C585&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-7.42.49-AM.png?w=880&amp;quality=70&amp;strip=all&amp;ssl=1 880w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-7.42.49-AM.png?resize=300%2C199&amp;quality=70&amp;strip=all&amp;ssl=1 300w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-7.42.49-AM.png?resize=770%2C512&amp;quality=70&amp;strip=all&amp;ssl=1 770w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-7.42.49-AM.png?resize=526%2C350&amp;quality=70&amp;strip=all&amp;ssl=1 526w, https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-7.42.49-AM.png?resize=680%2C452&amp;quality=70&amp;strip=all&amp;ssl=1 680w" data-lazy-sizes="(max-width: 880px) 100vw, 880px" data-lazy-src="https://i2.wp.com/philadelphiaweekly.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-7.42.49-AM.png?resize=880%2C585&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></a><figcaption>Eat waffles for a great cause this weekend at Waffle Sunday at the Kensington CO-OP. | Image provided</figcaption></figure></header><div class="sharing-desktop"><ul class="Sharing"><li class="Sharing-item"><a href="https://www.facebook.com/sharer/sharer.php?u=https://philadelphiaweekly.com/10-under-10-march-12-19/&t=" title="Share on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="Sharing-name">Share</span></a></li><li class="Sharing-item"><a href="https://twitter.com/intent/tweet?source=https://philadelphiaweekly.com&text=Check out this article:%2010 under $10 | March 12-19%20-%20https://philadelphiaweekly.com/10-under-10-march-12-19/" target="_blank" title="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i><span class="Sharing-name">Tweet</span></a></li><li class="Sharing-item"><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://philadelphiaweekly.com&text=Check out this article:%2010 under $10 | March 12-19%20-%20https://philadelphiaweekly.com/10-under-10-march-12-19/" target="_blank" title="LinkedIn"><i class="fa fa-linkedin" aria-hidden="true"></i><span class="Sharing-name">Post</span></a></li><li class="Sharing-item"><a href="mailto:?subject=Check out this post&body=Check out this post: 10 under $10 | March 12-19%20https://philadelphiaweekly.com/10-under-10-march-12-19/" target="_blank" title="Email"><i class="fa fa-envelope" aria-hidden="true"></i><span class="Sharing-name">Email</span></a></li></ul></div><article id="Post-18538"  class="Post Post--single post-18538 post type-post status-publish format-standard has-post-thumbnail hentry category-arts category-comedy category-food-drink category-interests tag-10-under-10 tag-events tag-fun tag-philadelphia tag-things-to-do"><div class="Post-content"><p><strong>Medusa Market: Friday the 13th!</strong></p><p>Support local creators and vendors at Tattooed Mom’s periodic witch market. Booze and grub will be on hand, including half-priced drinks from 5 to 7 p.m. and 10 to 11 p.m. | Friday, March 13, 6 pm. Free. Tattooed Mom, 530 South St.  <a href="https://www.tattooedmomphilly.com/event/medusas-market-friday-13th/">tattooedmomphilly.com</a></p><p><strong>A Black Celebration | Friday the 13th edition</strong></p><p>This spooky and sassy ‘80s dance party, named after the Depeche Mode album, will feature Slasher-themed decor and movie music sprinkled in with all of your ‘80s goth and alternative favorites. | Friday, March 13, 10 pm. $5. Ruba Club, 416 Green St. <a href="https://www.facebook.com/events/1341476942680755/">facebook.com</a></p><p><strong>The Presence (and Absence) of Women in Science</strong></p><p>Unfortunately, STEM fields have been dominated by men. In this program, historian and Johns Hopkins PhD candidate Joanna Behrman will examine the historical roots of the issue, along with some of what has worked – and what hasn’t – to make science more accessible for all. | Saturday, March 14, 11 am. Free. Science History Institute, 315 Chestnut St.&nbsp; <a href="https://www.facebook.com/events/1541334706007773/">facebook.com</a></p><p><strong>Guinness Glass Engraving</strong></p><p>Byrne’s is offering you the opportunity to engrave your very own Guinness glass. We think you should engrave yours with a giant penis. Otherwise, you’re doing it wrong. | Sunday, March 15, 4 pm. Free. Byrne’s Tavern, 3301 Richmond St.&nbsp; <a href="https://www.facebook.com/events/3050028135009591/">facebook.com</a></p><p><strong>Waffle Sunday</strong></p><p>The only thing better than eating waffles is eating them for a good cause. Charity organization Waffles4Tourette’s is giving you the opportunity to feast on hot, fresh, waffly deliciousness and even drink some Mimosas (assuming you’re of legal age) at the same time. | Sunday, March 15, 10 am. Free. Kensington Community Food Co-op, 2670 Coral St.&nbsp; <a href="https://www.facebook.com/events/515519439375729/">facebook.com</a></p><p><strong>PennFems Presents: The Women Behind the Movements</strong></p><p>The Women Behind the Movements event is an opportunity to learn about phenomenal women who have led some of the most pivotal movements of our generation – and make some buttons as well. The Women&#8217;s March, Black Lives Matter, “Un violador en tu camino,” and more will all be topics of discussion. There will be food. | Monday, March 16, 7 pm. Free. Penn Women’s Center, 3643 Locust Walk.&nbsp; <a href="https://www.facebook.com/events/224161005435983/">facebook.com</a></p><p><strong>Varga&#8217;s March Madness: Evil Genius v. Sterling Pig</strong></p><p>Varga will be tapping two kegs at the same time – one an Evil Genius beer and the other by Sterling Pig. The first one that gets kicked advances to the next round. | Monday, March 16, 8 pm. Free. Varga Bar, 941 Spruce St.&nbsp; <a href="https://www.facebook.com/events/200430241046230/">facebook.com</a></p><p><strong>St. Patrick&#8217;s Day Brewery Crawl</strong></p><p>If you ain’t beerin’, you’re doing St. Patrick’s Day all wrong. But not to fear! Yards Brewing Company, Love City Brewing Company, Triple Bottom Brewing Company and Roy-Pitz Barrel House will host you in this fun brewery crawl along Spring Garden Street. | Tuesday, March 17, 4 pm. Free. Spring Arts, 10th and Spring Garden. <a href="https://www.facebook.com/events/174245607336885/">facebook.com</a></p><p><strong>Neil Shubin | Some Assembly Required</strong></p><p>Evolutionary biologist Neil Shubin was a member of the field team that made the 2004 landmark discovery of Tiktaalik roseae, a 375 million-year-old fossil dubbed the &#8220;missing link&#8221; between fish and land animals. He’ll be at Parkway Central Library to discuss “Some Assembly Required,” Shubin’s new book in which he constructs an erudite but accessible account of the great leaps forward in animal evolution that can perhaps even help explain the inevitability (or lack thereof) of our existence. | Wednesday, March 18, 7:30 pm. Free. Parkway Central Library, 1901 Vine St. <a href="https://libwww.freelibrary.org/programs/authorevents/?id=96652">freelibrary.org</a></p><p><strong>Pennsylvania Rally Against Hate</strong></p><p>Pennsylvania was founded on principles of tolerance and diversity. Yet even today, with hate crimes on the rise, and with our commonwealth still reeling from the tragedy at Tree of Life, our hate crime laws have not caught up to reflect our core ideals. The Rally Against Hate is an opportunity for you to speak out against that bullshit whether you’re Jewish or not. | Wednesday, March 18, 7:30 am. Free. Jewish Community Services Building, 2100 Arch St.&nbsp; <a href="https://jewishphilly.org/get-involved/event-registrations/pennsylvania-rally-against-hate/?fbclid=IwAR0IJUw3C0IuQYGxye69LhEn3OxebrAYLMaiZuOQ7osOxMtaFLGdnlm9ysk">jewishphilly.com</a><br></p><h5 class="related-posts__title">Related</h5><ul class="related-posts"><li><a href="https://philadelphiaweekly.com/next-on-tap-south-phillys-event-mega-palace-the-2300-arena-is-anything-philly-needs-it-to-be/" rel="bookmark" title="Permanent Link to Next on tap: South Philly&#8217;s event mega-palace, the 2300 Arena, is anything Philly needs it to be">Next on tap: South Philly&#8217;s event mega-palace, the 2300 Arena, is anything Philly needs it to be</a></li><li><a href="https://philadelphiaweekly.com/distillers-talk-and-whiskey-taste/" rel="bookmark" title="Permanent Link to Distiller&#8217;s talk and Whiskey taste">Distiller&#8217;s talk and Whiskey taste</a></li><li><a href="https://philadelphiaweekly.com/the-scene-taste-of-philly/" rel="bookmark" title="Permanent Link to The Scene: Taste of Philly">The Scene: Taste of Philly</a></li><li><a href="https://philadelphiaweekly.com/coming-up-irish/" rel="bookmark" title="Permanent Link to Coming up Irish">Coming up Irish</a></li></ul><ul class="Meta"><li class="Meta-item Meta-item--tags"><ul><li><a href="https://philadelphiaweekly.com/tag/10-under-10/" title=" 10 under 10 ">10 under 10</a></li><li><a href="https://philadelphiaweekly.com/tag/events/" title=" events ">events</a></li><li><a href="https://philadelphiaweekly.com/tag/fun/" title=" fun ">fun</a></li><li><a href="https://philadelphiaweekly.com/tag/philadelphia/" title=" philadelphia ">philadelphia</a></li><li><a href="https://philadelphiaweekly.com/tag/things-to-do/" title=" things to do ">things to do</a></li></ul></li></ul></div></article><ul class="author-article-bio"><li class="author-bio__item"> <a class="author-bio__headshot" href="https://philadelphiaweekly.com/writer/tom-beck/"><figure><img width="200" height="200" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-headshot size-headshot wp-post-image jetpack-lazy-image" alt="Tom Beck Headshot" data-attachment-id="9751" data-permalink="https://philadelphiaweekly.com/writer/tom-beck/tom_beck/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?fit=2662%2C2789&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="2662,2789" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Tom_Beck" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?fit=286%2C300&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?fit=977%2C1024&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?resize=100%2C100&amp;quality=70&amp;strip=all&amp;ssl=1 100w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 200w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?resize=680%2C680&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?zoom=2&amp;resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 400w, https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?zoom=3&amp;resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1 600w" data-lazy-sizes="(max-width: 200px) 100vw, 200px" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/Tom_Beck.jpeg?resize=200%2C200&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /></figure> </a><div class="author-name__container"> <a class="author-bio__name" href="https://philadelphiaweekly.com/writer/tom-beck/"><h6>Tom Beck</h6> </a><ul class="author-bio__social"><li class="author-bio__social__item"> <a href="https://www.twitter.com/ImTomBeck"> <i class="author-bio__social__icon fa fa-twitter" aria-hidden="true"></i><div class="author-bio__social__handle">@ImTomBeck</div> </a></li></ul></div><div class="author-bio__info"><p>Tom Beck is a freelance reporter and Temple University grad based in Philadelphia who also serves as an associate editor for the Star Community Newsweekly and South Philly Review.</p></div></li></ul></main></div><section class="RelatedPosts"><div class="category-row__bar"><h2 class="category-row__title">Up Next in Arts</h2></div><ul class="posts-row"><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/pw-weekend-picks-june-28-30/" title="PW weekend picks: June 28-30"> <img width="680" height="480" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/a70a2012ff7f4948bddd1377efae9a3e.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="" data-attachment-id="2689" data-permalink="https://philadelphiaweekly.com/pw-weekend-picks-june-28-30/a70a2012ff7f4948bddd1377efae9a3e/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/a70a2012ff7f4948bddd1377efae9a3e.jpg?fit=1620%2C1080&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1620,1080" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="a70a2012ff7f4948bddd1377efae9a3e" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/a70a2012ff7f4948bddd1377efae9a3e.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/a70a2012ff7f4948bddd1377efae9a3e.jpg?fit=1024%2C683&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/a70a2012ff7f4948bddd1377efae9a3e.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/a70a2012ff7f4948bddd1377efae9a3e.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/10/a70a2012ff7f4948bddd1377efae9a3e.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/pw-weekend-picks-june-28-30/" title="PW weekend picks: June 28-30"><h5 class="RecentPosts-title">PW weekend picks: June 28-30</h5> </a><div class="posts-teaser"><p>OUR PICK: Clark Park Music and Arts FestivalIt’s all about celebrating the talented citizens of West Philly at the annual outdoor Clark Park Music and Arts Festival. </p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Jun 28, 2019</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/are-brands-like-rap-snacks-a-blessing-and-a-curse-in-the-inner-city-sections-they-serve/" title="Are brands like Rap Snacks a blessing and a curse in the inner city sections they serve?"> <img width="680" height="480" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/5dc5459a7c2a0.image_.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="Philadelphia hip hop entrepreneur James Lindsay" data-attachment-id="9720" data-permalink="https://philadelphiaweekly.com/are-brands-like-rap-snacks-a-blessing-and-a-curse-in-the-inner-city-sections-they-serve/5dc5459a7c2a0-image/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/5dc5459a7c2a0.image_.jpg?fit=1280%2C914&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1280,914" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="5dc5459a7c2a0.image" data-image-description="&lt;p&gt;Philadelphia hip hop entrepreneur James Lindsay has been instrumental in the creation of Rap Snacks, a potato chip brand wildly popular within pockets of inner-city Philadelphia. | Image: David Cabrera&lt;/p&gt;
" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/5dc5459a7c2a0.image_.jpg?fit=300%2C214&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/5dc5459a7c2a0.image_.jpg?fit=1024%2C731&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/5dc5459a7c2a0.image_.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/are-brands-like-rap-snacks-a-blessing-and-a-curse-in-the-inner-city-sections-they-serve/" title="Are brands like Rap Snacks a blessing and a curse in the inner city sections they serve?"><h5 class="RecentPosts-title">Are brands like Rap Snacks a blessing and a curse in the inner city sections they serve?</h5> </a><div class="posts-teaser"><p>This piece had all the makings of a straightforward feature.</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Nov 8, 2019</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/the-laughter-we-need-1812-productions-this-is-the-week-that-is-finally-earns-long-overdue-praise/" title="The laughter we need: 1812 Productions’ &#8216;This Is The Week That Is&#8217; finally earns long overdue praise"> <img width="680" height="480" src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/74482651ad235b91d90e6dc3de739fa2.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="" data-attachment-id="7382" data-permalink="https://philadelphiaweekly.com/the-laughter-we-need-1812-productions-this-is-the-week-that-is-finally-earns-long-overdue-praise/74482651ad235b91d90e6dc3de739fa2/" data-orig-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/74482651ad235b91d90e6dc3de739fa2.jpg?fit=1576%2C1314&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1576,1314" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="74482651ad235b91d90e6dc3de739fa2" data-image-description="" data-medium-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/74482651ad235b91d90e6dc3de739fa2.jpg?fit=300%2C250&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/74482651ad235b91d90e6dc3de739fa2.jpg?fit=1024%2C854&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/74482651ad235b91d90e6dc3de739fa2.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 680w, https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/74482651ad235b91d90e6dc3de739fa2.jpg?zoom=2&amp;resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1 1360w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://i1.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/74482651ad235b91d90e6dc3de739fa2.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/the-laughter-we-need-1812-productions-this-is-the-week-that-is-finally-earns-long-overdue-praise/" title="The laughter we need: 1812 Productions’ &#8216;This Is The Week That Is&#8217; finally earns long overdue praise"><h5 class="RecentPosts-title">The laughter we need: 1812 Productions’ &#8216;This Is The Week That Is&#8217; finally earns long overdue praise</h5> </a><div class="posts-teaser"><p>Superstition may peg 13 as the unluckiest of numbers, but 1812 Productions 13th season of its annual political satire This Is The Week That Is seems to be its best year yet.Opened on Nov. 28, with a run through Jan. 5,&hellip;</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Nov 29, 2018</li></ul></footer></li><li class="posts-row__item"><header class="Post-header"><figure class="RelatedPosts-postThumbnail"> <a href="https://philadelphiaweekly.com/love-on-the-rocks-for-over-150-years-mcgillins-has-served-up-food-drink-and-love-connections/" title="Love on the rocks: For over 150 years, McGillin&#8217;s has served up food, drink and love connections"> <img width="680" height="480" src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/6793caffbe963234229c48d142add3e4.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1" class="attachment-related-post size-related-post wp-post-image jetpack-lazy-image" alt="" data-attachment-id="5496" data-permalink="https://philadelphiaweekly.com/love-on-the-rocks-for-over-150-years-mcgillins-has-served-up-food-drink-and-love-connections/6793caffbe963234229c48d142add3e4/" data-orig-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/6793caffbe963234229c48d142add3e4.jpg?fit=1280%2C853&amp;quality=70&amp;strip=all&amp;ssl=1" data-orig-size="1280,853" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="6793caffbe963234229c48d142add3e4" data-image-description="" data-medium-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/6793caffbe963234229c48d142add3e4.jpg?fit=300%2C200&amp;quality=70&amp;strip=all&amp;ssl=1" data-large-file="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/6793caffbe963234229c48d142add3e4.jpg?fit=1024%2C682&amp;quality=70&amp;strip=all&amp;ssl=1" data-lazy-src="https://i0.wp.com/philadelphiaweekly.com/wp-content/uploads/2019/11/6793caffbe963234229c48d142add3e4.jpg?resize=680%2C480&amp;quality=70&amp;strip=all&amp;ssl=1&amp;is-pending-load=1" srcset="/wp-content/themes/truro-pw-child/ui/placeholder-thumb.jpg" /> </a></figure></header><div class="Post-content"> <a href="https://philadelphiaweekly.com/love-on-the-rocks-for-over-150-years-mcgillins-has-served-up-food-drink-and-love-connections/" title="Love on the rocks: For over 150 years, McGillin&#8217;s has served up food, drink and love connections"><h5 class="RecentPosts-title">Love on the rocks: For over 150 years, McGillin&#8217;s has served up food, drink and love connections</h5> </a><div class="posts-teaser"><p>It starts with a welcomed glance across the room, an immediate attraction between two strangers.From that comes a greeting, followed by a name, a drink and, with all luck, a number. A social exchange presumed extinct in the rejection-proof era&hellip;</p></div></div><footer class="RelatedPosts-postFooter"><ul class="Meta"><li class="Meta-item Meta-item--date">Feb 8, 2019</li></ul></footer></li></ul></section><div class="Columns-row columns-even"><div class="Columns-column"><div class="most-popular"><h2>Most Popular This Week</h2><ol class="most-popular-list"><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/opinion/" class="category category-3039">Opinion</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/think-youre-punk/">Think you&#039;re punk?</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/opinion/" class="category category-3039">Opinion</a>, <a href="https://philadelphiaweekly.com/sections/people/" class="category category-91">People</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/place-at-the-table/">&#039;Place at the table&#039;</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/food-festivities-and-all-the-fireworks-planned-for-this-summers-wawa-welcome-america-celebration/">Food, festivities and ALL the fireworks planned for this summer’s Wawa Welcome America celebration</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/people/" class="category category-91">People</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/buying-black/">Buying Black</a></li><li class="most-popular-list__item"><span class="Meta most-popular__category"><a href="https://philadelphiaweekly.com/sections/news/" class="category category-92">News</a></span><a class="most-popular__link" href="https://philadelphiaweekly.com/the-current-state/">&#039;The current state&#039;</a></li></ol></div> <a class="Button" href="/popular">More Popular Articles</a></div><div class="Columns-column columns-even__right"><div class="calendar-events-teaser"><h2>Upcoming Philly Events</h2><ul class="calendar-events"><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/heart-paw-east-market-grand-opening/"> <time class="calendar-events__date">Sat, Mar 14</time><h6 class="calendar-events__title">Heart + Paw East Market Grand Opening</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Heart + Paw</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/members-only-coffee-sacred-adornment-jewelry-as-belief/"> <time class="calendar-events__date">Sat, Mar 14</time><h6 class="calendar-events__title">Members-Only Coffee | Sacred Adornment: Jewelry as Belief</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Glencairn Museum</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/the-pour-house-celebrates-st-paddys-on-haddon-square/"> <time class="calendar-events__date">Sat, Mar 14</time><h6 class="calendar-events__title">The Pour House Celebrates St. Paddy’s on Haddon Square</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Haddon Square</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/prepare-for-patty-at-misconduct-tavern/"> <time class="calendar-events__date">Sat, Mar 14</time><h6 class="calendar-events__title">Prepare for Patty at Misconduct Tavern</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Misconduct Tavern</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/expanding-your-orgasmic-potential-w-dr-nan/"> <time class="calendar-events__date">Sun, Mar 15</time><h6 class="calendar-events__title">Expanding Your Orgasmic Potential w/ Dr. Nan</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">The Velvet Lily</li></ul><li class="calendar-events__item"> <a href="https://philadelphiaweekly.com/event/green-eggs-gams-a-dr-seuss-burlesque/"> <time class="calendar-events__date">Sun, Mar 15</time><h6 class="calendar-events__title">Green Eggs &amp; Gams: A Dr. Seuss Burlesque</h6></a><ul class="Meta"><li class="Meta-item Meta-item--author">Franky Bradley&#8217;s</li></ul></li></ul> <a class="Button" href="/calendar">More Events</a></div></div></div></div></div></div><footer class="footer"><div class="footer-section footer-section--primary"><div class="footer-container"></div></div><div class="footer-section footer-section--secondary"><div class="footer-container"><div class="footer-inner"><div class="footer-inner__branding"><div class="footer-inner__logo"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_social"><p>Follow @PhillyWeekly</p><ul class="footer-inner__social__list"><li> <a href="https://www.facebook.com/pg/phillyweekly/posts/"> <i class="fa fa-facebook-square" aria-hidden="true"></i> <span>Facebook</span> </a></li><li> <a href="https://twitter.com/PhillyWeekly/"> <i class="fa fa-twitter" aria-hidden="true"></i> <span>Twitter</span> </a></li><li> <a href="https://www.instagram.com/phillyweekly/"> <i class="fa fa-instagram" aria-hidden="true"></i> <span>Instagram</span> </a></li><li> <a href="https://philadelphiaweekly.com/feeds"> <i class="fa fa-rss" aria-hidden="true"></i> <span>Your News Reader</span> </a></li></ul></div></div><nav class="Navigation Navigation--footer"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-133"><a href="#">About PW</a><ul class="sub-menu"><li id="menu-item-334" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334"><a href="https://philadelphiaweekly.com/about/">About Us</a></li><li id="menu-item-386" class="menu-item menu-item-type-post_type_archive menu-item-object-writer menu-item-386"><a href="https://philadelphiaweekly.com/writer/">Our Writers</a></li><li id="menu-item-336" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-336"><a href="/advertising">Advertising &#038; Partnerships</a></li><li id="menu-item-338" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-338"><a href="/events/community/add">Submit an Event</a></li></ul></li><li id="menu-item-134" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-134"><a href="#">Explore PW</a><ul class="sub-menu"><li id="menu-item-228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-228"><a href="https://philadelphiaweekly.com/sections/">Sections</a></li><li id="menu-item-137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137"><a href="https://philadelphiaweekly.com/latest/">Latest</a></li><li id="menu-item-136" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136"><a href="https://philadelphiaweekly.com/popular/">Popular</a></li><li id="menu-item-335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-335"><a href="https://philadelphiaweekly.com/calendar/">Calendar</a></li></ul></li></ul></div></nav><div class="footer-inner_contact-text"><div class="footer-inner__logo--desktop"> <img class="footer-branding" src="https://philadelphiaweekly.com/wp-content/uploads/2019/09/Philadelphia-Weekly-Logo-White.svg" alt="Philadelphia Weekly" /></div><div class="footer-inner_contact"><p>1520 Locust Street, Fifth Floor</p><p>Philadelphia, PA 19102</p></div><div class="footer-inner_contact footer-inner_contact__phone"><p>215-543-3743</p><p><a href="mailto:mail@philadelphiaweekly.com">mail@philadelphiaweekly.com</a></p></div><div class="footer-info"> &copy; Copyright Philadelphia Weekly</div></div></div></div></footer></div> <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <script type="text/javascript">(function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();</script> <script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/philadelphiaweekly.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script> <script type='text/javascript'>var wpaComplementary = [""];</script> <script type='text/javascript'>var customizer = {"sliderSlideCount":"1","sliderLoop":"0","sliderAutoPlay":"0","sliderAutoPlaySpeed":"7000","sliderArrows":"1","sliderDots":"1"};</script> <link rel="stylesheet" href="https://use.typekit.net/cgg8jik.css"> <script type="text/javascript" defer src="https://philadelphiaweekly.com/wp-content/cache/autoptimize/js/autoptimize_33b0ef4b84d52645882e25dc183de2fc.js"></script><script data-cfasync='false'>!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){function e(){t.media=a}var a=t.media||"all";t.addEventListener?t.addEventListener("load",e):t.attachEvent&&t.attachEvent("onload",e),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(e,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);</script></body></html>